ObjectCastsShadows

Returns or sets an object's casts shadows property, or whether or not an object casts shadows on other objects and a ground plane.

Syntax

Rhino.ObjectCastsShadows (strObject [, blnEnable])

Rhino.ObjectCastsShadows (arrObjects, blnEnable)

Parameters

strObject

Required.  String.  The identifier of the object.

arrObjects

Required.  Array.  An array of strings identifying the objects to modify.

blnEnable

Optional.  Boolean.  The state, either enabled (True) or disabled (False).

Returns

Boolean

If a state is not specified,  the current casts shadows state if successful.

Boolean

If a state is specified, the previous casts shadows if successful.

Number

If arrObjects is specified, then the number of objects modified if successful.

Null

If not successful, or on error.

Example

Dim arrObjects

arrObjects = Rhino.GetObjects("Select objects")

If IsArray(arrObjects) Then

  Call Rhino.ObjectCastsShadows(arrObjects, False)

End If

Also See

ObjectReceivesShadows