ObjectReceivesShadows

Returns or sets an object's receives shadows property, or whether or not an object receives shadows from other objects.

Syntax

Rhino.ObjectReceivesShadows (strObject [, blnEnable])

Rhino.ObjectReceivesShadows (arrObjects, blnEnable)

Parameters

strObject

Required.  String.  The identifier of the object.

arrObjects

Required.  Array.  An array of strings identifying the objects to modify.

blnEnable

Optional.  Boolean.  The state, either enabled (True) or disabled (False).

Returns

Boolean

If a state is not specified,  the current receives shadows state if successful.

Boolean

If a state is specified, the previous receives shadows if successful.

Number

If arrObjects is specified, then the number of objects modified if successful.

Null

If not successful, or on error.

Example

Dim arrObjects

arrObjects = Rhino.GetObjects("Select objects")

If IsArray(arrObjects) Then

  Call Rhino.ObjectReceivesShadows(arrObjects, False)

End If

Also See

ObjectCastsShadows