ObjectType
Returns the object type.
Syntax
Rhino.ObjectType (strObject)
Parameters
strObject |
Required. String. The identifier
of the object. |
Returns
Number |
The object type if successful. The
valid object types are as follows:
Value |
Hex |
Description |
0 |
&h0 |
Unknown object |
1 |
&h1 |
Point |
2 |
&h2 |
Point cloud |
4 |
&h4 |
Curve |
8 |
&h8 |
Surface (single-face Brep) |
16 |
&h10 |
Polysurface (multiple-face Brep) |
32 |
&h20 |
Mesh |
256 |
&h100 |
Light |
512 |
&h200 |
Annotation |
4096 |
&h1000 |
Instance (Block) reference |
8192 |
&h2000 |
Text dot |
16384 |
&h4000 |
Grip |
32768 |
&h8000 |
Detail |
65536 |
&h10000 |
Hatch |
131072 |
&h20000 |
Morph control |
134217728 |
&h8000000 |
Cage |
268435456 |
&h10000000 |
Phantom |
536870912 |
&h20000000 |
Clipping plane |
1073741824 |
&h40000000 |
Extrusion |
|
Null |
If not successful, or on error. |
Example
Dim strObject, intType
strObject = Rhino.GetObject("Select
object")
If Not IsNull(strObject) Then
intType = Rhino.ObjectType(strObject)
Rhino.Print "Object type:
" & CStr(intType)
End If
Also See
ObjectsByType