ObjectsByType

Returns the identifiers of all objects based on the objects' geometry type.

Syntax

Rhino.ObjectsByType (intType [, blnSelect [, intState]])

Parameters

intType

Required.  Number.  The type(s) of geometry objects (points, curves, surfaces, meshes, etc.) that can be returned.  Object types can be added together to filter several different kinds of geometry.

Value

Hex

Description

 (Default) 0

&h0

All objects (Default)

1

&h1

Point

2

&h2

Point cloud

4

&h4

Curve

8

&h8

Surface (single-face Brep or Extrusion)

16

&h10

Polysurface (multiple-face Brep or Extrusion)

32

&h20

Mesh

256

&h100

Light

512

&h200

Annotation

4096

&h1000

Instance (Block) reference

8192

&h2000

Text dot

16384

&h4000

Grip

32768

&h8000

Detail

65536

&h10000

Hatch

131072

&h20000

Morph control

134217728

&h8000000

Cage

268435456

&h10000000

Phantom

536870912

&h20000000

Clipping plane

1073741824

&h40000000

Extrusion

blnSelect

Optional.  Boolean.  Select the objects.  If omitted, the objects are not selected (False).

intState

Optional.  Number.  The object state (normal, locked, and hidden). Object states can be added together to filter several different states of geometry.

Value

Hex

Description

(Default) 0

&h0

All objects (normal, locked, and hidden)

1

&h1

Normal objects

2

&h2

Locked objects

4

&h4

Hidden objects

Returns

Array

An array of strings identifying the objects if successful.

Null

If not successful, or on error. Object states can be added together to filter several different states of geometry.

Example

Dim arrObjects

arrObjects = Rhino.ObjectsByType(4 + 8, True)

Also See

ObjectsByColor

ObjectsByGroup

ObjectsByLayer

ObjectsByName

ObjectsByURL