BooleanIntersection

Performs a Boolean intersection operation on two sets of input surfaces and polysurfaces. For more details, see the BooleanIntersection command in the Rhino help file.

Syntax

Rhino.BooleanIntersection (arrInput0, arrInput1 [, blnDelete [, blnManifoldOnly]])

Parameters

arrInput0

Required.  Array.  The identifiers of the surfaces or polysurfaces.

arrInput1

Required.  Array.  The identifiers of the surfaces or polysurfaces.

blnDelete

Optional.  Boolean.  Delete all input objects. The default is to delete all input objects (True).

blnManifoldOnly

Optional.  Boolean.  If True (Default), then non-manifold inputs are ignored.

Returns

Array

An array containing the identifiers of the newly created objects, if successful.

Null

If not successful, or on error.

Example

Const rhObjectSurface = 8

Const rhObjectPolysurface = 16

Dim arrInput0, arrInput1

arrInput0 = Rhino.GetObjects("Select first set of surfaces or polysurfaces", rhObjectSurface + rhObjectPolysurface)

If IsArray(arrInput0) Then

arrInput1 = Rhino.GetObjects("Select second set of surfaces or polysurfaces", rhObjectSurface + rhObjectPolysurface)

If IsArray(arrInput1) Then

Rhino.BooleanIntersection arrInput0, arrInput1

End If

End If

Also See

BooleanDifference

BooleanUnion