BooleanUnion

Performs a Boolean union operation on a set of input surfaces and polysurfaces. For more details, see the BooleanUnion command in the Rhino help file.

Syntax

Rhino.BooleanUnion (arrInput [, blnDelete [, blnManifoldOnly]])

Parameters

arrInput

Required.  Array.  The identifiers of the surfaces or polysurfaces to union.

blnDelete

Optional.  Boolean.  Delete all input objects. The default is to delete all input objects (True).

blnManifoldOnly

Optional.  Boolean.  If True (Default), then non-manifold inputs are ignored.

Returns

Array

An array containing the identifiers of the newly created objects, if successful.

Null

If not successful, or on error.

Example

Const rhObjectSurface = 8

Const rhObjectPolysurface = 16

Dim arrInput

arrInput = Rhino.GetObjects("Select surfaces or polysurfaces to union", rhObjectSurface + rhObjectPolysurface)

If IsArray(arrInput) Then

Rhino.BooleanUnion arrInput

End If

Also See

BooleanDifference

BooleanUnion