IsSurfaceTrimmed

Verifies a surface object has been trimmed.

Syntax

Rhino.IsSurfaceTrimmed (strObject)

Parameters

strObject

Required.  String.  The object's identifier.

Returns

Boolean

True if successful, otherwise False.

Null

On error.

Example

Const rhObjectSurface = 8

Dim strObject

strObject = Rhino.GetObject("Select a surface", rhObjectSurface)

If Rhino.IsSurfaceTrimmed(strObject) Then

Rhino.Print "The surface is trimmed."

Else

Rhino.Print "The surface is not trimmed."

End If

Also See

IsSurface

IsSurfaceClosed

IsSurfacePeroidic

IsSurfacePlanar

IsSurfaceSingular