IsSurfaceClosed

Verifies a surface object is closed in the specified direction.  If the surface fully encloses a volume, it is considered a solid.

Syntax

Rhino.IsSurfaceClosed (strObject, intDirection)

Parameters

strObject

Required.  String.  The object's identifier.

intDirection

Required.  Number.  The direction, either 0 = U, or 1 = V.

Returns

Boolean

True if successful, otherwise False.

Null

On error.

Example

Const rhObjectSurface = 8

Dim strObject

strObject = Rhino.GetObject("Select a surface", rhObjectSurface)

If Rhino.IsSurfaceClosed(strObject, 0) Then

Rhino.Print "The surface is closed in the U direction."

Else

Rhino.Print "The surface is not closed in the U direction."

End If

Also See

IsSurface

IsSurfacePeroidic

IsSurfacePlanar

IsSurfaceSingular

IsSurfaceTrimmed