Returns a shear transformation matrix.
Rhino.XformShear (arrPlane, arrX1, arrY1, arrZ1)
arrPlane |
Required. Array (Plane). The plane, where arrPlane(0) is the fixed point. |
arrX1 |
Required. Array (3-D Vector). The x-axis scale factor. |
arrY1 |
Required. Array (3-D Vector). The y-axis scale factor. |
arrZ1 |
Required. Array (3-D Vector). The z-axis scale factor. |
Array |
The 4x4 transformation matrix. |
Null |
On error. |
arrObjects = Rhino.GetObjects("Select objects to shear")
If IsArray(arrObjects) Then
arrCPlane = Rhino.ViewCPlane
arrXform = Rhino.XformShear(arrCPlane, Array(1,1,0), Array(-1,1,0), Array(0,0,1))
Rhino.TransformObjects arrObjects, arrXform, True
End If