GetDocumentUserText

Returns user text that is stored in the document. For more details on User Text, see the discussion found in the User Data Methods summary.

Syntax

Rhino.GetDocumentUserText ([strKey])

Parameters

strKey

Optional.  String.  The key name.  If omitted or an empty string ("") is specified, all key names for the object are returned.

Returns

String

If strKey is specified, then the associated value if successful.

Array

If strKey is not specified, then an array of key names if successful.

Null

If not successful, or on error.

Example

Rhino.Print Rhino.GetDocumentUserText("Designer")

Rhino.Print Rhino.GetDocumentUserText("Notes")

Also See

IsDocumentUserText

SetDocumentUserText