SetDocumentUserText

Sets or removes user text stored in the document. For more details on User Text, see the discussion found in the User Data Methods summary.

Syntax

Rhino.SetDocumentUserText (strKey [, strValue])

Parameters

strKey

Required.  String.  The key name to set.

strValue

Optional.  String.  The string value to set. If omitted the key/value pair specified by strKey will be deleted.

Returns

Boolean

True or False indicating success or failure.

Null

If not successful, or on error.

Example

Rhino.SetDocumentUserText "Designer", "Dale Fugier"

Rhino.SetDocumentUserText "Notes", "Added some layer and updated some geometry"

Also See

GetDocumentUserText

IsDocumentUserText