Returns a list of view display modes, including those listed in the Advanced Display Modes section of Rhino's Options dialog box.
Rhino.ViewDisplayModes ([blnReturnNames [, blnHideIncompatible]])
blnReturnName |
Optional. Boolean. If True (default), then the names of the display modes are returned. If False, then the identifiers of the display modes are returned. |
blnHideIncompatible |
Optional. Boolean. If True (default), then display modes that cannot be assigned to objects, using AddObjectDisplayMode, are not returned. If False, then all object display modes are returned. |
Array |
A array of strings identifying the display mode names or identifiers if successful. |
Null |
If not successful, or on error. |
Dim arrModes, strMode
arrModes = Rhino.ViewDisplayModes(False)
For Each strMode In arrModes
Rhino.Print strMode & " = " & Rhino.ViewDisplayModeName(strMode)
Next