ViewFlatShade

Returns or sets a view's display mode to flat shaded.

Syntax

Rhino.ViewFlatShade ([strView [, blnEnable]])

Parameters

strView

Optional.  String.  The title or identifier of the view.  If omitted, the current active view is used.

blnEnable

Optional.  Boolean.  The new flat shaded display state.  If blnEnable is not specified, the current flat shaded state is returned.

Returns

Array

If blnEnable is not specified,  then the current flat shaded state if successful.

Array

If blnEnable is specified,  then the previous flat shaded state if successful.

Null

If not successful, or on error.

Example

Dim strView, blnEnable

strView = Rhino.CurrentView

blnEnable = Rhino.ViewFlatShade(strView)

If False = blnEnable Then

Rhino.ViewFlatShade strView, True

End If

Also See

ViewDisplayMode

ViewDisplayModeEx

ViewDisplayModes