Returns or sets the radius of the viewing frustum of a parallel-projected view. This function is useful when you need an absolute zoom factor for a parallel-projected view.
Rhino.ViewRadius ([strView [, dblRadius]])
strView |
Optional. String. The title or identifier of the view. If omitted, the current active view is used. |
dblRadius |
Optional. Number. The view radius. |
Number |
If dblRadius is not specified, the current view radius for the specified view if successful. |
Number |
If dblRadius is specified, the previous view radius for the specified view if successful. |
Null |
If not successful, or on error. |
Const rhParallelView = 1
Dim arrViews, strView
arrViews = Rhino.ViewNames
If IsArray(arrViews) Then
For Each strView In arrViews
If Rhino.ViewProjection(strView) = rhParallelView Then
Rhino.ViewRadius strView, 10.0
End If
Next
End If