Click or drag to resize

GH_GraphicsUtilGrid Method (Graphics, RectangleF, Int32, Int32, Color, Color)

Draw a grid.

Namespace:  Grasshopper.GUI
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public static void Grid(
	Graphics g,
	RectangleF rec,
	int densityX,
	int densityY,
	Color colorBg,
	Color colorWire
)

Parameters

g
Type: System.DrawingGraphics
Graphics object to draw with.
rec
Type: System.DrawingRectangleF
Grid rectangle.
densityX
Type: SystemInt32
Density in x direction.
densityY
Type: SystemInt32
Density in y direction.
colorBg
Type: System.DrawingColor
Background colour override, the default is 30/255 white.
colorWire
Type: System.DrawingColor
Grid line colour override, the default is 40/255 black.
See Also