Click or drag to resize

GH_GraphicsUtilShadowVertical Method (Graphics, Int32, Int32, Int32, Int32, Boolean, Color)

Draws a vertical shadow edge.

Namespace:  Grasshopper.GUI
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public static void ShadowVertical(
	Graphics g,
	int x,
	int y0,
	int y1,
	int size,
	bool right,
	Color color
)

Parameters

g
Type: System.DrawingGraphics
Graphics object to draw with.
x
Type: SystemInt32
Offset of shadow edge.
y0
Type: SystemInt32
Start of shadow edge.
y1
Type: SystemInt32
End of shadow edge.
size
Type: SystemInt32
Length of cast shadow.
right
Type: SystemBoolean
If true, shadow is drawn to the right of the elevated line.
color
Type: System.DrawingColor
Color at shadow edge.
See Also