Click or drag to resize

GH_GraphicsUtilShadowVertical Method (Graphics, Single, Single, Single, Single, Boolean, Int32)

Draws a vertical shadow edge.

Namespace:  Grasshopper.GUI
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public static void ShadowVertical(
	Graphics g,
	float x,
	float y0,
	float y1,
	float size = 10f,
	bool right = true,
	int darkness = 50
)

Parameters

g
Type: System.DrawingGraphics
Graphics object to draw with.
x
Type: SystemSingle
Offset of shadow edge.
y0
Type: SystemSingle
Start of shadow edge.
y1
Type: SystemSingle
End of shadow edge.
size (Optional)
Type: SystemSingle
Length of cast shadow.
right (Optional)
Type: SystemBoolean
If true, shadow is drawn to the right of the elevated line.
darkness (Optional)
Type: SystemInt32
Alpha component of darkness directly underneath the edge.
See Also