Click or drag to resize

GH_GraphicsUtilShadowVertical Method (Graphics, Int32, Int32, Int32, Int32, Boolean, Int32)

Draws a vertical shadow edge.

Namespace:  Grasshopper.GUI
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public static void ShadowVertical(
	Graphics g,
	int x,
	int y0,
	int y1,
	int size = 10,
	bool right = true,
	int darkness = 50
)

Parameters

g
Type: System.DrawingGraphics
Graphics object to draw with.
x
Type: SystemInt32
Offset of shadow edge.
y0
Type: SystemInt32
Start of shadow edge.
y1
Type: SystemInt32
End of shadow edge.
size (Optional)
Type: SystemInt32
Length of cast shadow.
right (Optional)
Type: SystemBoolean
If true, shadow is drawn to the right of the elevated line.
darkness (Optional)
Type: SystemInt32
Alpha component of darkness directly underneath the edge.
See Also