Click or drag to resize

GH_TooltipAssignTooltipFields Method

Set all fields of the Tooltip. You'll still need to call Show() to display the tooltip.

Namespace:  Grasshopper.GUI
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public static void AssignTooltipFields(
	string title = null,
	string text = null,
	string description = null,
	Image icon = null,
	Image diagram = null
)

Parameters

title (Optional)
Type: SystemString
The Title text on the tooltip
text (Optional)
Type: SystemString
The text content of the tooltip
description (Optional)
Type: SystemString
The block text to be displayed in the sunken area of the tooltip.
icon (Optional)
Type: System.DrawingImage
The Icon to be displayed next to the Title.
diagram (Optional)
Type: System.DrawingImage
The image to be displayed in the sunken area.
See Also