Click or drag to resize

GH_WindowsFormUtilCenterFormOnEditor Method (Window, Boolean)

Positions a Form so that it is centered on the active editor. If the editor doesn't exist or is hidden, the form will be centered on the screen instead.

Namespace:  Grasshopper.GUI
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public static void CenterFormOnEditor(
	Window F,
	bool limitToScreen
)

Parameters

F
Type: Window
The Form to adjust
limitToScreen
Type: SystemBoolean
If True, the Form won't be allowed to extend beyond the limits of the screen containing the cursor.
See Also