Click or drag to resize

GH_WindowsFormUtil Methods

Methods
  NameDescription
Public methodStatic memberCenterFormOnCursor(Form, Boolean)
Positions a Form so that it is centered around the cursor
Public methodStatic memberCenterFormOnCursor(Window, Boolean)
Positions a Form so that it is centered around the cursor
Public methodStatic memberCenterFormOnEditor(Form, Boolean)
Positions a Form so that it is centered on the active editor. If the editor doesn't exist or is hidden, the form will be centered on the screen instead.
Public methodStatic memberCenterFormOnEditor(Window, Boolean)
Positions a Form so that it is centered on the active editor. If the editor doesn't exist or is hidden, the form will be centered on the screen instead.
Public methodStatic memberCenterFormOnScreen(Form, Boolean)
Positions a Form so that it is centered on the current screen. The current screen being defined as the screen containing the cursor.
Public methodStatic memberCenterFormOnScreen(Window, Boolean)
Positions a Form so that it is centered on the current screen. The current screen being defined as the screen containing the cursor.
Public methodStatic memberCenterFormOnWindow(Form, Form, Boolean)
Positions a Form so that it is centered on the supplied window. If the window doesn't exist or is hidden, the form will be centered on the screen instead.
Public methodStatic memberCenterFormOnWindow(Window, Window, Boolean)
Positions a Form so that it is centered on the supplied window. If the window doesn't exist or is hidden, the form will be centered on the screen instead.
Top
See Also