Click or drag to resize

GH_WindowsFormUtilCenterFormOnWindow Method (Window, Window, Boolean)

Positions a Form so that it is centered on the supplied window. If the window doesn't exist or is hidden, the form will be centered on the screen instead.

Namespace:  Grasshopper.GUI
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public static void CenterFormOnWindow(
	Window F,
	Window parentWindow,
	bool limitToScreen
)

Parameters

F
Type: Window
The Form to adjust
parentWindow
Type: Window
limitToScreen
Type: SystemBoolean
If True, the Form won't be allowed to extend beyond the limits of the screen containing the cursor.
See Also