#include <RhRdkContent.h>
◆ CChildSlotIterator()
◆ ~CChildSlotIterator()
virtual CRhRdkContent::CChildSlotIterator::~CChildSlotIterator |
( |
| ) |
|
|
virtual |
◆ EVF()
virtual void* CRhRdkContent::CChildSlotIterator::EVF |
( |
const wchar_t * |
wszFunc, |
|
|
void * |
pvData |
|
) |
| |
|
virtual |
Emergency virtual function for future expansion.
Reimplemented from CRhRdkObject.
◆ NextChildSlot()
virtual bool CRhRdkContent::CChildSlotIterator::NextChildSlot |
( |
ON_wString & |
sParamNameOut, |
|
|
ON_wString & |
sChildSlotNameOut, |
|
|
ON_wString & |
sDisplayNameOut |
|
) |
| |
|
pure virtual |
Retrieve information about the next child slot.
- Parameters
-
sParamNameOut | Receives the internal name of the parameter that is associated with the child slot. |
sChildSlotNameOut | Receives the name of the child slot. |
sDisplayNameOut | Receives the display name of the child slot/parameter. |
- Returns
- true if information was retrieved, false if no more child slots.
Implemented in CRhRdkTwoColorTextureBaseCSI, and CRhRdkOneColorTextureBaseCSI.
◆ m_Context
◆ m_pContent
const CRhRdkContent* CRhRdkContent::CChildSlotIterator::m_pContent |
|
protected |
◆ m_reserved
ON__UINT_PTR CRhRdkContent::CChildSlotIterator::m_reserved |
|
protected |