Rhino C++ API  8.6
Public Member Functions | List of all members
CRhRdkContentArrayNC Class Reference

#include <RhRdkContent.h>

Inheritance diagram for CRhRdkContentArrayNC:
ON_SimpleArray< CRhRdkContent * >

Public Member Functions

void FromArrayOfConst (const CRhRdkContentArray &a)
 
void ToArrayOfConst (OUT CRhRdkContentArray &a) const
 
- Public Member Functions inherited from ON_SimpleArray< CRhRdkContent * >
 ON_SimpleArray () ON_NOEXCEPT
 construction //////////////////////////////////////////////////////// More...
 
 ON_SimpleArray (const ON_SimpleArray< CRhRdkContent * > &)
 Copy constructor. More...
 
 ON_SimpleArray (size_t)
 size_t parameter = initial capacity More...
 
virtual ~ON_SimpleArray ()
 
void Append (const CRhRdkContent * &)
 
void Append (int, const CRhRdkContent * *)
 Append copy of an array T[count]. More...
 
CRhRdkContent * & AppendNew ()
 array operations //////////////////////////////////////////////////// More...
 
CRhRdkContent * * Array ()
 The Array() function return the. More...
 
const CRhRdkContent * * Array () const
 m_a pointer value. More...
 
CRhRdkContent * * At (int)
 At(index) returns nullptr if index < 0 or index >= count. More...
 
const CRhRdkContent * * At (int) const
 
CRhRdkContent * * At (ON__INT64)
 
const CRhRdkContent * * At (ON__INT64) const
 
CRhRdkContent * * At (ON__UINT64)
 
const CRhRdkContent * * At (ON__UINT64) const
 
CRhRdkContent * * At (unsigned int)
 
const CRhRdkContent * * At (unsigned int) const
 
int BinarySearch (const CRhRdkContent * *, int(*)(const CRhRdkContent * *, const CRhRdkContent * *)) const
 See Also: ON_CompareIncreasing<T> and ON_CompareDeccreasing<T> More...
 
int BinarySearch (const CRhRdkContent * *, int(*)(const CRhRdkContent * *, const CRhRdkContent * *), int) const
 
const CRhRdkContent * * BinarySearchPtr (const CRhRdkContent * *, int(*)(const CRhRdkContent * *, const CRhRdkContent * *)) const
 
const CRhRdkContent * * BinarySearchPtr (const CRhRdkContent * *, int(*)(const CRhRdkContent * *, const CRhRdkContent * *), int) const
 
int Capacity () const
 capacity of array More...
 
int Count () const
 query /////////////////////////////////////////////////////////////// More...
 
ON__UINT32 DataCRC (ON__UINT32 current_remainder) const
 
void Destroy ()
 onfree any memory and set count and capacity to zero More...
 
void EmergencyDestroy (void)
 emergency bailout /////////////////////////////////////////////////// More...
 
void Empty ()
 Sets count to 0, leaves capacity untouched. More...
 
CRhRdkContent * * First ()
 
const CRhRdkContent * * First () const
 returns nullptr if count = 0 More...
 
bool HeapSort (int(*)(const CRhRdkContent * *, const CRhRdkContent * *))
 
void Insert (int, const CRhRdkContent * &)
 
int InsertInSortedList (const CRhRdkContent * &, int(*)(const CRhRdkContent * *, const CRhRdkContent * *))
 
int InsertInSortedList (const CRhRdkContent * &, int(*)(const CRhRdkContent * *, const CRhRdkContent * *), int)
 
CRhRdkContent * * KeepArray ()
 
CRhRdkContent * * Last ()
 
const CRhRdkContent * * Last () const
 returns nullptr if count = 0 More...
 
void MemSet (unsigned char)
 
int NewCapacity () const
 
 operator const CRhRdkContent * * () const
 
 operator CRhRdkContent ** ()
 The cast operators return a pointer. More...
 
ON_SimpleArray< CRhRdkContent * > & operator= (const ON_SimpleArray< CRhRdkContent * > &)
 
CRhRdkContent * & operator[] (int)
 
const CRhRdkContent * & operator[] (int) const
 
CRhRdkContent * & operator[] (ON__INT64)
 
const CRhRdkContent * & operator[] (ON__INT64) const
 
CRhRdkContent * & operator[] (ON__UINT64)
 
const CRhRdkContent * & operator[] (ON__UINT64) const
 
CRhRdkContent * & operator[] (unsigned int)
 
const CRhRdkContent * & operator[] (unsigned int) const
 
bool Permute (const int *)
 
void Prepend (int, const CRhRdkContent * *)
 Prepend copy of an array T[count]. More...
 
bool QuickSort (int(*)(const CRhRdkContent * *, const CRhRdkContent * *))
 See Also: ON_CompareIncreasing<T> and ON_CompareDeccreasing<T> More...
 
bool QuickSortAndRemoveDuplicates (int(*)(const CRhRdkContent * *, const CRhRdkContent * *))
 See Also: ON_CompareIncreasing<T> and ON_CompareDeccreasing<T> More...
 
virtual CRhRdkContent * * Realloc (CRhRdkContent * *, int)
 low level memory management ////////////////////////////////////////// More...
 
void Remove ()
 
virtual void Remove (int)
 
void RemoveIf (bool predicate(const CRhRdkContent * &key))
 
void RemoveValue (const CRhRdkContent * &)
 
CRhRdkContent * * Reserve (size_t)
 memory management //////////////////////////////////////////////////// More...
 
void Reverse ()
 reverse order More...
 
int Search (const CRhRdkContent * &) const
 
int Search (const CRhRdkContent * *, int(*)(const CRhRdkContent * *, const CRhRdkContent * *)) const
 See Also: ON_CompareIncreasing<T> and ON_CompareDeccreasing<T> More...
 
void SetArray (CRhRdkContent * *)
 
void SetArray (CRhRdkContent * *, int, int)
 
CRhRdkContent * * SetCapacity (size_t)
 
void SetCount (int)
 low level memory management ////////////////////////////////////////// More...
 
void SetRange (int from, int count, CRhRdkContent *)
 
void Shrink ()
 remove unused capacity More...
 
unsigned int SizeOfArray () const
 amount of memory in the m_a[] array More...
 
unsigned int SizeOfElement () const
 amount of memory in an m_a[] array element More...
 
bool Sort (ON::sort_algorithm sort_algorithm, int *, int(*)(const CRhRdkContent * *, const CRhRdkContent * *)) const
 
bool Sort (ON::sort_algorithm sort_algorithm, int *, int(*)(const CRhRdkContent * *, const CRhRdkContent * *, void *), void *) const
 
void Swap (int, int)
 swap elements i and j More...
 
unsigned int UnsignedCount () const
 
void Zero ()
 

Additional Inherited Members

- Protected Member Functions inherited from ON_SimpleArray< CRhRdkContent * >
void Move (int, int, int)
 implementation ////////////////////////////////////////////////////// More...
 
- Protected Attributes inherited from ON_SimpleArray< CRhRdkContent * >
CRhRdkContent * * m_a
 pointer to array memory More...
 
int m_capacity
 actual length of m_a[] More...
 
int m_count
 0 <= m_count <= m_capacity More...
 

Detailed Description

Non-const version of CRhRdkContentArray. Used for holding temporary non-const contents immediately after creation.

Member Function Documentation

◆ FromArrayOfConst()

void CRhRdkContentArrayNC::FromArrayOfConst ( const CRhRdkContentArray a)

Copy content pointers from a const array to this array.

◆ ToArrayOfConst()

void CRhRdkContentArrayNC::ToArrayOfConst ( OUT CRhRdkContentArray a) const

Copy content pointers from this array to a const array.