Rhino C++ API
8.18
Main Page
Related Pages
Modules
Classes
Class List
Class Index
Class Hierarchy
Class Members
All
_
a
b
c
d
e
f
g
h
i
j
k
l
m
n
o
p
q
r
s
t
u
v
w
x
y
z
~
Functions
_
a
b
c
d
e
f
g
h
i
j
k
l
m
n
o
p
q
r
s
t
u
v
w
x
y
z
~
Variables
_
a
b
c
d
e
f
g
h
i
j
k
l
m
n
o
p
q
r
s
t
u
v
w
x
y
z
Typedefs
Enumerations
a
b
c
d
e
f
g
h
i
k
l
m
n
o
p
q
r
s
t
u
v
w
Enumerator
a
b
c
d
e
f
g
h
i
j
k
l
m
n
o
p
q
r
s
t
u
v
w
x
y
z
Related Functions
c
d
g
i
o
q
r
s
t
•
All
Classes
Namespaces
Functions
Variables
Typedefs
Enumerations
Enumerator
Friends
Modules
Pages
CRhinoLicenseValidator Member List
This is the complete list of members for
CRhinoLicenseValidator
, including all inherited members.
beta_build
enum value
CRhinoLicenseValidator
build_type_force_32bit
enum value
CRhinoLicenseValidator
CRhinoLicenseValidator
()
CRhinoLicenseValidator
CRhPlugInLicenseManager
class
CRhinoLicenseValidator
friend
error_hide_message
enum value
CRhinoLicenseValidator
error_show_message
enum value
CRhinoLicenseValidator
evaluation_build
enum value
CRhinoLicenseValidator
m_build_type
CRhinoLicenseValidator
m_date_to_expire
CRhinoLicenseValidator
m_error_message
CRhinoLicenseValidator
m_lease
CRhinoLicenseValidator
m_license_count
CRhinoLicenseValidator
m_license_title
CRhinoLicenseValidator
m_product_icon
CRhinoLicenseValidator
m_product_license
CRhinoLicenseValidator
m_requires_online_validation
CRhinoLicenseValidator
m_requires_previous_version_license_verification
CRhinoLicenseValidator
m_serial_number
CRhinoLicenseValidator
OnLeaseChanged
(CRhinoLeaseChangedEventArgs &)=0
CRhinoLicenseValidator
pure virtual
PlugIn
()
CRhinoLicenseValidator
product_build_type
enum name
CRhinoLicenseValidator
ProductBuildType
()=0
CRhinoLicenseValidator
pure virtual
release_build
enum value
CRhinoLicenseValidator
result
enum name
CRhinoLicenseValidator
result_force_32bit
enum value
CRhinoLicenseValidator
SetLease
(const CRhinoLicenseLease *)
CRhinoLicenseValidator
success
enum value
CRhinoLicenseValidator
unspecified_build
enum value
CRhinoLicenseValidator
ValidateProductKey
(const wchar_t *product_key)=0
CRhinoLicenseValidator
pure virtual
VerifyLicenseKey
(const wchar_t *licenseKey, const wchar_t *validationCode, const double validationCodeInstalledDate, bool gracePeriodExpired)=0
CRhinoLicenseValidator
pure virtual
VerifyPreviousVersionLicense
(const wchar_t *license, const wchar_t *previousVersionLicense)=0
CRhinoLicenseValidator
pure virtual
~CRhinoLicenseValidator
()
CRhinoLicenseValidator
virtual
Generated on Tue Apr 8 2025 16:23:51 for Rhino C++ API by
1.8.17