- m -
- m__legacy_flags_Get()
: ON_BrepTrim
- m__legacy_flags_Set()
: ON_BrepTrim
- Macro()
: CRhinoAppShortcutKeys
- MacroBitmapID()
: CRhinoUiFile
- MacroButtonText()
: CRhinoUiFile
- MacroCount()
: CRhinoUiFile
- MacroHelpText()
: CRhinoUiFile
- MacroID()
: CRhinoUiFile
- MacroMenuText()
: CRhinoUiFile
- MacroName()
: CRhinoUiFile
- MacroRunScript()
: CRhinoUiFile
- MacroScript()
: CRhinoUiFile
- MacroToolTip()
: CRhinoUiFile
- Magnify()
: CRhinoViewport
- MainFrame()
: CRhinoApp
- MainFrameOnSize()
: CRhinoUiDockBarManager
- MainHMenu()
: CRhinoApp
, MRhinoApp
- MainRhinoIcon()
: CRhinoSkinDLL
- MainRhinoMenu()
: CRhinoSkinDLL
- MainThread()
: MRhinoApp
- MainViewport()
: CRhinoView
- MainViewportId()
: CRhinoView
- MainWindow()
: CRhinoApp
- MainWnd()
: CRhinoApp
- Major()
: RhinoVersion
- MajorCircleDegrees()
: ON_Torus
- MajorCircleRadians()
: ON_Torus
- MajorRadius()
: ON_Torus
- MajorString()
: RhinoVersion
- MajorWideString()
: RhinoVersion
- Make()
: RhRdk::Realtime::DisplayMode::Factories
- make_shared()
: IRhinoUiController
- MakeActivePage()
: IRhinoOptionsPageHost
- MakeBold()
: ON_RtfStringBuilder
- MakeButtonDibs()
: CRhinoUiTabbedSheetCtrl
- MakeChildPage()
: CRhinoWindow
- MakeClampedUniformKnotVector()
: ON_NurbsCurve
, ON_NurbsSurface
- MakeCopy()
: CRhRdkBasicMaterial
, CRhRdkBasicMaterialBase
, CRhRdkContent
, CRhRdkContentField
, CRhRdkDynamicContentField
, CRhRdkMaterial
, CRhRdkOneColorTextureBase
, CRhRdkTexturedContentField
, RhRdk::CustomRenderMeshes::IRenderMeshes::IInstance
, RhRdk::CustomRenderMeshes::IRenderMeshes::IMappingChannel
, RhRdk::CustomRenderMeshes::IRenderMeshes
- MakeCopyForPreview()
: CRhRdkContent
- MakeDefaultContextCurrent()
: CRhinoDisplayEngine_OGL
- MakeDeformable()
: ON_Brep
, ON_Geometry
, ON_InstanceRef
, ON_LineCurve
, ON_Mesh
, ON_NurbsCage
, ON_NurbsCurve
, ON_NurbsSurface
, ON_Point
, ON_PointCloud
, ON_PointGrid
, ON_PolyCurve
, ON_PolylineCurve
, ON_SubD
, ON_SumSurface
, ON_TextDot
- MakeDisplayEngine()
: RhRdk::Realtime::DisplayMode::Factory
- MakeFacename()
: ON_RtfStringBuilder
- MakeFileExtensionPattern()
: CRhRdkFileType
- MakeFullPath()
: CRhinoFileUtilities
- MakeGroupInstance()
: CRhRdkContent
- MakeIncreasing()
: ON_Interval
- MakeItalic()
: ON_RtfStringBuilder
- MakeLower()
: ON_String
, ON_wString
- MakeLowerOrdinal()
: ON_String
, ON_wString
- MakeModal()
: IRhinoSdkRenderFrame
- MakeNonRational()
: ON_BezierCage
, ON_BezierCurve
, ON_BezierSurface
, ON_MorphControl
, ON_NurbsCage
, ON_NurbsCurve
, ON_NurbsSurface
- MakeNSImage()
: CRhinoDib
- MakeOpaque()
: CRhinoDib
- MakeOwnerDraw()
: CRhinoUiButton
- MakePeriodicUniformKnotVector()
: ON_NurbsCurve
, ON_NurbsSurface
- MakePiecewiseBezier()
: ON_NurbsCurve
- MakeRational()
: ON_BezierCage
, ON_BezierCurve
, ON_BezierSurface
, ON_MorphControl
, ON_NurbsCage
, ON_NurbsCurve
, ON_NurbsSurface
- MakeReferenceTableName()
: CRhinoFileImportPlugIn
- MakeReflectSymmetric()
: ON_SubD
- MakeReverse()
: ON_String
, ON_wString
- MakeSymmetric()
: ON_SubD
- MakeTrimCurveNurb()
: ON_Brep
- MakeUnderline()
: ON_RtfStringBuilder
- MakeUndoString()
: CRhRdkContentArray
- MakeUniqueFilename()
: CRhinoFileUtilities
- MakeUpper()
: ON_String
, ON_wString
- MakeUpperOrdinal()
: ON_String
, ON_wString
- MakeValidFileName()
: CRhinoFileUtilities
- MakeValidForV2()
: ON_Brep
- MakeVisible()
: CRhinoOpenDocumentOptions
- Malloc()
: CRhinoApp
- ManagedArrays()
: ON_SubDMeshFragment
- ManagedFamilyMemberWithRichTextProperties()
: ON_Font
- ManagedFamilyMemberWithWeightStretchStyle()
: ON_Font
- ManagedFont()
: ON_Font
- ManagedFontFromRichTextProperties()
: ON_Font
- ManagedFontList()
: ON_Font
- ManagedFonts()
: ON_ManagedFonts
- ManagedFontSerialNumber()
: ON_Font
- ManagedGlyph()
: ON_FontGlyph
- ManageKnotForExperts()
: ON_NurbsCurve
- Manifest()
: CRhinoDoc
, ON_BinaryArchive
, ONX_Model
- ManifestContentVersionNumber()
: ON_ComponentManifest
- ManifestMap()
: ON_BinaryArchive
- ManualControlAllowed()
: CRhRdkSunStorage
, IRhRdkSunRO
, ON_Sun
- ManualControlOn()
: CRhRdkSunStorage
, IRhRdkSunRO
, ON_Sun
- MapCharacterOrdinal()
: ON_String
, ON_wString
- MapItemCount()
: ON_ManifestMap
- MapItemFromSourceId()
: ON_ManifestMap
- MapItemFromSourceIndex()
: ON_ManifestMap
- MappedNameCodePointCount()
: ON_NameHash
- MappedNameSha1Hash()
: ON_NameHash
- Mapping()
: CRhRdkObjectDataAccess
, IRhRdkDecal
, MappingChannel
, Mesh
, ON_Decal
, RhRdk::CustomRenderMeshes::IRenderMeshes::IMappingChannel
, RhRdk::Realtime2::ChangeQueue::MappingChannel
- MappingChannel()
: CRhRdkSimulatedTexture
, CRhRdkTexture
, MappingChannel
, ON_Displacement
, ON_Displacement::SubItem
, ON_MappingRef
, ON_ObjectRenderingAttributes
, RhRdk::Realtime2::ChangeQueue::MappingChannel
- MappingChannels()
: RhRdk::CustomRenderMeshes::IRenderMeshes::IInstance::IGeometry
, RhRdk::Realtime2::ChangeQueue::MappingChannels
, RhRdk::Realtime2::ChangeQueue::Mesh
, RhRdk::Realtime2::ChangeQueue::MeshInstance
, RhRdk::Realtime::ChangeQueue::MappingChannels
- MappingCRC()
: ON_TextureMapping
- MappingRef()
: ON_ObjectRenderingAttributes
- MappingTag()
: CRhinoCurvatureAnalysisSettings
, CRhinoDraftAngleAnalysisSettings
- MapString()
: ON_String
, ON_wString
- MapStringOrdinal()
: ON_String
, ON_wString
- MapToInside()
: IRhRdkDecal
, ON_Decal
- Margin()
: CRhinoUiDockBarCaptionButton
, IRhinoUiHolder
- Mark()
: CRhinoObject
, ON_BrepQuadFacePackSide
, ON_ClassId
, ON_SubDComponentBase
, ON_SubDComponentPtr
, ON_SubDEdgePtr
, ON_SubDFacePtr
, ON_SubDQuadFacePackSide
, ON_SubDVertexPtr
- MarkAggregateComponentStatusAsNotCurrent()
: ON_Brep
, ON_Object
, ON_SubD
- MarkAsNotCurrent()
: ON_AggregateComponentStatus
, ON_AggregateComponentStatusEx
- MarkBits()
: ON_ComponentStatus
, ON_SubDComponentBase
, ON_SubDComponentPtr
, ON_SubDEdgePtr
, ON_SubDFacePtr
, ON_SubDVertexPtr
- MarkComponents()
: ON_MeshMarker
- MarkConnectedRegion()
: ON_SubD
- MarkedEdgeCount()
: ON_SubDFace
, ON_SubDVertex
- MarkedFaceCount()
: ON_SubDEdge
, ON_SubDVertex
- MarkedVertexCount()
: ON_SubDEdge
, ON_SubDFace
- MarkFace()
: ON_MeshMarker
- MarkFoci()
: CArgsRhinoGetEllipse
- MarkFocus()
: CArgsRhinoGetParabola
- MarkVertex()
: ON_MeshMarker
- MaskBorder()
: ON_Annotation
, ON_DimStyle
, ON_TextMask
- MaskColor()
: ON_Annotation
, ON_DimStyle
, ON_TextMask
- MaskFillType()
: ON_Annotation
, ON_DimStyle
, ON_TextMask
- MaskFrameFromUnsigned()
: ON_TextMask
- MaskFrameType()
: ON_Annotation
, ON_DimStyle
, ON_TextMask
- MaskingColor()
: CRhinoUiMemDC
- MaskReadError()
: ON_BinaryArchive
- MaskTypeFromUnsigned()
: ON_TextMask
- Match()
: CRhRdkDocument
, ON_XMeshEventList
- MatchAnnotationObject()
: CRhinoAnnotation
- MatchEndTangent()
: CArgsRhinoLoft
- Matches()
: ON_GeometryFingerprint
, ON_WeightedAverageHash
- MatchPackFacesStructure()
: ON_BrepQuadFacePack
- MatchStartTangent()
: CArgsRhinoLoft
- MatchTangency()
: ON_BezierSurface
- MatchTrimEnds()
: ON_Brep
- MatchViewportAspectRatio()
: CRhinoPrintInfo
- Material()
: CRhinoMaterialTable
, CRhRdkCustomRenderMeshes
, IRhRdkCustomRenderMeshes
, IRhRdkGroundPlane
, IRhRdkPreviewSceneServer::IObject
, Material
, ON_PhysicallyBasedMaterial
, RhRdk::CustomRenderMeshes::IRenderMeshes::IInstance
, RhRdk::Realtime2::ChangeQueue::Material
- MaterialCachingEnabled()
: CRhinoDisplayPipeline
- MaterialChannel()
: CRhinoMaterial
- MaterialChannelIdFromIndex()
: ON_Material
- MaterialChannelIndex()
: ON_BrepFace
, ON_SubDFace
- MaterialChannelIndexFromId()
: ON_Material
- MaterialCount()
: CRhinoMaterialTable
- MaterialFromAttributes()
: ONX_Model
- MaterialFromId()
: ChangeQueue
, ONX_Model
, RhRdk::Realtime2::ChangeQueue
- MaterialFromIndex()
: ONX_Model
- MaterialFromLayerIndex()
: ONX_Model
- MaterialFromOriginalInstanceId()
: RhRdk::Realtime2::ChangeQueue
- MaterialId()
: GroundPlane
, Light
, Material
, MeshInstance
, RhRdk::Realtime2::ChangeQueue::GroundPlane
, RhRdk::Realtime2::ChangeQueue::Light
, RhRdk::Realtime2::ChangeQueue::Material
, RhRdk::Realtime2::ChangeQueue::MeshInstance
- MaterialInstanceId()
: CRhRdkObjectDataAccess
, IRhRdkGroundPlane
, ON_GroundPlane
- MaterialList()
: CRhRdkDocument
- MaterialPlugInId()
: ON_Material
- MaterialRef()
: ON_RenderingAttributes
- MaterialSource()
: ON_3dmObjectAttributes
, ON_MaterialRef
- MaterialTableEvent()
: CRhinoEventWatcher
, CRhinoObjectPropertiesModelessDockingDialog
, IRhinoPropertiesPanelPageEventWatcher
- MatrixForm()
: ON_Quaternion
- Max()
: IRhRdkParamBlock::IParam
, ON_2iBoundingBox
, ON_BoundingBox
, ON_Interval
- MaxClipPlanesSupported()
: CRhinoDisplayEngine
, CRhinoDisplayEngine_GDI
, CRhinoDisplayEngine_OGL
- MaxColor()
: CRhinoEdgeContinuitySettings
- MaxConcurrentTasks()
: CRhinoGetCancel
- MaxCount()
: ON_Matrix
- MaxCVIndex()
: ON_MorphControl
- MaxDecalsSupported()
: CRhinoDisplayEngine
, CRhinoDisplayEngine_OGL
- MaximizeDrawRect()
: CRhinoPrintInfo
- MaximizeRestoreView()
: CRhinoView
- MaximumAbsoluteValueAt()
: ON_PlaneEquation
- MaximumBispanCount()
: ON_SubDSurfaceNurbsFragment
- MaximumCoefficient()
: ON_PlaneEquation
- MaximumConvexCornerAngleRadians()
: ON_SubDFromMeshParameters
- MaximumConvexCornerEdgeCount()
: ON_SubDFromMeshParameters
- MaximumCoordinate()
: ON_2dPoint
, ON_2dVector
, ON_2fPoint
, ON_2fVector
, ON_3dPoint
, ON_3dSimplex
, ON_3dVector
, ON_3fPoint
, ON_3fVector
, ON_4dPoint
, ON_4fPoint
, ON_Circle
, ON_ConvexHullPoint2
, ON_ConvexHullRef
, ON_ConvexHullRefEx
, ON_ConvexPoly
, ON_Line
- MaximumCoordinateIndex()
: ON_2dPoint
, ON_2dVector
, ON_2fPoint
, ON_2fVector
, ON_3dPoint
, ON_3dVector
, ON_3fPoint
, ON_3fVector
, ON_4dPoint
, ON_4fPoint
- MaximumCustomClippingPlaneCount()
: ON_DepthImage
- MaximumDensityPointCount()
: ON_SubDMeshFragmentIterator
- MaximumDensityQuadCount()
: ON_SubDMeshFragmentIterator
- MaximumDistance()
: ON_MeshThicknessAnalysis
- MaximumDistanceTo()
: ON_BoundingBox
, ON_CurveLeafBox
, ON_CurveTreeBezier
, ON_Line
, ON_SurfaceTreeBezier
- MaximumDistanceUpperBound()
: ON_CurveTreeNode
, ON_SurfaceTreeNode
- MaximumEdgeFaceCount()
: ON_SubDVertex
- MaximumEdgeLength()
: ON_MeshParameters
- MaximumEdgeSharpness()
: ON_SubDFace
- MaximumElementId()
: ON_FixedSizePool
- MaximumEndSharpness()
: ON_SubDEdgeSharpness
- MaximumEventSerialNumber()
: ON_MeshXPointPool
- MaximumFaceEdgeCount()
: ON_SubDVertex
- MaximumIncrementalChange()
: ON_ParticleSystem
- MaximumMeshDensity()
: ON_SubDMeshFragmentIterator
- MaximumPasses()
: RhRdk::Realtime::DisplayMode::IHUDCallbacks
- MaximumPrincipalCurvature()
: ON_SurfaceCurvature
- MaximumRadius()
: ON_SurfaceCurvature
- MaximumValueAt()
: ON_PlaneEquation
- MaxLightsSupported()
: CRhinoDisplayEngine
, CRhinoDisplayEngine_OGL
- MaxObjectMappingsSupported()
: CRhinoDisplayEngine
, CRhinoDisplayEngine_OGL
- MaxPreviewCacheMB()
: CRhRdkRendererSupportOptions
- MaxPreviewSeconds()
: CRhRdkRendererSupportOptions
- MaxProceduralCommandsSupported()
: CRhinoDisplayEngine
- MaxProceduralsSupported()
: CRhinoDisplayEngine
- MaxProceduralTransformsSupported()
: CRhinoDisplayEngine
- MaxRadius()
: CRhinoGetRectangleRounded
- MaxTextureCoords()
: CRhinoDisplayEngine_OGL
- MaxTextureSize()
: CRhinoDisplayEngine_OGL
- MaxTextureUnits()
: CRhinoDisplayEngine_OGL
- MaxTileResolution()
: CRhinoPrintInfo
- MaxValue()
: CRhRdkAutomaticUIRow
- MaxYear()
: ON_Sun
- MaxZ()
: CRhinoZBuffer
- MeanCurvature()
: ON_SurfaceCurvature
- MeasuredDirectionFromUnsigned()
: ON_DimOrdinate
- MeasureItem()
: CRhinoUiComboBox
, CRhinoUiFontComboBox
, CRhinoUiListBoxEx
, CRhinoUiOptionsListCtrlComboBox
- Measurement()
: ON_Centermark
, ON_DimAngular
, ON_Dimension
, ON_DimLinear
, ON_DimOrdinate
, ON_DimRadial
- MeasureString()
: CRhinoDisplayPipeline
- MeasureTextContent()
: ON_TextContent
- MeasureTextRun()
: ON_TextContent
- MeasureTextRunArray()
: ON_TextContent
- Member()
: CRhinoGroupObject
- MemberCount()
: CRhinoGroupObject
- MemberFromBoldAndItalic()
: ON_FontFaceQuartet
- MemberFromUnsigned()
: ON_FontFaceQuartet
- Members()
: CRhinoGroup
- MemberToString()
: ON_FontFaceQuartet
- Memdup()
: CRhinoApp
- MemoryRelocate()
: CRhinoClippingPlaneObject
, CRhinoDetailViewObject
, CRhinoGroupObject
, CRhinoInstanceObject
, CRhinoLight
, CRhinoObject
, CRhinoPointCloudObject
, CRhinoPointObject
, ON_Brep
, ON_DetailView
, ON_Mesh
, ON_MorphControl
, ON_Object
, ON_SubD
- MemSet()
: ON_SimpleArray< T >
- Menu()
: CRuiUpdateUi
- MenuID()
: CRuiOnUpdateMenuItem
- MenuItemID()
: CRuiOnUpdateMenuItem
, CRuiUpdateUi
- MenuItemIndex()
: CRuiUpdateUi
- MenuItemUUID()
: CRuiUpdateUi
- MenuOrder()
: CRhRdkTask
- MenuProc()
: CRhinoContextMenu
, CRhinoContextMenuExtension
, CRhinoPopupMenu
- MenuSeparators()
: CRhRdkTask
- MenuString()
: CRhRdkTask
, IRhRdkColorPicker
- MenuUUID()
: CRuiUpdateUi
- Merge()
: CRhinoFileReadOptions
, ON_HiddenLineDrawing
, ON_SubD
, ON_XMeshPolyline
- MergeColinearBoundaryEdges()
: ON_SubDFromMeshParameters
- MergeColinearEdges()
: ON_SubD
- MergeColinearInteriorEdges()
: ON_SubDFromMeshParameters
- MergeConsecutiveEdges()
: ON_SubD
- MergeCrossingEdgeChains()
: ON_SubDEdgeChain
- MergeFaces()
: ON_Brep
, ON_SubD
- MergeFaceSets()
: ON_Mesh
, ON_SubD
- MergeFrom()
: ON_XMLNode
- Mesh()
: CRhinoGetMeshes
, CRhinoMeshObject
, CRhinoMeshRef
, CRhinoObjRef
, CRhRdkCustomRenderMeshes
, CRhRdkRenderMesh
, IRhRdkCustomRenderMeshes
, Mesh
, ON_BrepFace
, ON_Extrusion
, ON_MeshCache
, ON_MeshComponentRef
, ON_MeshNgonIterator
, ON_MeshRef
, RhRdk::CustomRenderMeshes::IRenderMeshes::IInstance::IGeometry
, RhRdk::Realtime2::ChangeQueue::Mesh
- MeshBufferingEnabled()
: CRhinoDisplayEngine
, CRhinoDisplayEngine_OGL
- MeshComponent()
: ON_Mesh
- MeshComponentRef()
: CRhinoObjRef
, ON_Mesh
, ON_MeshTopology
- MeshCount()
: CRhinoBrepObject
, CRhinoExtrusionObject
, CRhinoGetMeshes
, CRhinoInstanceObject
, CRhinoMeshObject
, CRhinoObject
, CRhinoSubDObject
, ON_MeshCache
, ON_MeshThicknessAnalysis
, ON_MeshThicknessAnalysisVertexIterator
- MeshCountForId()
: ChangeQueue
- MeshCurve()
: ON_Curve
- MeshDensity()
: ON_MeshParameters
- MeshDensityAsPercentage()
: ON_MeshParameters
- MeshDisplayAttributes()
: CRhinoBrepObject
, CRhinoObject
, CRhinoSubDObject
- Mesher()
: ON_MeshParameters
- MesherId()
: ON_MeshParameters
- Meshes()
: Mesh
- MeshEx()
: CRhRdkRenderMesh
- MeshFace()
: ON_MeshComponentRef
- MeshFaceIndex()
: ON_MeshComponentRef
- MeshFaceTree()
: ON_Mesh
- MeshForm()
: ON_TriangleMesh
- MeshFragmentCount()
: ON_SubD
, ON_SubDFaceIterator
- MeshFragmentIterator()
: CRhinoSubDDisplay
- MeshFragments()
: ON_SubDFace
- MeshFromId()
: ChangeQueue
- MeshGenerationEnabled()
: CRhinoDisplayPipeline
- MeshId()
: MeshInstance
, RhRdk::Realtime2::ChangeQueue::Mesh
, RhRdk::Realtime2::ChangeQueue::MeshInstance
- MeshIdFromMeshType()
: ON_MeshCache
- MeshIndex()
: Material
, MeshInstance
- MeshInstance()
: CRhRdkCustomRenderMeshes
, IRhRdkCustomRenderMeshes2
, MeshInstance
, RhRdk::Realtime2::ChangeQueue::MeshInstance
- MeshInstanceId()
: Material
, RhRdk::Realtime2::ChangeQueue::DynamicObject
, RhRdk::Realtime2::ChangeQueue::Material
, RhRdk::Realtime::ChangeQueue::DynamicObject
- MeshInstancesCountForBaseId()
: ChangeQueue
- MeshInverseTransform()
: ON_MeshX
- MeshLocation()
: ON_SubDDisplayParameters
- MeshMemoryLimit()
: ON_Displacement::Defaults
, ON_Displacement
- MeshModifiers()
: ON_3dmObjectAttributes
- MeshModifiersCategory()
: IRhinoSnapshotsClient
- MeshNgon()
: ON_MeshComponentRef
- MeshNgonIndex()
: ON_MeshComponentRef
- MeshParameterIdFromUnsigned()
: ON_MeshParameters
- MeshParameters()
: CRhinoDocProperties
, ON_Mesh
- MeshPart()
: ON_Mesh
- MeshQuality()
: CRhinoMeshStlUI
- MeshRef()
: CRhinoSubDObject
- MeshReference()
: ON_TriangleMesh
- MeshSelections()
: CRhinoGetObject
- MeshSharedPtr()
: ON_MeshCache
- MeshStyleFromUnsigned()
: ON_MeshParameters
- MeshTolerance()
: CRhinoMeshStlUI
- MeshTopology()
: ON_MeshComponentRef
- MeshTopologyEdge()
: ON_MeshComponentRef
- MeshTopologyEdgeIndex()
: ON_MeshComponentRef
- MeshTopologyVertex()
: ON_MeshComponentRef
- MeshTopologyVertexIndex()
: ON_MeshComponentRef
- MeshTransform()
: ON_MeshX
- MeshTree()
: ON_Mesh
- MeshType()
: ON
- MeshVertexIndex()
: CRhinoGripObject
- Metallic()
: CRhRdkMaterial::PhysicallyBased::ChildSlotNames
, CRhRdkMaterial::PhysicallyBased::ParameterNames
, ON_PhysicallyBasedMaterial
- MetersPerUnit()
: ON_UnitSystem
- MetersToUnits()
: CRhRdkSimulatedTexture
, CRhRdkTexture
- Method()
: IRhRdkDithering
, IRhRdkToneMapping
, ON_Dithering
, ON_SubDFromSurfaceParameters
- MFCViewEx()
: CRhinoView
- Mid()
: ON_Interval
, ON_String
, ON_wString
- MiddleMouseToolBar()
: CRhinoAppGeneralSettings
- Midpoint()
: ON_2dPoint
, ON_2fPoint
, ON_3dPoint
, ON_3fPoint
- MidPoint()
: ON_Arc
, ON_XMeshEdge
- MidPointOption()
: CArgsRhinoGetLine
- MidPointPrompt()
: CArgsRhinoGetLine
- MillimetersPerUnit()
: ON_UnitSystem
- MimicDigClick()
: CRhinoDigitizerManager
- Min()
: IRhRdkParamBlock::IParam
, ON_2iBoundingBox
, ON_BoundingBox
, ON_Interval
- MinCount()
: ON_Matrix
- Minimize()
: ON_SimpleMinimizer
- MinimumColumnWidth()
: CRhinoUiGridListCtrl
- MinimumConcaveCornerAngleRadians()
: ON_SubDFromMeshParameters
- MinimumConcaveCornerEdgeCount()
: ON_SubDFromMeshParameters
- MinimumCoordinate()
: ON_2dPoint
, ON_2dVector
, ON_3dPoint
, ON_3dVector
, ON_4dPoint
- MinimumCoordinateIndex()
: ON_2dPoint
, ON_2dVector
, ON_3dPoint
, ON_3dVector
, ON_4dPoint
- MinimumDistanceLowerBound()
: ON_CurveTreeNode
, ON_SurfaceTreeNode
- MinimumDistanceTo()
: ON_BoundingBox
, ON_CurveLeafBox
, ON_CurveTreeBezier
, ON_Line
, ON_SurfaceLeafBox
, ON_SurfaceTreeBezier
- MinimumDistanceUpperBound()
: ON_CurveTreeNode
, ON_SurfaceTreeNode
- MinimumEdgeFaceCount()
: ON_SubDVertex
- MinimumEdgeLength()
: ON_MeshParameters
- MinimumEdgeLengthFromTolerance()
: ON_MeshParameters
- MinimumEndSharpness()
: ON_SubDEdgeSharpness
- MinimumFaceEdgeCount()
: ON_SubDVertex
- MinimumFaceId()
: ON_SubDSectorId
- MinimumMeshDensity()
: ON_SubDMeshFragmentIterator
- MinimumPrincipalCurvature()
: ON_SurfaceCurvature
- MinimumRadius()
: ON_SurfaceCurvature
- MinimumRhino3dmVersion()
: CRhinoGetFileDialog
- MinimumSectorEdgeCount()
: ON_SubDSectorType
- MinimumSectorFaceCount()
: ON_SubDSectorType
- MinimumSize()
: IRhinoPage
- MinimumTolerance()
: ON_MeshParameters
- MinimumValueAt()
: ON_PlaneEquation
- Minor()
: RhinoVersion
- MinorCircleDegrees()
: ON_Torus
- MinorCircleRadians()
: ON_Torus
- MinorRadius()
: ON_Torus
- Minute()
: RhinoVersion
- MinutesBetweenFrames()
: ON_3dmAnimationProperties
- MinValue()
: CRhRdkAutomaticUIRow
- MinYear()
: ON_Sun
- MinZ()
: CRhinoZBuffer
- MipMappingEnabled()
: CDisplayAttributeMaterial
- Mirror()
: ON_Xform
- MirrorTransformation()
: ON_Xform
- MissingAntecedents()
: CRhinoHistoryRecord
- Modality()
: IRhRdkEditor
- Mode()
: CRhinoFileReadOptions
, CRhinoVisualAnalysisMode
, IRhRdkRenderChannels
, ON_3dmObjectAttributes
, ON_BinaryArchive
, ON_RenderChannels
- ModeFromUnsigned()
: ON_Texture
- Model()
: ONX_ModelComponentIterator
- ModelAidSettings()
: CRhinoAppSettings
- ModelAliases()
: CRhinoWorkSession
- ModelBasepoint()
: CRhinoDocProperties
- ModelComponent()
: CRhinoObject
, ON_ModelComponentReference
- ModelComponentCheck()
: CRhinoDoc
- ModelComponentId()
: ON_ModelComponentReference
- ModelComponentIndex()
: ON_ModelComponentReference
- ModelComponentNameHash()
: ON_ModelComponentReference
- ModelComponentRuntimeSerialNumber()
: ON_ModelComponentReference
- ModelComponentStatus()
: ON_ModelComponent
- ModelComponentStatusIsLocked()
: ON_ModelComponent
- ModelComponentStatusIsSet()
: ON_ModelComponent
- ModelContentVersionNumber()
: ONX_Model
- ModelCount()
: CRhinoWorkSession
- ModelEast()
: ON_EarthAnchorPoint
- ModelessUserInterfaceDocSerialNumber()
: CRhinoDoc
- ModelFolder()
: CRhinoFileUtilities
- ModelGeometryBoundingBox()
: ONX_Model
- ModelGeometryComponentFromId()
: ONX_Model
- ModelGeometryFromId()
: ONX_Model
- ModelIsVisible()
: ON_Layer
- ModelLengthUnitSystem()
: ON
, ON_3dmAnnotationContext
- ModelLocationIsSet()
: ON_EarthAnchorPoint
- ModelName()
: CRhinoDoc
, CRhinoDocProperties
- ModelNameFromSerialNumber()
: CRhinoWorkSession
- ModelNames()
: CRhinoWorkSession
- ModelNorth()
: ON_EarthAnchorPoint
- ModelObjectId()
: CRhinoObject
, ON_Light
, ON_ModelComponent
, ON_Object
- ModelPath()
: CRhinoFileUtilities
- ModelPersistentVisibility()
: ON_Layer
- ModelPoint()
: ON_EarthAnchorPoint
- ModelSerialNumber()
: ON_BinaryArchive
, ON_DimStyleContext
, ON_ModelComponent
- ModelSerialNumberIsLocked()
: ON_ModelComponent
- ModelSerialNumberIsSet()
: ON_ModelComponent
- ModelSpaceHatchScale()
: CRhinoAnnotationSettings
, CRhinoAnnotationSettingsEx
- ModelSpaceTextScale()
: CRhinoAnnotationSettings
, CRhinoAnnotationSettingsEx
- ModelToOriginalMap()
: ONX_Model
- ModelTransform()
: CRhinoDisplayEngine
, CRhinoDisplayPipeline
- ModelTransformation()
: ON_DepthImage
- ModelTransformationInverse()
: ON_DepthImage
- ModelTransformationStackCount()
: ON_DepthImage
- ModelTransformIsIdentity()
: CRhinoDisplayEngine
, CRhinoDisplayPipeline
- ModelUnits()
: CRhinoDoc
, CRhinoDocProperties
- ModelUnitsAndTolerances()
: CRhinoDocProperties
- ModelUnitSystem()
: CRhinoDimStyleContext
, CRhinoFileReadOptions
, ON_DimStyleContext
- ModelUnitSystemScale()
: CRhinoFileReadOptions
- ModelURL()
: CRhinoDocProperties
- ModifiedValueControlColor()
: CRhinoUiPaintColorSettings
- ModifyAlias()
: CRhinoAppAliasList
- ModifyAliasMacro()
: CRhinoAppAliasList
- ModifyAliasName()
: CRhinoAppAliasList
- ModifyAttributes()
: CRhinoGripObject
, CRhinoObject
- ModifyContent()
: CRhRdkContentUndo
, IRhRdkContentUndo
- ModifyDimStyle()
: CRhinoDimStyleTable
, ON_DimStyleContext
- ModifyEditFieldsStyle()
: CRhinoUiPointEdit
- ModifyGridItem()
: CRhinoUiGridListCtrl
- ModifyGroup()
: CRhinoGroupTable
- ModifyHatchPattern()
: CRhinoHatchPatternTable
- ModifyInstanceDefinition()
: CRhinoInstanceDefinitionTable
- ModifyInstanceDefinitionGeometry()
: CRhinoInstanceDefinitionTable
- ModifyLayer()
: CRhinoLayerTable
- ModifyLight()
: CRhinoLightTable
, CRhRdkLightManagerSupport
- ModifyLinetype()
: CRhinoLinetypeTable
, CRhinoUiLinetypeListCtrl
- ModifyListStyle()
: CRhinoUiOptionsListCtrl
- ModifyMaterial()
: CRhinoMaterialTable
- ModifyNgon()
: ON_Mesh
- ModifyObjectAttributes()
: CRhinoDoc
- ModifyObjectAttributesHelper()
: CRhinoHistoryManager
- ModifyPage()
: IRhinoPropertiesPanelPageHost
- ModifyTextureMapping()
: CRhinoTextureMappingTable
- ModlessDockingDialogManager()
: CRhinoUiManager
- ModuleState()
: CRhinoContextMenuExtension
, CRhinoDoc
- MonitorFromPoint()
: CRhinoUiMultiMonitor
- MonitorFromRect()
: CRhinoUiMultiMonitor
- MonitorRectFromPoint()
: CRhinoUiMultiMonitor
- MonitorRectFromRect()
: CRhinoUiMultiMonitor
- MonitorRectFromWindow()
: CRhinoUiMultiMonitor
- MonitorRects()
: CRhinoApp
- MonochromeModeId()
: CRhinoDisplayAttrsMgr
- Month()
: RhinoVersion
- Morph()
: ON_BezierCage
, ON_BezierCurve
, ON_BezierSurface
, ON_Brep
, ON_Geometry
, ON_LineCurve
, ON_Mesh
, ON_MorphControl
, ON_NurbsCage
, ON_NurbsCurve
, ON_NurbsSurface
, ON_Plane
, ON_Point
, ON_PointCloud
, ON_PolyCurve
, ON_PolylineCurve
, ON_SubD
, ON_SubDEdgeChainCurve
, ON_TextDot
- Morph4dPoint()
: ON_SpaceMorph
- MorphControl()
: CRhinoObjectGrips
- MorphObject()
: CRhinoDoc
- MorphPoint()
: CRhinoBendSpaceMorph
, CRhinoFlowSpaceMorph
, CRhinoMaelstromSpaceMorph
, CRhinoSplopSpaceMorph
, CRhinoSporphSpaceMorph
, CRhinoStretchSpaceMorph
, CRhinoTaperSpaceMorph
, CRhinoTwistSpaceMorph
, ON_BezierCageMorph
, ON_CageMorph
, ON_MorphControl
, ON_SpaceMorph
- MorphPointList()
: ON_SpaceMorph
- MorphPointLocalizerHelper()
: ON_MorphControl
- MorphPointVarient1Helper()
: ON_MorphControl
- MorphPointVarient2Helper()
: ON_MorphControl
- MorphVector()
: ON_SpaceMorph
- MotifCount()
: ON_Symmetry
- MotifTransformation()
: ON_Symmetry
- MouseAdjustLensLength()
: CRhinoViewport
- MouseDollyZoom()
: CRhinoViewport
- MouseInOutDolly()
: CRhinoViewport
- MouseLateralDolly()
: CRhinoViewport
- MouseMagnify()
: CRhinoViewport
- MouseMoved()
: CRhinoGetPoint
- MouseOkToDisplayToolTip()
: CRhinoUiButton
- MouseOrGestureViewZoom()
: CRhinoView
- MouseOverHighlight()
: CRhinoAppSettings
- MouseOverHighlightSubObjects()
: CRhinoAppSettings
- MouseOverThisButton()
: CRhinoUiButton
- MousePickboxRadius()
: CRhinoAppSettings
- MouseRotateCamera()
: CRhinoViewport
- MouseRotateView()
: CRhinoViewport
- MouseSettings()
: CRhinoAppSettings
- MouseTilt()
: CRhinoViewport
- MouseTrackballVector()
: CRhinoViewport
- Move()
: CRhinoUiDockBarTab
, CRhinoUiExpandableTabCtrl_New
, IRhinoUiWindow
, IRhRdkAutomaticUI
, ON_ClassArray< T >
, ON_SimpleArray< T >
- MoveAfter()
: ON_XMLNode
- MoveBefore()
: ON_XMLNode
- MoveDown()
: CRhRdkPostEffectPlugInManager
- MoveDownPossible()
: CRhRdkPostEffectPlugInManager
- MoveFile()
: CRhinoFileUtilities
- MoveGrip()
: CRhinoGripObject
- MoveGripHelper()
: CRhinoGripObject
- MoveItemDown()
: CRhinoUiListBoxEx
- MoveItemUp()
: CRhinoUiListBoxEx
- MoveItemWindow()
: CRhinoUiOptionsListCtrlCheckBox
, CRhinoUiOptionsListCtrlComboBox
, CRhinoUiOptionsListCtrlEditBox
, CRhinoUiOptionsListCtrlIPAddress
, CRhinoUiOptionsListCtrlItem
, CRhinoUiOptionsListCtrlPointEditBox
, CRhinoUiOptionsListCtrlPushButton
, CRhinoUiOptionsListCtrlRadioButtonColumn
, CRhinoUiOptionsListCtrlSeparator
, CRhinoUiOptionsListCtrlStaticText
- MoveNamedConstructionPlane()
: CRhinoDocProperties
- MoveNamedView()
: CRhinoDocProperties
- MovePage()
: CRhinoUiTabbedSheetCtrlItem
- MovePostEffectBefore()
: ON_PostEffects
- MoveSelectedPoints()
: IRhRdkCustomCurveCtrl
- MovesWithAssociatedObjects()
: CRhinoWidget
- MoveTo()
: CRhinoDisplayEngine
- MoveToLineTo()
: CRhinoDisplayEngine
- MoveToNextIsoSideTrim()
: ON_BrepQuadFacePackSide
- MoveToStripEndTagged()
: ON_BrepQuadFacePackSide
- MoveUp()
: CRhRdkPostEffectPlugInManager
- MoveUpPossible()
: CRhRdkPostEffectPlugInManager
- MoveUserData()
: ON_Object
- MoveUserDataFrom()
: ON_UserDataHolder
- MoveUserDataTo()
: ON_UserDataHolder
- MoveWindow()
: CRhinoView
, CRhRdkRenderWindowCustomDlg
, IRhRdkRenderWindowCustomDlg
, IRhRdkThumbnails
- MoveWindowRect()
: CRhinoPrintInfo
- MoveWnd()
: CRhinoUiDockBarTab
- MRhinoApp()
: MRhinoApp
- MruCommandList()
: CRhinoApp
, CRhinoDoc
- MRUDisplayString()
: CRhinoScriptContext
- MRUDisplayStringPointer()
: CRhinoScriptContext
- MruFileName()
: CRhinoEmapAnalysisSettings
- MruFileNameCount()
: CRhinoEmapAnalysisSettings
- MruMenuString()
: CRhinoApp
, CRhinoDoc
- MruRemoveFileName()
: CRhinoEmapAnalysisSettings
- MsgString()
: CRhinoUiTabbedSheetCtrlMsg
- MultiByteDecode()
: ON_String
- MultiByteEncode()
: ON_wString
- MultiPassDrawBackground()
: CRhinoDisplayPipeline_OGL
- MultiPassDrawMiddleground()
: CRhinoDisplayPipeline_OGL
- MultiPassInitFrameBuffer()
: CRhinoDisplayPipeline_OGL
- Multiply()
: ON_ArithmeticCalculator
, ON_Matrix
- MultiplyBy()
: CRhRdkColor
- MultiplyObjectTransform()
: CRhinoDisplayPipeline
- MultiSelect()
: IRhRdkCustomCurveCtrl
- MultithreadedTextureEvaluation()
: CRhRdkRendererSupportOptions