- s -
- SafeFrame()
: CRhinoDoc
, CRhRdkDocument
, ON_3dmRenderSettings
- SafeMFCDoc()
: CRhinoDoc
- SafeMFCView()
: CRhinoView
- SameSymmetricObjectGeometry()
: ON_Symmetry
- SameSymmetricObjectTopology()
: ON_Symmetry
- Sanitize()
: ON_SubDEdgeSharpness
- SanitizeDomain()
: ON_PolyCurve
- Saturation()
: CRhRdkColor
, ON_Color
- Save()
: CRhinoDirectoryManager
, CRhinoLayerState
, CRhinoSaveAndRestoreAppFileReadOptions
, CRhRdkContentIOPlugIn
, IRhRdkContentIOPlugIn
- Save3dmAnalysisMesh()
: ON_BinaryArchive
- Save3dmAnalysisMeshObjectTypeFlags()
: ON_BinaryArchive
- Save3dmPreviewImage()
: ON_BinaryArchive
- Save3dmRenderMesh()
: ON_BinaryArchive
- Save3dmRenderMeshObjectTypeFlags()
: ON_BinaryArchive
- SaveAllModified()
: CRhinoApp
- SaveAllModifiedDocuments()
: CRhinoDoc
- SaveAsImage()
: CRhRdkTexture
- SaveAsV3()
: CRhinoPlugIn
- SaveBackBuffer()
: CRhinoDisplayEngine
, CRhinoDisplayEngine_GDI
, CRhinoDisplayEngine_OGL
, CRhinoDisplayPipeline
- SaveCompressedTextureFiles()
: CRhRdkRendererSupportOptions
- SaveCustomRenderFile()
: CRhRdkRenderPlugIn
- SavedCSN()
: CRhRdkContent
- SaveDepthBuffer()
: CRhinoDisplayEngine
, CRhinoDisplayEngine_OGL
, CRhinoDisplayPipeline
- SavedFileReadOptions()
: CRhinoSaveAndRestoreAppFileReadOptions
- SavedLevelOfDetail()
: ON_TextLogLevelOfDetail
- SavedMainMenu()
: CRhinoApp
- SaveDocument()
: CRhinoDoc
, IRhinoSnapshotsClient
- SavedSubdivisionPoint()
: ON_SubDComponentBase
- SavedSubdivisionPointIsSet()
: ON_SubDComponentBase
- SaveGraphicsState()
: CRhinoDisplayEngine_GDI
- SaveGripStatus()
: CRhinoCopyGripsHelper
- SaveImage()
: CRhRdkSdkRender
- SaveLoadProtectionToRegistry()
: CRhinoPlugIn
- SaveModified()
: CRhinoDoc
- SaveObject()
: IRhinoSnapshotsClient
- SaveOriginalObjectIdAndComponentIndex()
: ON_Squisher
, ON_SquisherImpl
- SaveProfile()
: CDisplayPipelineAttributes
, CRhinoAppAliasList
, CRhinoAppAppearanceSettings
, CRhinoAppChooseOneObjectSettings
, CRhinoAppContextMenuSettings
, CRhinoAppCursorToolTipSettings
, CRhinoAppDontRepeatCommandSettings
, CRhinoAppFileSettings
, CRhinoAppGeneralSettings
, CRhinoAppGridSettings
, CRhinoAppModelAidSettings
, CRhinoAppMouseSettings
, CRhinoAppSelectionFilterSettings
, CRhinoAppSettings
, CRhinoAppShortcutKeys
, CRhinoAppSmartTrackSettings
, CRhinoAppSpaceBallSettings
, CRhinoAppViewSettings
, CRhinoCommand
, CRhinoCurvatureAnalysisSettings
, CRhinoCurvatureGraphSettings
, CRhinoDigitizerManager
, CRhinoDirectionAnalysisSettings
, CRhinoDirectoryManager
, CRhinoDisplayAttrsMgr
, CRhinoDisplaySettings
, CRhinoDraftAngleAnalysisSettings
, CRhinoEdgeAnalysisSettings
, CRhinoEdgeContinuitySettings
, CRhinoEmapAnalysisSettings
, CRhinoEndAnalysisSettings
, CRhinoHistoryManager
, CRhinoMeshDensity
, CRhinoMeshStlUI
, CRhinoOpenGLSettings
, CRhinoPlugIn
, CRhinoThicknessAnalysisSettings
, CRhinoUiPaintColorSettings
, CRhinoWidgetColorSettings
, CRhinoZebraAnalysisSettings
, DisplayAttrsMgrList
, DisplayAttrsMgrListDesc
- SaveProfile3dPoint()
: CRhinoProfileContext
- SaveProfile3dVector()
: CRhinoProfileContext
- SaveProfileBinary()
: CRhinoProfileContext
, CRhinoRegProfileContext
- SaveProfileBool()
: CRhinoProfileContext
, CRhinoPropListProfileContext
- SaveProfileColor()
: CRhinoProfileContext
, CRhinoPropListProfileContext
- SaveProfileDouble()
: CRhinoProfileContext
, CRhinoPropListProfileContext
- SaveProfileInt()
: CRhinoProfileContext
, CRhinoPropListProfileContext
- SaveProfileLegacyPlugInMeshParameters()
: CRhinoProfileContext
- SaveProfileMeshParameters()
: CRhinoProfileContext
- SaveProfilePoint()
: CRhinoProfileContext
- SaveProfileRect()
: CRhinoProfileContext
- SaveProfileRGBA()
: CRhinoProfileContext
, CRhinoPropListProfileContext
- SaveProfileString()
: CRhinoIniProfileContext
, CRhinoProfileContext
, CRhinoPropListProfileContext
, CRhinoRegProfileContext
- SaveProfileStringDictioary()
: CRhinoProfileContext
- SaveProfileUuid()
: CRhinoProfileContext
- SaveProfileXform()
: CRhinoProfileContext
- SaveRenderedImage()
: CRhinoRenderPlugIn
- SaveRenderImageAs()
: IRhinoSdkRenderFrame
, IRhinoSdkRenderFrameEx2
, IRhRdkRenderWindow
- SaveSettings()
: CRhinoLayer
, CRhinoPlugIn
, CRhinoPrintInfo
- SaveSnapshot()
: CRhinoDocProperties
- SaveState()
: CRhinoUiDockBar
- SaveToBuffer()
: ON_EmbeddedFile
- SaveToFile()
: CRhRdkSunStorage
, IRhRdkSunRO
, ON_EmbeddedFile
- SaveToLibraryFile()
: CRhRdkContent
- SaveToLibraryFile_Internal()
: CRhRdkContent
- SaveToSoloStorage()
: CRhRdkLightManagerSupport
- SaveToXMLNode()
: ON_Sun
- SaveViewChanges()
: CRhinoAppSettings
- Scalar()
: ON_Quaternion
- Scale()
: CRhinoDpi
, ON_3dmUnitsAndTolerances
, ON_BezierCage
, ON_BezierCurve
, ON_BezierSurface
, ON_DimStyle
, ON_FontMetrics
, ON_Geometry
, ON_Matrix
, ON_TextBox
, ON_Xform
- ScaleAsString()
: ON_ScaleValue
- ScaleAsStringPointer()
: ON_ScaleValue
- ScaleBackgroundToFit()
: ON_3dmRenderSettings
- ScaleBlendTangents()
: RhinoSdkBlend
- ScaleConrolPoints()
: ON_BezierCurve
- ScaledDPI()
: CRhinoPrintInfo
- ScaleFormatFromUnsigned()
: CRhinoDetailViewObject
- ScaleGripDistance()
: CRhinoGumballFrame
- ScaleGripPoint()
: CRhinoGumballFrame
- ScaleHeight()
: CArgsRhinoRailRevolve
- ScaleLeftLength_mm()
: ON_DimStyle
- ScaleModeX()
: IRhRdkCustomCurveCtrl
- ScaleModeY()
: IRhRdkCustomCurveCtrl
- ScaleObjects()
: CRhinoDoc
- ScaleOverrideDimstyle()
: ON_Annotation
- ScalePattern()
: ON_Hatch
- ScaleRightLength_mm()
: ON_DimStyle
- ScaleStringFormatFromUnsigned()
: ON_ScaleValue
- ScaleStringParseSettings()
: ON_ScaleValue
- ScaleTransformation()
: ON_Xform
- ScaleValue()
: ON_DimStyle
- Scan()
: ON_String
, ON_wString
- ScanBuffer()
: ON_String
, ON_wString
- ScanBufferVargs()
: ON_String
, ON_wString
- ScanWidth()
: CRhinoDib
- SceneBoundingBox()
: IRhRdkSdkRenderMeshIterator
- ScreenCaptureToBitmap()
: CRhinoView
- ScreenDpi()
: CRhinoDpi
- ScreenHeight()
: CRhinoViewport
- ScreenLength()
: CRhinoDisplayEngine
- ScreenPointInBoundary()
: CRhinoDetailViewObject
- ScreenPortHeight()
: ON_Viewport
- ScreenPortSize()
: ON_Viewport
- ScreenPortWidth()
: ON_Viewport
- ScreenToClient()
: CRhinoView
- ScreenToClip()
: CRhinoDisplayEngine
, ON_Xform
- ScreenToClipInverse()
: CRhinoDisplayEngine
- ScreenWidth()
: CRhinoViewport
- Script()
: CRhinoScriptContext
- ScriptCode()
: ON_Locale
- ScriptGetNewNameQuery()
: CRhinoComponentNameConflictUI
- ScriptMode()
: CRhinoGetFileDialog
- ScriptPointer()
: CRhinoScriptContext
- ScriptQuery()
: CRhinoComponentNameConflictUI
- ScriptQueryGetGetNamePrompt()
: CRhinoComponentNameConflictUI
- ScriptQueryGetGetOptionPrompt()
: CRhinoComponentNameConflictUI
- ScrollPos()
: CRhinoUiDialogScrollHelper
- ScrollTabClientPoint()
: CRhinoUiExpandableTabCtrl
, CRhinoUiExpandableTabCtrlItem
- ScrollTabClientRect()
: CRhinoUiExpandableTabCtrl
, CRhinoUiExpandableTabCtrlItem
- ScrollTextDialogToBottom()
: CRhinoTextOut
- ScrollToOrigin()
: CRhinoUiDialogScrollHelper
- SdkRender()
: IRhRdkRenderSession
, IRhRdkRenderWindow
- SdkServiceRelease()
: CRhinoApp
- SDKServiceRelease()
: CRhinoPlugInInfo
- SdkVersion()
: CRhinoApp
- SDKVersion()
: CRhinoPlugInInfo
- SealAdjacentSides()
: ON_SubDMeshFragment
- SealNormals()
: ON_SubDMeshFragment
- SealPoints()
: ON_SubDMeshFragment
- Search()
: ON_ClassArray< T >
, ON_RTree
, ON_SimpleArray< T >
- Search2d()
: ON_RTree
- SearchPath()
: CRhinoDirectoryManager
- SearchPathCount()
: CRhinoDirectoryManager
- SearchPathCountEntry()
: CRhinoDirectoryManager
- SearchPathEntryPrefix()
: CRhinoDirectoryManager
- SearchPathKey()
: CRhinoDirectoryManager
- Second()
: ON_SubDComponentPtrPair
- SecondarySnapModes()
: CRhinoSnapEvent
- SecondaryText()
: ON_TextDot
- SecondaryTextString()
: CRhinoTextDot
- SecondDiameterPrompt()
: CArgsRhinoGetSpiral
- SecondDirectionCount()
: CArgsRhinoGetPlane
- SecondDirectionMinCount()
: CArgsRhinoGetPlane
- SecondIsNotNull()
: ON_SubDComponentPtrPair
- SecondIsNull()
: ON_SubDComponentPtrPair
- SecondMeshDensityDirectionPrompt()
: CArgsRhinoGetPlane
- SecondPoint()
: CArgsRhinoGetEllipse
, CArgsRhinoGetPlane
, CArgsRhinoGetPolygon
- SecondPointPrompt()
: CArgsRhinoGetLine
- SecondPointPrompt3Point()
: CArgsRhinoGetPlane
- SecondPointPromptCenter()
: CArgsRhinoGetPlane
- SecondPointPromptCorners()
: CArgsRhinoGetPlane
- SecondPointPromptVertical()
: CArgsRhinoGetPlane
- SecondPrompt()
: CArgsRhinoGetCurve
, CArgsRhinoGetEllipse
, CArgsRhinoGetSubCurve
- SecondRadius()
: CArgsRhinoGetSpiral
, CArgsRhinoGetTubeExtra
- SecondRadiusPrompt()
: CArgsRhinoGetSpiral
, CArgsRhinoGetTubeExtra
- Section()
: CRhinoProfileContextIterator
, ON_RtfStringBuilder
, ON_TextBuilder
, ON_TextRunBuilder
- SectionAttributesEqual()
: ON_SectionStyle
- SectionAttributesSource()
: ON_3dmObjectAttributes
- SectionAttributesSourceFromUnsigned()
: ON
- SectionBehavior()
: ON_3dmView
- SectionCount()
: CRhinoProfileContextIterator
, IRhRdkAutomaticUI
- SectionExists()
: IRhRdkAutomaticUI
- SectionFillRule()
: ON_SectionStyle
- SectionFillRuleFromUnsigned()
: ON
- SectionId()
: CRhRdkContentField
- SectionLabelStyleFromUnsigned()
: ON
- SectionOptions()
: CRhRdkSunDialog
- Sections()
: CRhinoProfileContextIterator
- SectorArea()
: ON_Arc
- SectorAreaCentroid()
: ON_Arc
- SectorCoefficient()
: ON_SubDSectorType
- SectorCoefficientCalculationError()
: ON_SubDSectorType
- SectorEdgeCountFromFaceCount()
: ON_SubDSectorType
- SectorFaceCount()
: ON_SubDSectorId
- SectorFaceCountFromEdgeCount()
: ON_SubDSectorType
- SectorPointRingCountFromEdgeCount()
: ON_SubDSectorType
- SectorPointRingCountFromFaceCount()
: ON_SubDSectorType
- SectorRingSubD()
: ON_SubDSectorType
- SectorSurfacePointForExperts()
: ON_SubDVertex
- SectorTypeHash()
: ON_SubDSectorType
- Seed()
: ON_RandomNumberGenerator
- Seek()
: ON_Buffer
, ON_FileStream
- Seek3dmChunkFromCurrentPosition()
: ON_BinaryArchive
- Seek3dmChunkFromStart()
: ON_BinaryArchive
- SeekBackward()
: ON_BinaryArchive
- SeekForward()
: ON_BinaryArchive
- SeekFromCurrentPosition()
: ON_Buffer
, ON_FileStream
- SeekFromEnd()
: ON_Buffer
, ON_FileStream
- SeekFromStart()
: ON_BinaryArchive
, ON_Buffer
, ON_FileStream
- Segment()
: ON_Linetype
, ON_Polyline
, ON_XMLSegmentedStream
- SegmentArea()
: ON_Arc
- SegmentAreaCentroid()
: ON_Arc
- SegmentCount()
: CRhinoPolyEdge
, ON_Linetype
, ON_PolyEdgeCurve
, ON_Polyline
- SegmentCurve()
: CRhinoPolyEdge
, ON_PolyCurve
, ON_PolyEdgeCurve
- SegmentCurveParameter()
: ON_PolyCurve
- SegmentCurves()
: ON_PolyCurve
- SegmentDirection()
: ON_Polyline
- SegmentDomain()
: ON_PolyCurve
- SegmentIndex()
: ON_PolyCurve
- SegmentObjRef()
: CRhinoPolyEdgeSegment
- SegmentObjRefCount()
: CRhinoPolyEdgeSegment
- SegmentParameters()
: ON_PolyCurve
- Segments()
: ON_CurvePiping::Defaults
, ON_CurvePiping
, ON_Linetype
- SegmentTangent()
: ON_Polyline
- SegmentTypeFromUnsigned()
: ON_LinetypeSegment
- SelChangedMessageNumber()
: IRhRdkThumbnails
- SelChangingMessageNumber()
: IRhRdkThumbnails
- Select()
: CRhinoObject
, CRhinoPolyEdge
, CRhinoPolyEdgeSegment
- SelectAllPoints()
: IRhRdkCustomCurveCtrl
- SelectContent()
: IRhRdkContents
- SelectDimToContinue()
: CRhinoGetDimLinear
- SelectedButton()
: CRhinoUiOptionsListCtrlRadioButtonColumn
- SelectedCount()
: ON_AggregateComponentStatus
, ON_AggregateComponentStatusEx
- SelectedGripColor()
: CRhinoAppSettings
- SelectedLayer()
: CRhinoUiLayerListCtrl
- SelectedLayerIndex()
: CRhinoLayerComboBox
, CRhinoUiLayerComboBox
- SelectedLayers()
: CRhinoUiLayerListCtrl
- SelectedObjectColor()
: CRhinoAppAppearanceSettings
, CRhinoAppSettings
- SelectedObjectCornerColor()
: CRhinoAppSettings
- SelectedObjectCornerLength()
: CRhinoAppSettings
- SelectedObjectCornerThickness()
: CRhinoAppSettings
- SelectedObjectCount()
: CRhinoObjectPropertiesModelessDockingDialog
- SelectedObjectFilter()
: CRhinoFileWriteOptions
- SelectedPersistentCount()
: ON_AggregateComponentStatus
, ON_AggregateComponentStatusEx
- SelectedPrintWidth()
: CRhinoUiPrintWidthListCtrl
- SelectedShade()
: CRhinoViewport
- SelectedState()
: ON_ComponentStatus
- SelectedStyleIndex()
: CRhinoDimStyleComboBox
- SelectedSubobjectFilter()
: CRhinoFileWriteOptions
- SelectGrips()
: CRhinoObjectGrips
- SelectionContiguous()
: CRhinoUiGridListCtrl
- SelectionDepth()
: CRhinoObjRef
- SelectionDistance()
: CRhinoObjRef
- SelectionFilterSettings()
: CRhinoAppSettings
- SelectionMap()
: CRhinoDisplayPipeline
- SelectionMethod()
: CRhinoObjRef
- SelectionPoint()
: CRhinoObjRef
- SelectionStyle()
: CRhinoObjRef
- SelectionView()
: CRhinoObjRef
- SelectionViewDetailSerialNumber()
: CRhinoObjRef
- SelectionWindowCrossingFillColor()
: CRhinoAppAppearanceSettings
- SelectionWindowCrossingStrokeColor()
: CRhinoAppAppearanceSettings
- SelectionWindowFillColor()
: CRhinoAppAppearanceSettings
- SelectionWindowStrokeColor()
: CRhinoAppAppearanceSettings
- SelectItem()
: CRhinoUiGridListCtrl
- SelectItemIndex()
: CRhinoUiGridListCtrl
- SelectiveClippingOption()
: ON_HiddenLineDrawing
, ON_HLD_Object
- SelectLinetype()
: CRhinoUiLinetypeListCtrl
- SelectLinetypeIndex()
: CRhinoUiLinetypeListCtrl
- SelectObjects()
: CRhinoTransformCommand
- SelectOnMouseMove()
: CRhinoUiPopuUpListBox
- SelectSubDComponent()
: CRhinoSubDObject
- SelectSubObject()
: CRhinoBrepObject
, CRhinoCurveObject
, CRhinoExtrusionObject
, CRhinoGroupObject
, CRhinoInstanceObject
, CRhinoMeshObject
, CRhinoObject
, CRhinoPointCloudObject
, CRhinoSubDObject
- SelFilter()
: CRhinoSelCommand
- SelSubObjectFilter()
: CRhinoSelSubObjectCommand
- SendChangeWhenDragging()
: CRhRdkSdkNumberEdit
- SendCharToCommandWnd()
: CRhinoApp
- SendCommandWindowPrintToConsole()
: CRhinoApp
- SendCommandWindowPrintToConsoleEnabled()
: CRhinoApp
- SendKeyDownToCommandWnd()
: CRhinoApp
- SendParentNotification()
: CRhinoUiExpandableTabCtrl
, CRhinoUiOptionsListCtrl
- SendPoint()
: CRhinoDigitizerPlugIn
- SendRay()
: CRhinoDigitizerPlugIn
- SendSelChangedMessage()
: CRhinoUiTabbedSheetCtrl
- SendTabbedSheetCustomMessage()
: CRhinoUiTabbedSheetCtrl
- SendTaskRequestExecute()
: IRhRdkTaskOrigin
- SendTaskRequestUpdate()
: IRhRdkTaskOrigin
- SeparateInteriorEdge()
: ON_SubD
- SeparateInteriorEdgeChains()
: ON_SubD
- SeparateInteriorEdges()
: ON_SubD
- SeparateNgons()
: ON_Mesh
- SeparateVertex()
: ON_SubD
- Separator()
: CRhRdkContent::DumpContext
- SeparatorLabelBkGrndColor()
: CRhinoUiOptionsListCtrl
- SeparatorLabelTextColor()
: CRhinoUiOptionsListCtrl
- SerializeStatus()
: CRhinoDoc
- SerialNumber()
: CRhinoApp
, CRhinoEventWatcher
, CRhinoGet
, CRhinoGetObject
- ServiceReleaseString()
: RhinoVersion
- ServiceReleaseWideString()
: RhinoVersion
- Set()
: CRhinoDib::Pixel
, CRhinoStringDictionary
, CRhRdkColor
, IRhRdkCurrentEnvironment
, IRhRdkNewContentCtrl::IAssignBy
, ON_2dPoint
, ON_2dVector
, ON_2fPoint
, ON_2fVector
, ON_3dPoint
, ON_3dVector
, ON_3fPoint
, ON_3fVector
, ON_4dPoint
, ON_4fPoint
, ON_BoundingBox
, ON_BoundingBoxAndHash
, ON_COMPONENT_INDEX
, ON_CurveLeafBox
, ON_DepthImageTriangleMesh
, ON_Interval
, ON_MappingTag
, ON_MeshComponentRef
, ON_MeshCurvatureStats
, ON_ModelComponentContentMark
, ON_PlaneEquation
, ON_Quaternion
, ON_SubDQuadNeighborhood
, ON_SurfaceLeafBox
, ON_SurfaceProperties
, ON_wString
, RhRdk::CustomRenderMeshes::IRenderMeshes::ProviderTracking::ITracker
- Set2dCenterPoint()
: ON_Centermark
, ON_DimAngular
, ON_DimRadial
- Set2dDefPoint1()
: ON_DimAngular
, ON_DimLinear
- Set2dDefPoint2()
: ON_DimAngular
, ON_DimLinear
- Set2dDefPt()
: ON_DimOrdinate
- Set2dDimlinePoint()
: ON_DimAngular
, ON_DimLinear
, ON_DimRadial
- Set2dLeaderPt()
: ON_DimOrdinate
- Set2dPointValue()
: CRhinoUiRegistry
- Set2dRadiusPoint()
: ON_DimRadial
- Set2dTextPoint()
: ON_Dimension
- Set3dBasePoint()
: ON_DimOrdinate
- Set3dCenterPoint()
: ON_Centermark
, ON_DimRadial
- Set3dDefPoint1()
: ON_DimLinear
- Set3dDefPoint2()
: ON_DimLinear
- Set3dDefPt()
: ON_DimOrdinate
- Set3dDimlinePoint()
: ON_DimLinear
, ON_DimRadial
- Set3dLeaderPt()
: ON_DimOrdinate
- Set3dmViewLocked()
: CRhinoNamedViewCameraIcon
- Set3dPoint()
: CRhinoSettings
- Set3dPointValue()
: CRhinoUiRegistry
- Set3dRadiusPoint()
: ON_DimRadial
- Set3dVector()
: CRhinoSettings
- Set3dVectorValue()
: CRhinoUiRegistry
- Set_Local_Min()
: ON_X_EVENT
- Set_user()
: ON_Brep
- SetAbsoluteDisplayDensity()
: ON_SubDDisplayParameters
- SetAbsoluteTolerance()
: ON_3dmUnitsAndTolerances
, ON_HiddenLineDrawing
- SetAcceptEdges()
: ON_SubDComponentFilter
- SetAcceptFaces()
: ON_SubDComponentFilter
- SetAcceptNumber()
: CArgsRhinoGetArc
, CArgsRhinoGetEllipse
- SetAcceptVertices()
: ON_SubDComponentFilter
- SetAccuracy()
: ON_CurvePiping
, ON_Sun
- SetActionFrameLinked()
: IRhRdkSafeFrame
, ON_SafeFrame
- SetActionFrameOn()
: IRhRdkSafeFrame
, ON_SafeFrame
- SetActionFrameXScale()
: IRhRdkSafeFrame
, ON_SafeFrame
- SetActionFrameYScale()
: IRhRdkSafeFrame
, ON_SafeFrame
- SetActions()
: CRhRdkAction
- SetActiveCacheHandle()
: CDisplayPipelineAttributes
- SetActiveDetailObject()
: CRhinoPageView
- SetActiveInViewportFilter()
: CRhinoObjectIterator
- SetActiveItem()
: CRhinoUiExpandableTabCtrl
- SetActivePage()
: CRhinoUiTabPageCtrl
- SetActiveRhinoViewSerialNumber()
: CRhinoDoc
- SetActiveSpace()
: CRhinoGumball
- SetActiveView()
: CRhinoApp
- SetActiveViewport()
: CRhinoApp
- SetActiveWindow()
: CRhinoView
- SetAdaptiveBakingQuality()
: CRhRdkRendererSupportOptions
- SetAdaptiveDisplayDensity()
: ON_SubDDisplayParameters
- SetAddPlugInFileTypes()
: CRhinoGetFileDialog
- SetAddThickness()
: CArgsRhinoGetThickBox
- SetAddToMRU()
: CRhinoOpenDocumentOptions
- SetAddTransparentBackgroundControl()
: CRhinoGetFileDialog
- SetAdjust()
: IRhRdkRenderWindow
- SetAdjustmentClamp()
: CRhRdkTexture
- SetAdjustmentClampMax()
: CRhRdkTexture
- SetAdjustmentClampMin()
: CRhRdkTexture
- SetAdjustmentGain()
: CRhRdkTexture
- SetAdjustmentGamma()
: CRhRdkTexture
- SetAdjustmentGrayscale()
: CRhRdkTexture
- SetAdjustmentHueShift()
: CRhRdkTexture
- SetAdjustmentInvert()
: CRhRdkTexture
- SetAdjustmentMultiplier()
: CRhRdkTexture
- SetAdjustmentSaturation()
: CRhRdkTexture
- SetAdjustmentScaleToClamp()
: CRhRdkTexture
- SetAdjustWidth()
: CRhinoUiPopUpListWnd
- SetAdvance()
: ON_TextRun
- SetAdvancedBrepMappingToolFunctions()
: ON_TextureMapping
- SetAdvancedGetTextureMappingFromDocumentFunction()
: ON_TextureMapping
- SetAliases()
: CRhinoAppSettings
- SetAlignment()
: CRhinoUiStaticEx
, ON_Annotation
, ON_TextContent
- SetAllColors()
: ON_SectionAnalysisAppearance
- SetAllExpressionSettingsToFalse()
: ON_ParseSettings
- SetAllObjectDrawingColors()
: CDisplayPipelineAttributes
- SetAllow3Point()
: CArgsRhinoGetPlane
- SetAllowActivateCommandWindowCaret()
: CRhinoApp
- SetAllowCancelWhileAnotherApplicationHasFocus()
: CRhinoGetCancel
- SetAllowCenter()
: CArgsRhinoGetPlane
- SetAllowCorners()
: CArgsRhinoGetPlane
- SetAllowDefaultCancellationHandling()
: ON_Terminator
- SetAllowDeformable()
: CArgsRhinoGetArc
, CArgsRhinoGetCircle
, CArgsRhinoGetPlane
- SetAllowEmpty()
: CRhinoUiEdit
- SetAllowEscapeAndEnter()
: CRhinoUiDialog
- SetAllowForceAspectRatio()
: CArgsRhinoGetPlane
- SetAllowGpuProcedurals()
: CRhinoOpenGLSettings
- SetAllowRounded()
: CArgsRhinoGetPlane
- SetAllowSetDuringChange()
: CRhRdkSdkNumberEdit
- SetAllowTextScaling()
: ON_Annotation
- SetAllowVertical()
: CArgsRhinoGetPlane
- SetAllowWireframeEffects()
: CRhRdkPostEffectPlugInManager
- SetAllParameters()
: ON_PostEffect
- SetAllPlugInsToDocumentDefaults()
: CRhRdkPostEffectPlugInManager
- SetAllPlugInsToFactoryDefaults()
: CRhRdkPostEffectPlugInManager
- SetAllTags()
: ON_MeshXPointPool
- SetAllToFalse()
: ON_ParseSettings
- SetAlpha()
: CRhRdkColor
, ON_4fColor
, ON_Color
, ON_PhysicallyBasedMaterial
- SetAlternate()
: ON_Annotation
, ON_DimStyle
- SetAlternateBelow()
: ON_Annotation
, ON_DimStyle
- SetAlternateDimensionLengthDisplay()
: ON_Annotation
, ON_DimStyle
- SetAlternateLengthFactor()
: ON_Annotation
, ON_DimStyle
- SetAlternateLengthResolution()
: ON_Annotation
, ON_DimStyle
- SetAlternatePrefix()
: ON_Annotation
, ON_DimStyle
- SetAlternateRoundOff()
: ON_Annotation
, ON_DimStyle
- SetAlternateSuffix()
: ON_Annotation
, ON_DimStyle
- SetAlternateToleranceResolution()
: ON_Annotation
, ON_DimStyle
- SetAlternateZeroSuppress()
: ON_Annotation
, ON_DimStyle
- SetAltitude()
: CRhRdkSunStorage
, IRhRdkGroundPlane
, IRhRdkSun
, ON_GroundPlane
, ON_Sun
- SetAlwaysClampToZero()
: CRhRdkSdkRealNumberEdit
- SetAlwaysDisplayAllFiletypes()
: CRhinoAppFileSettings
- SetAlwaysModelDistances()
: ON_Linetype
- SetAlwaysOnTop()
: CRhinoTextDot
, ON_TextDot
- SetAlwaysShowSunPreview()
: CRhRdkRendererSupportOptions
- SetAlwaysUnpackEmbeddedFilesToTemp()
: CRhRdkRendererSupportOptions
- SetAmbient()
: CRhRdkBasicMaterial
, CRhRdkBasicMaterialCCI
, ON_Light
, ON_Material
- SetAmount()
: CRhRdkBasicMaterial::CTextureSlot
, CRhRdkBasicMaterialCCI
- SetAnalysisMeshSettings()
: CRhinoDocProperties
- SetAnalysisModeDisplayAttributes()
: CRhinoVisualAnalysisMode
- SetAncestry()
: CRhRdkCustomRenderMeshes
, CRhRdkRenderMesh
, IRhRdkCustomRenderMeshes2
- SetAnchorLocation()
: CRhinoPrintInfo
- SetAndLockId()
: ON_ModelComponent
- SetAngle()
: CArgsRhinoGetArc
, CArgsRhinoGetEllipse
- SetAngleDegrees()
: ON_Arc
, ON_HatchLine
, ON_RevSurface
- SetAngleFormat()
: ON_Annotation
, ON_DimStyle
- SetAngleIntervalRadians()
: ON_Arc
- SetAngleRadians()
: ON_Arc
, ON_HatchLine
, ON_RevSurface
- SetAngleRangeDegrees()
: CRhinoDraftAngleAnalysisSettings
- SetAngleRangeRadians()
: CRhinoDraftAngleAnalysisSettings
- SetAngleResolution()
: ON_Annotation
, ON_DimStyle
- SetAngleRoundOff()
: ON_Annotation
, ON_DimStyle
- SetAngleTolerance()
: CArgsRhinoFair
, ON_3dmUnitsAndTolerances
- SetAngleToleranceRadians()
: CArgsRhinoLoft
- SetAngleZeroSuppress()
: ON_Annotation
, ON_DimStyle
- SetAngularDimensionType()
: ON_DimAngular
- SetAnimationProperties()
: CRhinoDocProperties
- SetAnisotropic()
: ON_PhysicallyBasedMaterial
- SetAnisotropicRotation()
: ON_PhysicallyBasedMaterial
- SetAnnotationBold()
: ON_Annotation
- SetAnnotationFacename()
: ON_Annotation
- SetAnnotationFont()
: ON_Annotation
- SetAnnotationItalic()
: ON_Annotation
- SetAnnotationSelectionPoint()
: CRhinoObjRef
- SetAnnotationSettings()
: CRhinoDocProperties
- SetAnnotationTextFormat()
: ON_Annotation
- SetAnnotationUnderline()
: ON_Annotation
- SetApexPrompt()
: CArgsRhinoGetCone
- SetAppearanceSettings()
: CRhinoAppSettings
- SetAppleFontWeightTrait()
: ON_Font
- SetAppleWeightOfFont()
: ON_Font
- SetApplyDisplayModeWidthScales()
: CRhinoPrintInfo
- SetApplyToneMappingWhileRendering()
: CRhRdkDocument
, CRhRdkRenderingSettings
- SetApplyWhileRendering()
: IRhRdkToneMapping
- SetAppName()
: CRhinoApp
, MRhinoApp
- SetArc()
: CRhinoBendSpaceMorph
- SetArchive3dmVersion()
: ON_BinaryArchive
- SetArchiveFullPath()
: ON_BinaryArchive
- SetArchiveId()
: ON_SubDComponentBase
- SetArcLengthParameterization()
: ON_PolylineCurve
- SetArcLengthSymbol()
: ON_Annotation
, ON_DimStyle
- SetArcMode()
: CArgsRhinoGetArc
- SetAroundCurve()
: CArgsRhinoGetPolygon
, CArgsRhinoGetSpiral
- SetAroundDirectionCount()
: CArgsRhinoGetCircle
, CArgsRhinoGetEllipse
- SetAroundDirectionMinCount()
: CArgsRhinoGetCircle
, CArgsRhinoGetEllipse
- SetAroundMeshDensityDirectionPrompt()
: CArgsRhinoGetCircle
, CArgsRhinoGetEllipse
- SetArray()
: ON_ClassArray< T >
, ON_SimpleArray< T >
- SetArrowBlockId()
: ON_Arrowhead
- SetArrowBlockId1()
: ON_Annotation
, ON_DimStyle
- SetArrowBlockId2()
: ON_Annotation
, ON_DimStyle
- SetArrowColor()
: ON_DimStyle
- SetArrowColorSource()
: ON_DimStyle
- SetArrowFit()
: ON_Dimension
, ON_DimStyle
- SetArrowheadType()
: ON_Arrowhead
- SetArrowPlotColor()
: ON_DimStyle
- SetArrowPlotColorSource()
: ON_DimStyle
- SetArrowSize()
: ON_Annotation
, ON_DimStyle
- SetArrowType1()
: ON_Annotation
, ON_DimStyle
- SetArrowType1And2()
: ON_Annotation
, ON_DimStyle
- SetArrowType2()
: ON_Annotation
, ON_DimStyle
- SetAscentOfCapital()
: ON_FontMetrics
- SetAscentOfI()
: ON_FontMetrics
- SetAscentOfx()
: ON_FontMetrics
- SetAskOnLoadProtection()
: CRhinoAppSettings
- SetAsModelDouble()
: CRhRdkVariant
- SetAsModelFloat()
: CRhRdkVariant
- SetAsPercentile()
: CRhRdkSdkRealNumberEdit
- SetAssignBy()
: IRhRdkNewContentCtrl
- SetAsString()
: IRhRdk_XMLSection
, ON_XMLParameters
- SetAsSystemComponent()
: ON_ModelComponent
- SetAsUnsetSystemComponent()
: ON_ModelComponent
- SetAsyncRenderContext()
: CRhRdkSdkRender
, IRhRdkRenderSession
- SetAt()
: ON_String
, ON_wString
- SetAttenuation()
: ON_Light
- SetAutoAdjustTargetDepth()
: CRhinoAppViewSettings
- SetAutoAlignCPlane()
: CRhinoAppSettings
- SetAutoAltitude()
: IRhRdkGroundPlane
, ON_GroundPlane
- SetAutocompleteCommands()
: CRhinoAppSettings
- SetAutoCPlaneAlignment()
: CRhinoAppSettings
- SetAutoDelete()
: CRhinoDoc
, CRhinoUiOptionsListCtrlItem
, CRhinoUiPopUpListWnd
, CRhRdkContent
, ON_RenderContent
- SetAutoDeleteMaterialsOn()
: CRhRdkCustomRenderMeshes
, IRhRdkCustomRenderMeshes
- SetAutoDeleteMeshesOn()
: CRhRdkCustomRenderMeshes
, IRhRdkCustomRenderMeshes
- SetAutoGumballAlignment()
: CRhinoAppSettings
- SetAutoGumballExtrudeMergeFaces()
: CRhinoAppSettings
- SetAutomaticMeshToSubD()
: ON_SubD
- SetAutoPercentileScaling()
: CRhRdkSdkRealNumberEdit
- SetAutoRepeatDelay()
: CRhRdkSdkNumberEdit
- SetAutoSaveKeepAmount()
: CRhRdkRendererSupportOptions
- SetAutoSaveRenderings()
: CRhRdkRendererSupportOptions
- SetAutoScalingParams()
: IRhRdkCustomCurveCtrl
- SetAutoSubclassGroupBoxes()
: CRhRdkResizingDialog
- SetAutoTypePropValue()
: ON_XMLNode
- SetAutoUpdate()
: ON_ShutLining
- SetAxis()
: CArgsRhinoRailRevolve
, CArgsRhinoRevolve
- SetAxisEndPrompt()
: CArgsRhinoRailRevolve
- SetAxisStartPrompt()
: CArgsRhinoRailRevolve
- SetAziAlt()
: CRhRdkSunStorage
- SetAzimuth()
: CRhRdkSunStorage
, IRhRdkSun
, ON_Sun
- SetAzimuthAndAltitudeFromVector()
: ON_Sun
- SetBackgroundBitmap()
: CDisplayPipelineAttributes
- SetBackgroundColor()
: CRhinoUiStaticEx
, CRhRdkBasicEnvironmentCCI
, CRhRdkSimulatedEnvironment
, IRhinoUiHolder
, IRhinoUiSection
, IRhRdkAutomaticUI
, IRhRdkColorButton
, ON_Environment
- SetBackgroundFillColor()
: ON_SectionStyle
- SetBackgroundFillMode()
: ON_SectionStyle
- SetBackgroundImage()
: CRhRdkSimulatedEnvironment
, ON_Environment
- SetBackgroundProjection()
: CRhRdkSimulatedEnvironment
, ON_Environment
- SetBackgroundStyleOverride()
: CDisplayPipelineAttributes
- SetBadHairColor()
: CRhinoEdgeContinuitySettings
- SetBakingQueueThreads()
: CRhRdkRendererSupportOptions
- SetBarycentricCoordinateTolerance()
: ON_MeshX
- SetBase()
: CRhinoGetAngle
, CRhinoGetDirection
, CRhinoGetDistance
, CRhinoGetRectangle3Point
, ON_HatchLine
- SetBaseColor()
: ON_PhysicallyBasedMaterial
- SetBaseGumball()
: CRhinoGumballDisplayConduit
- SetBaselineSpacing()
: ON_Annotation
, ON_DimStyle
- SetBaseObjRef()
: CRhinoGetPoint
- SetBasePoint()
: CRhinoGetPoint
, CRhinoGetXform
, CRhinoUiDragBitmapWnd
, ON_Hatch
- SetBaseSurface()
: ON_OffsetSurface
, ON_OffsetSurfaceFunction
- SetBezier()
: ON_CurveTreeBezier
, ON_CurveTreeNode
, ON_SurfaceTreeBezier
- SetBezierCage()
: ON_BezierCageMorph
- SetBinaryValue()
: CRhinoUiRegistry
- SetBispanCount()
: ON_SubDSurfaceNurbsFragment
- SetBitapTransparentColor()
: CRhinoUiDragBitmapWnd
- SetBitmap()
: CRhinoDib
- SetBitmapTypes()
: CRhinoGetFileDialog
- SetBkColor()
: CRhinoUiProgressCtrl
- SetBlackPoint()
: ON_Displacement
, ON_Displacement::SubItem
- SetBlank()
: CRhRdkSdkNumberEdit
- SetBlue()
: ON_4fColor
- SetBold()
: CRhinoTextDot
, ON_RtfFirstChar::TextRun
, ON_RtfStringBuilder::TextRun
, ON_TextBuilder::TextProps
, ON_TextDot
- SetBool()
: CRhinoSettings
, ON_ArchivableDictionary
- SetBoolArray()
: ON_ArchivableDictionary
- SetBoolValue()
: CRhinoHistory
, CRhinoUiRegistry
, ON_HistoryRecord
- SetBoolValues()
: CRhinoHistory
, ON_HistoryRecord
- SetBorders()
: CRhinoUiExpandableTabCtrl
, CRhinoUiExpandableTabCtrl_New
, CRhinoUiOptionsListCtrl
- SetBothSides()
: CArgsRhinoGetCylinderExtra
, ON_Thickening
- SetBothSidesPrompt()
: CArgsRhinoGetCylinderExtra
- SetBoundaryColor()
: ON_SectionStyle
- SetBoundaryCurve()
: CRhinoDetailViewObject
- SetBoundaryLinetype()
: ON_SectionStyle
- SetBoundaryVisible()
: ON_SectionStyle
- SetBoundaryWidthScale()
: ON_SectionStyle
- SetBoundingBox()
: ON_InstanceDefinition
, ON_TextRun
- SetBounds()
: CRhRdkSdkNumberEdit
- SetBox()
: CRhRdkRenderMesh
- SetBoxMapping()
: ON_TextureMapping
- SetBRDF()
: ON_PhysicallyBasedMaterial
- SetBrep()
: CRhinoBrepObject
- SetBrepValue()
: CRhinoHistory
- SetBuffer()
: ON_BinaryArchiveBuffer
- SetBufferCheckSum()
: ON_CheckSum
- SetBuiltInMappingChannel()
: ON_Texture
- SetButtonColor()
: CRhinoUiButton
, IRhRdkColorPicker
- SetButtonState()
: CRhinoUiDockBarCaptionButton
- SetCachedAttributesValid()
: CRhinoDisplayPipeline
- SetCachedTextureCoordinates()
: CRhinoObject
, ON_Mesh
- SetCachedTextureCoordinatesEx()
: ON_Mesh
- SetCachedTextureCoordinatesFromMaterial()
: ON_Mesh
- SetCachedTextureCoordinatesFromPlugIn()
: CRhinoObject
- SetCacheImage()
: IRhRdkPreviewSceneServer
- SetCage()
: CRhinoCageObject
- SetCallback()
: ON_Base64EncodeStream
, ON_CompressStream
, ON_UncompressStream
- SetCallbacks()
: ON_RdkUserData
- SetCamera()
: CRhinoDisplayEngine
, CRhinoDisplayPipeline
, CRhinoNamedViewCameraIcon
, ON_Viewport
- SetCamera35mmLenseLength()
: ON_Viewport
- SetCamera35mmLensLength()
: ON_Viewport
- SetCameraAngle()
: ON_Viewport
- SetCameraDirection()
: CRhinoViewport
, ON_Viewport
- SetCameraDirectionLock()
: ON_Viewport
- SetCameraLocation()
: CRhinoViewport
, ON_Viewport
- SetCameraLocationLock()
: ON_Viewport
- SetCameraPathId()
: ON_3dmAnimationProperties
- SetCameraPosition()
: ON_AerialPhotoImage
- SetCameraUp()
: ON_Viewport
- SetCameraUpLock()
: ON_Viewport
- SetCancelCallback()
: IRhRdkPreviewCallbacks
- SetCancellationToken()
: IRhRdkPreviewSceneServer
- SetCanHideCursor()
: CRhRdkSdkNumberEdit
- SetCap()
: CArgsRhinoGetCircle
, CArgsRhinoGetPolygon
- SetCapacity()
: ON_ClassArray< T >
, ON_ConvexHullPoint2
, ON_SimpleArray< T >
- SetCapFaceStyle()
: CArgsRhinoGetConeExtra
, CArgsRhinoGetCylinderExtra
, CArgsRhinoGetEllipse
- SetCapMode()
: CArgsRhinoGetParabola
- SetCaption()
: CRhRdkSunDialog
- SetCapture()
: CRhinoDisplayPipeline
, CRhinoView
- SetCaptureMethod()
: ON_3dmAnimationProperties
- SetCaptureRect()
: CRhinoZBuffer
- SetCaptureType()
: ON_3dmAnimationProperties
- SetCapType()
: ON_CurvePiping
- SetCenter()
: CRhinoGumball
, CRhinoGumballFrame
- SetCenterMark()
: ON_DimStyle
- SetCenterMarkSize()
: ON_Annotation
- SetCenterMarkStyle()
: ON_Annotation
, ON_DimStyle
- SetCenterPoint()
: ON_TextDot
- SetCenterPrompt()
: CArgsRhinoGetArc
, CArgsRhinoGetSpiral
- SetChamfer()
: ON_EdgeSoftening
- SetChanged()
: IRhinoUiDataSource
- SetChangeThreshold()
: CRhRdkSdkNumberEdit
- SetCharSet()
: ON_TextBuilder::TextProps
- SetCheck()
: CRhinoUiOptionsListCtrlCheckBox
, CRuiUpdateUi
, IRhRdkCommandUpdate
- SetChecked()
: CRhRdkAction
- SetCheckForRemappedIds()
: ON_BinaryArchive
- SetCheckState()
: CRuiUpdateUi
- SetCheckSupportFilesBeforeRendering()
: CRhRdkRendererSupportOptions
- SetCheckText()
: CRhinoUiOptionsListCtrlCheckBox
- SetCheckVisibility()
: CRhinoSnapContext
- SetChild()
: CRhRdkContent
, ON_RenderContent
- SetChildSlotAmount()
: CRhRdkContent
, ON_RenderContent
- SetChildSlotName()
: CRhRdkContent
, IRhRdkColorButton
, ON_RenderContent
- SetChildSlotOn()
: CRhRdkContent
, ON_RenderContent
- SetChooseOneObjectSettings()
: CRhinoAppSettings
- SetChunkBoundaryCheck()
: ON_BinaryArchive
- SetCircle()
: CArgsRhinoGetPolygon
- SetCircleType()
: CArgsRhinoGetCircle
- SetCircumscribedAroundCurveCenterPrompt()
: CArgsRhinoGetPolygon
- SetCircumscribedCenterPrompt()
: CArgsRhinoGetPolygon
- SetClampedGrevilleKnotVector()
: ON_NurbsSurface
- SetClampEnd()
: CArgsRhinoFair
- SetClampStart()
: CArgsRhinoFair
- SetClarity()
: CRhRdkBasicMaterial
, CRhRdkBasicMaterialCCI
- SetCleanupTolerance()
: ON_Symmetry
- SetClearcoat()
: ON_PhysicallyBasedMaterial
- SetClearcoatRoughness()
: ON_PhysicallyBasedMaterial
- SetClearTextOnDeleteKey()
: CRhinoUiOptionsListCtrlFileNameEditBox
- SetClickAction()
: IRhRdkColorButton
- SetClippingPlaneLabelStyle()
: ON_3dmObjectAttributes
- SetClippingPlanes()
: CRhinoDisplayEngine
, CRhinoViewport
- SetClippingPlaneSurface()
: CRhinoClippingPlaneObject
- SetClippingRegionTransformation()
: CRhinoViewport
- SetClipPlaneTolerance()
: ON_ClippingRegion
- SetClipRect()
: CRhinoDisplayEngine_GDI
- SetClipRegion()
: CRhinoDisplayEngine
- SetClipSectionUsage()
: CDisplayPipelineAttributes
- SetClosed()
: CArgsRhinoLoft
, ON_Mesh
- SetClosedObjectPostProcess()
: ON_MeshParameters
- SetClosedSurfaceConstraint()
: ON_BendFaceConstraint
- SetCodePage()
: ON_TextBuilder::TextProps
- SetCodePoint()
: ON_FontGlyph
- SetColor()
: CRhinoSettings
, CRhinoUiColorButton
, CRhinoUiOptionsListCtrlColorButton
, CRhinoUiStaticEx
, IRhRdkColorButton
, IRhWidgetDrawCache
, ON_Layer
, ON_TextBuilder::TextProps
, ON_TextRun
- SetColor1()
: CRhRdkOneColorTextureBase
- SetColor2()
: CRhRdkTwoColorTextureBase
- SetColorAdjuster()
: CRhRdkSimulatedTexture
- SetColorEx()
: IRhRdkColorButton
- SetColorFadeEffect()
: CDisplayPipelineAttributes
- SetColorFormat()
: ON_TextLog
- SetColorPalette()
: CRhinoUiColorButton
, CRhinoUiColorComboBox
, CRhinoUiColorListBox
, CRhinoUiGradientSliderCtrl
- SetColors()
: ON_SubDMeshFragment
- SetColorsExistForExperts()
: ON_SubDMeshFragment
- SetColorsFromCallback()
: ON_SubDMeshFragment
- SetColorsMappingTag()
: ON_SubD
- SetColorSource()
: ON_3dmObjectAttributes
- SetColorSwatchDrawStyle()
: CRhinoUiComboBox
- SetColorValue()
: CRhinoHistory
, ON_HistoryRecord
- SetColorValues()
: CRhinoHistory
, ON_HistoryRecord
- SetCombineEditors()
: CRhRdkRendererSupportOptions
- SetCombineSimilarTextures()
: CRhRdkRendererSupportOptions
- SetCommand()
: CRhinoHistory
- SetCommandPrompt()
: CRhinoApp
, CRhinoGet
- SetCommandPromptDefault()
: CRhinoGet
- SetCommandPromptMessage()
: CRhinoApp
- SetCommandToRepeat()
: CRhinoApp
, CRhinoDoc
- SetCommandWindowFonts()
: CRhinoAppFonts
- SetCommandWindowText()
: CRhinoApp
- SetCommandWndPrompt()
: CRhinoGet
- SetComplexPointInput()
: CRhinoGetPoint
- SetComponent()
: ON_ComponentIndexAndNumber
, ON_SubDComponentAndNumber
, ON_SubDComponentAndPoint
- SetComponentDirection()
: ON_SubDComponentPtr
- SetComponentMarkBitsFromSymmetryMotif()
: ON_SubD
- SetComponentMarks()
: ON_SubD
- SetComponentRuntimeSerialNumber()
: ON_ComponentManifestItem
- SetComponentStates()
: ON_Brep
, ON_Object
, ON_SubD
- SetComponentStatus()
: ON_Brep
, ON_Object
, ON_SubD
- SetComponentToDraw()
: CRhinoSubDDisplayAttributes
- SetComponentType()
: ON_ComponentManifestItem
, ON_ModelComponent
- SetComponentWithNameConflict()
: CRhinoComponentNameConflictUI
- SetComposeFS()
: RtfComposer
- SetComputeCurvature()
: ON_MeshParameters
, ON_SubDDisplayParameters
- SetConcaveCornerOption()
: ON_SubDFromMeshParameters
- SetCone()
: CRhRdkRenderMesh
- SetConeCylConstraint()
: CArgsRhinoGetCircle
- SetConfirmationSeconds()
: CRhRdkSdkRender
- SetConstantOffset()
: ON_SubDExpandEdgesParameters
- SetConstraintsX()
: IRhRdkCustomCurveCtrl
- SetConstraintsY()
: IRhRdkCustomCurveCtrl
- SetConstructionPlane()
: CRhinoViewport
- SetContentFilterInfo()
: CRhRdkDocument
- SetContentHash()
: ON_FileReference
- SetContentIsSymmetricForExperts()
: ON_SubD
- SetContentUIAgent()
: CRhRdkContentFactory
- SetContext()
: ON_HiddenLineDrawing
- SetContextAngleUnitSystem()
: ON_ParseSettings
- SetContextForExperts()
: ON_SubDDisplayParameters
- SetContextFromChangeContext()
: CRhRdkContent
- SetContextId()
: ON_SubDSurfaceInterpolator
- SetContextLengthUnitSystem()
: ON_ParseSettings
- SetContextLocaleId()
: ON_ParseSettings
- SetContextMenuSettings()
: CRhinoAppSettings
- SetContinuity()
: CRhinoEdgeContinuitySettings
- SetControl()
: CRhinoMorphControl
- SetControlClickSubObjectDeselect()
: CRhinoAppSettings
- SetControlColors()
: CRhinoUiTabbedSheetCtrl
- SetControlKeyScaling()
: CRhRdkSdkNumberEdit
- SetController()
: CRhRdkCustomContentUI
, CRhRdkSunDialog
, IRhinoUiWithController
, IRhRdkContentUI
- SetControlNetPoint()
: ON_SubDVertex
- SetControlNetQuad()
: ON_SubDMeshFragment
- SetControlType()
: CRhinoUiOptionsListCtrlItem
- SetConversion()
: CRhRdkContentField
- SetConvexCornerOption()
: ON_SubDFromMeshParameters
- SetCopyHistoryOnReplace()
: CRhinoObject
- SetCopyOnReplaceObject()
: CRhinoHistory
, ON_HistoryRecord
- SetCornerMode()
: CArgsRhinoGetPlane
- SetCornerPrompt()
: CArgsRhinoGetPolygon
- SetCornerRadius()
: CArgsRhinoGetPlane
- SetCornerRho()
: CArgsRhinoGetPlane
- SetCorners()
: ON_SubDFromSurfaceParameters
- SetCount()
: ON_ClassArray< T >
, ON_SimpleArray< T >
- SetCRCCache()
: CRhRdkContent
- SetCreateAsOwnerDraw()
: CRhinoUiComboBox
- SetCreateBackupFile()
: CRhinoFileWriteOptions
- SetCreateDefaultViews()
: CRhinoCreateDocumentOptions
- SetCreateHeadless()
: CRhinoCreateDocumentOptions
, CRhinoOpenDocumentOptions
- SetCreateStealthWorksession()
: CRhinoCreateDocumentOptions
, CRhinoOpenDocumentOptions
- SetCreateTriStateCeckBox()
: CRhinoUiOptionsListCtrlCheckBox
- SetCullFaceMode()
: CRhinoDisplayEngine
, CRhinoDisplayEngine_OGL
- SetCurColor()
: CRhinoUiComboBox
- SetCurFont()
: CRhinoUiComboBox
- SetCurGroupSel()
: CRhinoUiOptionsListCtrlGroupComboBox
- SetCurLayer()
: CRhinoUiComboBox
- SetCurLinetype()
: CRhinoUiComboBox
- SetCurPrintWidth()
: CRhinoUiComboBox
- SetCurrentColor()
: CRhinoDocProperties
, CRhinoObjectColorComboBox
, CRhinoPlotColorComboBox
- SetCurrentColorSource()
: CRhinoDocProperties
- SetCurrentCulture()
: ON_Locale
- SetCurrentDimensionStyleId()
: ON_3dmSettings
, ONX_Model
- SetCurrentDimStyleIndex()
: CRhinoDimStyleTable
- SetCurrentDockBarId()
: CRhinoUiDockBarTab
- SetCurrentFont()
: ON_TextRunBuilder
- SetCurrentFrame()
: ON_3dmAnimationProperties
- SetCurrentHatchPattern()
: CRhinoHatchPatternTable
- SetCurrentHatchPatternId()
: ON_3dmSettings
- SetCurrentHatchPatternIndex()
: CRhinoHatchPatternTable
- SetCurrentLayerId()
: ON_3dmSettings
- SetCurrentLayerIndex()
: CRhinoLayerTable
- SetCurrentLayerOnExport()
: CRhinoPrintInfo
- SetCurrentLinePatternId()
: ON_3dmSettings
- SetCurrentLinetypeIndex()
: CRhinoLinetypeTable
- SetCurrentLinetypeSource()
: CRhinoLinetypeTable
- SetCurrentMaterialId()
: ON_3dmSettings
- SetCurrentMaterialIndex()
: CRhinoMaterialTable
- SetCurrentMaterialSource()
: CRhinoDocProperties
, CRhinoMaterialTable
- SetCurrentMode()
: CArgsRhinoGetPlane
- SetCurrentTextStyleId()
: ON_3dmSettings
- SetCurrentWireDensity()
: CRhinoDocProperties
- SetCurSel()
: CRhinoUiOptionsListCtrl
, CRhinoUiTabbedSheetCtrl
- SetCursorOn()
: IRhRdkCustomCurveCtrl
- SetCursorPosition()
: IRhRdkCustomCurveCtrl
- SetCursorToolTip()
: CRhinoApp
- SetCursorToolTipNumberPane()
: CRhinoApp
- SetCursorToolTipOsnapPane()
: CRhinoApp
- SetCursorToolTipPane()
: CRhinoApp
- SetCursorToolTipPointPane()
: CRhinoApp
- SetCursorToolTipPromptPane()
: CRhinoApp
- SetCursorToolTipSettings()
: CRhinoAppSettings
- SetCurvatureAnalysisSettings()
: CRhinoAppSettings
- SetCurvatureColorAnalysisColors()
: ON_Brep
, ON_Mesh
, ON_SubD
- SetCurvatureGraphSettings()
: CRhinoAppSettings
- SetCurvatures()
: ON_SubDMeshFragment
- SetCurvatureScale()
: CRhinoEdgeContinuitySettings
- SetCurvaturesExistForExperts()
: ON_SubDMeshFragment
- SetCurvatureTolerancePercent()
: CRhinoEdgeContinuitySettings
- SetCurve()
: CArgsRhinoGetPolygon
, CArgsRhinoGetSubCurve
, CRhinoCurveObject
, ON_HatchLoop
- SetCurveAttributes()
: CRhinoDisplayEngine
- SetCurveConstraint()
: ON_BendFaceConstraint
- SetCurveSelectionPoint()
: CRhinoObjRef
- SetCurveThickness()
: CRhinoDisplayPipeline
- SetCurveThicknessScale()
: CDisplayPipelineAttributes
- SetCurveThicknessUsage()
: CDisplayPipelineAttributes
- SetCurveValue()
: CRhinoHistory
- SetCustomClippingConvexRegion()
: ON_DepthImage
- SetCustomColor()
: CRhinoUiComboBox
- SetCustomDrawList()
: CRhinoDisplayPipeline
- SetCustomEnvironment()
: IRhRdkSkylight
- SetCustomEnvironmentForReflectionAndRefraction()
: CRhRdkRenderingSettings
- SetCustomEnvironmentOn()
: IRhRdkSkylight
- SetCustomLibraryPath()
: CRhRdkRendererSupportOptions
- SetCustomLinetype()
: ON_3dmObjectAttributes
- SetCustomList()
: IRhRdkRenderChannels
, ON_RenderChannels
- SetCustomMappingPrimitive()
: ON_TextureMapping
- SetCustomMeasurementFunctions()
: ON_Font
- SetCustomPaths()
: CRhRdkRendererSupportOptions
- SetCustomRenderMeshParameters()
: CRhinoDocProperties
, ON_3dmObjectAttributes
- SetCustomRenderMeshSettings()
: CRhinoDocProperties
- SetCustomSectionStyle()
: ON_3dmObjectAttributes
, ON_Layer
- SetCustomSettings()
: ON_MeshParameters
- SetCustomSettingsEnabled()
: ON_MeshParameters
- SetCustomUnitSystem()
: ON_UnitSystem
- SetCustomUnitSystemName()
: ON_UnitSystem
- SetCustomUnitSystemScale()
: ON_UnitSystem
- SetCustomXML()
: ON_Decal
- SetCV()
: ON_BezierCage
, ON_BezierCurve
, ON_BezierSurface
, ON_NurbsCage
, ON_NurbsCurve
, ON_NurbsSurface
- SetCVColumn()
: ON_NurbsSurface
- SetCVRow()
: ON_NurbsSurface
- SetCylinderMapping()
: ON_TextureMapping
- SetDamagedState()
: ON_ComponentStatus
- SetDashes()
: ON_HatchLine
- SetData()
: CRhinoUiTabbedSheetCtrlItem
- SetDataPtr()
: CRhinoUiTabbedSheetCtrlItem
- SetDaylightSavingMinutes()
: CRhRdkSunStorage
, IRhRdkSun
, ON_Sun
, ON_SunEngine
- SetDaylightSavingOn()
: CRhRdkSunStorage
, IRhRdkSun
, ON_Sun
- SetDaysBetweenFrames()
: ON_3dmAnimationProperties
- SetDebugText()
: IRhRdkNewContentCtrl
- SetDecimalPlaces()
: CRhRdkSdkRealNumberEdit
- SetDecimalSeparator()
: ON_Annotation
, ON_DimStyle
- SetDefault()
: CRhinoGetAngle
, CRhinoGetDirection
, CRhinoGetDistance
- SetDefaultAngleUnitSystem()
: ON_ParseSettings
- SetDefaultBool()
: CRhinoSettings
- SetDefaultColor()
: CRhinoGet
, CRhinoSettings
- SetDefaultDirectory()
: CRhinoDirectoryManager
, CRhinoGetFileDialog
- SetDefaultDirectoryFromFileName()
: CRhinoDirectoryManager
- SetDefaultDouble()
: CRhinoSettings
- SetDefaultFacename()
: ON_RtfStringBuilder
- SetDefaultFileExtensionFromFileName()
: CRhinoGetFileDialog
- SetDefaultFloat()
: CRhinoSettings
- SetDefaultInteger()
: CRhinoGet
, CRhinoSettings
- SetDefaultNewComponentName()
: CRhinoComponentNameConflictUI
- SetDefaultNumber()
: CRhinoGet
- SetDefaultOnEventReturnCode()
: CRhinoDropTarget
- SetDefaultPoint()
: CRhinoGet
, CRhinoSettings
- SetDefaultPrompts()
: CArgsRhinoText
- SetDefaultRadius()
: CArgsRhinoGetArc
- SetDefaultReadType()
: ON_XMLParameters
- SetDefaultRect()
: CRhinoSettings
- SetDefaultRenderApp()
: CRhinoApp
- SetDefaultResolutionMethod()
: CRhinoComponentNameConflictUI
- SetDefaultSize()
: CArgsRhinoGetCircle
, CRhinoSettings
- SetDefaultString()
: CRhinoGet
, CRhinoSettings
- SetDefaultStringDictionary()
: CRhinoSettings
- SetDefaultStringList()
: CRhinoSettings
- SetDefaultSurfaceParameterMappingTag()
: ON_MappingTag
- SetDefaultUuid()
: CRhinoSettings
- SetDefinitionMode()
: CRhinoDimAngular
- SetDeformable()
: CArgsRhinoGetArc
, CArgsRhinoGetCircle
, CArgsRhinoGetEllipse
, CArgsRhinoGetPlane
, CArgsRhinoRevolve
- SetDeformablePointCount()
: CArgsRhinoGetEllipse
, CArgsRhinoRevolve
- SetDeformation()
: ON_SquishParameters
- SetDegree()
: CArgsRhinoGetArc
, CArgsRhinoGetCircle
, CArgsRhinoGetCurve
- SetDelayFloatInfo()
: CRhinoUiDockBar
- SetDeletedModelComponentState()
: ON_ModelComponent
- SetDeletedState()
: ON_ComponentStatus
- SetDeleteInput()
: CArgsRhinoRevolve
- SetDensity()
: CRhinoEdgeContinuitySettings
- SetDepth()
: ON_ClippingPlane
, ON_ClippingPlaneInfo
- SetDepthEnabled()
: ON_ClippingPlane
, ON_ClippingPlaneInfo
- SetDepthMode()
: CRhinoDisplayEngine
, CRhinoDisplayEngine_OGL
, CRhinoDisplayPipeline
- SetDerivative()
: ON_SurfaceValues
- SetDerivativeArrayForExperts()
: ON_SurfaceValues
- SetDescription()
: CRhinoInstanceDefinitionTable
, IRhRdkUndoRecord
, ON_HatchPattern
, ON_InstanceDefinition
- SetDesiredFrameRate()
: CRhinoDisplayPipeline
- SetDestinationDocument()
: CRhinoFileReadOptions
- SetDestinationIdentification()
: ON_ManifestMapItem
- SetDestroyOnClickOnListItem()
: CRhinoUiPopUpListWnd
- SetDestroyOnKillFocus()
: CRhinoUiPopUpListWnd
- SetDetailMeasured()
: ON_Dimension
- SetDetails()
: CRhinoObjRef
- SetDetailView()
: CRhinoDetailViewObject
- SetDiagonal()
: ON_Matrix
- SetDiagonalHatchEffect()
: CDisplayPipelineAttributes
- SetDialogTitle()
: CRhinoComponentNameConflictUI
, CRhinoGetFileDialog
- SetDiameterMode()
: CArgsRhinoGetSpiral
- SetDiameterPrompt()
: CArgsRhinoGetCircle
, CArgsRhinoGetSpiral
- SetDib()
: CRhinoDib
, IRhRdkRenderWindow
- SetDiffuse()
: CRhRdkBasicMaterial
, CRhRdkBasicMaterialCCI
, ON_Light
, ON_Material
- SetDimension()
: CRhinoCentermark
, CRhinoDimAngular
, CRhinoDimLinear
, CRhinoDimOrdinate
, CRhinoDimRadial
- SetDimensionLayerId()
: CRhinoAnnotationSettings
, ON_3dmAnnotationSettings
- SetDimensionLengthDisplay()
: ON_Annotation
, ON_DimStyle
- SetDimensionLineColor()
: ON_DimStyle
- SetDimensionLineColorSource()
: ON_DimStyle
- SetDimensionLinePlotColor()
: ON_DimStyle
- SetDimensionLinePlotColorSource()
: ON_DimStyle
- SetDimensionLinePlotWeight()
: ON_DimStyle
- SetDimensionLinePlotWeightSource()
: ON_DimStyle
- SetDimensionStyleId()
: ON_Annotation
- SetDimensionStyleIdForExperts()
: ON_Annotation
- SetDimExtension()
: ON_Annotation
, ON_DimStyle
- SetDimRadialTextAngleStyle()
: ON_Annotation
, ON_DimStyle
- SetDimRadialTextLocation()
: ON_Annotation
, ON_DimStyle
- SetDimRadialTextOrientation()
: ON_Annotation
, ON_DimStyle
- SetDimScale()
: CRhinoAnnotationSettings
, ON_Annotation
, ON_DimStyle
- SetDimScaleSource()
: ON_DimStyle
- SetDimStyleIndex()
: CArgsRhinoText
- SetDimTextAngleStyle()
: ON_Annotation
, ON_DimStyle
- SetDimTextLocation()
: ON_Annotation
, ON_DimStyle
- SetDimTextOrientation()
: ON_Annotation
, ON_DimStyle
- SetDimToContinue()
: CRhinoGetDimLinear
- SetDir()
: CArgsRhinoGetArc
, CArgsRhinoGetEllipse
- SetDirection()
: CArgsRhinoGetParabola
, ON_Light
- SetDirectionAnalysisSettings()
: CRhinoAppSettings
- SetDirectionArrowIconColorU()
: CRhinoAppAppearanceSettings
- SetDirectionArrowIconColorV()
: CRhinoAppAppearanceSettings
- SetDirectionArrowIconColorW()
: CRhinoAppAppearanceSettings
- SetDirectionArrowIconThickness()
: CRhinoAppAppearanceSettings
- SetDirectionPrompt()
: CArgsRhinoGetArc
, CArgsRhinoGetParabola
- SetDisableLighting()
: CRhRdkBasicMaterial
, CRhRdkBasicMaterialCCI
, ON_Material
- SetDisableRightClickAsEnter()
: CRhinoAppSettings
- SetDisplayAppearanceForExperts()
: CRhinoSubDObject
- SetDisplayAttributesStretch()
: CRhinoPrintInfo
- SetDisplayDensity()
: ON_SubDDisplayParameters
- SetDisplayInViewport()
: CRhRdkTexture
- SetDisplayMax()
: IRhRdkCustomCurveCtrl
- SetDisplayMin()
: IRhRdkCustomCurveCtrl
- SetDisplayMode()
: CRhinoDisplayPipeline
, CRhinoUiBlockPreview
, CRhinoViewport
, CRhinoZBuffer
, ON_3dmAnimationProperties
- SetDisplayOptionsDialog()
: CRhinoFileType
- SetDisplayPrecision()
: CRhinoUiEdit
- SetDisplaySettings()
: CRhinoAppSettings
- SetDisplaySize()
: CRhinoUiDialogScrollHelper
- SetDisplayString()
: CRhinoCommandOption
, ON_TextRun
- SetDisplayUnits()
: CRhinoUiPrintWidthListCtrl
- SetDisplayXform()
: CRhinoViewport
- SetDistance()
: ON_OffsetSurfaceFunction
, ON_Thickening
- SetDistanceDisplayMode()
: ON_3dmUnitsAndTolerances
- SetDistanceDisplayPrecision()
: ON_3dmUnitsAndTolerances
- SetDistanceScale()
: CRhinoEdgeContinuitySettings
, ON_Dimension
- SetDistanceTolerance()
: CRhinoEdgeContinuitySettings
- SetDither()
: CRhRdkImageAdjust
, IRhRdkImageAdjust
- SetDithering()
: CRhRdkRenderingSettings
- SetDitherTransparencyEffect()
: CDisplayPipelineAttributes
- SetDlgItemToolTip()
: CRhinoUiDialog
- SetDockBarClientWnd()
: CRhinoUiDockBar
- SetDockBarFlag()
: CRhinoUiDockBar
- SetDockBarMouseCapture()
: CRhinoUiDockBar
- SetDocRuntimeSerialNumber()
: CRhinoScriptContext
- SetDocument()
: CRhinoComponentNameConflictUI
, CRhinoGet
, CRhinoPrintInfo
, CRhinoWidgetGeometry
, RhMeshPipeArgs
- SetDocumentAssoc()
: CDisplayAttributeMaterial
, CRhRdkContent
, CRhRdkSimulatedTexture
- SetDocumentSerialNumber()
: CRhinoFileWriteOptions
- SetDocumentUserString()
: ONX_Model
- SetDomain()
: CArgsRhinoRevolve
, ON_ArcCurve
, ON_BrepFace
, ON_Curve
, ON_CurveProxy
, ON_Extrusion
, ON_LineCurve
, ON_NurbsCurve
, ON_NurbsSurface
, ON_PlaneSurface
, ON_PolyCurve
, ON_PolylineCurve
, ON_RevSurface
, ON_SubDEdgeChainCurve
, ON_SumSurface
, ON_Surface
- SetDontRepeatCommands()
: CRhinoAppSettings
- SetDontRepeatList()
: CRhinoAppDontRepeatCommandSettings
- SetDot()
: CRhinoTextDot
- SetDouble()
: CRhinoSettings
, ON_ArchivableDictionary
- SetDoubleArray()
: ON_ArchivableDictionary
- SetDoubleFormat()
: ON_TextLog
- SetDoublePrecision()
: ON_MeshParameters
- SetDoubleValue()
: CRhinoHistory
, CRhinoUiRegistry
, ON_HistoryRecord
- SetDoubleValues()
: CRhinoHistory
, ON_HistoryRecord
- SetDPI()
: CRhinoDib
- SetDpiScale()
: CRhinoDisplayEngine
, CRhinoDisplayPipeline
- SetDraftAngleAnalysisSettings()
: CRhinoAppSettings
- SetDraftAngleColorAnalysisColors()
: ON_Brep
, ON_Mesh
, ON_SubD
- SetDraftCurve()
: ON_SilhouetteParameters
- SetDragBitmap()
: CRhinoUiDragBitmapWnd
- SetDragPlane()
: CRhinoView
- SetDragZoomingOn()
: IRhRdkCustomCurveCtrl
- SetDrawAttr()
: IRhWidgetDrawCache
- SetDrawChannelsOverride()
: CRhinoDisplayPipeline
- SetDrawCheckBox()
: CRhinoUiOptionsListCtrlCheckBox
- SetDrawClippingPlanes()
: CRhinoPrintInfo
- SetDrawColor()
: CRhinoViewport
- SetDrawDecorations()
: CRhinoUiBlockPreview
- SetDrawDownArrow()
: CRhinoUiOptionsListCtrlComboBox
- SetDrawForward()
: ON_Annotation
, ON_DimStyle
- SetDrawLights()
: CRhinoPrintInfo
- SetDrawSeparatorLine()
: CRhinoUiOptionsListCtrlSeparator
- SetDrawsShadedMeshes()
: CRhinoGetPoint
- SetDrawTextMask()
: ON_Annotation
, ON_DimStyle
, ON_TextMask
- SetDWORDValue()
: CRhinoUiRegistry
- SetDynamicCircleCallback()
: CArgsRhinoGetCircle
- SetDynamicCylinderCallback()
: CArgsRhinoGetCylinderExtra
- SetDynamicDisplayAppearanceForExperts()
: CRhinoSubDObject
- SetDynamicDisplayForExperts()
: CRhinoSubDObject
- SetDynamicDrawBounds()
: CRhinoGetPoint
- SetDynamicDrawColor()
: CRhinoGetPoint
- SetDynamicLightLocation()
: CRhinoLight
- SetDynamicRectangleCallback()
: CArgsRhinoGetPlane
, CRhinoGetRectangle
- SetDynamicTransform()
: CRhinoObject
- SetEarthAnchorPoint()
: CRhinoDocProperties
- SetEarthCoordinateSystem()
: ON_EarthAnchorPoint
- SetEarthLocation()
: ON_EarthAnchorPoint
- SetEccentricity()
: CArgsRhinoGetEllipse
- SetEchoMode()
: CRhinoScriptContext
- SetEdgeAnalysisSettings()
: CRhinoAppSettings
- SetEdgeAngleThreshold()
: ON_EdgeSoftening
- SetEdgeChain()
: ON_SubDEdgeChainCurve
- SetEdgeChainSharpness()
: ON_SubDEdgeSharpness
- SetEdgeContinuitySettings()
: CRhinoAppSettings
- SetEdgeCurve()
: ON_Brep
- SetEdgeDomain()
: ON_Brep
- SetEdgeEndPrompt()
: CArgsRhinoGetPolygon
- SetEdgeMark()
: ON_SubDQuadFacePackSide
- SetEdgeMarks()
: ON_SubDFace
- SetEdgeMidpointPrompt()
: CArgsRhinoGetPolygon
- SetEdgeMode()
: CArgsRhinoGetPolygon
- SetEdgePoint()
: ON_MESH_POINT
- SetEdgeSelectionPoint()
: CRhinoObjRef
- SetEdgeSharpness()
: ON_SubD
- SetEdgeStartPrompt()
: CArgsRhinoGetPolygon
- SetEdgeTags()
: ON_SubD
- SetEdgeTolerance()
: ON_Brep
- SetEdgeTolerances()
: ON_Brep
- SetEdgeTopologyFilter()
: ON_SubDComponentFilter
- SetEdgeVertex()
: ON_Brep
- SetEditBoxBackground()
: CRhinoUiPaintColorSettings
- SetEditByTyping()
: CRhRdkSdkNumberEdit
- SetEditLabelOnDoubleClick()
: CRhinoUiTabbedSheetCtrl
- SetEditStyle()
: CRhinoUiListBoxEx
- SetEditText()
: CRhinoUiListBoxEx
- SetEditType()
: CRhinoUiEdit
- SetElapsedSeconds()
: IRhRdkRenderSession
- SetElevation()
: ON_EarthAnchorPoint
- SetEllipseMode()
: CArgsRhinoGetEllipse
- SetEmapAnalysisSettings()
: CRhinoAppSettings
- SetEmbeddedFileId()
: ON_FileReference
- SetEmbedFilesDocumentDefault()
: CRhRdkRendererSupportOptions
- SetEmbedOn()
: CRhRdkRenderingSettings
- SetEmbedSupportFilesOn()
: CRhRdkDocument
- SetEmission()
: CRhRdkBasicMaterial
, CRhRdkBasicMaterialCCI
, ON_Material
, ON_PhysicallyBasedMaterial
- SetEmptyText()
: IRhinoUiHolder
- SetEnable()
: IRhRdkCommandUpdate
- SetEnableAllowed()
: CRhRdkSunStorage
, IRhRdkSun
, ON_Sun
- SetEnableCache()
: IRhRdkCustomRenderMeshManager
- SetEnabled()
: CRhinoUiPanelFactory
, CRhRdkAction
, IRhRdkGroundPlane
, IRhRdkSafeFrame
, IRhRdkSkylight
, ON_Dithering
, ON_GroundPlane
, ON_SafeFrame
, ON_ShutLining::Curve
, ON_Skylight
- SetEnableDisplayCommands()
: CRhinoDialog
- SetEnableEditLabel()
: CRhinoUiLinetypeListCtrl
- SetEnableGumballToolTips()
: CRhinoAppCursorToolTipSettings
- SetEnableMultipleSelect()
: CRhinoUiLayerListCtrl
, CRhinoUiLinetypeListCtrl
- SetEnableOn()
: CRhRdkSunStorage
, IRhRdkSun
, ON_Sun
- SetEnableOsnapHighlight()
: CRhinoAppSettings
- SetEnableOsnaps()
: CRhinoAppSettings
- SetEnableScale()
: CRhinoGumballAppearance
- SetEnableSpinnerWhenBlank()
: CRhRdkSdkNumberEdit
- SetEndAnalysisSettings()
: CRhinoAppSettings
- SetEndAngle()
: CArgsRhinoRevolve
- SetEndAnglePrompt()
: CArgsRhinoGetArc
- SetEndDay()
: ON_3dmAnimationProperties
- SetEndDir()
: CArgsRhinoGetSpiral
- SetEndDistance()
: CRhinoTaperSpaceMorph
- SetEndHour()
: ON_3dmAnimationProperties
- SetEndMinutes()
: ON_3dmAnimationProperties
- SetEndMonth()
: ON_3dmAnimationProperties
- SetEndPoint()
: CArgsRhinoGetParabola
, CArgsRhinoGetSpiral
, CArgsRhinoLoft
, CRhinoPolyEdge
, ON_ArcCurve
, ON_Curve
, ON_LineCurve
, ON_NurbsCurve
, ON_PolyCurve
, ON_PolyEdgeCurve
, ON_PolylineCurve
, ON_SubDEdgeChainCurve
- SetEndPrompt()
: CArgsRhinoGetArc
, CArgsRhinoGetParabola
, CArgsRhinoGetSpiral
- SetEndSeconds()
: ON_3dmAnimationProperties
- SetEndTangent()
: CArgsRhinoGetCurve
- SetEndYear()
: ON_3dmAnimationProperties
- SetEnvironment()
: IRhRdkPreviewSceneServerEx
- SetEnvironmentId()
: ON_Skylight
- SetEnvironmentInstanceId()
: CRhRdkPreviewBackground
- SetEnvironmentMappingMode()
: CRhRdkTexture
- SetEnvironmentOverride()
: ON_Skylight
- SetEquationsHelper()
: ON_SurfaceLeafBox
- SetError()
: CRhRdkTask
, ON_DecodeBase64
- SetErrorHandler()
: ON_Buffer
- SetErrorString()
: CRhRdkContentCreator
- SetEvaluationSerialNumber()
: ON_TextContent
- SetEventPriority()
: IRhinoUiController
- SetExcludedFiles()
: CRhinoAppFileSettings
- SetExcludedParamNames()
: CRhRdkContent::CRenderCRCFlags
- SetExpandableTabFlag()
: CRhinoUiExpandableTabCtrl
- SetExtDir1()
: ON_DimAngular
- SetExtDir2()
: ON_DimAngular
- SetExtensionLineColor()
: ON_DimStyle
- SetExtensionLineColorSource()
: ON_DimStyle
- SetExtensionLineExtension()
: ON_Annotation
- SetExtensionLineOffset()
: ON_Annotation
- SetExtensionLinePlotColor()
: ON_DimStyle
- SetExtensionLinePlotColorSource()
: ON_DimStyle
- SetExtensionLinePlotWeight()
: ON_DimStyle
- SetExtensionLinePlotWeightSource()
: ON_DimStyle
- SetExtents()
: ON_PlaneSurface
- SetExtExtension()
: ON_DimStyle
- SetExtOffset()
: ON_DimStyle
- SetExtraordinaryVertexProcess()
: ON_SubDToBrepParameters
- SetExtraRequirementParameter()
: CRhRdkBasicMaterial
, CRhRdkContent
, CRhRdkOneColorTextureBase
, CRhRdkTwoColorTextureBase
, IAutoUIExtraRequirements
- SetExtrusion()
: CRhinoExtrusionObject
- SetFaceBoundary()
: ON_SubD
- SetFaceColor()
: ON_SubDExpandEdgesParameters
- SetFaceEdgeCountFilter()
: ON_SubDComponentFilter
- SetFaceIndex()
: ON_Displacement::SubItem
- SetFaceMark()
: ON_SubDQuadFacePackSide
- SetFaceMode()
: IRhinoMeshExtruder
- SetFacePackingIdForExperts()
: ON_SubD
- SetFacePoint()
: ON_MESH_POINT
- SetFaceStatus()
: ON_SubDExpandEdgesParameters
- SetFaceStyle()
: ON_SubDExpandEdgesParameters
- SetFaceted()
: ON_CurvePiping
, ON_EdgeSoftening
, ON_ShutLining
- SetFaceTopologyFilter()
: ON_SubDComponentFilter
- SetFaceType()
: ON_MeshParameters
- SetFairing()
: ON_Displacement
- SetFairingOn()
: ON_Displacement
- SetFamilyName()
: ON_Font
- SetFancyMesh()
: CRhinoDrawFancyAttributes
- SetFeatureAttrs()
: CRhinoRenderOverlays
- SetFeedbackColor()
: CArgsRhinoAnnotationLeader
, CArgsRhinoGetLine
, CArgsRhinoGetPlane
- SetField()
: CRhRdkBasicMaterial::CTextureSlot
- SetFieldGridOn()
: IRhRdkSafeFrame
, ON_SafeFrame
- SetFieldOverride()
: ON_DimStyle
- SetFieldOverrideAll()
: ON_DimStyle
- SetFieldsOn()
: IRhRdkSafeFrame
- SetFileCheckSum()
: ON_CheckSum
- SetFileDialog()
: CRhinoUiOptionsListCtrlFileNameEditBox
- SetFileDialogCtrlType()
: CRhinoUiOptionsListCtrlFileNameEditBox
- SetFileExtension()
: ON_3dmAnimationProperties
- SetFileFullPath()
: ON_Bitmap
- SetFileName()
: CRhinoEmapAnalysisSettings
, CRhinoFileWriteOptions
- SetFilename()
: CRhRdkSimulatedTexture
, CRhRdkTextureArray
, IRhRdkFileBasedContent
, ON_EmbeddedFile
, ON_RenderTexture
- SetFilenameOverride()
: CRhRdkContentCreatorLoad
- SetFilePath()
: CRhinoUiStaticEx
- SetFileReadingPlugInId()
: CRhinoOpenDocumentOptions
- SetFileReadOptions()
: CRhinoApp
- SetFileReference()
: ON_Bitmap
- SetFileSearchRecursiveDepth()
: CRhinoAppFileSettings
- SetFileSettings()
: CRhinoAppSettings
- SetFileTypeIdAndIndex()
: CRhinoFileWriteOptions
- SetFileTypeIndex()
: CRhinoFileType
- SetFileTypePlugInID()
: CRhinoFileType
- SetFileWriteOptions()
: CRhinoGetFileDialog
- SetFillBackground()
: CRhRdkResizingDialog
- SetFillOrBoundaryRequest()
: CRhinoRenderOverlays
- SetFillType()
: ON_HatchPattern
- SetFilter()
: CRhRdkContentField
- SetFiltered()
: CRhRdkBasicMaterialCCI
, CRhRdkSimulatedTexture
- SetFilterOn()
: CRhRdkBasicMaterial::CTextureSlot
- SetFinalMaxFaces()
: ON_Displacement
- SetFinalMaxFacesOn()
: ON_Displacement
- SetFirstCommandId()
: CRhRdkCustomRenderFrameToolBar
, IRhRdkCustomRenderFrameToolBar
- SetFirstDiameterPrompt()
: CArgsRhinoGetSpiral
- SetFirstDirectionCount()
: CArgsRhinoGetPlane
- SetFirstDirectionMinCount()
: CArgsRhinoGetPlane
- SetFirstMeshDensityDirectionPrompt()
: CArgsRhinoGetPlane
- SetFirstPoint()
: CArgsRhinoGetEllipse
, CArgsRhinoGetLine
, CArgsRhinoGetPlane
, CArgsRhinoGetPolygon
- SetFirstPointPrompt()
: CArgsRhinoGetLine
- SetFirstPointPrompt3Point()
: CArgsRhinoGetPlane
- SetFirstPointPromptCenter()
: CArgsRhinoGetPlane
- SetFirstPointPromptCorners()
: CArgsRhinoGetPlane
- SetFirstPointPromptVertical()
: CArgsRhinoGetPlane
- SetFirstPrompt()
: CArgsRhinoAnnotationLeader
, CArgsRhinoGetCurve
, CArgsRhinoGetEllipse
, CArgsRhinoGetSubCurve
- SetFirstPromptIfEmpty()
: CArgsRhinoGetEllipse
- SetFirstRadius()
: CArgsRhinoGetSpiral
- SetFirstRadiusPrompt()
: CArgsRhinoGetSpiral
- SetFixedColumnWidth()
: CRhinoUiOptionsListCtrl
- SetFixedExtensionLen()
: ON_DimStyle
- SetFixedExtensionLength()
: ON_Annotation
- SetFixedExtensionLengthOn()
: ON_Annotation
- SetFixedExtensionLenOn()
: ON_DimStyle
- SetFixedSpinnerDelta()
: CRhRdkSdkNumberEdit
- SetFlags()
: CRhinoPlugInCommandRecord
- SetFlamingoLibrary()
: CRhRdkBasicMaterial
- SetFlat()
: CArgsRhinoGetSpiral
- SetFlip()
: CArgsRhinoGetPolygon
- SetFloat()
: CRhinoSettings
, ON_ArchivableDictionary
- SetFloatArray()
: ON_ArchivableDictionary
- SetFloatFormat()
: ON_TextLog
- SetFloatingRhinoViewPlacement()
: CRhinoView
- SetFocalBlurAperture()
: ON_3dmView
- SetFocalBlurDistance()
: ON_3dmView
- SetFocalBlurJitter()
: ON_3dmView
- SetFocalBlurMode()
: ON_3dmView
- SetFocalBlurSampleCount()
: ON_3dmView
- SetFocus()
: CRhinoView
, IRhinoUiWindow
- SetFocused()
: IRhinoWindow
- SetFocusPoint()
: CArgsRhinoGetParabola
- SetFocusPrompt()
: CArgsRhinoGetParabola
- SetFolderName()
: ON_3dmAnimationProperties
- SetFont()
: ON_Annotation
, ON_DimStyle
, ON_TextRun
, ON_TextStyle
- SetFontCharacteristics()
: ON_Font
- SetFontCharacteristicsForExperts()
: ON_Font
- SetFontDescriptionForExperts()
: ON_Font
- SetFontFace()
: CRhinoTextDot
, ON_TextDot
- SetFontFaceName()
: ON_Font
- SetFontFromDescription()
: ON_TextStyle
- SetFontIndex()
: ON_RtfFirstChar::TextRun
, ON_RtfStringBuilder::TextRun
- SetFontOrigin()
: ON_Font
- SetFontStretch()
: ON_Font
- SetFontStyle()
: ON_Font
- SetFontWeight()
: ON_Font
- SetForceArrowPosition()
: ON_Dimension
- SetForcedAspectRatio()
: CArgsRhinoGetPlane
- SetForceDimLine()
: ON_Dimension
, ON_DimStyle
- SetForcedStyles()
: CRhRdkSdkNumberEdit
- SetForcedVaries()
: IRhRdkNewContentCtrl
- SetForceSoftening()
: ON_EdgeSoftening
- SetForceTextPosition()
: ON_Dimension
- SetForceUpdate()
: ON_ShutLining
- SetForeColor()
: CRhinoUiProgressCtrl
- SetFormatKeyword()
: CRhinoUiEdit
- SetFormatPending()
: ON_TextBuilder::TextProps
- SetFormattingRectangleWidth()
: ON_Annotation
, ON_TextContent
- SetFractionalAlpha()
: ON_Color
- SetFractionalRGB()
: ON_Color
- SetFractionalRGBA()
: ON_Color
- SetFragmentColorsFromCallback()
: ON_SubD
- SetFragmentColorsMappingTag()
: ON_SubD
- SetFragmentTextureCoordinates()
: ON_SubD
- SetFrame()
: CRhinoGetAngle
- SetFrameCount()
: ON_3dmAnimationProperties
- SetFramePrompt()
: CArgsRhinoGetFrame
, CRhinoGetFrameOnObject
- SetFrameSize()
: CRhinoDisplayPipeline
- SetFresnelReflections()
: ON_Material
- SetFromAppleFontName()
: ON_Font
- SetFromArc()
: CRhinoGumball
, CRhinoGumballFrame
- SetFromBoundingBox()
: CRhinoGumball
, CRhinoGumballFrame
- SetFromBrepObject()
: CRhinoGumball
, CRhinoGumballFrame
- SetFromCircle()
: CRhinoGumball
, CRhinoGumballFrame
- SetFromClippingPlane()
: CRhinoGumball
, CRhinoGumballFrame
- SetFromColor()
: CRhinoUiGradientSliderCtrl
- SetFromCurrent()
: CRhinoWidgetColorSettings
- SetFromCurve()
: CRhinoGumball
, CRhinoGumballFrame
- SetFromDisplayObjectAttrs()
: CDisplayPipelineAttributes
- SetFromDoubleArray()
: ON_3dPointListRef
- SetFromEllipse()
: CRhinoGumball
, CRhinoGumballFrame
- SetFromExtrusion()
: CRhinoGumball
, CRhinoGumballFrame
- SetFromExtrusionObject()
: CRhinoGumball
, CRhinoGumballFrame
- SetFromFaceList()
: ON_MeshVertexFaceMap
- SetFromFloatArray()
: ON_3dPointListRef
- SetFromFontDescription()
: ON_Font
- SetFromHatch()
: CRhinoGumball
, CRhinoGumballFrame
- SetFromLight()
: CRhinoGumball
, CRhinoGumballFrame
- SetFromLine()
: CRhinoGumball
, CRhinoGumballFrame
- SetFromMesh()
: ON_3dPointListRef
, ON_MeshFaceList
, ON_MeshVertexFaceMap
- SetFromMeshObject()
: CRhinoGumball
, CRhinoGumballFrame
- SetFromMorphControlObject()
: CRhinoGumball
, CRhinoGumballFrame
- SetFromPlane()
: CRhinoGumball
, CRhinoGumballFrame
- SetFromPostScriptName()
: ON_Font
- SetFromQuadList()
: ON_MeshFaceList
- SetFromSectorType()
: ON_SubDMatrix
- SetFromSemicolonDelimitedString()
: CRhRdkContentKindList
- SetFromSettings()
: CRhinoDocProperties
- SetFromSubDComponentParameter()
: ON_ObjRefEvaluationParameter
- SetFromSubDObject()
: CRhinoGumball
, CRhinoGumballFrame
- SetFromTriangleList()
: ON_MeshFaceList
- SetFrustLeft()
: CRhinoStereoDisplayConduit
- SetFrustRight()
: CRhinoStereoDisplayConduit
- SetFrustum()
: ON_Viewport
- SetFrustumAspect()
: ON_Viewport
- SetFrustumLeftRightSymmetry()
: ON_Viewport
- SetFrustumNearFar()
: ON_Viewport
- SetFrustumTopBottomSymmetry()
: ON_Viewport
- SetFullCurve()
: ON_HLDFullCurve
- SetFullHeightSection()
: IRhinoUiHolder
- SetFullPath()
: ON_FileReference
- SetFullPathStatus()
: ON_FileReference
- SetFullscreen()
: CRhinoApp
- SetFuzzyAutocomplete()
: CRhinoAppSettings
- SetGamma()
: CRhRdkImageAdjust
, CRhRdkRenderingSettings
, IRhRdkImageAdjust
- SetGeneralSettings()
: CRhinoAppSettings
- SetGeometry()
: CRhinoProxyObject
, CRhRdkRenderMesh
- SetGeometryAttributeFilter()
: CRhinoDropTarget
, CRhinoGetObject
- SetGeometryEx()
: CRhRdkRenderMesh
- SetGeometryFilter()
: CRhinoDisplayConduit
, CRhinoDropTarget
, CRhinoGetObject
- SetGeometryObjectFilter()
: CRhinoFileWriteOptions
- SetGeometrySource()
: CRhinoDisplayPipeline
- SetGeometryValue()
: CRhinoHistory
, ON_HistoryRecord
- SetGeometryValues()
: CRhinoHistory
, ON_HistoryRecord
- SetGeometryWhenGripDropped()
: CRhinoWidget
- SetGetPointCursor()
: CRhinoGetPoint
- SetGetRenderedViewSettingsFromDoc()
: CRhinoAppSettings
- SetGettingStarModePolygon()
: CArgsRhinoGetPolygon
- SetGlobalDragForce()
: ON_ParticleSystem
- SetGlobalGravityForce()
: ON_ParticleSystem
- SetGloss()
: CRhRdkBasicMaterial
- SetGlossFinish()
: CRhRdkBasicMaterial
- SetGlyphMetrics()
: ON_Outline
- SetGoodHairColor()
: CRhinoEdgeContinuitySettings
- SetGradientColors()
: ON_Hatch
- SetGradientEndPoints()
: ON_Hatch
- SetGradientRepeat()
: ON_Hatch
- SetGradientType()
: ON_Hatch
- SetGraphInfo()
: CRhRdkTexture
- SetGreen()
: ON_4fColor
- SetGridAmplification()
: ON_MeshParameters
- SetGridAngleDegrees()
: ON_MeshParameters
- SetGridAngleRadians()
: ON_MeshParameters
- SetGridAspectRatio()
: ON_MeshParameters
- SetGridAttributes()
: CDisplayPipelineAttributes
- SetGridDefaults()
: CRhinoDocProperties
- SetGridFrequencies()
: IRhRdkCustomCurveCtrl
- SetGridFrequencyOn()
: IRhRdkCustomCurveCtrl
- SetGridLineColor()
: CRhinoUiOptionsListCtrl
- SetGridMaxCount()
: ON_MeshParameters
- SetGridMinCount()
: ON_MeshParameters
- SetGridModeOrientation()
: IRhRdkThumbnails
- SetGridSettings()
: CRhinoAppSettings
- SetGripDirections()
: CRhinoGripObject
- SetGripFrameTransform()
: CRhinoGetXform
- SetGripStatus()
: CRhinoObjectGrips
- SetGroupId()
: CRhRdkContent
, ON_RenderContent
, ON_SubDComponentPtr
- SetGumballAutoReset()
: CRhinoAppSettings
- SetGumballColors()
: CRhinoAppSettings
- SetGumballSizes()
: CRhinoAppSettings
- SetHalfMode()
: CArgsRhinoGetParabola
- SetHarvestContentParameters()
: CRhRdkRendererSupportOptions
- SetHash()
: RhRdk::CustomRenderMeshes::IRenderMeshes
- SetHasTransparentColor()
: CRhRdkSimulatedTexture
- SetHatch()
: CRhinoHatch
- SetHatchBackgroundFillColor()
: ON_3dmObjectAttributes
- SetHatchBoundaryVisible()
: ON_3dmObjectAttributes
- SetHatchColor()
: ON_SectionStyle
- SetHatchIndex()
: ON_SectionStyle
- SetHatchLines()
: ON_HatchPattern
- SetHatchRotation()
: ON_SectionStyle
- SetHatchScale()
: ON_SectionStyle
- SetHaveFirstPoint()
: CArgsRhinoGetPlane
- SetHavePlane()
: CArgsRhinoGetPlane
- SetHaveSecondPoint()
: CArgsRhinoGetPlane
- SetHaveThirdPoint()
: CArgsRhinoGetPlane
- SetHeight()
: CArgsRhinoGetConeExtra
, CArgsRhinoGetCylinderExtra
, CArgsRhinoText
, ON_Decal
, ON_TextBuilder::TextProps
- SetHeightInPoints()
: ON_TextDot
- SetHeightPrompt()
: CArgsRhinoGetBox
, CArgsRhinoGetCylinder
- SetHeights()
: ON_FontMetrics
- SetHelixMode()
: CArgsRhinoGetSpiral
- SetHidden()
: CRhRdkContent
, ON_RenderContent
- SetHiddenLineColor()
: CRhinoAppSettings
- SetHiddenLineColorMixingFactor()
: CRhinoAppSettings
- SetHiddenLineEnabled()
: CRhinoAppSettings
- SetHiddenLineMode()
: CRhinoAppSettings
- SetHiddenLineThicknessScale()
: CRhinoAppSettings
- SetHiddenModelComponentState()
: ON_ModelComponent
- SetHiddenPointFlag()
: ON_PointCloud
- SetHiddenState()
: ON_ComponentStatus
- SetHideFromUserInterface()
: CRhinoSettings
- SetHideOnClickOnListItem()
: CRhinoUiPopUpListWnd
- SetHideOnKillFocus()
: CRhinoUiPopUpListWnd
- SetHideOnMouseOver()
: CRhinoUiToolTip
- SetHighlightedState()
: ON_ComponentStatus
- SetHilightColors()
: CRhinoUiFontComboBox
- SetHistory()
: CRhinoObject
- SetHistoryVersion()
: CRhinoHistory
- SetHorizontalDirection()
: ON_Annotation
- SetHorzSweep()
: ON_Decal
- SetHotSpot()
: ON_Light
- SetHSL()
: CRhRdkColor
- SetHSV()
: ON_Color
- SetHtmlFilename()
: ON_3dmAnimationProperties
- SetHugeStringValue()
: ON_XMLProperty
- SetId()
: ON_AerialPhotoImage
, ON_ComponentManifestItem
, ON_ModelComponent
, ON_ShutLining::Curve
- SetIdentification()
: ON_ModelComponent
- SetIdRemap()
: ON_TextHash
- SetIgesLevel()
: ON_Layer
- SetIgnoredObject()
: ChangeQueue
, RhRdk::Realtime2::ChangeQueue
- SetIgnoreOn()
: CRhRdkSunDialog
- SetIgnoreTrims()
: CArgsRhinoGetLine
- SetIgnoreZeroTypeFonts()
: CRhinoUiFontComboBox
- SetImageFileName()
: ON_AerialPhotoImage
- SetImageFrustum()
: ON_AerialPhotoImage
- SetImageList()
: CRhinoUiButton
- SetImageListIndex()
: CRhinoUiButton
- SetImageSize()
: IRhinoSdkRenderFrame
, ON_AerialPhotoImage
- SetImpliedMultiplication()
: ON_ArithmeticCalculator
- SetImportFileLayerMatchingOption()
: CRhinoAppFileSettings
, CRhinoAppSettings
- SetIncludeAddButton()
: CRhinoUiTabbedSheetCtrl
- SetIncludeBitmaps()
: CRhinoFileWriteOptions
- SetIncludeByDisplay()
: CRhinoUiOptionsListCtrlColorComboBox
- SetIncludeByLayer()
: CRhinoUiOptionsListCtrlColorComboBox
, CRhinoUiOptionsListCtrlLinetypeComboBox
, CRhinoUiOptionsListCtrlPrintWidthComboBox
- SetIncludeByParent()
: CRhinoUiOptionsListCtrlColorComboBox
, CRhinoUiOptionsListCtrlLinetypeComboBox
, CRhinoUiOptionsListCtrlPrintWidthComboBox
- SetIncludeDefault()
: CRhinoUiOptionsListCtrlPrintWidthComboBox
- SetIncludeDefaults()
: CRhinoUiOptionsListCtrlLinetypeComboBox
- SetIncludeDegenerateEdgePoints()
: ON_MeshXPlane
- SetIncludeDeletedLayers()
: CRhinoUiOptionsListCtrlLayerComboBox
- SetIncludeDeletedLinetypes()
: CRhinoUiOptionsListCtrlLinetypeComboBox
- SetIncludeFirstAndLastButtons()
: CRhinoUiTabbedSheetCtrl
- SetIncludeHairline()
: CRhinoUiOptionsListCtrlPrintWidthComboBox
- SetIncludeNextAndPreviousButtons()
: CRhinoUiTabbedSheetCtrl
- SetIncludeNoPrint()
: CRhinoUiOptionsListCtrlPrintWidthComboBox
- SetIncludeNotes()
: CRhinoFileWriteOptions
- SetIncludeObjectHistory()
: CRhinoFileWriteOptions
- SetIncludeOverlapFacets()
: ON_MeshXPlane
- SetIncludePlugInInformation()
: CRhinoFileWriteOptions
- SetIncludePreviewImage()
: CRhinoFileWriteOptions
- SetIncludeRange()
: CArgsRhinoGetSubCurve
- SetIncludeReferenceLayers()
: CRhinoUiOptionsListCtrlLayerComboBox
- SetIncludeReferenceLinetypes()
: CRhinoUiOptionsListCtrlLinetypeComboBox
- SetIncludeReferenceModelInformation()
: CRhinoFileWriteOptions
- SetIncludeRenderMeshes()
: CRhinoFileWriteOptions
- SetIncludeSpinner()
: CRhinoUiEdit
- SetIncludeTextures()
: CRhinoFileWriteOptions
- SetIncludeVertexPoints()
: ON_MeshXPlane
- SetInColorTable()
: ON_RtfFirstChar
, ON_RtfStringBuilder
- SetIndentCount()
: ON_TextLog
- SetIndentItems()
: CRhinoUiOptionsListCtrl
- SetIndentLevel()
: CRhinoUiOptionsListCtrlItem
- SetIndentSize()
: ON_TextLog
- SetIndentSpacing()
: CRhinoUiOptionsListCtrl
- SetIndex()
: ON_2dexMap
, ON_ComponentManifestItem
, ON_ModelComponent
- SetInfiniteDepth()
: CRhinoDisplayPipeline
- SetIniFileName()
: CRhinoIniProfileContext
- SetInitialGeometry()
: CRhinoWidget
- SetInitialQuality()
: ON_Displacement
- SetInitialSize()
: CRhinoUiDialogItemResizer
- SetInitialSizeDockedHorz()
: CRhinoUiDockBar
- SetInitialSizeDockedVert()
: CRhinoUiDockBar
- SetInitialSizeFloating()
: CRhinoUiDockBar
- SetInListPassesResult()
: ON_SubDComponentIdList
- SetInnerColor()
: IRhRdkCustomCurveCtrl
- SetInPrintPreview()
: CRhinoDetailViewObject
- SetInputCurve()
: CArgsRhinoFair
- SetInscribed()
: CArgsRhinoGetPolygon
- SetInscribedAroundCurveCenterPrompt()
: CArgsRhinoGetPolygon
- SetInscribedCenterPrompt()
: CArgsRhinoGetPolygon
- SetInstanceDefinition()
: CRhinoInstanceObject
, CRhinoUiBlockPreview
- SetInstanceDefinitionObject()
: CRhinoUiBlockPreview
- SetInstanceDefinitionTransform()
: CRhinoDisplayEngine
, CRhinoDisplayPipeline
- SetInstanceDefinitionType()
: ON_InstanceDefinition
- SetInstanceGeometryIdList()
: ON_InstanceDefinition
- SetInstanceId()
: CRhRdkContent
- SetInstanceName()
: CRhRdkContent
, CRhRdkMaterial
- SetInstanceNameImpl()
: CRhRdkContent
- SetInstanceTransform()
: CRhinoInstanceObject
, CRhRdkCustomRenderMeshes
, IRhRdkCustomRenderMeshes
- SetInt16()
: ON_ArchivableDictionary
- SetInt16Array()
: ON_ArchivableDictionary
- SetInt32()
: ON_ArchivableDictionary
- SetInt32Array()
: ON_ArchivableDictionary
- SetInt64()
: ON_ArchivableDictionary
- SetInt8()
: ON_ArchivableDictionary
- SetInt8Array()
: ON_ArchivableDictionary
- SetInteger()
: CRhinoSettings
- SetIntensity()
: IRhRdkSun
, ON_Light
, ON_Sun
- SetInteractive()
: CArgsRhinoAnnotationLeader
, CArgsRhinoText
- SetInterestObject()
: CRhinoWidget
, IRhWidgetDrawCache
- SetInteriorCreaseOption()
: ON_SubDFromMeshParameters
- SetInternalDebuggingFlags()
: ON_XMLNode
- SetInterpolateMeshVertices()
: ON_SubDFromMeshParameters
- SetIntValue()
: CRhinoHistory
, CRhinoUiRegistry
, ON_HistoryRecord
- SetIntValues()
: CRhinoHistory
, ON_HistoryRecord
- SetInvalidTolerancesToDefaultValues()
: ON_3dmUnitsAndTolerances
- SetIOR()
: CRhRdkBasicMaterial
- SetIor()
: CRhRdkBasicMaterialCCI
- SetIOSettings()
: CRhinoDocProperties
- SetIPAddress()
: CRhinoUiOptionsListCtrlIPAddress
- SetIsAutosave()
: CRhinoFileWriteOptions
- SetIsBakedMaterial()
: CDisplayAttributeMaterial
- SetIsBump()
: ON_ShutLining::Curve
- SetIsChecked()
: IRhRdkTaskUpdate
- SetIsCombineable()
: CRhRdkContentArray
- SetIsEnabled()
: CRhinoUiOptionsListCtrlItem
, IRhinoWindow
, IRhRdkParamBlock::IParam
, IRhRdkTaskUpdate
- SetIsFullRowItem()
: CRhinoUiOptionsListCtrlItem
- SetIsHidden()
: IRhRdkParamBlock::IParam
- SetIsHiddenInAutoUI()
: CRhRdkContentField
- SetIsMenuButton()
: CRhinoUiButton
- SetIsModified()
: CRhinoDisplayAttrsMgr
- SetIsNormalMap()
: CRhRdkTexture
- SetIsPreview()
: CRhinoDisplayEngine
, CRhinoDisplayEngine_OGL
- SetIsReadOnly()
: CRhinoUiOptionsListCtrlItem
- SetIsReference()
: CRhRdkContent
- SetIsRenderCRCRecursive()
: CRhRdkContent
- SetIsRendering()
: IRhRdkRenderWindow
- SetIsRhinoObjectSelected()
: CRhRdkContent
- SetIsSelectionMapColor()
: CDisplayAttributeMaterial
- SetIsVisible()
: IRhinoWindow
, ON_Decal
- SetItalic()
: CRhinoTextDot
, ON_RtfFirstChar::TextRun
, ON_RtfStringBuilder::TextRun
, ON_TextBuilder::TextProps
, ON_TextDot
- SetItem()
: CRhinoUiListBoxEx
, CRhinoUiTabbedSheetCtrl
- SetItemData()
: CRhinoUiTabbedSheetCtrl
- SetItemDataPtr()
: CRhinoUiTabbedSheetCtrl
- SetItemProperty()
: CRhinoUiOptionsListCtrlItem
- SetItemState()
: CRhinoUiExpandableTabCtrlItem
, CRhinoUiOptionsListCtrlItem
- SetItemText()
: CRhinoUiListBoxEx
- SetItemWindow()
: CRhinoUiTabbedSheetCtrlItem
- SetIterationCount()
: CArgsRhinoFair
- SetIteratorObjectTypes()
: CRhRdkMarkedObjects
- SetJaggedSeams()
: ON_MeshParameters
- SetKeepOriginalFaces()
: IRhinoMeshExtruder
- SetKeyScaling()
: CRhRdkSdkNumberEdit
- SetKinkOffset1()
: ON_DimOrdinate
- SetKinkOffset2()
: ON_DimOrdinate
- SetKnot()
: ON_NurbsCage
, ON_NurbsCurve
, ON_NurbsSurface
- SetKnotSpacing()
: CArgsRhinoGetCurve
- SetLabel()
: CRhinoUiOptionsListCtrlItem
- SetLabelBackGroundColor()
: CRhinoUiOptionsListCtrlItem
- SetLabelBkGrndColor()
: CRhinoUiOptionsListCtrl
, CRhinoUiPointEdit
- SetLabelFormatLoc()
: CRhRdkRendererSupportOptions
- SetLabelFormatUTC()
: CRhRdkRendererSupportOptions
- SetLabelRect()
: CRhinoUiTabbedSheetCtrlItem
- SetLabelTextColor()
: CRhinoUiOptionsListCtrl
, CRhinoUiOptionsListCtrlItem
, CRhinoUiPointEdit
- SetLastSavedRenderFileExtension()
: CRhRdkRendererSupportOptions
- SetLastSaveName()
: CRhinoDib
- SetLatitude()
: CRhRdkSunStorage
, IRhRdkSun
, ON_3dmAnimationProperties
, ON_EarthAnchorPoint
, ON_Sun
, ON_SunEngine
- SetLatitudeAndLongitude()
: ON_EarthAnchorPoint
- SetLayerEditingEnabled()
: CRhinoUiLayerListCtrl
- SetLayerFilter()
: CRhinoObjectIterator
- SetLayoutRectangles()
: CRhinoPrintInfo
- SetLeader()
: CRhinoLeader
- SetLeaderArrowBlockId()
: ON_Annotation
, ON_DimStyle
- SetLeaderArrowSize()
: ON_Annotation
, ON_DimStyle
- SetLeaderArrowType()
: ON_Annotation
, ON_DimStyle
- SetLeaderContentAngleDegrees()
: ON_Annotation
, ON_DimStyle
- SetLeaderContentAngleRadians()
: ON_Annotation
, ON_DimStyle
- SetLeaderContentAngleStyle()
: ON_Annotation
, ON_DimStyle
- SetLeaderCurveType()
: ON_Annotation
, ON_DimStyle
- SetLeaderHasLanding()
: ON_Annotation
, ON_DimStyle
- SetLeaderLandingLength()
: ON_Annotation
, ON_DimStyle
- SetLeaderTextHorizontalAlignment()
: ON_Annotation
, ON_DimStyle
- SetLeaderTextOrientation()
: ON_Annotation
, ON_DimStyle
- SetLeaderTextVerticalAlignment()
: ON_Annotation
, ON_DimStyle
- SetLeafBox()
: ON_CurveTreeBezier
, ON_SurfaceTreeBezier
- SetLease()
: CRhinoLicenseValidator
- SetLength()
: CArgsRhinoGetLine
, CArgsRhinoGetPlane
, CArgsRhinoGetSpiral
, ON_Light
, ON_String
, ON_wString
- SetLengthFactor()
: ON_Annotation
, ON_DimStyle
- SetLengthResolution()
: ON_Annotation
, ON_DimStyle
- SetLevel0Component()
: ON_SubDComponentRegion
- SetLevel0EdgePtr()
: ON_SubDComponentRegion
- SetLevel0Face()
: ON_SubDComponentRegion
- SetLevel0Vertex()
: ON_SubDComponentRegion
- SetLevelOfDetail()
: CRhinoDisplayPipeline
, ON_TextLog
- SetLibrariesInitialLocation()
: CRhRdkRendererSupportOptions
- SetLibrariesInitialLocationCustomFolder()
: CRhRdkRendererSupportOptions
- SetLibraryStatus()
: ON
- SetLicenseCapabilities()
: CRhinoPlugIn
- SetLightIndex()
: ON_3dmAnimationProperties
, ON_Light
- SetLightName()
: ON_Light
- SetLightSolo()
: CRhRdkLightManagerSupport
- SetLimits()
: CRhRdkContentField
- SetLimitText()
: CRhRdkSdkNumberEdit
- SetLinearDimensionType()
: ON_DimLinear
- SetLinearRollingDelta()
: CRhRdkSdkNumberEdit
- SetLinearWorkflow()
: CRhinoDisplayEngine
, CRhinoDisplayEngine_OGL
- SetLineCapStyle()
: ON_Linetype
- SetLineJoinStyle()
: ON_Linetype
- SetLineMode()
: CArgsRhinoGetLine
- SetLinePattern()
: CRhinoDisplayPipeline
- SetLinetype()
: RhMeshPipeArgs
- SetLinetypeDrawScaleFactor()
: CRhinoPageView
- SetLinetypeIndex()
: ON_Layer
- SetLinetypePatternScale()
: ON_3dmObjectAttributes
- SetLinetypeScale()
: CRhinoLinetypeTable
- SetLinetypeSource()
: ON_3dmObjectAttributes
- SetLinetypeWidthUnitAsPageLengths()
: CRhinoPrintInfo
- SetLinkedComponentAppearance()
: ON_InstanceDefinition
- SetLinkedFileReference()
: ON_InstanceDefinition
- SetListBox()
: CRhinoUiListBoxExBuddy
- SetListStyle()
: CRhinoUiOptionsListCtrl
- SetLiveFrameOn()
: IRhRdkSafeFrame
, ON_SafeFrame
- SetLoadProtection()
: CRhinoPlugInRecord
- SetLocalDateTime()
: CRhRdkSunStorage
, IRhRdkSun
, ON_Sun
, ON_SunEngine
- SetLocalizedSystemComponentName()
: ON_ModelComponent
- SetLocalJulianDay()
: ON_SunEngine
- SetLocation()
: IRhinoWindow
, IRhRdkPreviewSceneServerEx::IObjectEx
, ON_AerialPhotoCameraPosition
, ON_Light
- SetLock()
: CRhRdkSdkNumberEdit
- SetLocked()
: CRhRdkContent
, ON_Layer
, RhRdk::Realtime::DisplayMode::IHUDFunctionality
- SetLockedModelComponentState()
: ON_ModelComponent
- SetLockedObjectColor()
: CRhinoAppAppearanceSettings
- SetLockedState()
: ON_ComponentStatus
- SetLockWindowTop()
: CRhinoUiPopUpListWnd
- SetLoftType()
: CArgsRhinoLoft
- SetLogfont()
: CRhinoUiOptionsListCtrlFontComboBox
- SetLogfontCharSet()
: ON_Font
- SetLongitude()
: CRhRdkSunStorage
, IRhRdkSun
, ON_3dmAnimationProperties
, ON_EarthAnchorPoint
, ON_Sun
, ON_SunEngine
- SetLookForMissingFile()
: CRhinoFileReadOptions
- SetLoopVertices()
: ON_Brep
- SetLowerBound()
: CRhRdkSdkNumberEdit
- SetLowerLimit()
: CRhinoGetNumber
- SetMacro()
: CRhinoAppShortcutKeys
- SetMakeBold()
: ON_RtfStringBuilder
- SetMakeFacename()
: ON_RtfStringBuilder
- SetMakeItalic()
: ON_RtfStringBuilder
- SetMakeUnderline()
: ON_RtfStringBuilder
- SetMakeVisible()
: CRhinoOpenDocumentOptions
- SetManagedAnnotationSettings()
: ON_3dmAnnotationContext
- SetManagedDimStyle()
: ON_3dmAnnotationContext
- SetManager()
: CRhRdkPostEffect
, CRhRdkPostEffectPlugIn
, IRhRdkPostEffect
- SetManualControlAllowed()
: CRhRdkSunStorage
, IRhRdkSun
, ON_Sun
- SetManualControlOn()
: CRhRdkSunStorage
, IRhRdkSun
, ON_Sun
- SetMapEntry()
: CRhinoWidgetGeometry
- SetMapping()
: ON_Decal
- SetMappingAndProjection()
: CRhRdkSimulatedTexture
- SetMappingChannel()
: CRhRdkSimulatedTexture
, CRhRdkTexture
, ON_Displacement
, ON_Displacement::SubItem
, ON_Texture
- SetMappingMeshInfo()
: ON_Mesh
- SetMapToInside()
: ON_Decal
- SetMargin()
: IRhinoUiHolder
- SetMargins()
: CRhinoPrintInfo
, CRhinoUiDockBarExpandableTabCtrl
, IRhRdkCustomCurveCtrl
- SetMark()
: ON_BrepQuadFacePackSide
, ON_SubDComponentBase
, ON_SubDComponentPtr
, ON_SubDEdgePtr
, ON_SubDFacePtr
, ON_SubDQuadFacePackSide
, ON_SubDVertexPtr
- SetMarkBits()
: ON_ComponentStatus
, ON_SubDComponentBase
, ON_SubDComponentPtr
, ON_SubDEdgePtr
, ON_SubDFacePtr
, ON_SubDVertexPtr
- SetMarkedObjectXform()
: CRhinoViewport
- SetMarkFoci()
: CArgsRhinoGetEllipse
- SetMarkFocus()
: CArgsRhinoGetParabola
- SetMaskBorder()
: ON_Annotation
, ON_DimStyle
, ON_TextMask
- SetMaskColor()
: ON_Annotation
, ON_DimStyle
, ON_TextMask
- SetMaskFillType()
: ON_Annotation
, ON_DimStyle
, ON_TextMask
- SetMaskFrameType()
: ON_Annotation
, ON_DimStyle
, ON_TextMask
- SetMaskingColor()
: CRhinoUiMemDC
- SetMatchEndTangent()
: CArgsRhinoLoft
- SetMatchStartTangent()
: CArgsRhinoLoft
- SetMaterialChannelIndex()
: ON_BrepFace
, ON_SubDFace
- SetMaterialInstanceId()
: CRhRdkObjectDataAccess
, IRhRdkGroundPlane
, ON_GroundPlane
- SetMaterialOverride()
: CRhinoSubDDisplayAttributes
- SetMaterialPlugInId()
: ON_Material
- SetMaterialSource()
: ON_3dmObjectAttributes
, ON_MaterialRef
- SetMax()
: CRhinoUiEdit
- SetMaxColor()
: CRhinoEdgeContinuitySettings
- SetMaxConcurrentTasks()
: CRhinoGetCancel
- SetMaximumClientArea()
: CRhinoUiPopUpListWnd
- SetMaximumConvexCornerAngleRadians()
: ON_SubDFromMeshParameters
- SetMaximumConvexCornerEdgeCount()
: ON_SubDFromMeshParameters
- SetMaximumEdgeLength()
: ON_MeshParameters
- SetMaximumPasses()
: RhRdk::Realtime::DisplayMode::IHUDCallbacks
- SetMaxTileResolution()
: CRhinoPrintInfo
- SetMeasuredDirection()
: ON_DimOrdinate
- SetMergeColinearBoundaryEdges()
: ON_SubDFromMeshParameters
- SetMergeColinearInteriorEdges()
: ON_SubDFromMeshParameters
- SetMesh()
: CRhinoMeshObject
, CRhRdkRenderMesh
, ON_BrepFace
, ON_Extrusion
, ON_MeshCache
, ON_MeshNgonIterator
- SetMeshEdgeSelectionPoint()
: CRhinoObjRef
- SetMesher()
: ON_MeshParameters
- SetMesherId()
: ON_MeshParameters
- SetMeshFaceSelectionPoint()
: CRhinoObjRef
- SetMeshForExperts()
: ON_MeshRef
- SetMeshInfo()
: ON_MeshMarker
- SetMeshLocation()
: ON_SubDDisplayParameters
- SetMeshMemoryLimit()
: ON_Displacement
- SetMeshParameters()
: CRhinoMeshStlUI
, ON_ArchivableDictionary
, ON_Mesh
- SetMeshTransform()
: ON_MeshX
- SetMeshValue()
: CRhinoHistory
- SetMeshVertexSelectionPoint()
: CRhinoObjRef
- SetMessage()
: CRhinoUiProgressBar
- SetMessageBoxTitle()
: CRhinoDisplayErrorMessage
- SetMetallic()
: ON_PhysicallyBasedMaterial
- SetMethod()
: IRhRdkDithering
, IRhRdkToneMapping
, ON_Dithering
, ON_SubDFromSurfaceParameters
- SetMidPointPrompt()
: CArgsRhinoGetLine
- SetMin()
: CRhinoUiEdit
- SetMinimumConcaveCornerAngleRadians()
: ON_SubDFromMeshParameters
- SetMinimumConcaveCornerEdgeCount()
: ON_SubDFromMeshParameters
- SetMinimumEdgeLength()
: ON_MeshParameters
- SetMinimumRhino3dmVersion()
: CRhinoGetFileDialog
- SetMinimumTolerance()
: ON_MeshParameters
- SetMinSizeToCurrentSize()
: CRhinoUiDialog
- SetMinutesBetweenFrames()
: ON_3dmAnimationProperties
- SetMissingLinkedFileQueryAction()
: CRhinoFileReadOptions
- SetMiterPlaneNormal()
: ON_Extrusion
- SetMode()
: CRhinoFileReadOptions
, IRhRdkRenderChannels
, ON_3dmObjectAttributes
, ON_RenderChannels
- SetModelAidSettings()
: CRhinoAppSettings
- SetModelBasepoint()
: CRhinoDocProperties
- SetModelComponentStatus()
: ON_ModelComponent
- SetModelEast()
: ON_EarthAnchorPoint
- SetModelLengthUnitSystem()
: ON_3dmAnnotationContext
- SetModelLocation()
: ON_EarthAnchorPoint
- SetModelName()
: CRhinoDoc
- SetModelNorth()
: ON_EarthAnchorPoint
- SetModelPersistentVisibility()
: ON_Layer
- SetModelPoint()
: ON_EarthAnchorPoint
- SetModelScaleToFit()
: CRhinoPrintInfo
- SetModelScaleToValue()
: CRhinoPrintInfo
- SetModelScaleType()
: CRhinoPrintInfo
- SetModelSerialNumber()
: ON_BinaryArchive
, ON_ModelComponent
- SetModelSpaceHatchScale()
: CRhinoAnnotationSettings
, CRhinoAnnotationSettingsEx
- SetModelSpaceTextScale()
: CRhinoAnnotationSettings
, CRhinoAnnotationSettingsEx
- SetModelTransform()
: CRhinoDisplayEngine
, CRhinoDisplayPipeline
- SetModelTransformation()
: ON_DepthImage
- SetModelUnitsAndTolerances()
: CRhinoDocProperties
- SetModelURL()
: CRhinoDocProperties
- SetModelViewMatrix()
: CRhinoDisplayEngine
- SetModelVisible()
: ON_Layer
- SetModelXform()
: CRhinoViewport
- SetModified()
: CRhinoUiTabCtrlPage
- SetModifiedFlag()
: CRhinoDoc
- SetMouseOverHighlight()
: CRhinoAppSettings
- SetMouseOverHighlightSubObjects()
: CRhinoAppSettings
- SetMouseSettings()
: CRhinoAppSettings
- SetMRUDisplayString()
: CRhinoScriptContext
- SetMruMenuString()
: CRhinoApp
, CRhinoDoc
, MRhinoApp
- SetMultiSampleMode()
: CRhinoDisplayEngine
, CRhinoDisplayEngine_OGL
- SetMultiSelect()
: IRhRdkCustomCurveCtrl
- SetMultiStringValue()
: CRhinoUiRegistry
- SetMultiStringValueA()
: CRhinoUiRegistry
- SetMultiStringValueW()
: CRhinoUiRegistry
- SetMultithreadedTextureEvaluation()
: CRhRdkRendererSupportOptions
- SetName()
: CDisplayPipelineAttributes
, CRhinoInstanceDefinitionTable
, CRhinoUiTabbedSheetCtrlItem
, CRhinoViewport
, ON_3dmObjectAttributes
, ON_AerialPhotoImage
, ON_ModelComponent
, ON_XMLProperty
- SetNameDocument()
: CRhinoOpenDocumentOptions
- SetNamedView()
: ON_3dmRenderSettings
- SetNamedViewsSetClippingPlanes()
: CRhinoAppViewSettings
- SetNamedViewsSetDisplayMode()
: CRhinoAppViewSettings
- SetNameHash()
: ON_ComponentManifestItem
- SetNeverEmbedFiles()
: CRhRdkRendererSupportOptions
- SetNewComponentName()
: CRhinoComponentNameConflictUI
- SetNewNameEditBoxDescription()
: CRhinoComponentNameConflictUI
- SetNewPicker()
: IRhRdkColorButton
- SetNextPointPrompt()
: CArgsRhinoGetPolyline
- SetNgonCount()
: ON_Mesh
- SetNgonFaceFragmentPackRectCorners()
: ON_SubDMeshFragment
- SetNgonFaceFragmentTextureCoordinateCorners()
: ON_SubDMeshFragment
- SetNgonVertexNormals()
: ON_Mesh
- SetNineBytes()
: ON_PANOSE1
- SetNoCancelOnMainFrameClose()
: CRhinoApp
- SetNonAttenuated()
: CRhinoBendSpaceMorph
- SetNonZero()
: CRhinoUiEdit
- SetNormal()
: CArgsRhinoGetArc
, CArgsRhinoGetEllipse
, CArgsRhinoGetPolygon
, ON_SurfaceValues
- SetNormalColors()
: CRhinoUiFontComboBox
- SetNorth()
: CRhRdkSunStorage
, IRhRdkSun
, ON_Sun
- SetNorthAngle()
: ON_3dmAnimationProperties
- SetNotes()
: CRhinoDocProperties
, CRhRdkContent
, ON_RenderContent
- SetNotificationHandler()
: IRhRdkColorButton
, IRhRdkCustomCurveCtrl
- SetNudgeAutoUpdateDelay()
: CRhinoAppSettings
- SetNudgeAutoUpdateMesh()
: CRhinoAppSettings
- SetNull()
: CRhRdkVariant
, ON_XMLVariant
- SetNumber()
: CRhinoUiEdit
, CRhinoUiOptionsListCtrlEditBox
, CRhinoUiOptionsListCtrlPointEditBox
, CRhinoUiPointEdit
, ON_ComponentIndexAndNumber
, ON_SubDComponentAndNumber
- SetNumberPreview()
: CRhinoGetPoint
- SetNumericKeypadDecimalKeyPeriod()
: CRhinoAppSettings
- SetNumSides()
: CArgsRhinoGetPolygon
- SetObject()
: CRhRdkRenderMesh
- SetObjectCategory()
: CRhRdkMarkedObjects
- SetObjectColor()
: CRhinoDisplayPipeline
- SetObjectFilter()
: CRhinoDisplayConduit
, CRhinoObjectIterator
- SetObjectFrame()
: CRhinoObject
, ON_3dmObjectAttributes
- SetObjectOn()
: CArgsRhinoGetFrame
, CRhinoGetFrameOnObject
- SetObjectOnPrompt()
: CRhinoGetFrameOnObject
- SetObjectPrompt()
: CArgsRhinoGetFrame
- SetObjectState()
: CRhRdkMarkedObjects
- SetObjectToClipTransformation()
: ON_ClippingRegion
- SetObjectTransform()
: CRhinoDisplayPipeline
- SetObjRefValue()
: CRhinoHistory
, ON_HistoryRecord
- SetObjRefValues()
: CRhinoHistory
, ON_HistoryRecord
- SetOcsMapping()
: ON_TextureMapping
- SetOffset()
: CRhinoPrintInfo
, CRhinoUiDragBitmapWnd
, CRhRdkSimulatedTexture
, CRhRdkTexture
, ON_HatchLine
, ON_TextRun
, ON_Texture
- SetOffsetLeft()
: CRhinoUiDragBitmapWnd
- SetOffsetLocked()
: CRhRdkTexture
- SetOffsetOnly()
: ON_Thickening
- SetOffsetPoint()
: ON_OffsetSurfaceFunction
- SetOn()
: CRhRdkBasicMaterial::CTextureSlot
, CRhRdkPostEffectPlugIn
, IRhRdkCurrentEnvironment
, IRhRdkDithering
, IRhRdkGroundPlane
, IRhRdkListablePostEffect
, IRhRdkSafeFrame
, IRhRdkSkylight
, ON_CurvePiping
, ON_Displacement
, ON_Displacement::SubItem
, ON_EdgeSoftening
, ON_PostEffect
, ON_ShutLining
, ON_Thickening
- SetOnlyShowTrueTypeFonts()
: CRhinoUiFontComboBox
- SetONMaterial()
: CRhRdkRenderMesh
- SetOnNumberErrorMode()
: CRhinoUiEdit
- SetOpacity()
: ON_PhysicallyBasedMaterial
- SetOpacityIOR()
: ON_PhysicallyBasedMaterial
- SetOpacityRoughness()
: ON_PhysicallyBasedMaterial
- SetOpenGLSettings()
: CRhinoAppSettings
- SetOpenNURBS3dmVersion()
: ON_BinaryArchive
- SetOptionAccelerators()
: CRhinoGet
- SetOptionVaries()
: CRhinoGet
- SetOrAddIndex()
: ON_2dexMap
- SetOrdered()
: ON_PointCloud
- SetOrientation()
: CRhinoUiTabbedSheetCtrl
- SetOrientationAnglesDegrees()
: ON_AerialPhotoCameraPosition
- SetOrientationAnglesRadians()
: ON_AerialPhotoCameraPosition
- SetOrientationRotation()
: ON_AerialPhotoCameraPosition
- SetOrientationVectors()
: ON_AerialPhotoCameraPosition
- SetOrientAutoCPlaneToView()
: CRhinoAppSettings
- SetOrigin()
: ON_Decal
, ON_Plane
- SetOrthoUseZ()
: CRhinoAppSettings
- SetOsnapMode()
: CRhinoAppSettings
- SetOuterColor()
: IRhRdkCustomCurveCtrl
- SetOuterProfile()
: ON_Extrusion
- SetOutputTextLog()
: ON_TextHash
- SetOverrideDimensionStyle()
: ON_Annotation
- SetOverrideFacename()
: ON_RtfStringBuilder
- SetPackageManagerSources()
: CRhinoAppSettings
- SetPackedTextureCoordinates()
: ON_SubDMeshFragment
- SetPackFaces()
: ON_SubDToBrepParameters
- SetPackId()
: ON_BrepQuadFacePackSide
, ON_SubDQuadFacePackSide
- SetPackIdForExperts()
: ON_BrepFace
, ON_SubDFace
- SetPackRectCornersForExperts()
: ON_SubDMeshFragment
- SetPackRectForExperts()
: ON_SubDFace
- SetPageLengthUnitSystem()
: ON_3dmAnnotationContext
- SetPageNumber()
: CRhinoPageView
- SetPageUnitsAndTolerances()
: CRhinoDocProperties
- SetPageViewNumber()
: CRhinoDoc
- SetPANOSE1()
: ON_Font
- SetPanPlanParallelViewsWithControlShiftRMB()
: CRhinoAppViewSettings
- SetPaperSize()
: CRhinoPageView
- SetParallel()
: ON_SilhouetteParameters
- SetParallelViewport()
: ON_HiddenLineDrawing
- SetParam()
: IRhRdk_XMLSection
, IRhRdkPostEffect::IState
, ON_PostEffectParams
, ON_XMLParameters
- SetParameter()
: CRhRdkBasicMaterial
, CRhRdkContent
, CRhRdkCustomRenderMeshProvider
, CRhRdkOneColorTextureBase
, CRhRdkPlugIn
, CRhRdkPostEffectPlugInEx
, CRhRdkTexture
, CRhRdkTwoColorTextureBase
, IRhRdkCustomRenderMeshProvider
, IRhRdkPostEffect
, IRhRdkPostEffectSection
, ON_PostEffect
, ON_RenderContent
, RhRdk::CustomRenderMeshes::IRenderMeshProvider
- SetParameterization()
: ON_PolyCurve
- SetParameters()
: CRhRdkContent
- SetParamNode()
: ON_XMLParameters
- SetParams()
: IRhRdkToneMapping
- SetParent()
: IRhinoUiWindow
, IRhinoWindow
- SetParentForOnCreate()
: CRhinoUiExpandableTabPage_New
- SetParentId()
: ON_ModelComponent
- SetParentIndex()
: CRhinoUiOptionsListCtrlItem
- SetParentInstanceObject()
: CRhinoObjRef
- SetParentIRef()
: ON_ObjRef
- SetParentLayerId()
: ON_Layer
- SetParentMessageWnd()
: CRhinoUiInPlaceEdit
- SetParseAddition()
: ON_ParseSettings
- SetParseArcDegreesMinutesSeconds()
: ON_ParseSettings
- SetParseArithmeticExpression()
: ON_ParseSettings
- SetParseCarriageReturnAsLeadingWhiteSpace()
: ON_ParseSettings
- SetParseCarriageReturnAsTrailingWhiteSpace()
: ON_ParseSettings
- SetParseCommaAsDecimalPoint()
: ON_ParseSettings
- SetParseCommaAsDigitSeparator()
: ON_ParseSettings
- SetParseDAsExponentInScientificENotation()
: ON_ParseSettings
- SetParseDecimalPoint()
: ON_ParseSettings
- SetParseDivideByZeroError()
: ON_ParseSettings
- SetParseDivision()
: ON_ParseSettings
- SetParseExplicitFormulaExpression()
: ON_ParseSettings
- SetParseFeetInches()
: ON_ParseSettings
- SetParseFormFeedAsLeadingWhiteSpace()
: ON_ParseSettings
- SetParseFormFeedAsTrailingWhiteSpace()
: ON_ParseSettings
- SetParseFullStopAsDecimalPoint()
: ON_ParseSettings
- SetParseFullStopAsDigitSeparator()
: ON_ParseSettings
- SetParseHorizontalTabAsWhiteSpace()
: ON_ParseSettings
- SetParseHyphenAsNumberDash()
: ON_ParseSettings
- SetParseHyphenMinusAsNumberDash()
: ON_ParseSettings
- SetParseIntegerDashFraction()
: ON_ParseSettings
- SetParseInvalidExpressionError()
: ON_ParseSettings
- SetParseLeadingWhiteSpace()
: ON_ParseSettings
- SetParseLineFeedAsLeadingWhiteSpace()
: ON_ParseSettings
- SetParseLineFeedAsTrailingWhiteSpace()
: ON_ParseSettings
- SetParseMathFunctions()
: ON_ParseSettings
- SetParseMultiplication()
: ON_ParseSettings
- SetParseNoBreakHyphenAsNumberDash()
: ON_ParseSettings
- SetParseNoBreakSpaceAsDigitSeparator()
: ON_ParseSettings
- SetParseNoBreakSpaceAsWhiteSpace()
: ON_ParseSettings
- SetParseNoBreakThinSpaceAsDigitSeparator()
: ON_ParseSettings
- SetParseNoBreakThinSpaceAsWhiteSpace()
: ON_ParseSettings
- SetParseOverflowError()
: ON_ParseSettings
- SetParsePairedParentheses()
: ON_ParseSettings
- SetParsePi()
: ON_ParseSettings
- SetParseRationalNumber()
: ON_ParseSettings
- SetParseScientificENotation()
: ON_ParseSettings
- SetParseSignificandDecimalPoint()
: ON_ParseSettings
- SetParseSignificandDigitSeparators()
: ON_ParseSettings
- SetParseSignificandFractionalPart()
: ON_ParseSettings
- SetParseSignificandIntegerPart()
: ON_ParseSettings
- SetParseSpaceAsDigitSeparator()
: ON_ParseSettings
- SetParseSpaceAsWhiteSpace()
: ON_ParseSettings
- SetParseSubtraction()
: ON_ParseSettings
- SetParseSurveyorsNotation()
: ON_ParseSettings
- SetParseThinSpaceAsDigitSeparator()
: ON_ParseSettings
- SetParseThinSpaceAsWhiteSpace()
: ON_ParseSettings
- SetParseUnaryMinus()
: ON_ParseSettings
- SetParseUnaryPlus()
: ON_ParseSettings
- SetParseVerticalTabAsLeadingWhiteSpace()
: ON_ParseSettings
- SetParseVerticalTabAsTrailingWhiteSpace()
: ON_ParseSettings
- SetParseWhiteSpaceBetweenFeetAndInches()
: ON_ParseSettings
- SetParseWhiteSpaceBetweenValueAndUnitSystem()
: ON_ParseSettings
- SetParticipationLists()
: ON_ClippingPlane
- SetParticipationListsEnabled()
: ON_ClippingPlane
- SetPath()
: ON_Extrusion
- SetPathAndUp()
: ON_Extrusion
- SetPathName()
: CRhinoDoc
- SetPattern()
: IRhWidgetDrawCache
- SetPatternIndex()
: CArgsRhinoHatch
, ON_Hatch
- SetPatternRotation()
: CArgsRhinoHatch
, CRhinoHatch
, ON_Hatch
- SetPatternScale()
: CArgsRhinoHatch
, CRhinoHatch
, ON_Hatch
- SetPaused()
: RhRdk::Realtime::DisplayMode::IHUDFunctionality
- SetPelsPerMeter()
: CRhinoDib
- SetPerFaceColor()
: ON_BrepFace
, ON_SubDFace
- SetPerFaceColorsFromPackId()
: ON_SubD
- SetPerFaceColorsFromSymmetryMotif()
: ON_SubD
- SetPeriodAsCRuntimeDecimalPoint()
: ON_Locale
- SetPeriodicGrevilleKnotVector()
: ON_NurbsSurface
- SetPermitCancel()
: CRhinoComponentNameConflictUI
- SetPersistentEdgeIdsFromRuntimeEdgePtrs()
: ON_SubDEdgeChain
- SetPersistentLocking()
: ON_Layer
- SetPersistentScript()
: CRhinoScriptContext
- SetPersistentVisibility()
: ON_Layer
- SetPerspective()
: ON_SilhouetteParameters
- SetPerspectiveClippingPlaneConstraints()
: ON_Viewport
- SetPerspectiveMinNearDist()
: ON_Viewport
- SetPerspectiveMinNearOverFar()
: ON_Viewport
- SetPerspectiveOnly()
: IRhRdkSafeFrame
, ON_SafeFrame
- SetPerViewportColor()
: ON_Layer
- SetPerViewportIsVisibleInNewDetails()
: ON_Layer
- SetPerViewportPersistentVisibility()
: ON_Layer
- SetPerViewportPlotColor()
: ON_Layer
- SetPerViewportPlotWeight()
: ON_Layer
- SetPerViewportVisible()
: ON_Layer
- SetPickOccluded()
: CRhinoAppSettings
- SetPictureFileNameAndSize()
: CArgsRhinoGetPlane
- SetPipeline()
: CDisplayPipelineAttributes
- SetPitch()
: CArgsRhinoGetSpiral
- SetPitchMode()
: CArgsRhinoGetSpiral
- SetPixel()
: CRhinoDib::CFastPixelAccess
, CRhinoDib
, ON_DepthImage
- SetPixelToMillimeterLinetypeScale()
: CRhinoPrintInfo
- SetPlane()
: CArgsRhinoGetCircle
, CArgsRhinoGetPlane
, CRhinoDimension
, CRhRdkRenderMesh
, ON_Annotation
, ON_Hatch
, ON_Leader
, ON_PointCloud
- SetPlaneAndMonoHelper()
: ON_SurfaceLeafBox
- SetPlaneMapping()
: ON_TextureMapping
- SetPlaneSurface()
: CRhinoClippingPlaneObject
- SetPlotColor()
: ON_Layer
- SetPlotColorSource()
: ON_3dmObjectAttributes
- SetPlotWeight()
: ON_Layer
- SetPlotWeightSource()
: ON_3dmObjectAttributes
- SetPlugIn()
: IRhinoSdkRenderFrame
- SetPlugInDescription()
: CRhinoPlugInInfo
- SetPlugInIconResourceName()
: CRhinoPlugInInfo
- SetPlugInId()
: CRhinoPlugInInfo
, ON_RenderContent
- SetPlugInShortName()
: CRhinoPlugInInfo
- SetPlugInVersion()
: CRhinoPlugInInfo
- SetPoint()
: CRhinoPointObject
, CRhinoSettings
, CRhinoTextDot
, CRhinoUiPointEdit
, ON_BrepVertex
, ON_OffsetSurfaceFunction
, ON_PointGrid
, ON_SubDComponentAndPoint
, ON_SurfaceValues
, ON_TextDot
- SetPoint0()
: CArgsRhinoGetCircle
- SetPoint1()
: CArgsRhinoGetArc
, CArgsRhinoGetCircle
- SetPoint2()
: CArgsRhinoGetArc
, CArgsRhinoGetCircle
- SetPoint2d()
: ON_Leader
- SetPoint3()
: CArgsRhinoGetArc
- SetPoint3d()
: ON_Leader
- SetPointAt()
: ON_HermiteSurface
- SetPointCloud()
: CRhinoPointCloudObject
- SetPointColor()
: IRhRdkCustomCurveCtrl
- SetPointConstraint()
: ON_BendFaceConstraint
- SetPointCount()
: CArgsRhinoGetArc
, CArgsRhinoGetCircle
- SetPointerAndUnlock()
: ON_PointerSleepLock
- SetPointOnArcPrompt()
: CArgsRhinoGetArc
- SetPointOnObjectValue()
: CRhinoHistory
, ON_HistoryRecord
- SetPointPickMargin()
: IRhRdkCustomCurveCtrl
- SetPointPrompt()
: CArgsRhinoAnnotationLeader
- SetPoints2d()
: ON_Leader
- SetPoints3d()
: ON_Leader
- SetPointSelectedColor()
: IRhRdkCustomCurveCtrl
- SetPointSize()
: IRhRdkCustomCurveCtrl
, ON_Font
- SetPointSnapX()
: IRhRdkCustomCurveCtrl
- SetPointSnapY()
: IRhRdkCustomCurveCtrl
- SetPointsPerTurn()
: CArgsRhinoGetSpiral
- SetPointValue()
: CRhinoHistory
, CRhinoUiRegistry
, ON_HistoryRecord
- SetPointValues()
: CRhinoHistory
, ON_HistoryRecord
- SetPolish()
: CRhRdkBasicMaterial
, CRhRdkBasicMaterialCCI
- SetPolyEdgeValue()
: CRhinoHistory
, ON_HistoryRecord
- SetPolyEdgeValues()
: CRhinoHistory
, ON_HistoryRecord
- SetPos()
: CRhinoUiProgressCtrl
- SetPositionAndSize()
: IRhRdkContentUI
- SetPOSIXLocale()
: MRhinoApp
- SetPostEffectSelection()
: CRhRdkDocument
- SetPostEffectsNode()
: ON_PostEffects
- SetPostEffectsOn()
: RhRdk::Realtime::DisplayMode::IHUDCallbacks3
- SetPostProcessFrameBuffer()
: CDisplayPipelineAttributes::LinearWorkflow
, CRhRdkLinearWorkflow
, IRhRdkLinearWorkflow
- SetPostProcessFrameBufferOn()
: CDisplayPipelineAttributes::LinearWorkflow
, IRhRdkLinearWorkflow
, ON_LinearWorkflow
- SetPostProcessGamma()
: CDisplayPipelineAttributes::LinearWorkflow
, CRhRdkLinearWorkflow
, IRhRdkLinearWorkflow
, ON_LinearWorkflow
- SetPostProcessGammaOn()
: CDisplayPipelineAttributes::LinearWorkflow
, IRhRdkLinearWorkflow
, ON_LinearWorkflow
- SetPostWeldAngle()
: ON_Displacement
- SetPowerCandela()
: ON_Light
- SetPowerLumens()
: ON_Light
- SetPowerWatts()
: ON_Light
- SetPreferedLocaleId()
: ON_ParseSettings
- SetPreferNativeRenderer()
: CRhRdkRendererSupportOptions
- SetPreferredUnpackFolder()
: CRhRdkRendererSupportOptions
- SetPrefix()
: ON_Annotation
, ON_DimStyle
- SetPreProcessColors()
: CDisplayPipelineAttributes::LinearWorkflow
, CRhRdkLinearWorkflow
, IRhRdkLinearWorkflow
- SetPreProcessColorsOn()
: CDisplayPipelineAttributes::LinearWorkflow
, IRhRdkLinearWorkflow
, ON_LinearWorkflow
- SetPreProcessGamma()
: CDisplayPipelineAttributes::LinearWorkflow
, CRhRdkLinearWorkflow
, IRhRdkLinearWorkflow
, ON_LinearWorkflow
- SetPreProcessGammaOn()
: ON_LinearWorkflow
- SetPreProcessTextures()
: CDisplayPipelineAttributes::LinearWorkflow
, CRhRdkLinearWorkflow
, IRhRdkLinearWorkflow
- SetPreProcessTexturesOn()
: CDisplayPipelineAttributes::LinearWorkflow
, IRhRdkLinearWorkflow
, ON_LinearWorkflow
- SetPreserveStructure()
: ON_SpaceMorph
- SetPressEnterWhenDonePrompt()
: CRhinoGetObject
- SetPreTransform()
: CRhinoGumballDisplayConduit
- SetPreviewCustomRenderMeshes()
: CRhRdkRendererSupportOptions
- SetPreviewEnvironmentId()
: CRhinoDisplayEngine
, CRhinoDisplayEngine_OGL
- SetPreviewIn3D()
: CRhRdkTexture
- SetPreviewLocalMapping()
: CRhRdkTexture
- SetPreviousDockBarId()
: CRhinoUiPanel
- SetPrimaryText()
: ON_TextDot
- SetPrincipalCurvatures()
: ON_SurfaceValues
- SetPrintInfo()
: CRhinoPrintControlsBase
- SetPrintingMode()
: CRhinoDisplayPipeline
- SetProfile()
: ON_ShutLining::Curve
- SetProfileCurve()
: CArgsRhinoRailRevolve
- SetProfileObject()
: CArgsRhinoRailRevolve
- SetProfilePrompt()
: CArgsRhinoRailRevolve
- SetProgress()
: IRhRdkRenderWindow
- SetProgressReporter()
: ON_SubDDisplayParameters
- SetProjection()
: CRhinoView
, CRhinoZBuffer
, CRhRdkBasicEnvironmentCCI
, ON_Decal
, ON_DepthImage
, ON_Viewport
- SetProjectionMode()
: CRhRdkSimulatedTexture
, CRhRdkTexture
- SetProjectOsnaps()
: CRhinoAppSettings
- SetProjectOsnapsInPlanParallelViews()
: CRhinoAppSettings
- SetPrompt0()
: CArgsRhinoGetCircle
- SetPrompt1()
: CArgsRhinoGetCircle
- SetPrompt2()
: CArgsRhinoGetCircle
- SetPromptForMeshDensity()
: CArgsRhinoGetCircle
, CArgsRhinoGetEllipse
, CArgsRhinoGetPlane
- SetPromptForThickness()
: CArgsRhinoGetTubeExtra
- SetProperty()
: ON_XMLNode
- SetPropertyList()
: CRhinoPropListFileProfileContext
- SetPropListFileName()
: CRhinoPropListProfileContext
- SetProviderId()
: CRhRdkCustomRenderMeshes
, IRhRdkCustomRenderMeshes
- SetProxy()
: ON_ObjRef
- SetProxyCurve()
: ON_CurveProxy
- SetProxyCurveDomain()
: ON_CurveProxy
- SetProxyCurveIsReversed()
: ON_CurveProxy
- SetProxySurface()
: ON_SurfaceProxy
- SetPSpaceCurve()
: ON_HLDFullCurve
- SetPull()
: ON_ShutLining::Curve
- SetPyramidConstraint()
: CArgsRhinoGetPolygon
- SetQuad()
: ON_Mesh
- SetQuadBuffering()
: CRhinoOpenGLSettings
- SetQuadOr3gonFaceFragmentPackRectCorners()
: ON_SubDMeshFragment
- SetQuadOr3gonFaceFragmentTextureCoordinateCorners()
: ON_SubDMeshFragment
- SetQuadrant()
: CArgsRhinoGetArc
, CArgsRhinoGetEllipse
- SetQueryMessage()
: CRhinoComponentNameConflictUI
- SetQuickPreview()
: ON_SpaceMorph
- SetQuiet()
: IRhRdkRenderSession
- SetRadialDimensionType()
: ON_DimRadial
- SetRadii()
: CRhinoFlowSpaceMorph
- SetRadio()
: CRuiUpdateUi
, IRhRdkCommandUpdate
, IRhRdkTaskUpdate
- SetRadius()
: ON_Centermark
, ON_CurvePiping
, ON_Decal
, ON_ShutLining::Curve
- SetRadiusPoint()
: CArgsRhinoGetSpiral
- SetRadiusPrompt()
: CArgsRhinoGetArc
, CArgsRhinoGetCircle
, CArgsRhinoGetSpiral
- SetRail()
: CArgsRhinoGetSpiral
, CArgsRhinoRailRevolve
- SetRailCurve()
: CArgsRhinoRailRevolve
- SetRailObject()
: CArgsRhinoRailRevolve
- SetRailPrompt()
: CArgsRhinoRailRevolve
- SetRange()
: CRhinoUiProgressCtrl
, ON_SimpleArray< T >
- SetRayHelper()
: ON_RayShooter
- SetRdkDocument()
: IRhRdkThumbnails
- SetRdkDocumentAssoc()
: CRhRdkContent
- SetRdkDocumentId()
: IRhRdkContentEditor
- SetRdkDocumentOwner()
: CRhRdkContent
- SetRdkMaterial()
: CRhRdkRenderMesh
- SetRdkMaterialInstanceId()
: ON_Material
- SetReadFileResult()
: CRhinoDoc
- SetReadingFontDefinition()
: ON_TextBuilder
- SetRealtimeDisplayId()
: CDisplayPipelineAttributes
- SetRealtimeRenderPasses()
: CDisplayPipelineAttributes
- SetRebuildPointCount()
: CArgsRhinoLoft
- SetRecalcOnAddOrInsert()
: CRhinoUiTabbedSheetCtrl
- SetRecomposeRTF()
: RtfComposer
- SetRecordNextCommand()
: CRhinoHistoryManager
- SetRect()
: CRhinoSettings
, ON_4dRect
, ON_4iRect
- SetRectangleBoundary()
: CRhinoDetailViewObject
- SetRectEmpty()
: ON_4dRect
, ON_4iRect
- SetRectToAvoid()
: CRhinoPopupMenu
- SetRectValue()
: CRhinoUiRegistry
- SetRed()
: ON_4fColor
- SetRedraw()
: CRhinoDisplayPipeline
- SetRedrawDisplayHint()
: CRhinoDoc
, CRhinoView
- SetReference()
: CRhinoGetAngle
, ON_RenderContent
- SetReferencedAnnotationSettings()
: ON_3dmAnnotationContext
- SetReferencedBinaryArchive()
: ON_3dmAnnotationContext
- SetReferencedComponentIdMapping()
: ON_BinaryArchive
- SetReferencedComponentIndexMapping()
: ON_BinaryArchive
- SetReferencedDimStyle()
: ON_3dmAnnotationContext
- SetReferenceId()
: ON_SubDComponentRef
- SetReferencePoint()
: CRhinoGetAngle
- SetRefine()
: ON_MeshParameters
- SetRefineAngleDegrees()
: ON_MeshParameters
- SetRefineAngleRadians()
: ON_MeshParameters
- SetRefineSensitivity()
: ON_Displacement
- SetRefineSteps()
: ON_Displacement
- SetRefitTolerance()
: CArgsRhinoLoft
- SetReflectionPlane()
: CRhinoSubDDisplayAttributes
- SetReflectiveIOR()
: ON_PhysicallyBasedMaterial
- SetReflectivity()
: CRhRdkBasicMaterial
, CRhRdkBasicMaterialCCI
, ON_Material
- SetReflectivityColor()
: CRhRdkBasicMaterial
, CRhRdkBasicMaterialCCI
- SetRelativePath()
: ON_FileReference
- SetRelativePathFromBasePath()
: ON_FileReference
- SetRelativeSectorCoefficientForExperts()
: ON_SubDEdgePtr
- SetRelativeSharpness()
: ON_SubDEdgePtr
- SetRelativeTolerance()
: ON_3dmUnitsAndTolerances
, ON_MeshParameters
- SetReleaseClipping()
: CRhRdkResizingDialog
- SetRemapIndex()
: CRhinoBitmapTable
, CRhinoDimStyleTable
, CRhinoGroupTable
, CRhinoHatchPatternTable
, CRhinoHistoryRecordTable
, CRhinoInstanceDefinitionTable
, CRhinoLayerTable
, CRhinoLightTable
, CRhinoLinetypeTable
, CRhinoMaterialTable
, CRhinoTextureMappingTable
- SetRememberCopyOption()
: CRhinoApp
- SetRenderCommand()
: IRhinoSdkRenderFrame
- SetRenderEngineId()
: ON_RenderContent
- SetRenderEnvironmentId()
: ON_3dmRenderSettings
- SetRenderEnvironmentOverride()
: ON_3dmRenderSettings
- SetRenderFull()
: ON_3dmAnimationProperties
- SetRenderingSize()
: ON_3dmView
- SetRenderingSource()
: ON_3dmRenderSettings
- SetRenderMaterialIndex()
: ON_Layer
- SetRenderMeshInfo()
: ON_Mesh
- SetRenderMeshParameters()
: CRhinoBrepObject
, CRhinoObject
, CRhinoSubDObject
- SetRenderMeshSettings()
: CRhinoDocProperties
- SetRenderMeshStyle()
: CRhinoDocProperties
- SetRenderPreview()
: ON_3dmAnimationProperties
- SetRenderSessionId()
: CRhRdkCustomRenderFrameToolBar
- SetRenderSettings()
: CRhinoDocProperties
- SetRenderTarget()
: CRhinoDisplayEngine
, CRhinoDisplayPipeline
- SetRenderWindow()
: CRhRdkCustomRenderFrameToolBar
- SetRepeat()
: CRhRdkSimulatedTexture
, CRhRdkTexture
, ON_Texture
- SetRepeatLocked()
: CRhRdkTexture
- SetReport()
: CRhRdkContentIOPlugInEx
- SetResizingConstraints()
: CRhRdkResizingDialog
- SetResolutionMethod()
: CRhinoComponentNameConflictUI
- SetReverse()
: CArgsRhinoGetSubCurve
- SetReverseTwist()
: CArgsRhinoGetSpiral
- SetRevisionHistory()
: CRhinoDocProperties
- SetRGB()
: ON_Color
- SetRGBA()
: ON_4fColor
, ON_Color
- SetRGBValue()
: CRhinoUiRegistry
- SetRhino3dmVersion()
: CRhinoFileWriteOptions
- SetRhinoFlag()
: CRhinoUiDialog
- SetRhinoFlags()
: CRhinoUiDialog
- SetRhinoView()
: CRhinoSdkRender
- SetRotateToView()
: CRhinoAppViewSettings
- SetRotateViewAroundAutogumball()
: CRhinoAppViewSettings
- SetRotateViewAroundObjectAtMouseCursor()
: CRhinoAppViewSettings
- SetRotation()
: CRhRdkSimulatedTexture
, CRhRdkTexture
, ON_Quaternion
, ON_Texture
- SetRoughness()
: ON_PhysicallyBasedMaterial
- SetRounded()
: CArgsRhinoGetPlane
- SetRoundOff()
: ON_Annotation
, ON_DimStyle
- SetRtfFmt()
: ON_Annotation
- SetRulerColors()
: IRhRdkCustomCurveCtrl
- SetRulerOn()
: IRhRdkCustomCurveCtrl
- SetRuntimeEdgePtrsFromPersistentSubD()
: ON_SubDEdgeChain
- SetRuntimeHorizontalAlignment()
: ON_TextContent
- SetRuntimeMark()
: ON_ComponentStatus
- SetSave3dmPreviewImage()
: ON_BinaryArchive
- SetSaveCompressedTextureFiles()
: CRhRdkRendererSupportOptions
- SetSavedSubdivisionPoint()
: ON_SubDComponentBase
- SetSavedSurfacePoint()
: ON_SubDVertex
- SetSaveOnClose()
: IRhinoSdkRenderFrame
- SetScale()
: CRhinoDetailViewObject
- SetScaleBackgroundToFit()
: ON_3dmRenderSettings
- SetScaleFromAnnotation()
: CRhinoGumballFrame
- SetScaleFromArc()
: CRhinoGumballFrame
- SetScaleFromBoundingBox()
: CRhinoGumballFrame
- SetScaleFromBrepObject()
: CRhinoGumballFrame
- SetScaleFromCircle()
: CRhinoGumballFrame
- SetScaleFromClippingPlane()
: CRhinoGumballFrame
- SetScaleFromCurve()
: CRhinoGumballFrame
- SetScaleFromEllipse()
: CRhinoGumballFrame
- SetScaleFromExtrusion()
: CRhinoGumballFrame
- SetScaleFromExtrusionObject()
: CRhinoGumballFrame
- SetScaleFromHatch()
: CRhinoGumballFrame
- SetScaleFromLight()
: CRhinoGumballFrame
- SetScaleFromLine()
: CRhinoGumballFrame
- SetScaleFromMeshObject()
: CRhinoGumballFrame
- SetScaleFromMorphControlObject()
: CRhinoGumballFrame
- SetScaleFromPlane()
: CRhinoGumballFrame
- SetScaleFromSubDObject()
: CRhinoGumballFrame
- SetScaleGripDistance()
: CRhinoGumballFrame
- SetScaleHeight()
: CArgsRhinoRailRevolve
- SetScaleModeX()
: IRhRdkCustomCurveCtrl
- SetScaleModeY()
: IRhRdkCustomCurveCtrl
- SetSceneBoundingBox()
: ChangeQueue
- SetSceneScale()
: IRhRdkPreviewSceneServer
- SetSchemeName()
: CRhinoUiRegistry
- SetScreenDrawTolerance()
: CRhinoDisplayEngine
- SetScreenPort()
: ON_Viewport
- SetScreenSize()
: CRhinoViewport
- SetScript()
: CRhinoScriptContext
- SetScriptMode()
: CRhinoGetFileDialog
- SetScriptQueryGetGetNamePrompt()
: CRhinoComponentNameConflictUI
- SetScriptQueryGetGetOptionPrompt()
: CRhinoComponentNameConflictUI
- SetScrollPos()
: CRhinoUiExpandableTabCtrl_New
, IRhinoUiHolder
- SetSecondaryText()
: ON_TextDot
- SetSecondaryTextString()
: CRhinoTextDot
- SetSecondDiameterPrompt()
: CArgsRhinoGetSpiral
- SetSecondDirectionCount()
: CArgsRhinoGetPlane
- SetSecondDirectionMinCount()
: CArgsRhinoGetPlane
- SetSecondMeshDensityDirectionPrompt()
: CArgsRhinoGetPlane
- SetSecondPoint()
: CArgsRhinoGetEllipse
, CArgsRhinoGetPlane
, CArgsRhinoGetPolygon
- SetSecondPointPrompt()
: CArgsRhinoGetLine
- SetSecondPointPrompt3Point()
: CArgsRhinoGetPlane
- SetSecondPointPromptCenter()
: CArgsRhinoGetPlane
- SetSecondPointPromptCorners()
: CArgsRhinoGetPlane
- SetSecondPointPromptVertical()
: CArgsRhinoGetPlane
- SetSecondPrompt()
: CArgsRhinoGetCurve
, CArgsRhinoGetEllipse
, CArgsRhinoGetSubCurve
, CRhinoGetDirection
, CRhinoGetDistance
- SetSecondPromptIfEmpty()
: CArgsRhinoGetEllipse
- SetSecondRadius()
: CArgsRhinoGetSpiral
, CArgsRhinoGetTubeExtra
- SetSecondRadiusPrompt()
: CArgsRhinoGetSpiral
, CArgsRhinoGetTubeExtra
- SetSectionAttributesSource()
: ON_3dmObjectAttributes
- SetSectionBehavior()
: ON_3dmView
- SetSectionExpanded()
: IRhRdkAutomaticUI
- SetSectionFillRule()
: ON_SectionStyle
- SetSectionHidden()
: IRhRdkAutomaticUI
- SetSectionOptions()
: CRhRdkSunDialog
- SetSegment()
: ON_Linetype
, ON_PolyCurve
- SetSegments()
: ON_CurvePiping
, ON_Linetype
- SetSel()
: CRhRdkSdkNumberEdit
- SetSelectedButton()
: CRhinoUiOptionsListCtrlRadioButtonColumn
- SetSelectedFilter()
: CRhinoDisplayConduit
- SetSelectedLayer()
: CRhinoUiLayerListCtrl
- SetSelectedLayers()
: CRhinoUiLayerListCtrl
- SetSelectedObjectColor()
: CRhinoAppAppearanceSettings
- SetSelectedObjectCornerColor()
: CRhinoAppSettings
- SetSelectedObjectCornerLength()
: CRhinoAppSettings
- SetSelectedObjectCornerThickness()
: CRhinoAppSettings
- SetSelectedObjectFilter()
: CRhinoFileWriteOptions
- SetSelectedPostEffect()
: ON_PostEffects
- SetSelectedPrintWidth()
: CRhinoUiPrintWidthListCtrl
- SetSelectedState()
: ON_ComponentStatus
- SetSelectedSubobjectFilter()
: CRhinoFileWriteOptions
- SetSelection()
: CRhRdkCustomContentUI
, CRhRdkSdkContentSelector
, CRhRdkTask
, IRhRdkContentUI
, IRhRdkContentUISection
, IRhRdkNewContentCtrl
, IRhRdkThumbnails
- SetSelectionComponent()
: CRhinoObjRef
- SetSelectionDepth()
: CRhinoObjRef
- SetSelectionDetailView()
: CRhinoObjRef
- SetSelectionDistance()
: CRhinoObjRef
- SetSelectionFilterSettings()
: CRhinoAppSettings
- SetSelectionPoint()
: CRhinoObjRef
- SetSelectionView()
: CRhinoObjRef
- SetSelectionWindowCrossingFillColor()
: CRhinoAppAppearanceSettings
- SetSelectionWindowCrossingStrokeColor()
: CRhinoAppAppearanceSettings
- SetSelectionWindowFillColor()
: CRhinoAppAppearanceSettings
- SetSelectionWindowStrokeColor()
: CRhinoAppAppearanceSettings
- SetSemicolonDelimitedString()
: CRhRdkUuidCollection
- SetSendChangeWhenDragging()
: CRhRdkSdkNumberEdit
- SetSeparatorLabelBkGrndColor()
: CRhinoUiOptionsListCtrl
- SetSeparatorLabelTextColor()
: CRhinoUiOptionsListCtrl
- SetSetting()
: CRhRdkDocument
- SetSettingsSubKey()
: IRhinoUiHolder
- SetShadeConstraints()
: IRhRdkCustomCurveCtrl
- SetShadingMethod()
: CDisplayPipelineAttributes
- SetShadingRequired()
: CRhinoDisplayPipeline
- SetShadowIntensity()
: CDisplayPipelineAttributes
, CRhRdkSunStorage
, IRhRdkSkylight
, IRhRdkSun
, ON_Light
, ON_Skylight
, ON_Sun
- SetShadowOnly()
: IRhRdkGroundPlane
, ON_GroundPlane
- SetShareable()
: ON_Material
- SetSharp()
: CArgsRhinoGetCurve
- SetSharpnessForExperts()
: ON_SubDEdge
- SetSheen()
: ON_PhysicallyBasedMaterial
- SetSheenTint()
: ON_PhysicallyBasedMaterial
- SetShiftKeyScaling()
: CRhRdkSdkNumberEdit
- SetShine()
: CRhRdkBasicMaterialCCI
, ON_Material
- SetShortCutKeys()
: CRhinoAppSettings
- SetShouldSerializeUserDataDefault()
: ON_BinaryArchive
- SetShouldSerializeUserDataItem()
: ON_BinaryArchive
- SetShowAutoGumball()
: CRhinoAppSettings
- SetShowColorWhenDisabled()
: IRhRdkColorButton
- SetShowConstructionAxes()
: CRhinoViewport
- SetShowConstructionGrid()
: CRhinoViewport
- SetShowContextMenu()
: IRhRdkNewContentCtrl
- SetShowCurvature()
: CRhinoEdgeContinuitySettings
- SetShowCustom()
: CRhRdkRendererSupportOptions
- SetShowDeformableOption()
: CArgsRhinoGetEllipse
- SetShowDetailsPanel()
: CRhRdkRendererSupportOptions
- SetShowDistance()
: CRhinoEdgeContinuitySettings
- SetShowDocuments()
: CRhRdkRendererSupportOptions
- SetShowDropDownOnBeginEdit()
: CRhinoUiOptionsListCtrlComboBox
- SetShowExternalPdfPrinters()
: CRhinoAppAppearanceSettings
- SetShowFlatSurfaceIsos()
: CDisplayPipelineAttributes
- SetShowHiddenLines()
: CRhinoAppSettings
- SetShowingSections()
: CRhRdkSunDialog
- SetShowLayoutDropShadow()
: CRhinoAppAppearanceSettings
- SetShown()
: IRhRdkListablePostEffect
, ON_PostEffect
- SetShowNewButtonInDropDown()
: IRhRdkNewContentCtrl
- SetShowOrthoHashMarks()
: CRhinoAppSettings
- SetShowPlugInItemInDropDown()
: IRhRdkNewContentCtrl
- SetShowPreview()
: CRhinoGetFileDialog
- SetShowRealtimeRenderProgressBar()
: CDisplayPipelineAttributes
- SetShowRenderContent()
: CRhRdkRendererSupportOptions
- SetShowSelectedObjectCorners()
: CRhinoAppSettings
- SetShowStyle()
: CRhinoUiProgressCtrl
- SetShowTangency()
: CRhinoEdgeContinuitySettings
- SetShowTangentEdges()
: CDisplayPipelineAttributes
- SetShowTangentSeams()
: CDisplayPipelineAttributes
- SetShowText()
: CRhinoUiProgressCtrl
- SetShowUnderside()
: IRhRdkGroundPlane
, ON_GroundPlane
- SetShowViewportXEdges()
: CRhinoAppSettings
- SetShowWorldAxes()
: CRhinoViewport
- SetSideTangency()
: ON_OffsetSurfaceFunction
- SetSignedOrdinate()
: ON_Annotation
, ON_DimStyle
- SetSilhouetteHighlighting()
: CRhinoAppSettings
- SetSilhouetteHighlightInnerColorScale()
: CRhinoAppSettings
- SetSilhouetteHighlightInnerFactor()
: CRhinoAppSettings
- SetSilhouetteHighlightOuterScale()
: CRhinoAppSettings
- SetSilhouetteMethod()
: CRhinoAppSettings
- SetSilhouetteThickness()
: CRhinoAppSettings
- SetSimpleArithmeticOn()
: CRhRdkSdkNumberEdit
- SetSimplePlanes()
: ON_MeshParameters
- SetSimplifyMethod()
: CArgsRhinoLoft
- SetSimulated()
: ON_Font
- SetSimulation()
: CRhRdkBasicMaterial::CTextureSlot
, CRhRdkBasicMaterial
, CRhRdkContent
, CRhRdkEnvironment
, CRhRdkMaterial
, CRhRdkTexture
- SetSingularConstraint()
: ON_BendFaceConstraint
- SetSize()
: CRhinoSettings
, CRhinoUiProgressBar
, IRhinoWindow
, IRhRdkRenderWindow
- SetSizeValue()
: CRhinoUiRegistry
- SetSkipBold()
: ON_RtfStringBuilder
- SetSkipColorTbl()
: ON_RtfStringBuilder
- SetSkipFacename()
: ON_RtfStringBuilder
- SetSkipItalic()
: ON_RtfStringBuilder
- SetSkipNestedLinkedDefinitions()
: ON_InstanceDefinition
- SetSkipUnderline()
: ON_RtfStringBuilder
- SetSkylighting()
: IRhRdkPreviewSceneServerEx
- SetSkylightShadowQuality()
: CDisplayPipelineAttributes
- SetSkylightShadowResolutionScale()
: CRhinoOpenGLSettings
- SetSkylightShadowResolutionScaleDynamic()
: CRhinoOpenGLSettings
- SetSmartMergeChoice()
: CRhRdkRendererSupportOptions
- SetSmartTrackSettings()
: CRhinoAppSettings
- SetSnappyGumball()
: CRhinoAppSettings
- SetSnapshot()
: ON_3dmRenderSettings
- SetSnapXform()
: CRhinoSnapContext
- SetSoftening()
: ON_EdgeSoftening
- SetSolid()
: ON_Thickening
- SetSolidOrientation()
: ON_Mesh
- SetSolidOrientationForExperts()
: ON_Brep
- SetSortAscending()
: CRhinoUiLinetypeListCtrl
- SetSourceDimstyle()
: ON_DimStyle
- SetSourceIdentification()
: ON_ManifestMapItem
- SetSpaceBallSettings()
: CRhinoAppSettings
- SetSpaceFilter()
: CRhinoObjectIterator
- SetSpecificViewport()
: ON_3dmRenderSettings
- SetSpecular()
: CRhRdkBasicMaterialCCI
, ON_Light
, ON_Material
, ON_PhysicallyBasedMaterial
- SetSpecularTint()
: ON_PhysicallyBasedMaterial
- SetSphere()
: CRhRdkRenderMesh
- SetSphereMapping()
: ON_TextureMapping
- SetSpine()
: CRhinoBendSpaceMorph
- SetSpinnerVisibility()
: CRhRdkSdkNumberEdit
- SetSpinnerWidth()
: CRhRdkSdkNumberEdit
- SetSpotAngleDegrees()
: ON_Light
- SetSpotAngleRadians()
: ON_Light
- SetSpotExponent()
: ON_Light
- SetSpringConstants()
: ON_SquishParameters
- SetSrfTangentMode()
: CRhinoPolyEdge
- SetStacked()
: ON_TextRun
- SetStackedOff()
: ON_TextRun
- SetStackFormat()
: ON_TextBuilder::TextProps
- SetStackFractionFormat()
: ON_Annotation
, ON_DimStyle
- SetStackFractionHeight()
: ON_TextRun
- SetStackHeightScale()
: ON_Annotation
, ON_DimStyle
- SetStackScale()
: ON_TextBuilder
, ON_TextBuilder::TextProps
, ON_TextRunBuilder
- SetStarAroundCurveCenterPrompt()
: CArgsRhinoGetPolygon
- SetStarCenterPrompt()
: CArgsRhinoGetPolygon
- SetStarEndPrompt()
: CArgsRhinoGetPolygon
- SetStarMark()
: ON_BrepQuadFacePackSide
- SetStarMode()
: CArgsRhinoGetPolygon
- SetStarSecondRadius()
: CArgsRhinoGetPolygon
- SetStarSecondRadiusPrompt()
: CArgsRhinoGetPolygon
- SetStartAngle()
: CArgsRhinoRevolve
- SetStartDay()
: ON_3dmAnimationProperties
- SetStartDir()
: CArgsRhinoGetSpiral
- SetStartHour()
: ON_3dmAnimationProperties
- SetStartMinutes()
: ON_3dmAnimationProperties
- SetStartMonth()
: ON_3dmAnimationProperties
- SetStartPoint()
: CArgsRhinoGetSpiral
, CArgsRhinoLoft
, CArgsRhinoText
, CRhinoPolyEdge
, ON_ArcCurve
, ON_Curve
, ON_LineCurve
, ON_NurbsCurve
, ON_PolyCurve
, ON_PolyEdgeCurve
, ON_PolylineCurve
, ON_SubDEdgeChainCurve
- SetStartPointPrompt()
: CArgsRhinoText
- SetStartPrompt()
: CArgsRhinoGetArc
, CArgsRhinoGetSpiral
- SetStartSeconds()
: ON_3dmAnimationProperties
- SetStartTangent()
: CArgsRhinoGetCurve
- SetStartTime()
: ON_ParticleSystem
- SetStartTimeInMilliseconds()
: IRhRdkPostEffectPipeline
- SetStartYear()
: ON_3dmAnimationProperties
- SetStates()
: ON_ComponentStatus
, ON_SubDComponentPtr
- SetStaticDisplayAppearanceForExperts()
: CRhinoSubDObject
- SetStaticDisplayForExperts()
: CRhinoSubDObject
- SetStatus()
: IRhRdkRenderSession
, ON_ComponentStatus
, ON_SubDComponentPtr
, ON_TriangleMesh
- SetStatusBarDistancePane()
: CRhinoApp
- SetStatusBarHelpText()
: CRhinoPopupMenu
- SetStatusBarLayerPaneWidth()
: CRhinoAppSettings
- SetStatusBarMessagePane()
: CRhinoApp
- SetStatusBarNumberPane()
: CRhinoApp
- SetStatusBarPointPane()
: CRhinoApp
- SetStatusCheck()
: ON_SubDEdgeChain
- SetStatusText()
: CRhinoUiDockBar
- SetStep()
: CRhinoUiProgressCtrl
- SetStereoMode()
: CRhinoDisplayEngine
, CRhinoDisplayEngine_OGL
, CRhinoDisplayPipeline
- SetStereoParallax()
: CRhinoDisplayEngine
, CRhinoDisplayPipeline
- SetStereoRenderContext()
: CDisplayPipelineAttributes
- SetStereoSeparation()
: CRhinoDisplayEngine
, CRhinoDisplayPipeline
- SetStickyAutoCPlane()
: CRhinoAppSettings
- SetStorageDeviceError()
: ON_BinaryArchive
- SetStretchFactor()
: CRhinoStretchSpaceMorph
- SetStrikeout()
: ON_FontMetrics
- SetStrikethrough()
: ON_Font
- SetStrikeThrough()
: ON_RtfFirstChar::TextRun
, ON_RtfStringBuilder::TextRun
- SetStrikethrough()
: ON_TextBuilder::TextProps
- SetString()
: CArgsRhinoText
, CRhinoSettings
, ON_ArchivableDictionary
- SetStringArray()
: ON_ArchivableDictionary
- SetStringDictionary()
: CRhinoSettings
- SetStringList()
: CRhinoSettings
- SetStringMap()
: ON_TextHash
- SetStringPrompt()
: CArgsRhinoText
- SetStringValue()
: CRhinoHistory
, CRhinoUiEdit
, CRhinoUiRegistry
, ON_HistoryRecord
- SetStringValueA()
: CRhinoUiRegistry
- SetStringValues()
: CRhinoHistory
, ON_HistoryRecord
- SetStringValueW()
: CRhinoUiRegistry
- SetStripMark()
: ON_BrepQuadFacePackSide
, ON_SubDQuadFacePackSide
- SetStripTrailingZeros()
: CRhRdkSdkRealNumberEdit
- SetStyle()
: ON_Light
- SetSubD()
: CRhinoSubDObject
- SetSubDAppearance()
: CRhinoDoc
, ON_SubD
- SetSubDAppearanceOverride()
: ON_SubDMeshFragmentIterator
- SetSubDApplyPattern()
: CDisplayPipelineAttributes
- SetSubDDisplayParameters()
: ON_MeshParameters
- SetSubDEdgeChainValue()
: CRhinoHistory
, ON_HistoryRecord
- SetSubDEdgeChainValues()
: CRhinoHistory
, ON_HistoryRecord
- SetSubDEdgeColor()
: CDisplayPipelineAttributes
- SetSubDEdgeColorReduction()
: CDisplayPipelineAttributes
- SetSubDEdgeThickness()
: CDisplayPipelineAttributes
- SetSubDEdgeUsage()
: CDisplayPipelineAttributes
- SetSubDEdgeVisibility()
: CDisplayPipelineAttributes
- SetSubDForExperts()
: CRhinoSubDObject
, ON_SubDRef
- SetSubDFriendly()
: CArgsRhinoGetCurve
- SetSubDFriendlyTag()
: ON_NurbsCurve
- SetSubdivisionDisplacement()
: ON_SubDComponentBase
- SetSubdivisionLevel()
: ON_SubDComponentBase
- SetSubDReflectionAxisLineColor()
: CDisplayPipelineAttributes
- SetSubDReflectionAxisLineThickness()
: CDisplayPipelineAttributes
- SetSubDReflectionColorPercentage()
: CDisplayPipelineAttributes
- SetSubDReflectionPlane()
: CDisplayPipelineAttributes
- SetSubDReflectionPlaneColor()
: CDisplayPipelineAttributes
- SetSubDReflectionPlaneColorUsage()
: CDisplayPipelineAttributes
- SetSubDThicknessScale()
: CDisplayPipelineAttributes
- SetSubDThicknessUsage()
: CDisplayPipelineAttributes
- SetSubDUsageIndexes()
: CDisplayPipelineAttributes
- SetSubsurface()
: ON_PhysicallyBasedMaterial
- SetSubsurfaceScatteringColor()
: ON_PhysicallyBasedMaterial
- SetSubsurfaceScatteringRadius()
: ON_PhysicallyBasedMaterial
- SetSuffix()
: ON_Annotation
, ON_DimStyle
- SetSuffixString()
: CRhRdkSdkNumberEdit
- SetSuperSample()
: CRhRdkOneColorTextureBase
- SetSuperSmartRolling()
: CRhRdkSdkRealNumberEdit
- SetSupportCancelation()
: IRhRdkPreviewSceneServer::ICancellation
- SetSupportsAutomaticInstancing()
: IRhRdkSdkRenderMeshIterator
- SetSupportsCustomRenderMeshes()
: CDisplayPipelineAttributes
- SetSuppressArrow1()
: ON_Annotation
, ON_DimStyle
- SetSuppressArrow2()
: ON_Annotation
, ON_DimStyle
- SetSuppressButtonFrameWhenNotHot()
: CRhinoUiButton
- SetSuppressExtension1()
: ON_Annotation
, ON_DimStyle
- SetSuppressExtension2()
: ON_Annotation
, ON_DimStyle
- SetSuppressTextWhenEnabled()
: CRhinoUiButton
- SetSurface()
: CArgsRhinoGetCurve
, CRhinoSurfaceObject
- SetSurfaceConstraint()
: ON_BendFaceConstraint
- SetSurfaceEdgeApplyPattern()
: CDisplayPipelineAttributes
- SetSurfaceEdgeThicknessScale()
: CDisplayPipelineAttributes
- SetSurfaceIsoApplyPattern()
: CDisplayPipelineAttributes
- SetSurfaceIsoThicknessScale()
: CDisplayPipelineAttributes
- SetSurfaceMode()
: CArgsRhinoGetParabola
- SetSurfaceNakedEdgeApplyPattern()
: CDisplayPipelineAttributes
- SetSurfaceNakedEdgeThicknessScale()
: CDisplayPipelineAttributes
- SetSurfaceNakedEdgeUseNormalEdgeThickness()
: CDisplayPipelineAttributes
- SetSurfaceParameterMapping()
: ON_TextureMapping
- SetSurfaceParameterMode()
: IRhinoMeshExtruder
- SetSurfaceParamtersFromTextureCoodinates()
: ON_Mesh
- SetSurfaceProperties()
: ON_MeshX
- SetSurfaceSeamFromEndsConstraint()
: ON_BendFaceConstraint
- SetSurfaceSelectionPoint()
: CRhinoObjRef
- SetSurfaceSideConstraint()
: ON_BendFaceConstraint
- SetSurfaceThicknessUsage()
: CDisplayPipelineAttributes
- SetSurfaceValue()
: CRhinoHistory
- SetSwapColors()
: CRhRdkTwoColorTextureBase
- SetSweepResolutionFormula()
: ON_Displacement
- SetSymmetricObject()
: ON_Symmetry
- SetSymmetryForExperts()
: ON_SubD
- SetSymmetrySet()
: ON_SubD
- SetSymmetrySetNextForExperts()
: ON_SubD
- SetSymmetrySetsForExperts()
: ON_SubD
- SetSymmetryTip()
: RhinoMeshUnwrapper
- SetSynchronousProgressCallbackFunction()
: ON_ProgressReporter
- SetTabBackground()
: CRhinoUiPaintColorSettings
- SetTabGap()
: CRhinoUiExpandableTabCtrl
- SetTagName()
: ON_XMLNode
- SetTags()
: CRhRdkContent
, ON_RenderContent
- SetTangencyScale()
: CRhinoEdgeContinuitySettings
- SetTangentColor()
: IRhRdkCustomCurveCtrl
- SetTangentScale()
: IRhRdkCustomCurveCtrl
- SetTangentSnapToAngle()
: IRhRdkCustomCurveCtrl
- SetTangentToleranceDegrees()
: CRhinoEdgeContinuitySettings
- SetTangentToleranceRadians()
: CRhinoEdgeContinuitySettings
- SetTaper()
: ON_Linetype
- SetTarget()
: CRhinoViewport
- SetTargetAndCameraLocation()
: CRhinoViewport
- SetTargetPathId()
: ON_3dmAnimationProperties
- SetTargetPoint()
: ON_3dmView
, ON_Viewport
- SetTConeDefaultPrompts()
: CArgsRhinoGetTube
, CArgsRhinoGetTubeExtra
- SetTemporaryFileName()
: CRhinoFileWriteOptions
- SetTenBytes()
: ON_PANOSE1
- SetTerminated()
: ON_RtfStringBuilder::TextRun
- SetTerminationQueryCallbackFunction()
: ON_Terminator
- SetTerminator()
: ON_SubDDisplayParameters
- SetText()
: CRhinoUiComboBoxItemData
, CRhinoUiOptionsListCtrlCheckBox
, CRhinoUiOptionsListCtrlColorComboBox
, CRhinoUiOptionsListCtrlComboBox
, CRhinoUiOptionsListCtrlEditBox
, CRhinoUiOptionsListCtrlFileNameEditBox
, CRhinoUiOptionsListCtrlIPAddress
, CRhinoUiOptionsListCtrlItem
, CRhinoUiOptionsListCtrlLayerComboBox
, CRhinoUiOptionsListCtrlPointEditBox
, CRhinoUiOptionsListCtrlPushButton
, CRhinoUiOptionsListCtrlRadioButtonColumn
, CRhinoUiOptionsListCtrlSeparator
, CRhinoUiOptionsListCtrlStaticText
, CRhinoUiProgressCtrl
, CRhinoUiSliderCtrl
, CRhinoUiStatic
, CRhinoUiStaticEx
, CRuiUpdateUi
, IRhRdkCommandUpdate
, ON_Annotation
- SetTextBkColor()
: CRhinoUiProgressCtrl
- SetTextColor()
: CRhinoEdgeContinuitySettings
, CRhinoUiStaticEx
, IRhRdkCustomCurveCtrl
, ON_DimStyle
- SetTextColorSource()
: ON_DimStyle
- SetTextEditorFontSize()
: RtfComposer
- SetTextFit()
: ON_Dimension
, ON_DimStyle
- SetTextFont()
: CRhinoUiProgressCtrl
- SetTextForeColor()
: CRhinoUiProgressCtrl
- SetTextGap()
: ON_Annotation
, ON_DimStyle
- SetTextHeight()
: CRhinoTextDot
, ON_Annotation
, ON_DimStyle
, ON_TextRun
, ON_TextRunArray
- SetTextHorizontalAlignment()
: ON_Annotation
, ON_DimStyle
- SetTextIsFilePath()
: CRhinoUiStatic
- SetTextIsWrapped()
: ON_TextContent
- SetTextMask()
: ON_Annotation
, ON_DimStyle
- SetTextMode()
: IRhRdkCustomCurveCtrl
- SetTextMoveLeader()
: ON_Annotation
, ON_DimStyle
- SetTextObject()
: CRhinoText
- SetTextOrientation()
: ON_Annotation
, ON_DimStyle
- SetTextOutputMode()
: CRhinoTextOut
- SetTextPlotColor()
: ON_DimStyle
- SetTextPlotColorSource()
: ON_DimStyle
- SetTextRotation()
: ON_Dimension
, ON_DimStyle
- SetTextRotationDegrees()
: ON_Annotation
, ON_TextContent
- SetTextRotationRadians()
: ON_Annotation
, ON_TextContent
- SetTextString()
: CRhinoTextDot
, ON_TextDot
- SetTextUnderlined()
: ON_Annotation
, ON_DimStyle
- SetTexture()
: CRhRdkBasicEnvironmentCCI
, CRhRdkBasicMaterialCCI
, IRhRdkDecal
, ON_Displacement
, ON_Displacement::SubItem
- SetTextureAmount()
: CRhRdkTexturedContentField
- SetTextureAmount1()
: CRhRdkOneColorTextureBase
- SetTextureAmount2()
: CRhRdkTwoColorTextureBase
- SetTextureAmountMax()
: CRhRdkTexturedContentField
- SetTextureAmountMin()
: CRhRdkTexturedContentField
- SetTextureCoord()
: ON_Mesh
- SetTextureCoordinateCornersForExperts()
: ON_SubDMeshFragment
- SetTextureCoordinateMode()
: IRhinoMeshExtruder
- SetTextureCoordinates()
: CRhinoBrepObject
, CRhinoExtrusionObject
, CRhinoMeshObject
, CRhinoObject
, CRhinoSubDObject
, ON_Mesh
- SetTextureCoordinatesEx()
: ON_Mesh
- SetTextureCoordinatesExistForExperts()
: ON_SubDMeshFragment
- SetTextureCoordinatesFromCorners()
: ON_SubDMeshFragment
- SetTextureCoordinatesFromPlugIn()
: CRhinoInstanceObject
, CRhinoObject
- SetTextureCoordinatesOption()
: ON_SubDFromMeshParameters
- SetTextureCoordinateType()
: ON_SubD
- SetTextureCoords()
: CRhinoDisplayEngine_OGL
- SetTextureDoubleAmount()
: CRhRdkTexturedContentField
- SetTextureDoubleAmountMax()
: CRhRdkTexturedContentField
- SetTextureDoubleAmountMin()
: CRhRdkTexturedContentField
- SetTextureInstanceId()
: ON_Decal
- SetTextureMappingTag()
: ON_SubD
- SetTextureOffset()
: IRhRdkGroundPlane
, ON_GroundPlane
- SetTextureOffsetLocked()
: IRhRdkGroundPlane
, ON_GroundPlane
- SetTextureOn()
: CRhRdkTexturedContentField
- SetTextureOn1()
: CRhRdkOneColorTextureBase
- SetTextureOn2()
: CRhRdkTwoColorTextureBase
- SetTexturePoint()
: ON_SubDFace
- SetTextureRange()
: ON_MeshParameters
- SetTextureRangePictureFrameHack()
: ON_MeshParameters
- SetTextureRepeatLocked()
: IRhRdkGroundPlane
- SetTextureRotation()
: IRhRdkGroundPlane
, ON_GroundPlane
- SetTextureSize()
: CRhRdkRendererSupportOptions
, IRhRdkGroundPlane
, ON_GroundPlane
- SetTextureSizeLocked()
: IRhRdkGroundPlane
, ON_GroundPlane
- SetTextureSlot()
: CRhRdkBasicMaterial
- SetTextVerticalAlignment()
: ON_Annotation
, ON_DimStyle
- SetTextWhenBlank()
: IRhRdkAutomaticUI
- SetThickness()
: CArgsRhinoGetThickBox
, CArgsRhinoGetTubeExtra
- SetThicknessAnalysisSettings()
: CRhinoAppSettings
- SetThicknessOption()
: CArgsRhinoGetThickBox
- SetThicknessPrompt()
: CArgsRhinoGetThickBox
, CArgsRhinoGetTubeExtra
- SetThirdDirectionCount()
: CArgsRhinoGetPlane
- SetThirdDirectionMinCount()
: CArgsRhinoGetPlane
- SetThirdMeshDensityDirectionPrompt()
: CArgsRhinoGetPlane
- SetThirdPoint()
: CArgsRhinoGetEllipse
, CArgsRhinoGetPlane
- SetThirdPointPrompt()
: CArgsRhinoGetPolyline
- SetThirdPointPrompt3Point()
: CArgsRhinoGetPlane
- SetThirdPointPromptVertical()
: CArgsRhinoGetPlane
- SetThirdPrompt()
: CArgsRhinoGetCurve
, CArgsRhinoGetEllipse
- SetThirdPromptIfEmpty()
: CArgsRhinoGetEllipse
- SetThreadId()
: ON_Terminator
- SetTile()
: CRhRdkOneColorTextureBase
- SetTiledFrameInfo()
: CRhinoDisplayPipeline
- SetTimeout()
: IRhRdkPreviewSceneServer::ICancellation
- SetTimeZone()
: CRhRdkSunStorage
, IRhRdkSun
, ON_Sun
- SetTimeZoneHours()
: ON_SunEngine
- Setting()
: CRhRdkDocument
- SettingFacename()
: ON_RtfStringBuilder
- Settings()
: CRhinoCommand
, CRhinoPlugIn
, CRhinoPlugInSettingsChanged::CParameters
- SettingsTag()
: IRhinoUiSection
- SetTitle()
: CRhinoDoc
- SetTitleFrameLinked()
: IRhRdkSafeFrame
, ON_SafeFrame
- SetTitleFrameOn()
: IRhRdkSafeFrame
, ON_SafeFrame
- SetTitleFrameXScale()
: IRhRdkSafeFrame
, ON_SafeFrame
- SetTitleFrameYScale()
: IRhRdkSafeFrame
, ON_SafeFrame
- SetToBackView()
: CRhinoViewport
- SetToBottomView()
: CRhinoViewport
- SetToColor()
: CRhinoUiGradientSliderCtrl
- SetToCurrent()
: CRhinoWidgetColorSettings
- SetToDefault()
: CRhRdkPostEffectPlugIn
- SetToDefaultAppearance()
: CRhinoGumballAppearance
- SetToDefaultColors()
: CRhinoGumballColors
- SetToDefaultDragSettings()
: CRhinoGumballDragSettings
- SetToDefaultFrame()
: CRhinoGumballFrame
- SetToDefaultGumball()
: CRhinoGumball
- SetToDefaultPickResult()
: CRhinoGumballPickResult
- SetToDefaults()
: ON_CurvePipingUserData
, ON_DisplacementUserData
, ON_EdgeSofteningUserData
, ON_RdkUserData
, ON_ShutLiningUserData
, ON_ThickeningUserData
, ON_XMLUserData
- SetToDefaultsImpl()
: ON_XMLUserData
- SetToDefaultSizes()
: CRhinoGumballSizes
- SetToFactoryColors()
: CRhinoGumballColors
- SetToFactorySizes()
: CRhinoGumballSizes
- SetToFrontView()
: CRhinoViewport
- SetToggleStateOnRightClick()
: CRhinoUiCheckBox
- SetToLeftView()
: CRhinoViewport
- SetTolerance()
: CArgsRhinoFair
, ON_MeshParameters
, ON_SpaceMorph
- SetToleranceFormat()
: ON_Annotation
, ON_DimStyle
- SetToleranceHeightScale()
: ON_Annotation
, ON_DimStyle
- SetToleranceLowerValue()
: ON_Annotation
, ON_DimStyle
- SetToleranceResolution()
: ON_Annotation
, ON_DimStyle
- SetTolerancesBoxesAndFlags()
: ON_Brep
- SetToleranceUpperValue()
: ON_Annotation
, ON_DimStyle
- SetToleranceWarning()
: CArgsRhinoGetSpiral
- SetToleranceZeroSuppress()
: ON_Annotation
, ON_DimStyle
- SetTolsFromLegacyValues()
: ON_Brep
- SetToneMapperParams()
: CRhRdkDocument
, CRhRdkRenderingSettings
- SetToneMapping()
: CRhRdkRenderingSettings
- SetToneMappingMethod()
: CRhRdkDocument
- SetToolBarBitmapSize()
: CRhinoUiFile
- SetToolTipBackgroundColor()
: CRhinoUiToolTip
- SetToolTipOwner()
: CRhinoUiDialog
- SetToolTipText()
: CRhinoUiButton
, CRhinoUiToolTip
- SetToolTipTextColor()
: CRhinoUiToolTip
- SetToPerspectiveView()
: CRhinoViewport
- SetToPlanView()
: CRhinoViewport
- SetTopologyComponentIndex()
: ON_MESH_POINT
- SetToRightView()
: CRhinoViewport
- SetToTopView()
: CRhinoViewport
- SetToTwoPointPerspectiveView()
: CRhinoViewport
- SetTraceImage()
: CRhinoViewport
- SetTrackingCursor()
: CRhinoUiOptionsListCtrl
- SetTransform()
: IRhinoMeshExtruder
- SetTransformation()
: CRhinoFileWriteOptions
- SetTransparency()
: CRhRdkBasicMaterial
, CRhRdkBasicMaterialCCI
, ON_Decal
, ON_Material
- SetTransparencyColor()
: CRhRdkBasicMaterial
, CRhRdkBasicMaterialCCI
- SetTransparent()
: CRhinoTextDot
, ON_TextDot
- SetTransparentBitampBackgroundChecked()
: CRhinoGetFileDialog
- SetTransparentColor()
: CRhRdkSimulatedTexture
- SetTransparentColorSensitivity()
: CRhRdkSimulatedTexture
- SetTriangle()
: ON_Mesh
- SetTrimBoundingBox()
: ON_Brep
- SetTrimBoundingBoxes()
: ON_Brep
- SetTrimCurve()
: ON_Brep
- SetTrimDomain()
: ON_Brep
- SetTrimDomainFromEdgeDomain()
: ON_PolyEdgeSegment
- SetTrimIsoFlag()
: ON_Brep
- SetTrimIsoFlags()
: ON_Brep
- SetTrimStartVertex()
: ON_Brep
- SetTrimToAxis()
: CArgsRhinoRevolve
- SetTrimTolerance()
: ON_Brep
- SetTrimTolerances()
: ON_Brep
- SetTrimTypeFlags()
: ON_Brep
- SetTurns()
: CArgsRhinoGetSpiral
- SetTwistAt()
: ON_HermiteSurface
- SetType()
: ON_HatchLoop
, ON_RtfFirstChar::TextRun
, ON_RtfStringBuilder::TextRun
, ON_TextRun
- SetTypeId()
: ON_RenderContent
- SetTypeMask()
: ON_SilhouetteParameters
- SetTypeName()
: ON_RenderContent
- SetTypePendingFlag()
: ON_XMLVariant
- SetUDegree()
: CArgsRhinoGetPlane
- SetUI()
: IRhRdkRenderWindow
- SetUInt8()
: ON_ArchivableDictionary
- SetUInt8Array()
: ON_ArchivableDictionary
- SetUiPaintColorSettings()
: CRhinoAppSettings
- SetUnclampedTagForExperts()
: ON_NurbsCurve
- SetUnderlined()
: ON_Font
, ON_RtfFirstChar::TextRun
, ON_RtfStringBuilder::TextRun
, ON_TextBuilder::TextProps
- SetUnderscore()
: ON_FontMetrics
- SetUndoString()
: IRhRdkColorButton
- SetUnicodeString()
: ON_TextRun
- SetUnits()
: CRhRdkVariant
, ON_XMLVariant
- SetUnitsAndTolerances()
: CRhinoDocProperties
- SetUnitsPerEM()
: ON_Outline
- SetUnitSystem()
: CRhinoUiUnitSystemComboBox
, ON_AerialPhotoCameraPosition
, ON_DimStyle
, ON_InstanceDefinition
, ON_UnitSystem
- SetUnitSystemFromContext()
: ON_DimStyle
- SetUnmanagedVertexCapacityForExperts()
: ON_SubDMeshFragment
- SetUnpackedTextureCoordinates()
: ON_SubDMeshFragment
- SetUnsetProperties()
: ON_Font
- SetUnusedDimStyleName()
: CRhinoDimStyleTable
- SetUnusedGroupName()
: CRhinoGroupTable
- SetUnusedLayerName()
: CRhinoLayerTable
- Setup()
: CRhinoUiGridListCtrl
- SetUParameterAt()
: ON_HermiteSurface
- SetUpdateDefaultDirectory()
: CRhinoOpenDocumentOptions
- SetUpdateDocumentPath()
: CRhinoFileWriteOptions
- SetUpdateModelComponentRadioButtonDescription()
: CRhinoComponentNameConflictUI
- SetUpDefaults()
: CRhRdkContentCreatorNew
, CRhRdkContentCreatorNewFileTexture
- SetupDisplayMaterial()
: CRhinoDisplayPipeline
- SetupDisplayPipeline()
: CRhinoView
- SetupFrustum()
: CRhinoDisplayPipeline
, CRhinoDisplayPipeline_GDI
, CRhinoDisplayPipeline_OGL
- SetupGLMatrices()
: CRhinoDisplayEngine_OGL
- SetupLighting()
: CRhinoDisplayPipeline
, CRhinoDisplayPipeline_OGL
- SetupMaterial()
: CRhinoDisplayEngine_OGL
- SetUPointCount()
: CArgsRhinoGetPlane
- SetUpperBound()
: CRhRdkSdkNumberEdit
- SetUpperLimit()
: CRhinoGetNumber
- SetupPixelFormat()
: CRhinoDisplayEngine_OGL
- SetUpPreview()
: CRhRdkPreviewBackground
, CRhRdkPreviewGeometry
, CRhRdkPreviewLighting
- SetupSceneServer()
: RhRdk::Realtime::DisplayMode
- SetupTexture()
: CRhinoDisplayEngine_OGL
- SetURL()
: CRhinoInstanceDefinitionTable
, ON_InstanceDefinition
- SetURL_Tag()
: ON_InstanceDefinition
- SetUseActiveLayerLinetype()
: CArgsRhinoGetArc
, CArgsRhinoGetCircle
, CArgsRhinoGetCurve
, CArgsRhinoGetEllipse
, CArgsRhinoGetLine
, CArgsRhinoGetParabola
, CArgsRhinoGetPlane
, CArgsRhinoGetPolygon
- SetUseAlpha()
: CRhinoUiOptionsListCtrlColorComboBox
, IRhRdkColorButton
- SetUseAsDefaultTemplate()
: CRhinoGetFileDialog
- SetUseAutoScaling()
: IRhRdkCustomCurveCtrl
- SetUseAxisColors()
: IRhWidgetDrawCache
- SetUseBaseColorTextureAlphaForObjectAlphaTransparencyTexture()
: ON_PhysicallyBasedMaterial
- SetUseBatchMode()
: CRhinoDisplayErrorMessage
, CRhinoFileWriteOptions
- SetUseBothComponentsRadioButtonDescription()
: CRhinoComponentNameConflictUI
- SetUseBufferCompression()
: ON_BinaryArchive
- SetUseCache()
: IRhRdkCustomRenderMeshes2
- SetUseCustomEnvironmentForReflectionAndRefraction()
: CRhRdkRenderingSettings
- SetUseDefaultLibraryPath()
: CRhRdkRendererSupportOptions
- SetUseDefaultSize()
: CArgsRhinoGetCircle
- SetUseDefaultTextPoint()
: ON_Dimension
- SetUseDiameterMode()
: CArgsRhinoGetCircle
- SetUseDiffuseTextureAlphaForObjectTransparencyTexture()
: ON_Material
- SetUseDimensionLayer()
: CRhinoDocProperties
- SetUseEndTangent()
: CArgsRhinoGetCurve
- SetUseFileDialog()
: CRhinoTextOut
- SetUseFirstPoint()
: CArgsRhinoGetPolygon
- SetUseForAllCheckBoxDescription()
: CRhinoComponentNameConflictUI
- SetUseHandCursor()
: CRhRdkSdkNumberEdit
- SetUseImageBasedLighting()
: CRhinoDisplayPipeline
- SetUseLabelColors()
: CRhinoUiOptionsListCtrlItem
- SetUseLinearWorkflow()
: CRhRdkRenderingSettings
- SetUseModelComponentRadioButtonDescription()
: CRhinoComponentNameConflictUI
- SetUseNormal()
: CArgsRhinoGetPolygon
- SetUseObjectsMappingChannels()
: CRhRdkCustomRenderMeshes
, IRhRdkCustomRenderMeshes
- SetUsePlane()
: CArgsRhinoGetCircle
- SetUsePoint0()
: CArgsRhinoGetCircle
- SetUsePoint1()
: CArgsRhinoGetCircle
- SetUsePoint3()
: CArgsRhinoGetArc
- SetUsePreviewCache()
: CRhRdkRendererSupportOptions
- SetUseQuickInitialPreview()
: CRhRdkRendererSupportOptions
- SetUserCanceled()
: IRhRdkCustomRenderMeshManager
- SetUseResolutionMethodForFutureConflicts()
: CRhinoComponentNameConflictUI
- SetUserQueriesPermitted()
: CRhinoOpenDocumentOptions
- SetUserScale()
: CRhinoDigitizerManager
- SetUserString()
: CRhinoDoc
, ON_Object
, ON_UserStringList
- SetUserStrings()
: ON_Object
, ON_UserStringList
- SetUserText()
: ON_Dimension
- SetUserTextPoint()
: ON_DimAngular
- SetUseSortedList()
: CRhinoUiOptionsListCtrlLayerComboBox
, CRhinoUiOptionsListCtrlLinetypeComboBox
- SetUseSpecialColors()
: CRhinoUiExpandableTabPage
, CRhinoUiExpandableTabPage_New
- SetUseStarSecondRadius()
: CArgsRhinoGetPolygon
- SetUseStartTangent()
: CArgsRhinoGetCurve
- SetUseTemporaryFileAndRename()
: CRhinoFileWriteOptions
- SetUseTextureAmount()
: CRhRdkTexturedContentField
- SetUseTextureOn()
: CRhRdkTexturedContentField
- SetUseThirdPoint()
: CArgsRhinoGetEllipse
- SetUTangentAt()
: ON_HermiteSurface
- SetUTCDateTime()
: CRhRdkSunStorage
, IRhRdkSun
, ON_Sun
- SetUuid()
: CDisplayPipelineAttributes
, CRhinoSettings
, ON_ArchivableDictionary
- SetUuidArray()
: ON_ArchivableDictionary
- SetUuidData()
: CRhinoUiComboBoxItemData
- SetUuidValue()
: CRhinoHistory
- SetUUIDValue()
: CRhinoUiRegistry
- SetUuidValue()
: ON_HistoryRecord
- SetUuidValues()
: CRhinoHistory
, ON_HistoryRecord
- SetUVBounds()
: ON_Decal
- SetUVN()
: IRhinoMeshExtruder
- SetV5CurrentLayerIndex()
: ON_3dmSettings
- SetValue()
: CRhinoUiEdit
, CRhinoUiRegistry
, CRhRdkAutomaticUIRow
, CRhRdkAutoUIContext
, CRhRdkContentField
, CRhRdkSdkIntegerNumberEdit
, CRhRdkSdkRealNumberEdit
, CRhRdkSunStorage
, CRhRdkVariant
, IRhRdkParamBlock::IParam
, IRhRdkRenderWindow::IChannel
, ON_RegKey
, ON_TestClass
, ON_XMLProperty
, ON_XMLUserData
, ON_XMLVariant
- SetValueRect()
: IRhRdkRenderWindow::IChannel
- SetValuesFromMeshParameters()
: CRhinoMeshStlUI
- SetValuesToSection()
: CRhRdkContentFields
- SetValueToSection()
: CRhRdkContentField
, CRhRdkFilenameContentField
- SetVariableOffset()
: ON_SubDExpandEdgesParameters
- SetVaries()
: CRhinoCommandOption
, CRhinoUiFontComboBox
, CRhRdkVariant
, IRhRdkColorButton
, ON_XMLVariant
- SetVDegree()
: CArgsRhinoGetPlane
- SetVector()
: CRhinoGet
, IRhRdkSun
- SetVectorAcross()
: ON_Decal
- SetVectorUp()
: ON_Decal
- SetVectorValue()
: CRhinoHistory
, ON_HistoryRecord
- SetVectorValues()
: CRhinoHistory
, ON_HistoryRecord
- SetVerifyInstanceId()
: CRhRdkObjectDataAccess
- SetVertex()
: ON_3dSimplex
, ON_Mesh
, ON_SubDVertexSharpnessCalculator
- SetVertexCount()
: ON_SubDMeshFragment
- SetVertexHiddenFlag()
: ON_Mesh
- SetVertexMarks()
: ON_SubDFace
- SetVertexMode()
: CArgsRhinoGetParabola
- SetVertexNormal()
: ON_Mesh
- SetVertexPoint()
: CArgsRhinoGetParabola
- SetVertexPrompt()
: CArgsRhinoGetParabola
- SetVertexSharpness()
: ON_SubD_ComponentIdTypeAndTag
- SetVertexSurfacePoint()
: ON_SubD
- SetVertexTags()
: ON_SubD
- SetVertexTextureCoordinate()
: ON_SubDMeshFragment
- SetVertexTolerance()
: ON_Brep
- SetVertexTolerances()
: ON_Brep
- SetVertexTopologyFilter()
: ON_SubDComponentFilter
- SetVertical()
: CArgsRhinoGetPolygon
, CArgsRhinoGetSpiral
- SetVerticalCircle()
: CArgsRhinoGetCircle
- SetVerticalDirectionCount()
: CArgsRhinoGetCircle
, CArgsRhinoGetEllipse
- SetVerticalDirectionMinCount()
: CArgsRhinoGetCircle
, CArgsRhinoGetEllipse
- SetVerticalMeshDensityDirectionPrompt()
: CArgsRhinoGetCircle
, CArgsRhinoGetEllipse
- SetVertices()
: ON_Brep
- SetVertSweep()
: ON_Decal
- SetView()
: CArgsRhinoHatch
, CRhinoViewport
, IRhinoSdkRenderFrame
, IRhRdkPreviewSceneServerEx
, IRhRdkRenderWindow
- SetViewArea()
: CRhinoPrintInfo
- SetViewContext()
: ON_3dmAnnotationContext
- SetViewport()
: CRhinoPrintInfo
, ON_HiddenLineDrawing
- SetViewportFilter()
: CRhinoObjectIterator
- SetViewportId()
: ON_Viewport
- SetViewportIdFilter()
: CRhinoObjectIterator
- SetViewportName()
: ON_3dmAnimationProperties
- SetViewportTabsVisibleAtStart()
: CRhinoAppAppearanceSettings
- SetViewportXEdgeLength()
: CRhinoAppSettings
- SetViewportXEdgeSensitivity()
: CRhinoAppSettings
- SetViewportXEdgeStyle()
: CRhinoAppSettings
- SetViewportXEdgeThickness()
: CRhinoAppSettings
- SetViewScale()
: ON_Viewport
- SetViewSettings()
: CRhinoAppSettings
- SetViewType()
: CRhinoUiBlockPreview
- SetVisible()
: ON_3dmObjectAttributes
, ON_Layer
- SetVisibleInRhinoUserInterface()
: CRhinoLayer
- SetVP()
: CRhinoViewport
- SetVParameterAt()
: ON_HermiteSurface
- SetVPointCount()
: CArgsRhinoGetPlane
- SetVTangentAt()
: ON_HermiteSurface
- SetWaitDuration()
: CRhinoGet
- SetWallpaperImage()
: CRhinoViewport
- SetWarnOnDeleteKey()
: CRhinoUiOptionsListCtrlFileNameEditBox
- SetWasCanceled()
: IRhRdkRenderSession
- SetWatermarkText()
: IRhRdkRenderWindow
- SetWeight()
: CRhinoGripObject
, ON_BezierCage
, ON_BezierCurve
, ON_BezierSurface
, ON_NurbsCage
, ON_NurbsCurve
, ON_NurbsSurface
- SetWhitePoint()
: ON_Displacement
, ON_Displacement::SubItem
- SetWidgetColorSettings()
: CRhinoAppSettings
- SetWidth()
: CArgsRhinoGetPlane
, ON_Light
, ON_Linetype
- SetWidthUnits()
: ON_Linetype
- SetWindingPoint()
: ON_WindingNumber
- SetWindowRect()
: CRhinoPrintInfo
- SetWindowRectFromScreen()
: CRhinoPrintInfo
- SetWindowsLogfontName()
: ON_Font
- SetWindowsLogfontWeight()
: ON_Font
- SetWireDensity()
: CRhinoCurvatureGraphSettings
- SetWireThicknessMode()
: CRhinoPrintInfo
- SetWireThicknessScale()
: CRhinoOpenGLSettings
- SetWireZBias()
: CRhinoDisplayAttrsMgr
- SetWorkingDirectory()
: CRhinoDirectoryManager
- SetWorldViewHatchScale()
: ON_3dmAnnotationSettings
- SetWorldViewTextScale()
: ON_3dmAnnotationSettings
- SetWrapType()
: CRhRdkSimulatedTexture
, CRhRdkTexture
- SetWriteLocalTempFileWhenSaving()
: CRhinoAppFileSettings
- SetWriteTypeProperty()
: ON_XMLParameters
- SetXform()
: ON_BezierCageMorph
- SetXformInstance()
: CRhRdkRenderMesh
- SetXformValue()
: CRhinoHistory
, ON_HistoryRecord
- SetXformValues()
: CRhinoHistory
, ON_HistoryRecord
- SetXML()
: CRhRdkLinearWorkflowEx
, CRhRdkSun
, ON_RenderContent
- SetZBiasLevel()
: CRhinoDisplayEngine
- SetZBiasMode()
: CRhinoDisplayPipeline
- SetZebraAnalysisSettings()
: CRhinoAppSettings
- SetZero()
: ON_4dRect
, ON_4iRect
- SetZeroSuppress()
: ON_Annotation
, ON_DimStyle
- SetZoomExtentsParallelViewBorder()
: CRhinoAppViewSettings
- SetZoomExtentsPerspectiveViewBorder()
: CRhinoAppViewSettings
- ShadeConstraints()
: IRhRdkCustomCurveCtrl
- ShadedModeId()
: CRhinoDisplayAttrsMgr
- ShadingRequired()
: CRhinoDisplayPipeline
- ShadowIntensity()
: CDisplayPipelineAttributes
, CRhRdkSunStorage
, IRhRdkSkylight
, IRhRdkSunRO
, ON_Light
, ON_Skylight
, ON_Sun
, RhRdk::Realtime2::ChangeQueue::Skylight
, Skylight
- ShadowOnly()
: GroundPlane
, IRhRdkGroundPlane
, ON_GroundPlane
, RhRdk::Realtime2::ChangeQueue::GroundPlane
- ShadowsEnabled()
: CRhinoDisplayEngine
- ShadowsIgnoreClippingPlanes()
: CDisplayPipelineAttributes
- ShallowCopy()
: ON_Viewport
- Shareable()
: ON_Material
- ShareContentsFrom()
: ON_SubD
- SharedCustomMappingPrimitive()
: ON_TextureMapping
- ShareDimple()
: ON_SubD
- SharedMesh()
: CRhinoMeshObject
, ON_BrepFace
, ON_MeshRef
- Sharp()
: CArgsRhinoGetCurve
- SharpAngleRadians()
: ON_MeshThicknessAnalysis
- SharpEdgeCount()
: ON_SubD
, ON_SubDFace
, ON_SubDVertex
, ON_SubDVertexSharpnessCalculator
- Sharpness()
: ON_SubDEdge
- SharpnessFromNormalizedValue()
: ON_SubDEdgeSharpness
- SharpnessFromSliderValue()
: ON_SubDEdgeSharpness
- Shear()
: ON_Xform
- ShearTransformation()
: ON_Xform
- Sheen()
: CRhRdkMaterial::PhysicallyBased::ChildSlotNames
, CRhRdkMaterial::PhysicallyBased::ParameterNames
, ON_PhysicallyBasedMaterial
- SheenTint()
: CRhRdkMaterial::PhysicallyBased::ChildSlotNames
, CRhRdkMaterial::PhysicallyBased::ParameterNames
, ON_PhysicallyBasedMaterial
- ShiftDown()
: CRhinoDib
- ShiftKeyDownWhenDragStarted()
: CRhinoDropTarget
- ShiftLeft()
: CRhinoDib
- ShiftRight()
: CRhinoDib
- ShiftUp()
: CRhinoDib
- Shine()
: CRhRdkBasicMaterialCCI
, ON_Material
- Shoot()
: ON_RayShooter
- ShootRayHelper()
: ON_RayShooter
- ShortCutKeys()
: CRhinoAppSettings
- ShortDescription()
: CRhinoBrepObject
, CRhinoCageObject
, CRhinoCentermark
, CRhinoClippingPlaneObject
, CRhinoCurveObject
, CRhinoDetailViewObject
, CRhinoDimAngular
, CRhinoDimLinear
, CRhinoDimOrdinate
, CRhinoDimRadial
, CRhinoExtrusionObject
, CRhinoGripObject
, CRhinoGroupObject
, CRhinoHatch
, CRhinoInstanceObject
, CRhinoLeader
, CRhinoLight
, CRhinoMeshObject
, CRhinoMorphControl
, CRhinoNamedViewCameraIcon
, CRhinoObject
, CRhinoPhantomObject
, CRhinoPointCloudObject
, CRhinoPointObject
, CRhinoProxyObject
, CRhinoSubDObject
, CRhinoText
, CRhinoTextDot
- ShortestEdge()
: ON_Triangle
- ShouldAggregateMeshes()
: ChangeQueue
, RhRdk::Realtime2::ChangeQueue
- ShouldExtendContextMenu()
: CRhinoContextMenuExtension
- ShouldSerializeAllUserData()
: ON_BinaryArchive
- ShouldSerializeNoUserData()
: ON_BinaryArchive
- ShouldSerializeSomeUserData()
: ON_BinaryArchive
- ShouldSerializeUserDataDefault()
: ON_BinaryArchive
- ShouldSerializeUserDataItem()
: ON_BinaryArchive
- ShouldWriteUserDataItem()
: ON_BinaryArchive
- Show()
: CRhinoUiDockBarTab
, CRhinoUiInPlaceButton
, CRhinoUiInPlaceEdit
, CRhRdkCustomContentUI
, IRhinoUiWindow
, IRhRdkContentUI
, RhRdk::Realtime::DisplayMode::IHUDCallbacks
- ShowAnnotations()
: CRhinoZBuffer
- ShowAutoGumball()
: CRhinoAppSettings
- ShowBackBuffer()
: CRhinoDisplayEngine
, CRhinoDisplayEngine_OGL
- ShowCaptureProgress()
: RhRdk::Realtime::DisplayMode
- ShowChannel()
: IRhRdkRenderWindow
- ShowClippingPlanes()
: CRhinoZBuffer
- ShowCloseButton()
: CRhinoUiDockBar
- ShowColorWhenDisabled()
: IRhRdkColorButton
- ShowConstructionAxes()
: CRhinoViewport
- ShowConstructionGrid()
: CRhinoViewport
- ShowContentTypeBrowser()
: CRhRdkDocument
- ShowContextMenu()
: IRhRdkNewContentCtrl
- ShowControls()
: RhRdk::Realtime::DisplayMode::IHUDCallbacks
- ShowCurvature()
: CRhinoEdgeContinuitySettings
- ShowCurves()
: CRhinoZBuffer
- ShowCustom()
: CRhRdkRendererSupportOptions
- ShowCustomStatusText()
: RhRdk::Realtime::DisplayMode::IHUDCallbacks
- ShowDeformableOption()
: CArgsRhinoGetEllipse
- ShowDetailsPanel()
: CRhRdkRendererSupportOptions
- ShowDistance()
: CRhinoEdgeContinuitySettings
- ShowDockBar()
: CRhinoUiDockBarManager
- ShowDockbarTab()
: CRhinoTabbedDockBarDialog
- ShowDocuments()
: CRhRdkRendererSupportOptions
- ShowDragWindow()
: CRhinoUiDragBitmapWnd
, CRhinoUiTabbedSheetCtrl
- ShowDropDownOnBeginEdit()
: CRhinoUiOptionsListCtrlComboBox
- ShowEdgeColor()
: CRhinoAppSettings
- ShowExternalPdfPrinters()
: CRhinoAppAppearanceSettings
- ShowFlatSurfaceIsos()
: CDisplayPipelineAttributes
- ShowFrameBuffer()
: CRhinoDisplayPipeline
, CRhinoDisplayPipeline_OGL
- ShowGearButton()
: CRhinoUiDockBar
- ShowGrips()
: CRhinoZBuffer
- ShowHeaderButton()
: IRhinoUiHolder
, IRhinoUiSection
- ShowHeight()
: CArgsRhinoGetConeExtra
, CArgsRhinoGetCylinderExtra
- ShowHelp()
: IRhinoPage
- ShowHiddenLines()
: CRhinoAppSettings
- ShowingChannel()
: IRhRdkRenderWindow
- ShowingSections()
: CRhRdkSunDialog
- ShowIsoCurves()
: CRhinoVisualAnalysisMode
- ShowIsocurves()
: CRhinoZBuffer
- ShowIsoCurves()
: ON_SectionAnalysisAppearance
- ShowItemWindow()
: CRhinoUiTabbedSheetCtrlItem
- ShowLayerPopDownWnd()
: CRhinoUiComboBox
, CRhinoUiOptionsListCtrlComboBox
- ShowLayoutDropShadow()
: CRhinoAppAppearanceSettings
- ShowLights()
: CRhinoZBuffer
- ShowMaximumPasses()
: RhRdk::Realtime::DisplayMode::IHUDCallbacks
- ShowMeshWires()
: CRhinoZBuffer
- Shown()
: IRhRdkListablePostEffect
, ON_PostEffect
- ShowNewButtonInDropDown()
: IRhRdkNewContentCtrl
- ShowObject()
: CRhinoDoc
- ShowOrthoHashMarks()
: CRhinoAppSettings
- ShowOsnapDialog()
: CRhinoAppSettings
- ShowPasses()
: RhRdk::Realtime::DisplayMode::IHUDCallbacks
- ShowPicker()
: IRhRdkColorPicker
- ShowPlugInItemInDropDown()
: IRhRdkNewContentCtrl
- ShowPoints()
: CRhinoZBuffer
- ShowPopDownWnd()
: CRhinoUiLayerComboBox
, CRhinoUiPopDownLayerWnd
- ShowPopUpMenu()
: CRhinoGumballPopUpMenu
- ShowPostEffectsOnControl()
: RhRdk::Realtime::DisplayMode::IHUDCallbacks3
- ShowPreview()
: CRhinoGetFileDialog
- ShowRealtimeRenderProgressBar()
: CDisplayPipelineAttributes
- ShowRenderContent()
: CRhRdkRendererSupportOptions
- ShowSelectedObjectCorners()
: CRhinoAppSettings
- ShowSidebar()
: CRhinoUiFile
- ShowSplash()
: CRhinoSkinDLL
- ShowStatusBar()
: CRhinoAppSettings
- ShowSubDReflectionPlaneAxisLine()
: CDisplayPipelineAttributes
- ShowSubDReflectionPlanePreview()
: CDisplayPipelineAttributes
- ShowTangency()
: CRhinoEdgeContinuitySettings
- ShowTangentEdges()
: CDisplayPipelineAttributes
- ShowTangentSeams()
: CDisplayPipelineAttributes
- ShowText()
: CRhinoZBuffer
- ShowTitle()
: CRhinoView
- ShowToast()
: CRhinoView
- ShowToolTip()
: CRhinoUiToolTip
- ShowUnderside()
: GroundPlane
, IRhRdkGroundPlane
, ON_GroundPlane
, RhRdk::Realtime2::ChangeQueue::GroundPlane
- ShowVariations()
: CArgsRhinoGetLine
- ShowViewportXEdges()
: CRhinoAppSettings
- ShowWindow()
: CRhinoView
- ShowWnd()
: CRhinoUiDockBarTab
- ShowWorldAxes()
: CRhinoViewport
- ShowZAxis()
: CRhinoAppSettings
- Shrink()
: ON_BoundingBox
, ON_ClassArray< T >
, ON_SimpleArray< T >
- ShrinkArray()
: ON_String
, ON_wString
- ShrinkSurface()
: ON_Brep
- ShrinkSurfaces()
: ON_Brep
- Shutdown()
: CRhinoDisplayEngine_OGL
- ShutdownEngine()
: CRhinoDisplayEngine
, CRhinoDisplayEngine_GDI
, CRhinoDisplayEngine_OGL
- ShutdownRenderer()
: RhRdk::Realtime::DisplayMode
- ShutLining()
: ON_MeshModifiers
- SidebarIsVisible()
: CRhinoUiFile
- SideFace()
: ON_SubDQuadNeighborhood
- SideFrame()
: ON_SubDMeshFragment
- SideNormal()
: ON_SubDMeshFragment
- SidePoint()
: ON_SubDMeshFragment
- SidePointCount()
: ON_SubDMeshFragmentGrid
- SidePointCountFromSideCount()
: ON_SubDMeshFragment
- SideSegmentCount()
: ON_SubDMeshFragmentGrid
- SideSegmentCountFromDisplayDensity()
: ON_SubDMeshFragment
- SideSegmentCountIsValid()
: ON_SubDMeshFragment
- SideTangency()
: ON_OffsetSurfaceFunction
- Sign()
: ON_DBL
- SignalUpdate()
: RhRdk::Realtime::DisplayMode
, RhRdk::Realtime::ISignalUpdate
- Signature()
: IRhRdkPreviewSceneServer
- SignedAngle()
: ON_2dVector
- SignedCurvatureAt()
: ON_Curve
- SignedOrdinate()
: ON_Annotation
, ON_DimStyle
- SignedVolume()
: ON_3dSimplex
- SignOfDeterminant()
: ON_Xform
- SilhouetteAttrIsOn()
: CRhinoDisplayPipeline
- SilhouetteHighlighting()
: CRhinoAppSettings
- SilhouetteHighlightInnerColorScale()
: CRhinoAppSettings
- SilhouetteHighlightInnerFactor()
: CRhinoAppSettings
- SilhouetteHighlightOuterScale()
: CRhinoAppSettings
- SilhouetteMethod()
: CRhinoAppSettings
- SilhouetteThickness()
: CRhinoAppSettings
- SilhouetteType()
: ON_SilhouetteParameters
- SimpleArithmeticOn()
: CRhRdkSdkNumberEdit
- SimpleNumber()
: ON_ArithmeticCalculator
- SimplePlanes()
: ON_MeshParameters
- SimplifyEdge()
: ON_Brep
- SimplifyMethod()
: CArgsRhinoLoft
- SimulatedFaceCount()
: ON_FontFaceQuartet
- SimulatedStretch()
: ON_Font
- SimulatedStyle()
: ON_Font
- SimulatedWeight()
: ON_Font
- SimulateEnvironment()
: CRhRdkEnvironment
- SimulateMaterial()
: CRhRdkBasicMaterial
, CRhRdkMaterial
- SimulateTexture()
: CRhRdkTexture
- SingleKind()
: CRhRdkContentKindList
- SingleMapping()
: RhRdk::Realtime2::ChangeQueue::MappingChannels
, RhRdk::Realtime::ChangeQueue::MappingChannels
- SingleMesh()
: RhRdk::Realtime2::ChangeQueue::Mesh
- SinglePassDrawBackground()
: CRhinoDisplayPipeline_OGL
- SinglePassDrawMiddleground()
: CRhinoDisplayPipeline_OGL
- SinglePassInitFrameBuffer()
: CRhinoDisplayPipeline_OGL
- SinglePassLighting()
: CRhinoDisplayPipeline_OGL
- SinglePrecision()
: ON_3dPointListRef
- Singleton()
: ON_Interval
- Size()
: CRhinoDib
, CRhinoZBuffer
, IRhinoWindow
, IRhRdkRenderWindow
, ON_4dRect
, ON_4iRect
, ON_Buffer
- size()
: RhRdk::Realtime2::ChangeQueue::MappingChannels
- SizeAppearanceColumn()
: CRhinoUiLinetypeListCtrl
, CRhinoUiPrintWidthListCtrl
- SizeBits()
: CRhinoDib
- SizeColumns()
: CRhinoUiLayerListCtrl
- SizeControl()
: CRhRdkResizingDialog
- SizedChanged()
: IRhinoPageHost
- SizeHeader()
: CRhinoDib
- SizeNameColumn()
: CRhinoUiLinetypeListCtrl
, CRhinoUiPrintWidthListCtrl
- SizeOf()
: CRhinoInstanceDefinition
, CRhinoObject
, CRhinoSubDObject
, ON_3dmObjectAttributes
, ON_ArcCurve
, ON_Bitmap
, ON_Brep
, ON_BrepEdge
, ON_BrepEdgeArray
, ON_BrepFace
, ON_BrepFaceArray
, ON_BrepFaceSideArray
, ON_BrepLoop
, ON_BrepLoopArray
, ON_BrepRegionArray
, ON_BrepRegionTopology
, ON_BrepTrim
, ON_BrepTrimArray
, ON_BrepVertex
, ON_BrepVertexArray
, ON_ClippingPlaneSurface
, ON_Curve
, ON_CurveOnSurface
, ON_CurveProxy
, ON_DetailView
, ON_EmbeddedBitmap
, ON_Extrusion
, ON_FileReference
, ON_InstanceDefinition
, ON_LineCurve
, ON_Mesh
, ON_MeshComponentRef
, ON_MeshTree
, ON_ModelComponent
, ON_MorphControl
, ON_NurbsCage
, ON_NurbsCurve
, ON_NurbsSurface
, ON_Object
, ON_PlaneSurface
, ON_PointCloud
, ON_PolyCurve
, ON_PolylineCurve
, ON_RevSurface
, ON_RTree
, ON_RTreeMemPool
, ON_String
, ON_SubD
, ON_SubDComponentRef
, ON_SubDEdgeChainCurve
, ON_SumSurface
, ON_Surface
, ON_SurfaceProxy
, ON_Texture
, ON_TextureMapping
, ON_UnknownUserData
, ON_UserData
, ON_UserStringList
, ON_WindowsBitmap
, ON_wString
- SizeOfActiveElements()
: ON_FixedSizePool
, ON_SubD
- SizeOfActiveMeshFragments()
: ON_SubD
- SizeOfAllElements()
: ON_SubD
- SizeOfAllMeshFragments()
: ON_SubD
- SizeOfArchive()
: ON_Write3dmBufferArchive
- SizeOfArray()
: ON_ClassArray< T >
, ON_SimpleArray< T >
- SizeOfBuffer()
: ON_Read3dmBufferArchive
, ON_Write3dmBufferArchive
- SizeofChunkLength()
: ON_BinaryArchive
- SizeofCRC()
: ON_3DM_BIG_CHUNK
- SizeOfElement()
: ON_ClassArray< T >
- SizeofElement()
: ON_FixedSizePool
- SizeOfElement()
: ON_SimpleArray< T >
- SizeofElement()
: ON_SimpleFixedSizePool< T >
- SizeofFragment()
: ON_SubDMeshFragment
- SizeofImage()
: ON_Bitmap
, ON_EmbeddedBitmap
, ON_WindowsBitmap
- SizeofPalette()
: ON_WindowsBitmap
- SizeOfPool()
: ON_FixedSizePool
- SizeofScan()
: ON_Bitmap
, ON_WindowsBitmap
- SizeOfUncompressedBuffer()
: ON_CompressedBuffer
- SizeOfUnusedBuffer()
: ON_RTreeMemPool
- SizeOfUnusedElements()
: ON_FixedSizePool
, ON_SubD
- SizeOfUnusedMeshFragments()
: ON_SubD
- SizeToContent()
: CRhinoUiBitmapButton
, CRhinoUiOptionsListCtrl
, CRhinoUiPopUpListWnd
- SkinPlugInID()
: CRhinoSkinDLL
- SkipBold()
: ON_RtfStringBuilder
- SkipColorTbl()
: ON_RtfStringBuilder
- SkipCompare()
: ONX_ModelTest
- SkipFacename()
: ON_RtfStringBuilder
- SkipItalic()
: ON_RtfStringBuilder
- SkipNestedLinkedDefinitions()
: ON_InstanceDefinition
- SkippingFacename()
: ON_RtfStringBuilder
- SkipUnderline()
: ON_RtfStringBuilder
- Skylight()
: CRhinoDoc
, CRhRdkDocument
, IRhRdkRenderSettingsSection
, ON_3dmRenderSettings
, RhRdk::Realtime2::ChangeQueue::Skylight
, Skylight
- Skylighting()
: IRhRdkPreviewSceneServer
- SkylightingTextureChildSlotName()
: CRhRdkEnvironment
- SkylightShadowResolutionScale()
: CRhinoOpenGLSettings
- SkylightShadowResolutionScaleDynamic()
: CRhinoOpenGLSettings
- Slerp()
: ON_Quaternion
- Slide()
: RhinoMeshEdgeSlider
, RhinoSubDEdgeSlider
- SlideAbsolute()
: RhinoMeshEdgeSlider
, RhinoSubDEdgeSlider
- SlideProportional()
: RhinoMeshEdgeSlider
, RhinoSubDEdgeSlider
- SmallCaptionButtonSize()
: CRhinoUiPaintManager
- SmartMergeChoice()
: CRhRdkRendererSupportOptions
- SmartTrackSettings()
: CRhinoAppSettings
- SmartUngroupRecursive()
: CRhRdkContent
- SmellsLike()
: CRhRdkMaterial
- SmellsLikeGem()
: CRhRdkMaterial
- SmellsLikeGlass()
: CRhRdkMaterial
- SmellsLikeMetal()
: CRhRdkMaterial
- SmellsLikePaint()
: CRhRdkMaterial
- SmellsLikePlaster()
: CRhRdkMaterial
- SmellsLikePlastic()
: CRhRdkMaterial
- SmellsLikeTexturedGem()
: CRhRdkMaterial
- SmellsLikeTexturedGlass()
: CRhRdkMaterial
- SmellsLikeTexturedMetal()
: CRhRdkMaterial
- SmellsLikeTexturedPaint()
: CRhRdkMaterial
- SmellsLikeTexturedPlaster()
: CRhRdkMaterial
- SmellsLikeTexturedPlastic()
: CRhRdkMaterial
- SmoothSectorCoefficient()
: ON_SubDSectorType
- SnapEvent()
: CRhinoGetPoint
- SnapPointsToPlane()
: ON_SubD
- SnappyGumball()
: CRhinoAppSettings
- Snapshot()
: ON_3dmRenderSettings
- SnapshotAt()
: CRhinoDocProperties
- SnapshotCount()
: CRhinoDocProperties
- SnapshotGetThumbnail()
: CRhinoDocProperties
- SnapshotLookUp()
: CRhinoDocProperties
- SnapshotNames()
: CRhinoDocProperties
- SnapshotRestored()
: IRhinoSnapshotsClient
- SnapshotsClientAt()
: CRhinoDocProperties
- SnapshotsClientCategory()
: CRhinoDocProperties
- SnapshotsClientCount()
: CRhinoDocProperties
- SnapshotsClientData()
: CRhinoDocProperties
- SnapshotsClientName()
: CRhinoDocProperties
- SnapshotsClients()
: CRhinoDocProperties
- SnapshotsDeleteTemporarySave()
: CRhinoDocProperties
- SnapshotsEnableClient()
: CRhinoDocProperties
- SnapshotsEnableClientForPartialRestore()
: CRhinoDocProperties
- SnapshotsGetUserString()
: CRhinoDocProperties
- SnapshotsGetUserStringKeys()
: CRhinoDocProperties
- SnapshotsGetUserStrings()
: CRhinoDocProperties
- SnapshotsGetView()
: CRhinoDocProperties
- SnapshotsIsClientEnabled()
: CRhinoDocProperties
- SnapshotsIsClientEnabledForPartialRestore()
: CRhinoDocProperties
- SnapshotsSetClientData()
: CRhinoDocProperties
- SnapshotsSetUserString()
: CRhinoDocProperties
- SnapshotsSetUserStrings()
: CRhinoDocProperties
- SnapshotsTemporaryRestore()
: CRhinoDocProperties
- SnapshotsTemporarySave()
: CRhinoDocProperties
- SnapshotsUserStringCount()
: CRhinoDocProperties
- SnapTo()
: CRhinoBrepObject
, CRhinoCentermark
, CRhinoClippingPlaneObject
, CRhinoCurveObject
, CRhinoDetailViewObject
, CRhinoDimAngular
, CRhinoDimLinear
, CRhinoDimOrdinate
, CRhinoDimRadial
, CRhinoDoc
, CRhinoExtrusionObject
, CRhinoGripObject
, CRhinoHatch
, CRhinoInferredCurve
, CRhinoInstanceObject
, CRhinoLeader
, CRhinoLight
, CRhinoMeshObject
, CRhinoNamedViewCameraIcon
, CRhinoObject
, CRhinoPointCloudObject
, CRhinoPointObject
, CRhinoSubDObject
, CRhinoText
, CRhinoTextDot
, CRhinoWireframeObject
, IRhWidgetDrawCache
- SnapToBBox()
: CRhinoSnapContext
- SnapToPoint()
: CRhinoSnapContext
- SnapToPointNoZ()
: CRhinoSnapContext
- Softening()
: ON_EdgeSoftening::Defaults
, ON_EdgeSoftening
- Solid()
: ON_Thickening::Defaults
, ON_Thickening
- SolidHatchMeshingTolerance()
: CRhinoDisplaySettings
- SolidOrientation()
: ON_Brep
, ON_Mesh
, ON_SubD
- Solve()
: ON_SubDSurfaceInterpolator
- SomeEqualStates()
: ON_ComponentStatus
- Sort()
: CRhinoBitmapTable
, CRhinoDimStyleTable
, CRhinoGroupTable
, CRhinoHatchPatternTable
, CRhinoInstanceDefinitionTable
, CRhinoLayerTable
, CRhinoLightTable
, CRhinoLinetypeTable
, CRhinoMaterialTable
, CRhinoTextureMappingTable
, CRhinoUiDockBarManager
, CRhinoUiPageDockBarManager
, IRhRdkParamBlock
, ON_ClassArray< T >
, ON_SimpleArray< T >
- SortAlgorithm()
: ON
- SortAscending()
: CRhinoUiLinetypeListCtrl
- SortBucket()
: CRhinoDisplayPipeline
- SortByFaceIndex()
: ON_MeshFaceSide
- SortByLayerName()
: CRhinoLayerTable
- SortByVertexIndex()
: ON_MeshFaceSide
- SortDockBarsByName()
: CRhinoUiDockBarManager
- SortedFigureInnerOrientation()
: ON_Outline
- SortedFigureOuterOrientation()
: ON_Outline
- SortEdges()
: ON_SubDVertex
- SortEdgesIntoEdgeChains()
: ON_SubDEdgeChain
- SortedPageViewList()
: CRhinoDoc
- SortFaceLoops()
: ON_Brep
- SortFigures()
: ON_Outline
- SortHighlightedObjects()
: CRhinoDisplayPipeline
- SortHighlightedSubWires()
: CRhinoDisplayPipeline
- SortHighlightedSurfaces()
: CRhinoDisplayPipeline
- SortHighlightedTextDots()
: CRhinoDisplayPipeline
- SortIndex()
: CRhinoUiDockBar
- SortLockedObjects()
: CRhinoDisplayPipeline
- SortLockedSurfaces()
: CRhinoDisplayPipeline
- SortLockedTextDots()
: CRhinoDisplayPipeline
- SortNormalObjects()
: CRhinoDisplayPipeline
- SortNormalSurfaces()
: CRhinoDisplayPipeline
- SortNormalTextDots()
: CRhinoDisplayPipeline
- SortTransparentObjects()
: CRhinoDisplayPipeline
- SortVertexEdges()
: ON_MeshTopology
- Source3dmFilePath()
: ONX_ModelTest
- Source3dmFileVersion()
: ONX_ModelTest
- SourceAndDestinationAreSet()
: ON_ManifestMapItem
- SourceDimstyle()
: ON_DimStyle
- SourceGitBranchName()
: ON
- SourceGitRevisionHash()
: ON
- SourceId()
: ON_ManifestMapItem
- SourceIdentification()
: ON
- SourceIdFaces()
: ON_MappingMeshInfo
- SourceIdHash32()
: ON_ManifestMapItem
- SourceIndex()
: ON_ManifestMapItem
- SourceIndexHash32()
: ON_ManifestMapItem
- SourceInManifest()
: ON_ManifestMapItem
- SourceIsSet()
: ON_ManifestMapItem
- SourceIsUnset()
: ON_ManifestMapItem
- SourceModel()
: ONX_ModelTest
- SourceModelHash()
: ONX_ModelTest
- SourceModelUnitSystem()
: CRhinoFileReadOptions
- SourceOrDestinationIsUnset()
: ON_ManifestMapItem
- SouthNode()
: ON_SurfaceTreeNode
- SouthPole()
: ON_Sphere
- Space()
: CRhinoObject
- SpaceBallSettings()
: CRhinoAppSettings
- SpaceToString()
: ON_TextureMapping
- SpanCount()
: ON_ArcCurve
, ON_Curve
, ON_CurveOnSurface
, ON_CurveProxy
, ON_Extrusion
, ON_LineCurve
, ON_NurbsCage
, ON_NurbsCurve
, ON_NurbsSurface
, ON_PlaneSurface
, ON_PolyCurve
, ON_PolylineCurve
, ON_RevSurface
, ON_SubDEdgeChainCurve
, ON_SumSurface
, ON_Surface
, ON_SurfaceProxy
- SpanIsLinear()
: ON_NurbsCurve
- SpanIsSingular()
: ON_NurbsCurve
- SpanVector()
: ON_Curve
, ON_Surface
- SpecificViewport()
: ON_3dmRenderSettings
- Specular()
: CRhRdkBasicMaterialCCI
, CRhRdkMaterial::PhysicallyBased::ChildSlotNames
, CRhRdkMaterial::PhysicallyBased::ParameterNames
, ON_Light
, ON_Material
, ON_PhysicallyBasedMaterial
- SpecularTint()
: CRhRdkMaterial::PhysicallyBased::ChildSlotNames
, CRhRdkMaterial::PhysicallyBased::ParameterNames
, ON_PhysicallyBasedMaterial
- Sphere()
: CRhRdkCustomRenderMeshes
, CRhRdkRenderMesh
, IRhRdkCustomRenderMeshes
- Spin()
: ON_Triangle
- SpinDragCursor()
: CRhRdkSdkNumberEdit
- SpinEdge()
: ON_SubD
- SpinnerWidth()
: CRhRdkSdkNumberEdit
- Split()
: CRhinoPolyEdgeSegment
, ON_ArcCurve
, ON_BezierCurve
, ON_BezierSurface
, ON_Curve
, ON_CurveProxy
, ON_CurveTreeNode
, ON_Extrusion
, ON_LineCurve
, ON_Mesh
, ON_NurbsCurve
, ON_NurbsSurface
, ON_PlaneSurface
, ON_PolyCurve
, ON_PolyEdgeSegment
, ON_PolylineCurve
, ON_RevSurface
, ON_SubDEdgeChainCurve
, ON_SumSurface
, ON_Surface
, ON_SurfaceTreeNode
, ON_Triangle
- SplitArray()
: ON_Mesh
- SplitBipolarFaces()
: ON_Brep
- SplitClosedFaces()
: ON_Brep
- SplitDir()
: ON_SurfaceTreeNode
- SplitEdge()
: ON_Brep
, ON_SubD
- SplitEdgeAtParameters()
: ON_Brep
- SplitFace()
: ON_SubD
- SplitKinkyEdge()
: ON_Brep
- SplitKinkyFace()
: ON_Brep
- SplitKinkyFaces()
: ON_Brep
- SplitName()
: ON_ModelComponent
- SplitPath()
: ON_FileSystemPath
, ON_String
, ON_wString
- SpotAngleDegrees()
: ON_Light
- SpotAngleRadians()
: ON_Light
- SpotExponent()
: ON_Light
- SquishBack2dMarks()
: ON_Squisher
, ON_SquisherImpl
- SquishCurve()
: ON_Squisher
, ON_SquisherImpl
- SquishMesh()
: ON_Squisher
, ON_SquisherImpl
- SquishPoint()
: ON_Squisher
, ON_SquisherImpl
- SquishPointCloud()
: ON_Squisher
, ON_SquisherImpl
- SquishSurface()
: ON_Squisher
, ON_SquisherImpl
- SquishTextDot()
: ON_Squisher
, ON_SquisherImpl
- SrfTangentMode()
: CRhinoPolyEdge
- StackedFromUnsigned()
: ON_TextRun
- StackEnd()
: ON_TextBuilder
, ON_TextRunBuilder
- StackFormat()
: ON_TextBuilder::TextProps
- StackFormatFromUnsigned()
: ON_DimStyle
- StackFraction()
: ON_TextBuilder
, ON_TextRunBuilder
- StackFractionFormat()
: ON_Annotation
, ON_DimStyle
- StackHeightFraction()
: ON_TextRun
- StackHeightScale()
: ON_Annotation
, ON_DimStyle
- StackScale()
: ON_TextBuilder::TextProps
- StackStyleFromUnsigned()
: ON_StackedText
- Standardize()
: ON_Brep
, ON_ConvexPoly
- StandardizeEdgeCurve()
: ON_Brep
- StandardizeEdgeCurves()
: ON_Brep
- StandardizeFaceSurface()
: ON_Brep
- StandardizeFaceSurfaces()
: ON_Brep
- StandardizeTrimCurve()
: ON_Brep
- StandardizeTrimCurves()
: ON_Brep
- StarAroundCurveCenterPrompt()
: CArgsRhinoGetPolygon
- StarCenterPrompt()
: CArgsRhinoGetPolygon
- StarEndPrompt()
: CArgsRhinoGetPolygon
- StarMode()
: CArgsRhinoGetPolygon
- StarSecondRadius()
: CArgsRhinoGetPolygon
- StarSecondRadiusPrompt()
: CArgsRhinoGetPolygon
- Start()
: CRhinoFileMenu
, CRhinoWidgetGeometry
, ON_StopWatch
- StartAngle()
: CArgsRhinoRevolve
- StartDay()
: ON_3dmAnimationProperties
- StartDir()
: CArgsRhinoGetSpiral
- StartedAsRhinoExe()
: CRhinoApp
- StartEngine()
: CRhinoDisplayEngine
, CRhinoDisplayEngine_GDI
, CRhinoDisplayEngine_OGL
- StartHour()
: ON_3dmAnimationProperties
- StartMinutes()
: ON_3dmAnimationProperties
- StartMonth()
: ON_3dmAnimationProperties
- StartPoint()
: CArgsRhinoGetSpiral
, CArgsRhinoLoft
, CArgsRhinoText
, ON_Arc
, ON_XMeshEdge
- StartPointPrompt()
: CArgsRhinoText
- StartPrompt()
: CArgsRhinoGetArc
, CArgsRhinoGetSpiral
- StartRenderer()
: RhRdk::Realtime::DisplayMode
- StartRendering()
: CRhRdkSdkRender
, IRhinoSdkRenderFrame
- StartRenderingInWindow()
: CRhinoSdkRender
, CRhRdkSdkRender
- StartRenderingQuiet()
: CRhRdkSdkRender
- StartSeconds()
: ON_3dmAnimationProperties
- StartsWith()
: ON_wString
- StartsWithNoCase()
: ON_wString
- StartTangent()
: CArgsRhinoGetCurve
- StartTime()
: CRhinoSdkRender
- StartTimeInMilliseconds()
: IRhRdkRenderingFileInfo
- StartTracking()
: CRhinoUiButton
, CRhinoUiDockBar
- StartVertex()
: ON_XMeshEdge
- StartYear()
: ON_3dmAnimationProperties
- StateCRC()
: CRhRdkPostEffectPlugInManager
- StaticDisplayContentSerialNumber()
: CRhinoSubDObject
- Status()
: ON_SubDComponentBase
, ON_SubDComponentPtr
, ON_SubDEdgePtr
, ON_SubDFacePtr
, ON_SubDMeshFragment
, ON_SubDVertexPtr
, ON_TriangleMesh
- StatusArray()
: ON_TriangleMesh
- StatusBar()
: CRhinoApp
- StatusBarIsVisisble()
: CRhinoAppSettings
- StatusBarLayerPaneWidth()
: CRhinoAppSettings
- StatusBarProgressMeterEnd()
: CRhinoApp
, CRhinoDoc
- StatusBarProgressMeterPos()
: CRhinoApp
, CRhinoDoc
- StatusBarProgressMeterStart()
: CRhinoApp
, CRhinoDoc
- StatusCheck()
: ON_ComponentStatus
, ON_SubDEdgeChain
- StatusCheckEnabled()
: ON_SubDEdgeChain
- StatusCheckFail()
: ON_SubDEdgeChain
- StatusCheckPass()
: ON_SubDEdgeChain
- StatusCount()
: ON_TriangleMesh
- StatusFromUnsigned()
: ON_FileReference
- StatusValue()
: CRhinoGumballFrame
- StdArcticAttrs()
: CRhinoDisplayAttrsMgr
- StdArtisticAttrs()
: CRhinoDisplayAttrsMgr
- StdGhostedAttrs()
: CRhinoDisplayAttrsMgr
- StdMonochromeAttrs()
: CRhinoDisplayAttrsMgr
- StdPenAttrs()
: CRhinoDisplayAttrsMgr
- StdRaytracedAttrs()
: CRhinoDisplayAttrsMgr
- StdRenderedAttrs()
: CRhinoDisplayAttrsMgr
- StdRenderedShadowsAttrs()
: CRhinoDisplayAttrsMgr
- StdShadedAttrs()
: CRhinoDisplayAttrsMgr
- StdTechAttrs()
: CRhinoDisplayAttrsMgr
- StdWireframeAttrs()
: CRhinoDisplayAttrsMgr
- StdXrayAttrs()
: CRhinoDisplayAttrsMgr
- Step()
: ON_ProgressStepCounter
, ON_TextIterator
- StepCount()
: ON_ProgressStepCounter
- StepIt()
: CRhinoUiProgressCtrl
- StickyAutoCPlane()
: CRhinoAppSettings
- Stop()
: CRhinoWidgetGeometry
, ON_StopWatch
- StopEngine()
: CRhinoDisplayEngine
, CRhinoDisplayEngine_OGL
- StopRendering()
: CRhinoSdkRender
, CRhRdkSdkRender
, IRhinoSdkRenderFrame
, IRhRdkAsyncRenderContext
, IRhRdkRenderSession
- StopTracking()
: CRhinoUiDockBar
- StorageDeviceError()
: ON_BinaryArchive
- StorageDeviceErrorFromUnsigned()
: ON_BinaryArchive
- StretchBlt()
: CRhinoDib
- StretchFactor()
: CRhinoPrintInfo
- StretchToWideString()
: ON_Font
- StrikeoutPosition()
: ON_FontMetrics
- StrikeoutThickness()
: ON_FontMetrics
- Strikethrough()
: ON_RtfFirstChar
, ON_RtfStringBuilder
, ON_TextBuilder
, ON_TextRunBuilder
- String()
: CArgsRhinoText
, CRhinoGet
, CRhRdkUuid
, ON_XMLNode
- StringCollateAndMapLocalePtr()
: ON_Locale
- StringFromProjection()
: CRhRdkSimulatedEnvironment
, ON_Environment
- StringHash()
: ON_MD5_Hash
, ON_SHA1_Hash
- StringMapLocale()
: ON_TextHash
- StringMapType()
: ON_TextHash
- StringPrompt()
: CArgsRhinoText
- StringTables()
: CRhinoApp
- StringTablesInitialized()
: CRhinoApp
- StringToPoint()
: ON_XMLVariant
- StringValue()
: CRhinoUiEdit
- StripsAreNeighbors()
: ON_BrepQuadFacePackSide
, ON_SubDQuadFacePackSide
- StripTrailingZeros()
: CRhRdkSdkRealNumberEdit
- Style()
: IRhRdkCustomCurveCtrl
, IRhRdkCustomCurveGraphSectionCallback
, IRhRdkCustomCurveGraphSectionSharedCallback
, ON_Light
- StyleIndexFromListIndex()
: CRhinoDimStyleComboBox
- StyleToWideString()
: ON_Font
- SubBrep()
: ON_Brep
- SubclassGroupBoxes()
: CRhRdkResizingDialog
- SubclassHeaderCtrl()
: CRhinoUiGridListCtrl
- SubD()
: CRhinoObjRef
, CRhinoSubDDisplay
, CRhinoSubDObject
, ON_SubDComponentIterator
, ON_SubDComponentList
, ON_SubDComponentRef
, ON_SubDEdgeArray
, ON_SubDEdgeChain
, ON_SubDEdgeChainCurve
, ON_SubDEdgeIterator
, ON_SubDFaceArray
, ON_SubDFaceIterator
, ON_SubDMesh
, ON_SubDMeshFragmentIterator
, ON_SubDRef
, ON_SubDRTree
, ON_SubDVertexArray
, ON_SubDVertexIterator
- SubDAppearance()
: CRhinoDoc
, CRhinoSubDObject
, ON_SubD
, ON_SubDMeshFragmentIterator
- SubDApplyPattern()
: CDisplayPipelineAttributes
- SubdApplyPattern()
: CDisplayPipelineAttributes
- SubDComponent()
: CRhinoObjRef
- SubDComponentId()
: CRhinoGripObject
- SubDComponentPtr()
: CRhinoGripObject
- SubDComponentRef()
: CRhinoObjRef
- SubDComponentsAreEligible()
: CRhinoSubDPickSettings
- SubDControlNetMesh()
: ON_SubD
- SubDCount()
: ON_SubDComponentRefList
- SubDDisplay()
: CRhinoSubDObject
- SubDDisplayAttributes()
: CRhinoSubDObject
- SubDDisplayParameters()
: ON_MeshParameters
- SubDEdge()
: CRhinoObjRef
, ON_SubDMeshFragment
- SubDEdgeColor()
: CDisplayPipelineAttributes
- SubDEdgeColorReduction()
: CDisplayPipelineAttributes
- SubDEdgeEdgeType()
: CDisplayPipelineAttributes
- SubDEdgeIsInsideWindowPick()
: CRhinoPickContext
- SubDEdgePtr()
: ON_SubDMeshFragment
- SubDEdgeRef()
: CRhinoObjRef
- SubDEdgeThickness()
: CDisplayPipelineAttributes
- SubDEdgeUsage()
: CDisplayPipelineAttributes
- SubDFace()
: CRhinoObjRef
, ON_SubDMeshFragment
- SubDFaceIsInsideWindowPick()
: CRhinoPickContext
- SubDFaceRef()
: CRhinoObjRef
- SubDFriendly()
: CArgsRhinoGetCurve
- SubDFriendlyTag()
: ON_NurbsCurve
- SubDGeometryContentSerialNumber()
: ON_SubDComponentList
, ON_SubDHash
- SubDHash()
: ON_SubD
, ON_SubDHash
- SubDimple()
: ON_SubD
- SubDimpleUseCount()
: ON_SubD
- SubDIsEligible()
: CRhinoSubDPickSettings
- SubDIsVisible()
: CRhinoSubDObject
- Subdivide()
: ON_SubDFaceNeighborhood
, ON_SubDQuadNeighborhood
- Subdivided()
: ON_SubDEdgeSharpness
- SubdivideSector()
: ON_SubD
- SubdivideSharpness()
: ON_SubDEdge
- SubdivisionCount()
: ON_SubDComponentRegion
- SubdivisionDisplacement()
: ON_SubDComponentBase
- SubdivisionDisplacementIsNonzero()
: ON_SubDComponentBase
- SubdivisionLevel()
: ON_SubDComponentBase
- SubdivisionPoint()
: ON_SubDComponentPtr
, ON_SubDEdge
, ON_SubDEdgePtr
, ON_SubDFace
, ON_SubDFacePtr
, ON_SubDVertex
- SubDLevel()
: ON_SubDComponentIterator
- SubDModifiedNofification()
: ON_SubD
- SubDObject()
: CRhinoSubDDisplay
- SubdominantEigenvalue()
: ON_SubDSectorType
- SubdominantEigenvalueMulitiplicity()
: ON_SubDSectorType
- SubDRef()
: CRhinoObjRef
, CRhinoSubDDisplay
, CRhinoSubDObject
, ON_SubDComponentIterator
, ON_SubDComponentRef
, ON_SubDEdgeChain
, ON_SubDEdgeChainCurve
, ON_SubDEdgeIterator
, ON_SubDFaceIterator
, ON_SubDMesh
, ON_SubDVertexIterator
- SubDReflectionAxisLineColor()
: CDisplayPipelineAttributes
- SubDReflectionAxisLineThickness()
: CDisplayPipelineAttributes
- SubDReflectionColorPercentage()
: CDisplayPipelineAttributes
- SubDReflectionPlane()
: CDisplayPipelineAttributes
- SubDReflectionPlaneAxisLineOn()
: CDisplayPipelineAttributes
- SubDReflectionPlaneColor()
: CDisplayPipelineAttributes
- SubDReflectionPlaneColorUsage()
: CDisplayPipelineAttributes
- SubDReflectionPlanePreviewOn()
: CDisplayPipelineAttributes
- SubDRenderContentSerialNumber()
: ON_SubDComponentList
- SubDResults()
: CRhinoSubDPickSettings
- SubDRuntimeSerialNumber()
: ON_SubDComponentList
, ON_SubDHash
- SubDSelections()
: CRhinoGetObject
- SubDSurfaceMesh()
: ON_SubD
- SubDThicknessScale()
: CDisplayPipelineAttributes
- SubDThicknessUsage()
: CDisplayPipelineAttributes
- SubDVertex()
: CRhinoObjRef
, ON_SubDMeshFragment
- SubDVertexPtr()
: ON_SubDMeshFragment
- SubDVertexRef()
: CRhinoObjRef
- SubItem()
: ON_Displacement::SubItem
- SubItemIterator()
: ON_Displacement::SubItemIterator
- SubLimple()
: ON_SubDMesh
- SubLimpleUseCount()
: ON_SubDMesh
- SubMenu()
: CRhRdkCustomTask
, CRhRdkTask
- SubObjectFromComponentIndex()
: CRhinoInstanceObject
- SubObjectsAreHighlighted()
: CRhinoBrepObject
, CRhinoCurveObject
, CRhinoExtrusionObject
, CRhinoGroupObject
, CRhinoInstanceObject
, CRhinoMeshObject
, CRhinoObject
, CRhinoPointCloudObject
, CRhinoSubDObject
- SubObjectsAreSelected()
: CRhinoBrepObject
, CRhinoCurveObject
, CRhinoExtrusionObject
, CRhinoGroupObject
, CRhinoInstanceObject
, CRhinoMeshObject
, CRhinoObject
, CRhinoPointCloudObject
, CRhinoSubDObject
- SubObjectSelect()
: CRhinoGetObject
- SubObjectStatus()
: CRhinoObject
- Subscript()
: ON_RtfStringBuilder
, ON_TextBuilder
, ON_TextRunBuilder
- SubstituteFont()
: ON_Font
- SubstituteGlyph()
: ON_FontGlyph
- SubString()
: ON_wString
- Subsurface()
: CRhRdkMaterial::PhysicallyBased::ChildSlotNames
, CRhRdkMaterial::PhysicallyBased::ParameterNames
, ON_PhysicallyBasedMaterial
- SubsurfaceScatteringColor()
: CRhRdkMaterial::PhysicallyBased::ChildSlotNames
, CRhRdkMaterial::PhysicallyBased::ParameterNames
, ON_PhysicallyBasedMaterial
- SubsurfaceScatteringRadius()
: CRhRdkMaterial::PhysicallyBased::ChildSlotNames
, CRhRdkMaterial::PhysicallyBased::ParameterNames
, ON_PhysicallyBasedMaterial
- Subtract()
: CRhRdkColor
, ON_ArithmeticCalculator
- SubtractRect()
: ON_4dRect
, ON_4iRect
- Suffix()
: ON_Annotation
, ON_DimStyle
- SuggestedVertexTag()
: ON_SubDVertex
- Sum()
: ON_MassProperties
- SummandCount()
: ON_Sum
- SumSurfaceForm()
: ON_Extrusion
- Sun()
: CRhinoDoc
, CRhRdkDocument
, CRhRdkSun
, IRhRdkRenderSettingsSection
, IRhRdkSunSection
, ON_3dmRenderSettings
- SunColorFromAltitude()
: ON_Sun
- SuperfluousKnot()
: ON_NurbsCurve
, ON_NurbsSurface
- SuperSample()
: CRhRdkOneColorTextureBase
- Superscript()
: ON_RtfStringBuilder
, ON_TextBuilder
, ON_TextRunBuilder
- SuperSmartRolling()
: CRhRdkSdkRealNumberEdit
- Support()
: ON_ConvexPoly
- SupportDataObject()
: CRhinoDropTarget
- SupportedByRenderer()
: CRhRdkTexture
- SupportedChannels()
: CRhRdkRenderPlugIn
- SupportedKinds()
: CRhRdkContentIOPlugIn
- SupportIndex()
: ON_ConvexHullPoint2
, ON_ConvexHullRef
, ON_ConvexHullRefEx
, ON_ConvexPoly
- Supports()
: CSupportChannels
- SupportsAnimation()
: IRhinoSnapshotsClient
- SupportsAutomaticInstancing()
: IRhRdkSdkRenderMeshIterator
- SupportsBrepProxyReferenceCounting()
: CRhinoExtrusionObject
, CRhinoObject
, CRhinoSubDObject
- SupportsCommand()
: CRhRdkContent
- SupportsContextHelp()
: CRhRdkBasicMaterial
, CRhRdkContent
- SupportsCustomPlugIn()
: CRhRdkPlugIn
- SupportsCustomRenderMeshes()
: CDisplayPipelineAttributes
- SupportsDataConversion()
: IRhinoSnapshotsClientEx
- SupportsDocument()
: IRhinoSnapshotsClient
- SupportsEditProperties()
: IRhRdkDecalSupport
- SupportsFeature()
: CRhRdkRenderPlugIn
- SupportsMultiSampling()
: CRhinoDisplayEngine
, CRhinoDisplayEngine_OGL
- SupportsObject()
: IRhinoSnapshotsClient
- SupportsObjects()
: IRhinoSnapshotsClient
- SupportsPause()
: CRhinoSdkRender
, CRhRdkSdkRender
, IRhRdkAsyncRenderContext
- SupportsSandbox()
: CRhRdkTask
- SupportsShading()
: CRhinoDisplayEngine
, CRhinoDisplayEngine_OGL
, CRhinoDisplayPipeline
- SupportsStencilBuffer()
: CRhinoDisplayEngine_OGL
- SupportsSubObjectSelection()
: IRhinoPropertiesPanelPage
- SupportsTask()
: CRhRdkBreadcrumbTaskOrigin
, CRhRdkContentInstanceBrowserTaskOrigin
, CRhRdkContentTypeBrowserTaskOrigin
, CRhRdkContextTaskOrigin
, CRhRdkFloatingPreviewTaskOrigin
, CRhRdkSingleSelectionTaskOrigin
, CRhRdkSubNodeTaskOrigin
, CRhRdkTaskOrigin
, IRhRdkTaskOrigin
- SupportsTiling()
: CRhinoDisplayPipeline
- SupportsVboBuffers()
: CRhinoDisplayEngine
- SuppressArrow1()
: ON_Annotation
, ON_DimStyle
- SuppressArrow2()
: ON_Annotation
, ON_DimStyle
- SuppressButtonFrameWhenNotHot()
: CRhinoUiButton
- SuppressExtension1()
: ON_Annotation
, ON_DimStyle
- SuppressExtension2()
: ON_Annotation
, ON_DimStyle
- SuppressTextWhenEnabled()
: CRhinoUiButton
- SuppressZeros()
: ON_NumberFormatter
- Surface()
: CArgsRhinoGetCurve
, CRhinoObjRef
, CRhinoPolyEdgeSegment
, CRhinoSurfaceObject
, ON_PolyEdgeSegment
- SurfaceAt()
: CRhinoPolyEdge
, ON_PolyEdgeCurve
- SurfaceBlend()
: RhinoSdkBlend
- SurfaceBlendShape()
: RhinoSdkBlend
- SurfaceBoundingBox()
: ON_SubDEdge
, ON_SubDFace
, ON_SubDMeshFragment
, ON_SubDMeshFragmentIterator
, ON_SubDVertex
- SurfaceCenterFrame()
: ON_SubDFace
- SurfaceCenterNormal()
: ON_SubDEdge
, ON_SubDFace
- SurfaceCenterPoint()
: ON_SubDEdge
, ON_SubDFace
- SurfaceColorWriting()
: CDisplayPipelineAttributes
- SurfaceEdgeApplyPattern()
: CDisplayPipelineAttributes
- SurfaceEdgeThicknessScale()
: CDisplayPipelineAttributes
- SurfaceEvaluationCoefficientsAvailable()
: ON_SubDSectorType
- SurfaceIndexOf()
: ON_BrepFace
, ON_BrepLoop
, ON_BrepTrim
- SurfaceIsoApplyPattern()
: CDisplayPipelineAttributes
- SurfaceIsoThicknessScale()
: CDisplayPipelineAttributes
- SurfaceMeshCacheExists()
: ON_SubD
- SurfaceMode()
: CArgsRhinoGetParabola
- SurfaceNakedEdgeApplyPattern()
: CDisplayPipelineAttributes
- SurfaceNakedEdgeThicknessScale()
: CDisplayPipelineAttributes
- SurfaceNakedEdgeUseNormalEdgeThickness()
: CDisplayPipelineAttributes
- SurfaceNormal()
: ON_SubDVertex
- SurfaceNormalDirection()
: ON_BrepFaceSide
- SurfaceNormalSign()
: ON_SubDSectorType
- SurfaceOf()
: ON_BrepFace
, ON_BrepLoop
, ON_BrepTrim
- SurfaceParameter()
: CRhinoObjRef
, CRhinoPolyEdge
, CRhinoPolyEdgeSegment
, ON_PolyEdgeCurve
, ON_PolyEdgeSegment
- SurfaceParameterMode()
: IRhinoMeshExtruder
- SurfacePoint()
: ON_SubDVertex
- SurfacePointIsSet()
: ON_SubDVertex
- SurfacePointRadiusFromControlPointRadius()
: ON_SubD
- SurfacePointVertexId()
: ON_SubDVertexSurfacePointCoefficient
- SurfaceProperties()
: ON_MeshX
- SurfaceStyle()
: ON
- SurfaceThicknessUsage()
: CDisplayPipelineAttributes
- SurfaceTree()
: ON_Surface
- SurfaceUseCount()
: ON_Brep
- Swap()
: ON_ClassArray< T >
, ON_Interval
, ON_SimpleArray< T >
, ON_SubDMesh
- SwapByteOrder()
: ON_wString
- SwapColors()
: CRhRdkTwoColorTextureBase
- SwapCols()
: ON_Matrix
- SwapContents()
: ON_SubD
- SwapCoordinates()
: ON_2dPointArray
, ON_2dVectorArray
, ON_2fPointArray
, ON_2fVectorArray
, ON_3dPointArray
, ON_3dVectorArray
, ON_3fPointArray
, ON_3fVectorArray
, ON_4dPointArray
, ON_4fPointArray
, ON_BoundingBox
, ON_Brep
, ON_CurveOnSurface
, ON_Geometry
, ON_LineCurve
, ON_Mesh
, ON_NurbsCurve
, ON_NurbsSurface
, ON_Plane
, ON_Point
, ON_PointCloud
, ON_PointGrid
, ON_PolyCurve
, ON_PolylineCurve
, ON_SubD
- SwapDimple()
: ON_SubD
- SwapEdge()
: ON_Mesh
- SwapItems()
: CRhinoUiListBoxEx
- SwapLeftAndRight()
: ON_ScaleValue
- SwapLoopParameters()
: ON_Brep
- SwapPair()
: ON_SubDComponentPtrPair
- SwapRedAndBlueSamples()
: CRhinoDib
- SwapRows()
: ON_Matrix
- SwapSourceAndDestiation()
: ON_ManifestMapItem
- SwapTextureCoordinate()
: ON_Texture
, ON_TextureMapping
- SwapTrimParameters()
: ON_Brep
- SweepPitch()
: ON_Displacement::Defaults
- SweepResolutionFormula()
: ON_Displacement::Defaults
, ON_Displacement
- Switch()
: CRhinoUiDockBarTab
- SwitchDockBar()
: CRhinoUiDockBarTab
- Symmetry()
: ON_SubD
- SymmetryCoordinates()
: ON_Symmetry
- SymmetryCoordinatesFromUnsigned()
: ON_Symmetry
- SymmetryCoordinatesToString()
: ON_Symmetry
- SymmetryHash()
: ON_Symmetry
- SymmetryId()
: ON_Symmetry
- SymmetryRegionFromUnsigned()
: ON_Symmetry
- SymmetryRegionHasFixedPoints()
: ON_Symmetry
- SymmetrySetCount()
: ON_SubD
- SymmetrySetNext()
: ON_SubD
- SymmetrySetPrimaryMotif()
: ON_SubD
- SymmetryType()
: ON_Symmetry
- SymmetryTypeFromUnsigned()
: ON_Symmetry
- SymmetryTypeToString()
: ON_Symmetry
- SynchAttributes()
: CRhinoObject
- SynchPopDownListWithCombo()
: CRhinoUiPopDownLayerWnd
- SynchronizeLegacyMaterial()
: ON_PhysicallyBasedMaterial
- SynchronizeSegmentDomains()
: ON_PolyCurve
- SynchSlider()
: CRhinoUiEdit
- SynchWithGUI()
: CRhinoAppAppearanceSettings
- SystemComponentCount()
: ON_ComponentManifest
- SystemDimstyleFromContentHash()
: ON_DimStyle
- SystemDimstyleFromId()
: ON_DimStyle
- SystemDimstyleFromIndex()
: ON_DimStyle
- SystemDimstyleFromName()
: ON_DimStyle
- SystemItemFromIndex()
: ON_ComponentManifest
- SystemItemFromNameHash()
: ON_ComponentManifest
- SystemLinetypeCount()
: CRhinoLinetypeTable