Rhino C++ API  8.18
All Classes Namespaces Functions Variables Typedefs Enumerations Enumerator Friends Modules Pages
CRhinoPolyEdge Member List

This is the complete list of members for CRhinoPolyEdge, including all inherited members.

AggregateComponentStatus() constON_Objectvirtual
Append(class CRhinoPolyEdgeSegment *new_segment)CRhinoPolyEdge
ON_PolyCurve::Append(ON_Curve *)ON_PolyCurve
AppendAndMatch(ON_Curve *)CRhinoPolyEdge
AreaMassProperties(ON_3dPoint base_point, ON_3dVector plane_normal, ON_MassProperties &mp, bool bArea=true, bool bFirstMoments=true, bool bSecondMoments=true, bool bProductMoments=true, double rel_tol=1.0e-6, double abs_tol=1.0e-6) constON_Curve
AttachUserData(class ON_UserData *pUserData)ON_Object
BoundingBox() constON_Geometry
BrepAt(double t) constCRhinoPolyEdge
BrepForm(class ON_Brep *brep=nullptr) constON_Geometryvirtual
ChangeClosedCurveSeam(double t) overrideCRhinoPolyEdgevirtual
ON_Curve::ChangeClosedCurveSeam(double t, double min_dist)ON_Curve
ChangeDimension(int desired_dimension) overrideON_PolyCurvevirtual
ClearAllComponentStates() constON_Object
ClearBoundingBox()ON_Geometryvirtual
ClearComponentStates(ON_ComponentStatus states_to_clear) constON_Objectvirtual
ClearComponentStates(ON_COMPONENT_INDEX component_index, ON_ComponentStatus states_to_clear) constON_Objectvirtual
CloseGap(int gap_index, int segments_to_modify)ON_PolyCurve
CloseGaps()ON_PolyCurve
ComponentIndex() constON_Geometryvirtual
ContainsAllEdges() constCRhinoPolyEdge
ContainsAnyEdges() constCRhinoPolyEdge
CopyUserData(const ON_Object &source_object, ON_UUID source_userdata_item_id, ON_Object::UserDataConflictResolution userdata_conflict_resolution)ON_Object
CopyUserData(const ON_Object &source_object)ON_Object
Count() constON_PolyCurve
Create(const ON_BrepTrim *trim, const CRhinoObject *rhino_object=0)CRhinoPolyEdge
Create(const ON_Curve *curve, const CRhinoObject *rhino_object=0)CRhinoPolyEdge
Create(const CRhinoObjRef &)CRhinoPolyEdge
Create(CRhinoDoc &doc, const ON_PolyEdgeHistory &history_value)CRhinoPolyEdge
CreateCubicLoft(int point_count, int point_dim, int point_stride, const double *point_list, double k, int is_closed=0, ON::cubic_loft_end_condition start_shape=ON::cubic_loft_ec_quadratic, ON::cubic_loft_end_condition end_shape=ON::cubic_loft_ec_quadratic, class ON_NurbsCurve *nurbs_curve=0)ON_Curvestatic
CreateCurveTree() constON_Curvevirtual
CRhinoPolyEdge()CRhinoPolyEdge
CurvatureAt(double t) constON_Curve
CurveTree() constON_Curve
DataCRC(ON__UINT32 current_remainder) const overrideON_PolyCurvevirtual
Degree() const overrideON_PolyCurvevirtual
DeleteComponents(const ON_COMPONENT_INDEX *ci_list, size_t ci_count)ON_Objectvirtual
DerivativeAt(double t) constON_Curve
Destroy()ON_PolyCurve
DestroyCurveTree()ON_Curve
DestroyRuntimeCache(bool bDelete=true) overrideCRhinoPolyEdgevirtual
DetachUserData(class ON_UserData *pUserData)ON_Object
Dimension() const overrideON_PolyCurvevirtual
Domain() const overrideON_PolyCurvevirtual
Dump(ON_TextLog &) const overrideON_PolyCurvevirtual
DuplicateCurve() const overrideCRhinoPolyEdgevirtual
EdgeAt(double t) constCRhinoPolyEdge
EdgeParameter(double t) constCRhinoPolyEdge
EmergencyDestroy()ON_PolyCurve
eTanMode enum nameCRhinoPolyEdge
Ev1Der(double t, ON_3dPoint &point, ON_3dVector &first_derivative, int side=0, int *hint=0) constON_Curve
Ev2Der(double t, ON_3dPoint &point, ON_3dVector &first_derivative, ON_3dVector &second_derivative, int side=0, int *hint=0) constON_Curve
Evaluate(double, int, int, double *, int=0, int *=0) const overrideON_PolyCurvevirtual
EvaluatePoint(const class ON_ObjRef &objref, ON_3dPoint &P) const overrideON_PolyCurvevirtual
EvaluateTangents(double t, ON_3dPoint &srfpoint, ON_3dVector &edgetangent, ON_3dVector &srfbinormal, ON_3dVector &srfisodir, ON_3dVector &srfnormal) constCRhinoPolyEdge
EvCurvature(double t, ON_3dPoint &point, ON_3dVector &tangent, ON_3dVector &kappa, int side=0, int *hint=0) constON_Curve
EvPoint(double t, ON_3dPoint &point, int side=0, int *hint=0) constON_Curve
EvSignedCurvature(double t, ON_3dPoint &point, ON_3dVector &tangent, double &kappa, const ON_3dVector *normal=nullptr, int side=0, int *hint=0) constON_Curve
EvSrfDerivatives(double t, ON_3dPoint &srfpoint, ON_3dVector &du, ON_3dVector &dv, ON_3dVector &duu, ON_3dVector &duv, ON_3dVector &dvv) constCRhinoPolyEdge
EvSrfNormalCurvature(double t, ON_3dVector srftangent, ON_3dVector &srfnormalcurvature, ON_3dVector &srfnormal) constCRhinoPolyEdge
EvSrfTangent(double t, ON_3dPoint &srfpoint, ON_3dVector &srftangent, ON_3dVector &srfnormal) constCRhinoPolyEdge
EvTangent(double t, ON_3dPoint &point, ON_3dVector &tangent, int side=0, int *hint=0) constON_Curve
ExplodeSingleSegmentCurve() constON_PolyCurve
Extend(const ON_Interval &domain) overrideON_PolyCurvevirtual
FaceAt(double t) constCRhinoPolyEdge
FindCurve(const ON_Curve *curve) constCRhinoPolyEdge
FindEdge(const ON_BrepEdge *edge) constCRhinoPolyEdge
FindNextGap(int segment_index0) constON_PolyCurve
FindTrim(const ON_BrepTrim *trim) constCRhinoPolyEdge
FirstSegmentCurve() constON_PolyCurve
FirstSpanIsLinear(double min_length, double tolerance) constON_Curve
FirstSpanIsLinear(double min_length, double tolerance, ON_Line *span_line) constON_Curve
FirstUserData() constON_Object
FrameAt(double t, ON_Plane &plane) constON_Curve
GetBBox(double *boxmin, double *boxmax, bool bGrowBox=false) const overrideON_PolyCurvevirtual
GetBoundingBox(ON_BoundingBox &bbox, bool bGrowBox=false) constON_Geometry
GetBoundingBox(ON_3dPoint &bbox_min, ON_3dPoint &bbox_max, bool bGrowBox=false) constON_Geometry
GetClosestPoint(const ON_3dPoint &, double *, double=0.0, const ON_Interval *=nullptr) const overrideON_PolyCurvevirtual
GetComponentsWithSetStates(ON_ComponentStatus states_filter, bool bAllEqualStates, ON_SimpleArray< ON_COMPONENT_INDEX > &components) constON_Objectvirtual
GetCurveParameterFromNurbFormParameter(double, double *) const overrideON_PolyCurvevirtual
GetDomain(double *t0, double *t1) constON_Curve
GetHistoryValue(CRhinoDoc &doc, ON_PolyEdgeHistory &polyedge_history) constCRhinoPolyEdge
GetLength(double *, double=1.0e-8, const ON_Interval *=nullptr) const overrideON_PolyCurvevirtual
GetLocalClosestPoint(const ON_3dPoint &, double, double *, const ON_Interval *=nullptr) const overrideON_PolyCurvevirtual
GetNextDiscontinuity(ON::continuity c, double t0, double t1, double *t, int *hint=nullptr, int *dtype=nullptr, double cos_angle_tolerance=ON_DEFAULT_ANGLE_TOLERANCE_COSINE, double curvature_tolerance=ON_SQRT_EPSILON) const overrideON_PolyCurvevirtual
GetNormalizedArcLengthPoint(double s, double *t, double fractional_tolerance=1.0e-8, const ON_Interval *sub_domain=nullptr) const overrideON_PolyCurvevirtual
GetNormalizedArcLengthPoints(int count, const double *s, double *t, double absolute_tolerance=0.0, double fractional_tolerance=1.0e-8, const ON_Interval *sub_domain=nullptr) const overrideON_PolyCurvevirtual
GetNurbForm(ON_NurbsCurve &, double=0.0, const ON_Interval *=nullptr) const overrideON_PolyCurvevirtual
GetNurbFormParameterFromCurveParameter(double, double *) const overrideON_PolyCurvevirtual
GetParameterTolerance(double t, double *tminus, double *tplus) constON_Curvevirtual
GetSpanVector(double *) const overrideON_PolyCurvevirtual
GetSpanVectorIndex(double t, int side, int *span_vector_index, ON_Interval *span_domain) constON_Curvevirtual
GetTightBoundingBox(class ON_BoundingBox &tight_bbox, bool bGrowBox=false, const class ON_Xform *xform=nullptr) const overrideON_PolyCurvevirtual
GetUserData(const ON_UUID &userdata_uuid) constON_Object
GetUserString(const wchar_t *key, ON_wString &string_value) constON_Object
GetUserStringKeys(ON_ClassArray< ON_wString > &user_string_keys) constON_Object
GetUserStrings(ON_ClassArray< ON_UserString > &user_strings) constON_Object
HarvestSegment(int)ON_PolyCurve
HasBrepForm() constON_Geometryvirtual
HasGap() constON_PolyCurve
HasGapAt(int segment_index) constON_PolyCurve
HasNurbForm() const overrideON_PolyCurvevirtual
HasSynchronizedSegmentDomains() constON_PolyCurve
Highlight(bool bHighlight=true) constCRhinoPolyEdge
Insert(int segment_index, class CRhinoPolyEdgeSegment *new_segment)CRhinoPolyEdge
ON_PolyCurve::Insert(int, ON_Curve *)ON_PolyCurve
IntersectCurve(const ON_Curve *curveB, ON_SimpleArray< ON_X_EVENT > &x, double intersection_tolerance=0.0, double overlap_tolerance=0.0, const ON_Interval *curveA_domain=0, const ON_Interval *curveB_domain=0) constON_Curve
IntersectPlane(ON_PlaneEquation plane_equation, ON_SimpleArray< ON_X_EVENT > &x, double intersection_tolerance=0.0, double overlap_tolerance=0.0, const ON_Interval *curve_domain=0) constON_Curve
IntersectSelf(ON_SimpleArray< ON_X_EVENT > &x, double intersection_tolerance=0.0, const ON_Interval *curve_domain=0) constON_Curvevirtual
IntersectSurface(const ON_Surface *surfaceB, ON_SimpleArray< ON_X_EVENT > &x, double intersection_tolerance=0.0, double overlap_tolerance=0.0, const ON_Interval *curveA_domain=0, const ON_Interval *surfaceB_udomain=0, const ON_Interval *surfaceB_vdomain=0) constON_Curve
IsArc(const ON_Plane *=nullptr, ON_Arc *=nullptr, double=ON_ZERO_TOLERANCE) const overrideON_PolyCurvevirtual
IsArcAt(double t, const ON_Plane *plane=0, ON_Arc *arc=0, double tolerance=ON_ZERO_TOLERANCE, double *t0=0, double *t1=0) constON_Curve
IsClosable(double tolerance, double min_abs_size=0.0, double min_rel_size=10.0) constON_Curve
IsClosed() const overrideCRhinoPolyEdgevirtual
IsContinuous(ON::continuity c, double t, int *hint=nullptr, double point_tolerance=ON_ZERO_TOLERANCE, double d1_tolerance=ON_ZERO_TOLERANCE, double d2_tolerance=ON_ZERO_TOLERANCE, double cos_angle_tolerance=ON_DEFAULT_ANGLE_TOLERANCE_COSINE, double curvature_tolerance=ON_SQRT_EPSILON) const overrideON_PolyCurvevirtual
IsCorrupt(bool bRepair, bool bSilentError, class ON_TextLog *text_log) constON_Object
IsDeformable() const overrideON_PolyCurvevirtual
IsEllipse(const ON_Plane *plane=nullptr, ON_Ellipse *ellipse=nullptr, double tolerance=ON_ZERO_TOLERANCE) constON_Curvevirtual
IsHighlighted() constCRhinoPolyEdge
IsInPlane(const ON_Plane &, double=ON_ZERO_TOLERANCE) const overrideON_PolyCurvevirtual
IsKindOf(const ON_ClassId *pClassId) constON_Object
IsLinear(double=ON_ZERO_TOLERANCE) const overrideON_PolyCurvevirtual
IsMorphable() const overrideON_PolyCurvevirtual
IsNested() constON_PolyCurve
IsoType(double t) constCRhinoPolyEdge
IsPeriodic(void) const overrideON_PolyCurvevirtual
IsPlanar(ON_Plane *=nullptr, double=ON_ZERO_TOLERANCE) const overrideON_PolyCurvevirtual
IsPolyline(ON_SimpleArray< ON_3dPoint > *pline_points=nullptr, ON_SimpleArray< double > *pline_t=nullptr) const overrideON_PolyCurvevirtual
IsSelected() constCRhinoPolyEdge
IsShort(double tolerance, const ON_Interval *sub_domain=0, double *length_estimate=0) const overrideON_PolyCurvevirtual
IsValid(class ON_TextLog *text_log=nullptr) const overrideON_PolyCurvevirtual
IsValid(bool bAllowGaps, ON_TextLog *text_log) constON_PolyCurve
LastSegmentCurve() constON_PolyCurve
LastSpanIsLinear(double min_length, double tolerance) constON_Curve
LastSpanIsLinear(double min_length, double tolerance, ON_Line *span_line) constON_Curve
LengthMassProperties(class ON_MassProperties &mp, bool bLength=true, bool bFirstMoments=true, bool bSecondMoments=true, bool bProductMoments=true, double rel_tol=1.0e-6, double abs_tol=1.0e-6) constON_Curve
MakeDeformable() overrideON_PolyCurvevirtual
MarkAggregateComponentStatusAsNotCurrent() constON_Objectvirtual
MemoryRelocate()ON_Objectvirtual
MeshCurve(ON_MeshCurveParameters &mp, ON_PolylineCurve *polyline, bool bSkipFirstPoint, const ON_Interval *domain) constON_Curve
ModelObjectId() constON_Objectvirtual
Morph(const ON_SpaceMorph &morph) overrideON_PolyCurve
ON_Curve::Morph(const class ON_SpaceMorph &morph)ON_Geometryvirtual
MoveUserData(ON_Object &source_object, ON_UUID source_userdata_item_id, ON_Object::UserDataConflictResolution userdata_conflict_resolution, bool bDeleteAllSourceItems)ON_Object
MoveUserData(ON_Object &source_object)ON_Object
NurbsCurve(ON_NurbsCurve *pNurbsCurve=nullptr, double tolerance=0.0, const ON_Interval *subdomain=nullptr) constON_Curve
ObjectType() const overrideON_Curvevirtual
ON_Curve() ON_NOEXCEPTON_Curve
ON_Curve(const ON_Curve &)ON_Curve
ON_Geometry()=defaultON_Geometry
ON_Geometry(const ON_Geometry &)=defaultON_Geometry
ON_Object() ON_NOEXCEPTON_Object
ON_Object(const ON_Object &)ON_Object
ON_PolyCurve() ON_NOEXCEPTON_PolyCurve
ON_PolyCurve(const ON_PolyCurve &)ON_PolyCurve
ON_PolyCurve(int)ON_PolyCurve
operator=(const ON_PolyCurve &)ON_PolyCurve
ON_Curve::operator=(const ON_Curve &)ON_Curve
ON_Geometry::operator=(const ON_Geometry &)=defaultON_Geometry
ON_Object::operator=(const ON_Object &)ON_Object
operator[](int) constCRhinoPolyEdge
ParameterSearch(double t, int &index, bool bEnableSnap) constON_PolyCurve
ON_Curve::ParameterSearch(double t, int &index, bool bEnableSnap, const ON_SimpleArray< double > &m_t, double RelTol=ON_SQRT_EPSILON) constON_Curveprotected
PointAt(double t) constON_Curve
PointAtEnd() constON_Curve
PointAtStart() constON_Curve
PolyCurveParameter(int segment_index, double segmentcurve_parameter) constON_PolyCurve
Prepend(class CRhinoPolyEdgeSegment *new_segment)CRhinoPolyEdge
ON_PolyCurve::Prepend(ON_Curve *)ON_PolyCurve
PrependAndMatch(ON_Curve *)CRhinoPolyEdge
PurgeUserData()ON_Object
Read(ON_BinaryArchive &) overrideON_PolyCurvevirtual
Remove()CRhinoPolyEdge
Remove(int index)CRhinoPolyEdge
RemoveNesting()ON_PolyCurve
RemoveNestingEx()ON_PolyCurve
RemoveShortSegments(double tolerance, bool bRemoveShortSegments=true) overrideON_PolyCurvevirtual
Reserve(int)ON_PolyCurve
Reverse() overrideON_PolyCurvevirtual
Rotate(double sin_angle, double cos_angle, const ON_3dVector &rotation_axis, const ON_3dPoint &rotation_center)ON_Geometry
Rotate(double rotation_angle, const ON_3dVector &rotation_axis, const ON_3dPoint &rotation_center)ON_Geometry
SanitizeDomain()ON_PolyCurve
Scale(double scale_factor)ON_Geometry
SegmentCount() constCRhinoPolyEdge
SegmentCurve(int segment_index) constCRhinoPolyEdge
SegmentCurveParameter(double polycurve_parameter) constON_PolyCurve
SegmentCurves() constON_PolyCurve
SegmentDomain(int segment_index) constON_PolyCurve
SegmentIndex(double polycurve_parameter) constON_PolyCurve
SegmentIndex(ON_Interval sub_domain, int *segment_index0, int *segment_index1) constON_PolyCurve
SegmentParameters() constON_PolyCurve
Select(bool bSelect=true, bool bSynchHighlight=true) constCRhinoPolyEdge
SetComponentStates(ON_COMPONENT_INDEX component_index, ON_ComponentStatus states_to_set) constON_Objectvirtual
SetComponentStatus(ON_COMPONENT_INDEX component_index, ON_ComponentStatus status_to_copy) constON_Objectvirtual
SetDomain(double t0, double t1) overrideON_PolyCurvevirtual
ON_Curve::SetDomain(ON_Interval domain)ON_Curve
SetEndPoint(ON_3dPoint end_point) overrideCRhinoPolyEdgevirtual
SetParameterization(const double *t)ON_PolyCurve
SetSegment(int index, ON_Curve *crv)ON_PolyCurve
SetSrfTangentMode(eTanMode tm)CRhinoPolyEdge
SetStartPoint(ON_3dPoint start_point) overrideCRhinoPolyEdgevirtual
SetUserString(const wchar_t *key, const wchar_t *string_value)ON_Object
SetUserStrings(int count, const ON_UserString *user_strings, bool bReplace)ON_Object
SignedCurvatureAt(double t, const ON_3dVector *plane_normal=nullptr) constON_Curve
SizeOf() const overrideON_PolyCurvevirtual
SpanCount() const overrideON_PolyCurvevirtual
SpanVector() constON_Curve
Split(double t, ON_Curve *&left_side, ON_Curve *&right_side) const overrideON_PolyCurvevirtual
SrfTangentMode() constCRhinoPolyEdge
SurfaceAt(double t) constCRhinoPolyEdge
SurfaceParameter(double t) constCRhinoPolyEdge
SwapCoordinates(int, int) overrideON_PolyCurvevirtual
SynchronizeSegmentDomains()ON_PolyCurve
TangentAt(double t) constON_Curve
ThisIsNullptr(bool bSilentError) constON_Object
TightBoundingBox() constON_Geometry
tmAuto enum valueCRhinoPolyEdge
tmIsoDir enum valueCRhinoPolyEdge
tmPerp enum valueCRhinoPolyEdge
tmUser enum valueCRhinoPolyEdge
Transform(const ON_Xform &) overrideON_PolyCurvevirtual
TransformUserData(const class ON_Xform &xform)ON_Object
Translate(const ON_3dVector &translation_vector)ON_Geometry
Trim(const ON_Interval &domain) overrideON_PolyCurvevirtual
TrimAt(double t) constCRhinoPolyEdge
TrimParameter(double t) constCRhinoPolyEdge
UnsetON_Geometrystatic
UpdateReferencedComponents(const class ON_ComponentManifest &source_manifest, const class ON_ComponentManifest &destination_manifest, const class ON_ManifestMap &manifest_map)ON_Objectvirtual
UserDataConflictResolution enum nameON_Object
UserStringCount() constON_Object
Write(ON_BinaryArchive &) const overrideON_PolyCurvevirtual
~CRhinoPolyEdge()CRhinoPolyEdge
~ON_Curve()ON_Curvevirtual
~ON_Geometry()=defaultON_Geometry
~ON_Object()ON_Objectvirtual
~ON_PolyCurve()ON_PolyCurvevirtual