Rhino C++ API  8.18
All Classes Namespaces Functions Variables Typedefs Enumerations Enumerator Friends Modules Pages
CRhinoPolyEdgeSegment Member List

This is the complete list of members for CRhinoPolyEdgeSegment, including all inherited members.

AddSegmentObjRef(const CRhinoObjRef &ref)CRhinoPolyEdgeSegment
AggregateComponentStatus() constON_Objectvirtual
AreaMassProperties(ON_3dPoint base_point, ON_3dVector plane_normal, ON_MassProperties &mp, bool bArea=true, bool bFirstMoments=true, bool bSecondMoments=true, bool bProductMoments=true, double rel_tol=1.0e-6, double abs_tol=1.0e-6) constON_Curve
AttachUserData(class ON_UserData *pUserData)ON_Object
BoundingBox() constON_Geometry
Brep() constCRhinoPolyEdgeSegment
BrepForm(class ON_Brep *brep=nullptr) constON_Geometryvirtual
ChangeClosedCurveSeam(double t, double min_dist)ON_Curve
ChangeClosedCurveSeam(double t)ON_Curvevirtual
ChangeDimension(int desired_dimension)ON_Curvevirtual
ClearAllComponentStates() constON_Object
ClearBoundingBox()ON_Geometryvirtual
ClearComponentStates(ON_ComponentStatus states_to_clear) constON_Objectvirtual
ClearComponentStates(ON_COMPONENT_INDEX component_index, ON_ComponentStatus states_to_clear) constON_Objectvirtual
ComponentIndex() const overrideCRhinoPolyEdgeSegmentvirtual
CopyUserData(const ON_Object &source_object, ON_UUID source_userdata_item_id, ON_Object::UserDataConflictResolution userdata_conflict_resolution)ON_Object
CopyUserData(const ON_Object &source_object)ON_Object
Create(const ON_BrepTrim *trim, const CRhinoObject *rhino_object=0)CRhinoPolyEdgeSegment
Create(const ON_Curve *curve, const CRhinoObject *rhino_object=0)CRhinoPolyEdgeSegment
Create(const ON_Curve *curve, const ON_COMPONENT_INDEX &component_index, const CRhinoObject *rhino_object=0)CRhinoPolyEdgeSegment
Create(const CRhinoObjRef &ref)CRhinoPolyEdgeSegment
Create(CRhinoDoc &doc, const ON_CurveProxyHistory &curveproxy_history)CRhinoPolyEdgeSegment
CreateCubicLoft(int point_count, int point_dim, int point_stride, const double *point_list, double k, int is_closed=0, ON::cubic_loft_end_condition start_shape=ON::cubic_loft_ec_quadratic, ON::cubic_loft_end_condition end_shape=ON::cubic_loft_ec_quadratic, class ON_NurbsCurve *nurbs_curve=0)ON_Curvestatic
CreateCurveTree() constON_Curvevirtual
CRhinoPolyEdge classCRhinoPolyEdgeSegmentfriend
CRhinoPolyEdgeSegment()CRhinoPolyEdgeSegment
CRhinoPolyEdgeSegment(const CRhinoPolyEdgeSegment &)CRhinoPolyEdgeSegment
CurvatureAt(double t) constON_Curve
CurveTree() constON_Curve
DataCRC(ON__UINT32 current_remainder) const overrideON_CurveProxyvirtual
Degree() const overrideON_CurveProxyvirtual
DeleteComponents(const ON_COMPONENT_INDEX *ci_list, size_t ci_count)ON_Objectvirtual
DerivativeAt(double t) constON_Curve
DestroyCurveTree()ON_Curve
DestroyRuntimeCache(bool bDelete=true) overrideCRhinoPolyEdgeSegmentvirtual
DetachUserData(class ON_UserData *pUserData)ON_Object
Dimension() const overrideON_CurveProxyvirtual
Domain() const overrideON_CurveProxyvirtual
Dump(ON_TextLog &) const overrideON_CurveProxyvirtual
DuplicateCurve() const overrideCRhinoPolyEdgeSegmentvirtual
Edge() constCRhinoPolyEdgeSegment
EdgeDomain() constCRhinoPolyEdgeSegment
EdgeParameter(double t) constCRhinoPolyEdgeSegment
EmergencyDestroy()ON_Object
Ev1Der(double t, ON_3dPoint &point, ON_3dVector &first_derivative, int side=0, int *hint=0) constON_Curve
Ev2Der(double t, ON_3dPoint &point, ON_3dVector &first_derivative, ON_3dVector &second_derivative, int side=0, int *hint=0) constON_Curve
Evaluate(double, int, int, double *, int=0, int *=0) const overrideON_CurveProxyvirtual
EvaluatePoint(const class ON_ObjRef &objref, ON_3dPoint &P) const overrideON_Curvevirtual
EvCurvature(double t, ON_3dPoint &point, ON_3dVector &tangent, ON_3dVector &kappa, int side=0, int *hint=0) constON_Curve
EvPoint(double t, ON_3dPoint &point, int side=0, int *hint=0) constON_Curve
EvSignedCurvature(double t, ON_3dPoint &point, ON_3dVector &tangent, double &kappa, const ON_3dVector *normal=nullptr, int side=0, int *hint=0) constON_Curve
EvTangent(double t, ON_3dPoint &point, ON_3dVector &tangent, int side=0, int *hint=0) constON_Curve
Extend(const ON_Interval &domain)ON_Curvevirtual
Face() constCRhinoPolyEdgeSegment
FirstSpanIsLinear(double min_length, double tolerance) constON_Curve
FirstSpanIsLinear(double min_length, double tolerance, ON_Line *span_line) constON_Curve
FirstUserData() constON_Object
FrameAt(double t, ON_Plane &plane) constON_Curve
GetBBox(double *boxmin, double *boxmax, bool bGrowBox=false) const overrideON_CurveProxyvirtual
GetBoundingBox(ON_BoundingBox &bbox, bool bGrowBox=false) constON_Geometry
GetBoundingBox(ON_3dPoint &bbox_min, ON_3dPoint &bbox_max, bool bGrowBox=false) constON_Geometry
GetClosestPoint(const ON_3dPoint &, double *, double=0.0, const ON_Interval *=nullptr) const overrideON_CurveProxyvirtual
GetComponentsWithSetStates(ON_ComponentStatus states_filter, bool bAllEqualStates, ON_SimpleArray< ON_COMPONENT_INDEX > &components) constON_Objectvirtual
GetCurveParameterFromNurbFormParameter(double, double *) const overrideON_CurveProxyvirtual
GetDomain(double *t0, double *t1) constON_Curve
GetHistoryValue(CRhinoDoc &doc, ON_CurveProxyHistory &curveproxy_history) constCRhinoPolyEdgeSegment
GetLength(double *, double=1.0e-8, const ON_Interval *=nullptr) const overrideON_CurveProxyvirtual
GetLocalClosestPoint(const ON_3dPoint &, double, double *, const ON_Interval *=nullptr) const overrideON_CurveProxyvirtual
GetNextDiscontinuity(ON::continuity c, double t0, double t1, double *t, int *hint=nullptr, int *dtype=nullptr, double cos_angle_tolerance=ON_DEFAULT_ANGLE_TOLERANCE_COSINE, double curvature_tolerance=ON_SQRT_EPSILON) const overrideON_CurveProxyvirtual
GetNormalizedArcLengthPoint(double s, double *t, double fractional_tolerance=1.0e-8, const ON_Interval *sub_domain=nullptr) const overrideON_CurveProxyvirtual
GetNormalizedArcLengthPoints(int count, const double *s, double *t, double absolute_tolerance=0.0, double fractional_tolerance=1.0e-8, const ON_Interval *sub_domain=nullptr) const overrideON_CurveProxyvirtual
GetNurbForm(ON_NurbsCurve &, double=0.0, const ON_Interval *=nullptr) const overrideON_CurveProxyvirtual
GetNurbFormParameterFromCurveParameter(double, double *) const overrideON_CurveProxyvirtual
GetParameterTolerance(double, double *, double *) const overrideON_CurveProxyvirtual
GetSpanVector(double *) const overrideON_CurveProxyvirtual
GetSpanVectorIndex(double t, int side, int *span_vector_index, ON_Interval *span_domain) constON_Curvevirtual
GetTightBoundingBox(class ON_BoundingBox &tight_bbox, bool bGrowBox=false, const class ON_Xform *xform=nullptr) const overrideON_Curvevirtual
GetUserData(const ON_UUID &userdata_uuid) constON_Object
GetUserString(const wchar_t *key, ON_wString &string_value) constON_Object
GetUserStringKeys(ON_ClassArray< ON_wString > &user_string_keys) constON_Object
GetUserStrings(ON_ClassArray< ON_UserString > &user_strings) constON_Object
HasBrepForm() constON_Geometryvirtual
HasNurbForm() const overrideON_CurveProxyvirtual
Highlight(bool bHighlight=true) constCRhinoPolyEdgeSegment
IntersectCurve(const ON_Curve *curveB, ON_SimpleArray< ON_X_EVENT > &x, double intersection_tolerance=0.0, double overlap_tolerance=0.0, const ON_Interval *curveA_domain=0, const ON_Interval *curveB_domain=0) constON_Curve
IntersectPlane(ON_PlaneEquation plane_equation, ON_SimpleArray< ON_X_EVENT > &x, double intersection_tolerance=0.0, double overlap_tolerance=0.0, const ON_Interval *curve_domain=0) constON_Curve
IntersectSelf(ON_SimpleArray< ON_X_EVENT > &x, double intersection_tolerance=0.0, const ON_Interval *curve_domain=0) constON_Curvevirtual
IntersectSurface(const ON_Surface *surfaceB, ON_SimpleArray< ON_X_EVENT > &x, double intersection_tolerance=0.0, double overlap_tolerance=0.0, const ON_Interval *curveA_domain=0, const ON_Interval *surfaceB_udomain=0, const ON_Interval *surfaceB_vdomain=0) constON_Curve
IsArc(const ON_Plane *=nullptr, ON_Arc *=nullptr, double=ON_ZERO_TOLERANCE) const overrideON_CurveProxyvirtual
IsArcAt(double t, const ON_Plane *plane=0, ON_Arc *arc=0, double tolerance=ON_ZERO_TOLERANCE, double *t0=0, double *t1=0) constON_Curve
IsClosable(double tolerance, double min_abs_size=0.0, double min_rel_size=10.0) constON_Curve
IsClosed() const overrideCRhinoPolyEdgeSegmentvirtual
IsContinuous(ON::continuity c, double t, int *hint=nullptr, double point_tolerance=ON_ZERO_TOLERANCE, double d1_tolerance=ON_ZERO_TOLERANCE, double d2_tolerance=ON_ZERO_TOLERANCE, double cos_angle_tolerance=ON_DEFAULT_ANGLE_TOLERANCE_COSINE, double curvature_tolerance=ON_SQRT_EPSILON) const overrideON_CurveProxyvirtual
IsCorrupt(bool bRepair, bool bSilentError, class ON_TextLog *text_log) constON_Object
IsDeformable() constON_Geometryvirtual
IsEllipse(const ON_Plane *plane=nullptr, ON_Ellipse *ellipse=nullptr, double tolerance=ON_ZERO_TOLERANCE) constON_Curvevirtual
IsHighlighted() constCRhinoPolyEdgeSegment
IsInPlane(const ON_Plane &, double=ON_ZERO_TOLERANCE) const overrideON_CurveProxyvirtual
IsKindOf(const ON_ClassId *pClassId) constON_Object
IsLinear(double=ON_ZERO_TOLERANCE) const overrideON_CurveProxyvirtual
IsMorphable() constON_Geometryvirtual
IsoType() constCRhinoPolyEdgeSegment
IsPeriodic(void) const overrideON_CurveProxyvirtual
IsPlanar(ON_Plane *=nullptr, double=ON_ZERO_TOLERANCE) const overrideON_CurveProxyvirtual
IsPolyline(ON_SimpleArray< ON_3dPoint > *pline_points=nullptr, ON_SimpleArray< double > *pline_t=nullptr) const overrideON_CurveProxyvirtual
IsSelected() constCRhinoPolyEdgeSegment
IsShort(double tolerance, const ON_Interval *sub_domain=0, double *length_estimate=0) const overrideON_CurveProxyvirtual
IsValid(class ON_TextLog *text_log=nullptr) const overrideON_CurveProxyvirtual
LastSpanIsLinear(double min_length, double tolerance) constON_Curve
LastSpanIsLinear(double min_length, double tolerance, ON_Line *span_line) constON_Curve
LengthMassProperties(class ON_MassProperties &mp, bool bLength=true, bool bFirstMoments=true, bool bSecondMoments=true, bool bProductMoments=true, double rel_tol=1.0e-6, double abs_tol=1.0e-6) constON_Curve
MakeDeformable()ON_Geometryvirtual
MarkAggregateComponentStatusAsNotCurrent() constON_Objectvirtual
MemoryRelocate()ON_Objectvirtual
MeshCurve(ON_MeshCurveParameters &mp, ON_PolylineCurve *polyline, bool bSkipFirstPoint, const ON_Interval *domain) constON_Curve
ModelObjectId() constON_Objectvirtual
Morph(const class ON_SpaceMorph &morph)ON_Geometryvirtual
MoveUserData(ON_Object &source_object, ON_UUID source_userdata_item_id, ON_Object::UserDataConflictResolution userdata_conflict_resolution, bool bDeleteAllSourceItems)ON_Object
MoveUserData(ON_Object &source_object)ON_Object
NurbsCurve(ON_NurbsCurve *pNurbsCurve=nullptr, double tolerance=0.0, const ON_Interval *subdomain=nullptr) constON_Curve
ObjectType() const overrideON_Curvevirtual
ON_Curve() ON_NOEXCEPTON_Curve
ON_Curve(const ON_Curve &)ON_Curve
ON_CurveProxy() ON_NOEXCEPTON_CurveProxy
ON_CurveProxy(const ON_CurveProxy &)ON_CurveProxy
ON_CurveProxy(const ON_Curve *)ON_CurveProxy
ON_CurveProxy(const ON_Curve *, ON_Interval)ON_CurveProxy
ON_Geometry()=defaultON_Geometry
ON_Geometry(const ON_Geometry &)=defaultON_Geometry
ON_Object() ON_NOEXCEPTON_Object
ON_Object(const ON_Object &)ON_Object
operator=(const CRhinoPolyEdgeSegment &)CRhinoPolyEdgeSegment
ON_CurveProxy::operator=(const ON_CurveProxy &)ON_CurveProxy
ON_Curve::operator=(const ON_Curve &)ON_Curve
ON_Geometry::operator=(const ON_Geometry &)=defaultON_Geometry
ON_Object::operator=(const ON_Object &)ON_Object
ParameterSearch(double t, int &index, bool bEnableSnap, const ON_SimpleArray< double > &m_t, double RelTol=ON_SQRT_EPSILON) constON_Curveprotected
PointAt(double t) constON_Curve
PointAtEnd() constON_Curve
PointAtStart() constON_Curve
ProxyCurve() constON_CurveProxy
ProxyCurveDomain() constON_CurveProxy
ProxyCurveIsReversed() constON_CurveProxy
PurgeUserData()ON_Object
Read(ON_BinaryArchive &) overrideON_CurveProxyvirtual
RealCurveParameter(double t) constON_CurveProxy
RemoveShortSegments(double tolerance, bool bRemoveShortSegments=true)ON_Curvevirtual
Reverse() overrideON_CurveProxyvirtual
ReversedEdgeDir() constCRhinoPolyEdgeSegment
ReversedTrimDir() constCRhinoPolyEdgeSegment
RhinoObject() constCRhinoPolyEdgeSegment
Rotate(double sin_angle, double cos_angle, const ON_3dVector &rotation_axis, const ON_3dPoint &rotation_center)ON_Geometry
Rotate(double rotation_angle, const ON_3dVector &rotation_axis, const ON_3dPoint &rotation_center)ON_Geometry
Scale(double scale_factor)ON_Geometry
SegmentObjRef(int segment_objref_index) constCRhinoPolyEdgeSegment
SegmentObjRefCount() constCRhinoPolyEdgeSegment
Select(bool bSelect=true, bool bSynchHighlight=true) constCRhinoPolyEdgeSegment
SetComponentStates(ON_COMPONENT_INDEX component_index, ON_ComponentStatus states_to_set) constON_Objectvirtual
SetComponentStatus(ON_COMPONENT_INDEX component_index, ON_ComponentStatus status_to_copy) constON_Objectvirtual
SetDomain(double t0, double t1) overrideON_CurveProxyvirtual
SetDomain(ON_Interval domain)ON_CurveProxy
SetEndPoint(ON_3dPoint end_point)ON_Curvevirtual
SetProxyCurve(const ON_Curve *real_curve)ON_CurveProxy
SetProxyCurve(const ON_Curve *real_curve, ON_Interval real_curve_subdomain)ON_CurveProxy
SetProxyCurveDomain(ON_Interval proxy_curve_subdomain)ON_CurveProxy
SetProxyCurveIsReversed(bool bReversed)ON_CurveProxyprotected
SetStartPoint(ON_3dPoint start_point)ON_Curvevirtual
SetUserString(const wchar_t *key, const wchar_t *string_value)ON_Object
SetUserStrings(int count, const ON_UserString *user_strings, bool bReplace)ON_Object
SignedCurvatureAt(double t, const ON_3dVector *plane_normal=nullptr) constON_Curve
SizeOf() const overrideON_CurveProxyvirtual
SpanCount() const overrideON_CurveProxyvirtual
SpanVector() constON_Curve
Split(double t, ON_Curve *&left_side, ON_Curve *&right_side) const overrideCRhinoPolyEdgeSegmentvirtual
Surface() constCRhinoPolyEdgeSegment
SurfaceParameter(double t) constCRhinoPolyEdgeSegment
SwapCoordinates(int i, int j)ON_Geometryvirtual
TangentAt(double t) constON_Curve
ThisCurveParameter(double real_curve_parameter) constON_CurveProxy
ThisIsNullptr(bool bSilentError) constON_Object
TightBoundingBox() constON_Geometry
Transform(const ON_Xform &) overrideON_CurveProxyvirtual
TransformUserData(const class ON_Xform &xform)ON_Object
Translate(const ON_3dVector &translation_vector)ON_Geometry
Trim() constCRhinoPolyEdgeSegment
Trim(const ON_Interval &domain) overrideCRhinoPolyEdgeSegmentvirtual
TrimDomain() constCRhinoPolyEdgeSegment
TrimParameter(double t) constCRhinoPolyEdgeSegment
UnsetON_Geometrystatic
UpdateReferencedComponents(const class ON_ComponentManifest &source_manifest, const class ON_ComponentManifest &destination_manifest, const class ON_ManifestMap &manifest_map)ON_Objectvirtual
UserDataConflictResolution enum nameON_Object
UserStringCount() constON_Object
Write(ON_BinaryArchive &) const overrideON_CurveProxyvirtual
~CRhinoPolyEdgeSegment()CRhinoPolyEdgeSegment
~ON_Curve()ON_Curvevirtual
~ON_CurveProxy()ON_CurveProxyvirtual
~ON_Geometry()=defaultON_Geometry
~ON_Object()ON_Objectvirtual