Rhino C++ API
8.13
|
#include <RhinoSdkUiOptionsListCtrlItem.h>
Public Member Functions | |
CRhinoUiOptionsListCtrlCheckBox (LPCTSTR lpsLabel=NULL, LPCTSTR lpsButtonCaption=NULL, int iIndentLevel=0) | |
virtual | ~CRhinoUiOptionsListCtrlCheckBox () |
bool | BeginEditItem (CRhinoUiOptionsListCtrl &list_ctrl, const CRect rEdit, begin_edit_item_reason eir) |
bool | CreateTriStateCeckBox () const |
bool | DrawCheckBox () const |
int | GetCheck () const |
LPCTSTR | GetCheckText () const |
void | MoveItemWindow (CRhinoUiOptionsListCtrl &list_ctrl, const CRect rEdit) |
afx_msg void | OnBnClicked () |
afx_msg void | OnDestroy () |
void | OnDrawItem (CDC &dc, const CRect &rItem, const CRect &rDeflate) const |
afx_msg BOOL32 | OnEraseBkgnd (CDC *pDC) |
virtual bool | OnItemButtonClicked () |
afx_msg void | OnKillFocus (CWnd *pNewWnd) |
afx_msg void | OnLButtonDown (UINT nFlags, CPoint point) |
afx_msg void | OnLButtonUp (UINT nFlags, CPoint point) |
afx_msg void | OnMouseMove (UINT nFlags, CPoint point) |
afx_msg BOOL32 | OnMouseWheel (UINT nFlags, short zDelta, CPoint pt) |
afx_msg void | OnPaint () |
int | SetCheck (int bst_state) |
void | SetCheckText (LPCTSTR lps) |
bool | SetCreateTriStateCeckBox (bool b) |
bool | SetDrawCheckBox (bool b) |
void | SetText (LPCTSTR lps) |
Public Member Functions inherited from CRhinoUiOptionsListCtrlItem | |
CRhinoUiOptionsListCtrlItem (const CRhinoUiOptionsListCtrlItem &) | |
CRhinoUiOptionsListCtrlItem (control_type ct=ct_invalid, LPCTSTR lpsLabel=NULL, LPCTSTR lpsText=NULL, int iIndentLevel=0) | |
virtual | ~CRhinoUiOptionsListCtrlItem () |
bool | AutoDelete () const |
control_type | ControlType () const |
void | DrawItemText (CDC &dc, const CString &s, const CRect &rItem, const CRect &rDeflate) const |
bool | GetItemProperty (item_property iprop) const |
bool | GetItemState (item_state istate) const |
CRhinoUiOptionsListCtrl * | GetListCtrl () const |
int | IndentLevel () const |
bool | IsEnabled () const |
bool | IsFullRowItem () const |
bool | IsItemExpandable () const |
bool | IsItemHidden () const |
bool | IsReadOnly () const |
virtual int | ItemHeight () const |
unsigned int | ItemID () const |
LPCTSTR | Label () const |
COLORREF | LabelBackGroundColor () const |
COLORREF | LabelTextColor () const |
const CRhinoUiOptionsListCtrlItem & | operator= (const CRhinoUiOptionsListCtrlItem &) |
int | ParentIndex () const |
bool | SetAutoDelete (bool b) |
int | SetIndentLevel (int iIndentLevel) |
bool | SetIsEnabled (bool b) |
bool | SetIsFullRowItem (bool b) |
bool | SetIsReadOnly (bool b) |
bool | SetItemProperty (item_property iprop, bool bEnabled) |
bool | SetItemState (item_state istate, bool bEnabled) |
bool | SetLabel (LPCTSTR lpsLabel) |
COLORREF | SetLabelBackGroundColor (COLORREF cr) |
COLORREF | SetLabelTextColor (COLORREF cr) |
bool | SetParentIndex (int iItem) |
bool | SetUseLabelColors (bool b) |
virtual LPCTSTR | Text () const |
bool | UseLabelColors () const |
CRhinoUiOptionsListCtrlCheckBox::CRhinoUiOptionsListCtrlCheckBox | ( | LPCTSTR | lpsLabel = NULL , |
LPCTSTR | lpsButtonCaption = NULL , |
||
int | iIndentLevel = 0 |
||
) |
Description:
Parameters:
Returns:
See Also:
|
virtual |
Description:
Parameters:
Returns:
See Also:
|
virtual |
bool CRhinoUiOptionsListCtrlCheckBox::CreateTriStateCeckBox | ( | ) | const |
Description:
Parameters:
Returns:
See Also:
bool CRhinoUiOptionsListCtrlCheckBox::DrawCheckBox | ( | ) | const |
Description:
Parameters:
Returns:
See Also:
int CRhinoUiOptionsListCtrlCheckBox::GetCheck | ( | ) | const |
Description:
Parameters:
Returns:
See Also:
LPCTSTR CRhinoUiOptionsListCtrlCheckBox::GetCheckText | ( | ) | const |
Description:
Parameters:
Returns:
See Also:
|
virtual |
afx_msg void CRhinoUiOptionsListCtrlCheckBox::OnBnClicked | ( | ) |
afx_msg void CRhinoUiOptionsListCtrlCheckBox::OnDestroy | ( | ) |
|
virtual |
afx_msg BOOL32 CRhinoUiOptionsListCtrlCheckBox::OnEraseBkgnd | ( | CDC * | pDC | ) |
|
virtual |
Description:
Parameters:
Returns:
See Also:
afx_msg void CRhinoUiOptionsListCtrlCheckBox::OnKillFocus | ( | CWnd * | pNewWnd | ) |
afx_msg void CRhinoUiOptionsListCtrlCheckBox::OnLButtonDown | ( | UINT | nFlags, |
CPoint | point | ||
) |
afx_msg void CRhinoUiOptionsListCtrlCheckBox::OnLButtonUp | ( | UINT | nFlags, |
CPoint | point | ||
) |
afx_msg void CRhinoUiOptionsListCtrlCheckBox::OnMouseMove | ( | UINT | nFlags, |
CPoint | point | ||
) |
afx_msg BOOL32 CRhinoUiOptionsListCtrlCheckBox::OnMouseWheel | ( | UINT | nFlags, |
short | zDelta, | ||
CPoint | pt | ||
) |
afx_msg void CRhinoUiOptionsListCtrlCheckBox::OnPaint | ( | ) |
int CRhinoUiOptionsListCtrlCheckBox::SetCheck | ( | int | bst_state | ) |
Description:
Parameters:
Returns:
See Also:
BST_UNCHECKED BST_CHECKED BST_INDETERMINATE
void CRhinoUiOptionsListCtrlCheckBox::SetCheckText | ( | LPCTSTR | lps | ) |
Description:
Parameters:
Returns:
See Also:
bool CRhinoUiOptionsListCtrlCheckBox::SetCreateTriStateCeckBox | ( | bool | b | ) |
Description:
Parameters:
Returns:
See Also:
bool CRhinoUiOptionsListCtrlCheckBox::SetDrawCheckBox | ( | bool | b | ) |
Description:
Parameters:
Returns:
See Also:
|
virtual |
Description: This method is used to set text value for this item. This value is displayed in the right column of the options list control.
Parameters: lps [in] New display text for this item.
See Also: CRhinoUiOptionsListCtrl::Text() CRhinoUiOptionsListCtrl::DrawItemText()
Reimplemented from CRhinoUiOptionsListCtrlItem.