Rhino C++ API
8.17
Main Page
Related Pages
Modules
Classes
Class List
Class Index
Class Hierarchy
Class Members
All
_
a
b
c
d
e
f
g
h
i
j
k
l
m
n
o
p
q
r
s
t
u
v
w
x
y
z
~
Functions
_
a
b
c
d
e
f
g
h
i
j
k
l
m
n
o
p
q
r
s
t
u
v
w
x
y
z
~
Variables
_
a
b
c
d
e
f
g
h
i
j
k
l
m
n
o
p
q
r
s
t
u
v
w
x
y
z
Typedefs
Enumerations
a
b
c
d
e
f
g
h
i
k
l
m
n
o
p
q
r
s
t
u
v
w
Enumerator
a
b
c
d
e
f
g
h
i
j
k
l
m
n
o
p
q
r
s
t
u
v
w
x
y
z
Related Functions
c
d
g
i
o
q
r
s
t
•
All
Classes
Namespaces
Functions
Variables
Typedefs
Enumerations
Enumerator
Friends
Modules
Pages
IRhRdkLinearWorkflow Member List
This is the complete list of members for
IRhRdkLinearWorkflow
, including all inherited members.
ApplyPostProcessGamma
(CRhinoDib &dibInOut) const =0
IRhRdkLinearWorkflow
pure virtual
ApplyPreProcessGamma
(CRhRdkColor &col, bool bForTexture) const =0
IRhRdkLinearWorkflow
pure virtual
ApplyPreProcessGamma
(CRhinoDib &dibInOut) const =0
IRhRdkLinearWorkflow
pure virtual
BeginChange
(RhRdkChangeContext cc) const =0
IRhRdkLinearWorkflow
pure virtual
ComputeCRC
(void) const =0
IRhRdkLinearWorkflow
pure virtual
CopyFrom
(const IRhRdkLinearWorkflow &lw)=0
IRhRdkLinearWorkflow
pure virtual
EndChange
(void)=0
IRhRdkLinearWorkflow
pure virtual
EVF
(const wchar_t *wszFunc, void *pvData)=0
IRhRdkLinearWorkflow
pure virtual
IsEqual
(const IRhRdkLinearWorkflow &lw) const =0
IRhRdkLinearWorkflow
pure virtual
New
(void)
IRhRdkLinearWorkflow
static
PostProcessFrameBuffer
(void) const =0
IRhRdkLinearWorkflow
pure virtual
PostProcessFrameBufferOn
(void) const
IRhRdkLinearWorkflow
inline
PostProcessGamma
(void) const =0
IRhRdkLinearWorkflow
pure virtual
PostProcessGammaOn
(void) const
IRhRdkLinearWorkflow
PostProcessGammaReciprocal
(void) const =0
IRhRdkLinearWorkflow
pure virtual
PreProcessColors
(void) const =0
IRhRdkLinearWorkflow
pure virtual
PreProcessColorsOn
(void) const
IRhRdkLinearWorkflow
inline
PreProcessGamma
(void) const =0
IRhRdkLinearWorkflow
pure virtual
PreProcessTextures
(void) const =0
IRhRdkLinearWorkflow
pure virtual
PreProcessTexturesOn
(void) const
IRhRdkLinearWorkflow
inline
SetPostProcessFrameBuffer
(bool b)=0
IRhRdkLinearWorkflow
pure virtual
SetPostProcessFrameBufferOn
(bool b)
IRhRdkLinearWorkflow
inline
SetPostProcessGamma
(float f)=0
IRhRdkLinearWorkflow
pure virtual
SetPostProcessGammaOn
(bool)
IRhRdkLinearWorkflow
SetPreProcessColors
(bool b)=0
IRhRdkLinearWorkflow
pure virtual
SetPreProcessColorsOn
(bool b)
IRhRdkLinearWorkflow
inline
SetPreProcessGamma
(float f)=0
IRhRdkLinearWorkflow
pure virtual
SetPreProcessTextures
(bool b)=0
IRhRdkLinearWorkflow
pure virtual
SetPreProcessTexturesOn
(bool b)
IRhRdkLinearWorkflow
inline
~IRhRdkLinearWorkflow
()
IRhRdkLinearWorkflow
inline
virtual
Generated on Wed Mar 12 2025 13:56:15 for Rhino C++ API by
1.8.17