Rhino C++ API  8.6
Public Member Functions | List of all members
IRhRdkRenderWindow::IGPUChannel Class Referenceabstract

#include <IRhRdkRenderWindow.h>

Public Member Functions

virtual ~IGPUChannel ()
 
virtual IGPUChannelClone (void) const =0
 
virtual void Close (void)=0
 
virtual void CopyTo (IChannelEx &chan) const =0
 
virtual CRhinoDisplayPipeline::DisplayTechnologies DisplayTechnology (void) const =0
 
virtual void * EVF (const wchar_t *, void *)=0
 
virtual int Height (void) const =0
 
virtual UUID Id (void) const =0
 
virtual unsigned int PixelSize (void) const =0
 
virtual ON_DEPRECATED unsigned int TextureHandle (void) const =0
 
virtual int Width (void) const =0
 

Constructor & Destructor Documentation

◆ ~IGPUChannel()

virtual IRhRdkRenderWindow::IGPUChannel::~IGPUChannel ( )
inlinevirtual

Member Function Documentation

◆ Clone()

virtual IGPUChannel* IRhRdkRenderWindow::IGPUChannel::Clone ( void  ) const
pure virtual
Returns
a clone of the channel.

◆ Close()

virtual void IRhRdkRenderWindow::IGPUChannel::Close ( void  )
pure virtual

Close the channel. Implemented as

delete this;

◆ CopyTo()

virtual void IRhRdkRenderWindow::IGPUChannel::CopyTo ( IChannelEx chan) const
pure virtual

Copy the channel to a 'CPU' channel.

◆ DisplayTechnology()

virtual CRhinoDisplayPipeline::DisplayTechnologies IRhRdkRenderWindow::IGPUChannel::DisplayTechnology ( void  ) const
pure virtual
Returns
the type of API used for this channel's texture handle.

◆ EVF()

virtual void* IRhRdkRenderWindow::IGPUChannel::EVF ( const wchar_t *  ,
void *   
)
pure virtual

Emergency virtual function for future expansion.

◆ Height()

virtual int IRhRdkRenderWindow::IGPUChannel::Height ( void  ) const
pure virtual
Returns
the channel height.

◆ Id()

virtual UUID IRhRdkRenderWindow::IGPUChannel::Id ( void  ) const
pure virtual
Returns
the channel id.

◆ PixelSize()

virtual unsigned int IRhRdkRenderWindow::IGPUChannel::PixelSize ( void  ) const
pure virtual
Returns
The size of one pixel's data in the channel.

◆ TextureHandle()

virtual ON_DEPRECATED unsigned int IRhRdkRenderWindow::IGPUChannel::TextureHandle ( void  ) const
pure virtual

This method has been deprecated. In order to access the texture handle, dynamic cast your object to IOpenGLChannel or IMetalChannel and use their respective methods. Use this class' DisplayTechnology() method to know which class to cast to.

◆ Width()

virtual int IRhRdkRenderWindow::IGPUChannel::Width ( void  ) const
pure virtual
Returns
the channel width.