#include <IRhRdkRenderWindow.h>
|
virtual | ~IChannelEx () |
|
virtual IChannelEx * | Clone (void) const =0 |
|
virtual bool | GetMinMaxValues (OUT float &fMin, OUT float &fMax) const =0 |
|
virtual bool | GetValueEx (int x, int y, ComponentOrder co, OUT void *pData) const =0 |
|
virtual bool | GetValueRect (int x, int y, int width, int height, int stride, ComponentOrder co, OUT void *pData) const =0 |
|
virtual int | Height (void) const =0 |
|
virtual UUID | Id (void) const =0 |
|
virtual int | Width (void) const =0 |
|
virtual | ~IChannel () |
|
virtual void | Close (void)=0 |
|
virtual void * | EVF (const wchar_t *, void *)=0 |
|
virtual const void * | GetValue (int x, int y) const =0 |
|
virtual UINT | PixelSize (void) const =0 |
|
virtual void | SetValue (int x, int y, ComponentOrder co, const void *pData)=0 |
|
virtual bool | SetValueRect (int x, int y, int width, int height, int stride, ComponentOrder co, const void *pData)=0 |
|
virtual bool | SetValueRect (int x, int y, int width, int height, int stride, ComponentOrder co, const void *pData, bool bUseOffset)=0 |
|
◆ ~IChannelEx()
virtual IRhRdkRenderWindow::IChannelEx::~IChannelEx |
( |
| ) |
|
|
inlinevirtual |
◆ Clone()
virtual IChannelEx* IRhRdkRenderWindow::IChannelEx::Clone |
( |
void |
| ) |
const |
|
pure virtual |
Makes a clone of the channel.
◆ GetMinMaxValues()
virtual bool IRhRdkRenderWindow::IChannelEx::GetMinMaxValues |
( |
OUT float & |
fMin, |
|
|
OUT float & |
fMax |
|
) |
| const |
|
pure virtual |
Get the minimum and maximum values in the channel
◆ GetValueEx()
virtual bool IRhRdkRenderWindow::IChannelEx::GetValueEx |
( |
int |
x, |
|
|
int |
y, |
|
|
ComponentOrder |
co, |
|
|
OUT void * |
pData |
|
) |
| const |
|
pure virtual |
Get value(s) from the channel.
- Parameters
-
x | is the horizontal pixel position. No validation is done on this value. The caller is responsible for ensuring that it is within the frame buffer. |
y | is the vertical pixel position. No validation is done on this value. The caller is responsible for ensuring that it is within the frame buffer. |
co | is the component order of the destination data. |
pData | accepts the data from the channel at the specified position and it must have enough room to accomodate the correct amount of data in the correct layout to match the pixel size. NOTE: RDK standard channels contain float data; the size of each pixel is always sizeof(float). For the special chanRGBA composite channel, the size of a pixel is 4 * sizeof(float). |
- Returns
- true if successful, else false.
◆ GetValueRect()
virtual bool IRhRdkRenderWindow::IChannelEx::GetValueRect |
( |
int |
x, |
|
|
int |
y, |
|
|
int |
width, |
|
|
int |
height, |
|
|
int |
stride, |
|
|
ComponentOrder |
co, |
|
|
OUT void * |
pData |
|
) |
| const |
|
pure virtual |
Get a rectangle of values from the channel. The input parameters are checked for validity. If the rectangle is not fully inside the frame buffer, the function will fail.
- Parameters
-
x | is the horizontal pixel position of the left edge. |
y | is the vertical pixel position of the top edge. |
width | is the width of the rectangle in pixels. |
height | is the height of the rectangle in pixels. |
stride | is the number of bytes between pixel rows in the destination buffer. |
co | is the component order of the destination data. |
pData | accepts the data from the channel starting at the specified position and it must have enough room to accomodate the correct amount of data in the correct layout to match the pixel size, the shape of the rectangle and the stride. NOTE: RDK standard channels contain float data; the size of each pixel is always sizeof(float). For the special chanRGBA composite channel, the size of a pixel is 4 * sizeof(float). |
- Returns
- true if successful, else false.
◆ Height()
virtual int IRhRdkRenderWindow::IChannelEx::Height |
( |
void |
| ) |
const |
|
pure virtual |
- Returns
- the channel height.
◆ Id()
virtual UUID IRhRdkRenderWindow::IChannelEx::Id |
( |
void |
| ) |
const |
|
pure virtual |
◆ Width()
virtual int IRhRdkRenderWindow::IChannelEx::Width |
( |
void |
| ) |
const |
|
pure virtual |
- Returns
- the channel width.