Rhino C++ API
8.13
|
#include <opennurbs_archive.h>
Static Public Attributes | |
static const ON_3dmAnnotationContext | Default |
Description: Context for an annotation object. This context is required when converting current annotation objects to and from formats used in earlier versions and is typically used when reading and writing 3dm archives.
|
default |
ON_3dmAnnotationContext::~ON_3dmAnnotationContext | ( | ) |
ON_3dmAnnotationContext::ON_3dmAnnotationContext | ( | const ON_3dmAnnotationContext & | ) |
const class ON_3dmAnnotationSettings& ON_3dmAnnotationContext::AnnotationSettings | ( | ) | const |
bool ON_3dmAnnotationContext::AnnotationSettingsAreSet | ( | ) | const |
Returns: True if the annotation settings have been explicitly set.
const class ON_BinaryArchive* ON_3dmAnnotationContext::BinaryArchive | ( | ) | const |
bool ON_3dmAnnotationContext::BinaryArchiveIsSet | ( | ) | const |
Returns: True if the the target binary archive is set.
const class ON_DimStyle& ON_3dmAnnotationContext::DimStyle | ( | ) | const |
This is the dimstyle the annotation object is question is using. It can be a "base" dimstyle from the dimstyle table or an "override" style attached used by a single instance of an annnotation object.
bool ON_3dmAnnotationContext::DimStyleIsSet | ( | ) | const |
Returns: True if the dimension style has been explicitly set.
bool ON_3dmAnnotationContext::IsOverrideDimStyle | ( | ) | const |
Parameters: bRequireSetOverrides - [in] true if explicit overrides are required. Returns: true if the context dim style is an override style (parent id is not nil) and it has overrides or bRequireSetOverrides is false.
ON::LengthUnitSystem ON_3dmAnnotationContext::ModelLengthUnitSystem | ( | ) | const |
ON_3dmAnnotationContext& ON_3dmAnnotationContext::operator= | ( | const ON_3dmAnnotationContext & | ) |
ON::LengthUnitSystem ON_3dmAnnotationContext::PageLengthUnitSystem | ( | ) | const |
const class ON_DimStyle& ON_3dmAnnotationContext::ParentDimStyle | ( | ) | const |
ON_UUID ON_3dmAnnotationContext::ParentDimStyleId | ( | ) | const |
Returns: If the dimstyle is not set or it has a nil parent id, then DimStyleId() is returned. Otherwise the parent id is returned.
void ON_3dmAnnotationContext::SetManagedAnnotationSettings | ( | const class ON_3dmAnnotationSettings & | annotation_settings | ) |
Parameters: annotation_settings - [in] A copy of annotation_settings is stored and manged by the ON_3dmAnnotationContext class instance.
void ON_3dmAnnotationContext::SetManagedDimStyle | ( | const class ON_DimStyle & | parent_dim_style, |
const class ON_DimStyle * | override_dim_style, | ||
int | V5_3dm_archive_index | ||
) |
Parameters: dim_style - [in] A copy of a dim_style is stored and manged by the ON_3dmAnnotationContext class instance.
void ON_3dmAnnotationContext::SetModelLengthUnitSystem | ( | ON::LengthUnitSystem | model_length_unit_system | ) |
void ON_3dmAnnotationContext::SetPageLengthUnitSystem | ( | ON::LengthUnitSystem | page_length_unit_system | ) |
void ON_3dmAnnotationContext::SetReferencedAnnotationSettings | ( | const class ON_3dmAnnotationSettings * | annotation_settings | ) |
Parameters: annotation_settings - [in] Annotation settings that are externally managed and will exist during the lifetime of the ON_3dmAnnotationContext class instance.
void ON_3dmAnnotationContext::SetReferencedBinaryArchive | ( | const class ON_BinaryArchive * | binary_archive | ) |
Parameters: binary_archive - [in] Binary archive that is externally managed and will exist during the lifetime of the ON_3dmAnnotationContext class instance.
void ON_3dmAnnotationContext::SetReferencedDimStyle | ( | const class ON_DimStyle * | parent_dim_style, |
const class ON_DimStyle * | override_dim_style, | ||
int | V5_3dm_archive_index | ||
) |
Parameters: dim_style - [in] A dimension style that is externally managed and will exist during the lifetime of the ON_3dmAnnotationContext class instance.
void ON_3dmAnnotationContext::SetViewContext | ( | ON::active_space | ) |
void ON_3dmAnnotationContext::UpdateReferencedDimStyle | ( | const class ON_DimStyle * | old_pointer, |
const class ON_DimStyle * | new_pointer | ||
) |
int ON_3dmAnnotationContext::V5_ArchiveDimStyleIndex | ( | ) | const |
Returns: 3dm archive dimension style table index to use when writing a V5 3dm archive. This is often different from DimStyle().Index().
ON::active_space ON_3dmAnnotationContext::ViewContext | ( | ) | const |
|
static |