Rhino C++ API  8.6
Public Member Functions | List of all members
ON_3fVectorArray Class Reference

#include <opennurbs_point.h>

Inheritance diagram for ON_3fVectorArray:
ON_SimpleArray< ON_3fVector >

Public Member Functions

 ON_3fVectorArray ()
 
 ON_3fVectorArray (const ON_3fVectorArray &)
 
 ON_3fVectorArray (int)
 
bool GetBBox (float boxmin[3], float boxmax[3], bool bGrowBox=false) const
 
ON_3fVectorArrayoperator= (const ON_3fVectorArray &)
 
bool SwapCoordinates (int, int)
 
bool Transform (const ON_Xform &)
 
- Public Member Functions inherited from ON_SimpleArray< ON_3fVector >
 ON_SimpleArray () ON_NOEXCEPT
 construction //////////////////////////////////////////////////////// More...
 
 ON_SimpleArray (const ON_SimpleArray< ON_3fVector > &)
 Copy constructor. More...
 
 ON_SimpleArray (size_t)
 size_t parameter = initial capacity More...
 
virtual ~ON_SimpleArray ()
 
void Append (const ON_3fVector &)
 
void Append (int, const ON_3fVector *)
 Append copy of an array T[count]. More...
 
ON_3fVectorAppendNew ()
 array operations //////////////////////////////////////////////////// More...
 
ON_3fVectorArray ()
 The Array() function return the. More...
 
const ON_3fVectorArray () const
 m_a pointer value. More...
 
ON_3fVectorAt (int)
 At(index) returns nullptr if index < 0 or index >= count. More...
 
const ON_3fVectorAt (int) const
 
ON_3fVectorAt (ON__INT64)
 
const ON_3fVectorAt (ON__INT64) const
 
ON_3fVectorAt (ON__UINT64)
 
const ON_3fVectorAt (ON__UINT64) const
 
ON_3fVectorAt (unsigned int)
 
const ON_3fVectorAt (unsigned int) const
 
int BinarySearch (const ON_3fVector *, int(*)(const ON_3fVector *, const ON_3fVector *)) const
 See Also: ON_CompareIncreasing<T> and ON_CompareDeccreasing<T> More...
 
int BinarySearch (const ON_3fVector *, int(*)(const ON_3fVector *, const ON_3fVector *), int) const
 
const ON_3fVectorBinarySearchPtr (const ON_3fVector *, int(*)(const ON_3fVector *, const ON_3fVector *)) const
 
const ON_3fVectorBinarySearchPtr (const ON_3fVector *, int(*)(const ON_3fVector *, const ON_3fVector *), int) const
 
int Capacity () const
 capacity of array More...
 
int Count () const
 query /////////////////////////////////////////////////////////////// More...
 
ON__UINT32 DataCRC (ON__UINT32 current_remainder) const
 
void Destroy ()
 onfree any memory and set count and capacity to zero More...
 
void EmergencyDestroy (void)
 emergency bailout /////////////////////////////////////////////////// More...
 
void Empty ()
 Sets count to 0, leaves capacity untouched. More...
 
ON_3fVectorFirst ()
 
const ON_3fVectorFirst () const
 returns nullptr if count = 0 More...
 
bool HeapSort (int(*)(const ON_3fVector *, const ON_3fVector *))
 
void Insert (int, const ON_3fVector &)
 
int InsertInSortedList (const ON_3fVector &, int(*)(const ON_3fVector *, const ON_3fVector *))
 
int InsertInSortedList (const ON_3fVector &, int(*)(const ON_3fVector *, const ON_3fVector *), int)
 
ON_3fVectorKeepArray ()
 
ON_3fVectorLast ()
 
const ON_3fVectorLast () const
 returns nullptr if count = 0 More...
 
void MemSet (unsigned char)
 
int NewCapacity () const
 
 operator const ON_3fVector * () const
 
 operator ON_3fVector * ()
 The cast operators return a pointer. More...
 
ON_SimpleArray< ON_3fVector > & operator= (const ON_SimpleArray< ON_3fVector > &)
 
ON_3fVectoroperator[] (int)
 
const ON_3fVectoroperator[] (int) const
 
ON_3fVectoroperator[] (ON__INT64)
 
const ON_3fVectoroperator[] (ON__INT64) const
 
ON_3fVectoroperator[] (ON__UINT64)
 
const ON_3fVectoroperator[] (ON__UINT64) const
 
ON_3fVectoroperator[] (unsigned int)
 
const ON_3fVectoroperator[] (unsigned int) const
 
bool Permute (const int *)
 
void Prepend (int, const ON_3fVector *)
 Prepend copy of an array T[count]. More...
 
bool QuickSort (int(*)(const ON_3fVector *, const ON_3fVector *))
 See Also: ON_CompareIncreasing<T> and ON_CompareDeccreasing<T> More...
 
bool QuickSortAndRemoveDuplicates (int(*)(const ON_3fVector *, const ON_3fVector *))
 See Also: ON_CompareIncreasing<T> and ON_CompareDeccreasing<T> More...
 
virtual ON_3fVectorRealloc (ON_3fVector *, int)
 low level memory management ////////////////////////////////////////// More...
 
void Remove ()
 
virtual void Remove (int)
 
void RemoveIf (bool predicate(const ON_3fVector &key))
 
void RemoveValue (const ON_3fVector &)
 
ON_3fVectorReserve (size_t)
 memory management //////////////////////////////////////////////////// More...
 
void Reverse ()
 reverse order More...
 
int Search (const ON_3fVector &) const
 
int Search (const ON_3fVector *, int(*)(const ON_3fVector *, const ON_3fVector *)) const
 See Also: ON_CompareIncreasing<T> and ON_CompareDeccreasing<T> More...
 
void SetArray (ON_3fVector *)
 
void SetArray (ON_3fVector *, int, int)
 
ON_3fVectorSetCapacity (size_t)
 
void SetCount (int)
 low level memory management ////////////////////////////////////////// More...
 
void SetRange (int from, int count, ON_3fVector)
 
void Shrink ()
 remove unused capacity More...
 
unsigned int SizeOfArray () const
 amount of memory in the m_a[] array More...
 
unsigned int SizeOfElement () const
 amount of memory in an m_a[] array element More...
 
bool Sort (ON::sort_algorithm sort_algorithm, int *, int(*)(const ON_3fVector *, const ON_3fVector *)) const
 
bool Sort (ON::sort_algorithm sort_algorithm, int *, int(*)(const ON_3fVector *, const ON_3fVector *, void *), void *) const
 
void Swap (int, int)
 swap elements i and j More...
 
unsigned int UnsignedCount () const
 
void Zero ()
 

Additional Inherited Members

- Protected Member Functions inherited from ON_SimpleArray< ON_3fVector >
void Move (int, int, int)
 implementation ////////////////////////////////////////////////////// More...
 
- Protected Attributes inherited from ON_SimpleArray< ON_3fVector >
ON_3fVectorm_a
 pointer to array memory More...
 
int m_capacity
 actual length of m_a[] More...
 
int m_count
 0 <= m_count <= m_capacity More...
 

Constructor & Destructor Documentation

◆ ON_3fVectorArray() [1/3]

ON_3fVectorArray::ON_3fVectorArray ( )

◆ ON_3fVectorArray() [2/3]

ON_3fVectorArray::ON_3fVectorArray ( int  )

◆ ON_3fVectorArray() [3/3]

ON_3fVectorArray::ON_3fVectorArray ( const ON_3fVectorArray )

Member Function Documentation

◆ GetBBox()

bool ON_3fVectorArray::GetBBox ( float  boxmin[3],
float  boxmax[3],
bool  bGrowBox = false 
) const

◆ operator=()

ON_3fVectorArray& ON_3fVectorArray::operator= ( const ON_3fVectorArray )

◆ SwapCoordinates()

bool ON_3fVectorArray::SwapCoordinates ( int  ,
int   
)

◆ Transform()

bool ON_3fVectorArray::Transform ( const ON_Xform )