Rhino C++ API
8.18
Main Page
Related Pages
Modules
Classes
Class List
Class Index
Class Hierarchy
Class Members
All
_
a
b
c
d
e
f
g
h
i
j
k
l
m
n
o
p
q
r
s
t
u
v
w
x
y
z
~
Functions
_
a
b
c
d
e
f
g
h
i
j
k
l
m
n
o
p
q
r
s
t
u
v
w
x
y
z
~
Variables
_
a
b
c
d
e
f
g
h
i
j
k
l
m
n
o
p
q
r
s
t
u
v
w
x
y
z
Typedefs
Enumerations
a
b
c
d
e
f
g
h
i
k
l
m
n
o
p
q
r
s
t
u
v
w
Enumerator
a
b
c
d
e
f
g
h
i
j
k
l
m
n
o
p
q
r
s
t
u
v
w
x
y
z
Related Functions
c
d
g
i
o
q
r
s
t
•
All
Classes
Namespaces
Functions
Variables
Typedefs
Enumerations
Enumerator
Friends
Modules
Pages
ON_GroundPlane Member List
This is the complete list of members for
ON_GroundPlane
, including all inherited members.
Altitude
(void) const
ON_GroundPlane
virtual
AutoAltitude
(void) const
ON_GroundPlane
virtual
Enabled
(void) const
ON_GroundPlane
virtual
EVF
(const wchar_t *func, void *data)
ON_GroundPlane
virtual
MaterialInstanceId
(void) const
ON_GroundPlane
virtual
ON_3dmRenderSettingsPrivate
class
ON_GroundPlane
friend
ON_GroundPlane
()
ON_GroundPlane
ON_GroundPlane
(ON_XMLNode &model_node)
ON_GroundPlane
ON_GroundPlane
(const ON_GroundPlane &gp)
ON_GroundPlane
OnInternalXmlChanged
(const ON_GroundPlane *)
ON_GroundPlane
virtual
operator!=
(const ON_GroundPlane &gp) const
ON_GroundPlane
virtual
operator=
(const ON_GroundPlane &gp)
ON_GroundPlane
virtual
operator==
(const ON_GroundPlane &gp) const
ON_GroundPlane
virtual
PopulateMaterial
(ON_Material &mat) const
ON_GroundPlane
virtual
SetAltitude
(double altitude)
ON_GroundPlane
virtual
SetAutoAltitude
(bool on)
ON_GroundPlane
virtual
SetEnabled
(bool on)
ON_GroundPlane
virtual
SetMaterialInstanceId
(const ON_UUID &uuid)
ON_GroundPlane
virtual
SetShadowOnly
(bool on)
ON_GroundPlane
virtual
SetShowUnderside
(bool on)
ON_GroundPlane
virtual
SetTextureOffset
(const ON_2dVector &vec)
ON_GroundPlane
virtual
SetTextureOffsetLocked
(bool locked)
ON_GroundPlane
virtual
SetTextureRotation
(double angle)
ON_GroundPlane
virtual
SetTextureSize
(const ON_2dVector &vec)
ON_GroundPlane
virtual
SetTextureSizeLocked
(bool locked)
ON_GroundPlane
virtual
ShadowOnly
(void) const
ON_GroundPlane
virtual
ShowUnderside
(void) const
ON_GroundPlane
virtual
TextureOffset
(void) const
ON_GroundPlane
virtual
TextureOffsetLocked
(void) const
ON_GroundPlane
virtual
TextureRotation
(void) const
ON_GroundPlane
virtual
TextureSize
(void) const
ON_GroundPlane
virtual
TextureSizeLocked
(void) const
ON_GroundPlane
virtual
~ON_GroundPlane
()
ON_GroundPlane
virtual
Generated on Tue Apr 8 2025 16:24:09 for Rhino C++ API by
1.8.17