Rhino C++ API
8.13
|
Surface/ImplicitFunction Intersection event. More...
#include <opennurbs_plus_implicitfn.h>
Public Types | |
enum | Type : int { Type::Unknown = 0, Type::NoEvent = 1, Type::Point = 2, Type::Curve = 3, Type::Surface = 4 } |
Public Member Functions | |
ON_SIXEvent () | |
Public Attributes | |
ON_CurvePair | m_curves |
ON_Surface * | m_surface |
Type | m_type |
ON_2dPoint | m_uv |
Surface/ImplicitFunction Intersection event.
|
strong |
|
inline |
ON_CurvePair ON_SIXEvent::m_curves |
ON_Surface* ON_SIXEvent::m_surface |
Type ON_SIXEvent::m_type |
ON_2dPoint ON_SIXEvent::m_uv |