Rhino C++ API
8.13
|
#include <opennurbs_plus_mesh_intersection.h>
Public Member Functions | |
ON_XMeshEventIterator (bool bMultiThread=false) | |
ON_XMeshEventIterator (const ON_XMeshEventIterator &src) | |
ON_XMeshEventIterator (const ON_XMeshEventPool &Pool, bool bMultiThread=false) | |
~ON_XMeshEventIterator () | |
int | Count () const |
Active count of the pool. More... | |
void | Create (const ON_XMeshEventPool &Pool, bool bMultiThread=false) |
ON_XMeshEvent * | Current () |
ON_XMeshEvent * | First () |
ON_XMeshEvent * | Next () |
ON_XMeshEventIterator & | operator= (const ON_XMeshEventIterator &src) |
void | Reset () |
To be used on the same pool with same mesh. More... | |
ON_XMeshEventIterator::ON_XMeshEventIterator | ( | bool | bMultiThread = false | ) |
ON_XMeshEventIterator::ON_XMeshEventIterator | ( | const ON_XMeshEventPool & | Pool, |
bool | bMultiThread = false |
||
) |
ON_XMeshEventIterator::ON_XMeshEventIterator | ( | const ON_XMeshEventIterator & | src | ) |
ON_XMeshEventIterator::~ON_XMeshEventIterator | ( | ) |
int ON_XMeshEventIterator::Count | ( | ) | const |
Active count of the pool.
void ON_XMeshEventIterator::Create | ( | const ON_XMeshEventPool & | Pool, |
bool | bMultiThread = false |
||
) |
ON_XMeshEvent* ON_XMeshEventIterator::Current | ( | ) |
ON_XMeshEvent* ON_XMeshEventIterator::First | ( | ) |
ON_XMeshEvent* ON_XMeshEventIterator::Next | ( | ) |
ON_XMeshEventIterator& ON_XMeshEventIterator::operator= | ( | const ON_XMeshEventIterator & | src | ) |
void ON_XMeshEventIterator::Reset | ( | ) |
To be used on the same pool with same mesh.