Rhino C++ API  8.6
Public Member Functions | Friends | List of all members
ON_XMeshEventPool Class Reference

#include <opennurbs_plus_mesh_intersection.h>

Public Member Functions

 ON_XMeshEventPool (bool bMultiThread=false)
 
 ~ON_XMeshEventPool ()
 
size_t ActiveCount () const
 
ON_XMeshEventNewEvent ()
 
void ReturnAll ()
 
bool ReturnEvent (ON_XMeshEvent *&pX)
 pX comes back 0. False if status is not active More...
 

Friends

class ON_XMeshEventIterator
 

Constructor & Destructor Documentation

◆ ON_XMeshEventPool()

ON_XMeshEventPool::ON_XMeshEventPool ( bool  bMultiThread = false)

◆ ~ON_XMeshEventPool()

ON_XMeshEventPool::~ON_XMeshEventPool ( )

Member Function Documentation

◆ ActiveCount()

size_t ON_XMeshEventPool::ActiveCount ( ) const

◆ NewEvent()

ON_XMeshEvent* ON_XMeshEventPool::NewEvent ( )

◆ ReturnAll()

void ON_XMeshEventPool::ReturnAll ( )

◆ ReturnEvent()

bool ON_XMeshEventPool::ReturnEvent ( ON_XMeshEvent *&  pX)

pX comes back 0. False if status is not active

Friends And Related Function Documentation

◆ ON_XMeshEventIterator

friend class ON_XMeshEventIterator
friend