#include <opennurbs_plus_mesh_intersection.h>
◆ ON_XMeshFaceIterator() [1/3]
ON_XMeshFaceIterator::ON_XMeshFaceIterator |
( |
bool |
bMultiThread = false | ) |
|
◆ ON_XMeshFaceIterator() [2/3]
ON_XMeshFaceIterator::ON_XMeshFaceIterator |
( |
const ON_XMeshFacePool & |
Pool, |
|
|
bool |
bCheckX, |
|
|
ON_XMesh * |
pM, |
|
|
bool |
bMultiThread = false |
|
) |
| |
◆ ON_XMeshFaceIterator() [3/3]
◆ ~ON_XMeshFaceIterator()
ON_XMeshFaceIterator::~ON_XMeshFaceIterator |
( |
| ) |
|
◆ Count()
int ON_XMeshFaceIterator::Count |
( |
| ) |
const |
Active count of the pool. If m_pM == 0 or m_bCheckX is false, this may be more
◆ Create()
void ON_XMeshFaceIterator::Create |
( |
const ON_XMeshFacePool & |
Pool, |
|
|
bool |
bCheckX, |
|
|
ON_XMesh * |
pM, |
|
|
bool |
bMultiThread = false |
|
) |
| |
◆ Current()
than the number of faces from this mesh that are active, but it does give a bound on the iteration.
◆ First()
◆ Next()
◆ operator=()
◆ Reset()
void ON_XMeshFaceIterator::Reset |
( |
| ) |
|
To be used on the same pool with same mesh.