Rhino C++ API
8.13
|
#include <opennurbs_plus_mesh_intersection.h>
Public Member Functions | |
ON_XMeshFacePool (bool bMultiThread=false) | |
~ON_XMeshFacePool () | |
size_t | ActiveCount () const |
ON_XMeshFace * | NewFace (ON_XMeshVertex *pV0, ON_XMeshVertex *pV1, ON_XMeshVertex *pV2, ON_XMeshEdge *pE0, bool bRev0, ON_XMeshEdge *pE1, bool bRev1, ON_XMeshEdge *pE2, bool bRev2, const ON_XMesh *pM) |
void | ReturnAll () |
bool | ReturnFace (ON_XMeshFace *&pF) |
pF comes back 0. False if status is not active More... | |
Friends | |
class | ON_XMeshFaceIterator |
ON_XMeshFacePool::ON_XMeshFacePool | ( | bool | bMultiThread = false | ) |
ON_XMeshFacePool::~ON_XMeshFacePool | ( | ) |
size_t ON_XMeshFacePool::ActiveCount | ( | ) | const |
ON_XMeshFace* ON_XMeshFacePool::NewFace | ( | ON_XMeshVertex * | pV0, |
ON_XMeshVertex * | pV1, | ||
ON_XMeshVertex * | pV2, | ||
ON_XMeshEdge * | pE0, | ||
bool | bRev0, | ||
ON_XMeshEdge * | pE1, | ||
bool | bRev1, | ||
ON_XMeshEdge * | pE2, | ||
bool | bRev2, | ||
const ON_XMesh * | pM | ||
) |
void ON_XMeshFacePool::ReturnAll | ( | ) |
bool ON_XMeshFacePool::ReturnFace | ( | ON_XMeshFace *& | pF | ) |
pF comes back 0. False if status is not active
|
friend |