Rhino C++ API
8.14
|
#include <opennurbs_plus_mesh_intersection.h>
Public Member Functions | |
ON_XMeshVertexIterator (bool bMultiThread=false) | |
ON_XMeshVertexIterator (const ON_XMeshVertexIterator &src) | |
ON_XMeshVertexIterator (const ON_XMeshVertexPool &Pool, bool bCheckX, ON_XMesh *pM, bool bMultiThread=false) | |
~ON_XMeshVertexIterator () | |
int | Count () const |
void | Create (const ON_XMeshVertexPool &Pool, bool bCheckX, ON_XMesh *pM, bool bMultiThread=false) |
ON_XMeshVertex * | Current () |
ON_XMeshVertex * | First () |
ON_XMeshVertex * | Next () |
ON_XMeshVertexIterator & | operator= (const ON_XMeshVertexIterator &src) |
void | Reset () |
To be used on the same pool with same mesh. More... | |
Friends | |
class | ON_XMesh |
In the three mesh component iterators, if the mesh is non-NULL, then only elements from that mesh will be considered.
ON_XMeshVertexIterator::ON_XMeshVertexIterator | ( | bool | bMultiThread = false | ) |
ON_XMeshVertexIterator::ON_XMeshVertexIterator | ( | const ON_XMeshVertexPool & | Pool, |
bool | bCheckX, | ||
ON_XMesh * | pM, | ||
bool | bMultiThread = false |
||
) |
ON_XMeshVertexIterator::ON_XMeshVertexIterator | ( | const ON_XMeshVertexIterator & | src | ) |
ON_XMeshVertexIterator::~ON_XMeshVertexIterator | ( | ) |
int ON_XMeshVertexIterator::Count | ( | ) | const |
Active count of the pool. If m_pM == 0 or m_bCheckX is false, this may be more
void ON_XMeshVertexIterator::Create | ( | const ON_XMeshVertexPool & | Pool, |
bool | bCheckX, | ||
ON_XMesh * | pM, | ||
bool | bMultiThread = false |
||
) |
ON_XMeshVertex* ON_XMeshVertexIterator::Current | ( | ) |
than the number of vertices from this mesh that are active, but it does give a bound on the iteration.
ON_XMeshVertex* ON_XMeshVertexIterator::First | ( | ) |
ON_XMeshVertex* ON_XMeshVertexIterator::Next | ( | ) |
ON_XMeshVertexIterator& ON_XMeshVertexIterator::operator= | ( | const ON_XMeshVertexIterator & | src | ) |
void ON_XMeshVertexIterator::Reset | ( | ) |
To be used on the same pool with same mesh.
|
friend |
Only use this if Return has not been used on the pool. It is specifically for use while creating an ON_XMesh from an ON_MeshTopology.