Rhino C++ API
8.13
|
#include <opennurbs_plus_mesh_intersection.h>
Public Member Functions | |
ON_XMeshVertexPool (bool bMultiThread=false) | |
~ON_XMeshVertexPool () | |
size_t | ActiveCount () const |
ON_XMeshVertex * | NewVertex (const ON_3dPoint &P, const ON_XMesh *pM) |
void | ReturnAll () |
bool | ReturnVertex (ON_XMeshVertex *&pV) |
pV comes back 0. False if status is not active More... | |
Friends | |
class | ON_XMeshVertexIterator |
ON_XMeshVertexPool::ON_XMeshVertexPool | ( | bool | bMultiThread = false | ) |
ON_XMeshVertexPool::~ON_XMeshVertexPool | ( | ) |
size_t ON_XMeshVertexPool::ActiveCount | ( | ) | const |
ON_XMeshVertex* ON_XMeshVertexPool::NewVertex | ( | const ON_3dPoint & | P, |
const ON_XMesh * | pM | ||
) |
void ON_XMeshVertexPool::ReturnAll | ( | ) |
bool ON_XMeshVertexPool::ReturnVertex | ( | ON_XMeshVertex *& | pV | ) |
pV comes back 0. False if status is not active
|
friend |