Rhino C++ API  8.6
Classes | Static Public Member Functions | List of all members
RtfComposer Class Reference

#include <opennurbs_textiterator.h>

Classes

class  RunInfo
 

Static Public Member Functions

static bool Compose (const ON_TextContent *text, ON_wString &rtf, bool bForceRtf)
 
static const ON_wString ComposeAppleRTF (const ON_TextContent *text)
 
static bool ComposeFS ()
 
static bool RecomposeRTF ()
 
static void SetComposeFS (bool b)
 
static void SetRecomposeRTF (bool b)
 
static void SetTextEditorFontSize (unsigned int size)
 
static int TextEditorFontSize ()
 

Member Function Documentation

◆ Compose()

static bool RtfComposer::Compose ( const ON_TextContent text,
ON_wString rtf,
bool  bForceRtf 
)
static

◆ ComposeAppleRTF()

static const ON_wString RtfComposer::ComposeAppleRTF ( const ON_TextContent text)
static

◆ ComposeFS()

static bool RtfComposer::ComposeFS ( )
static

◆ RecomposeRTF()

static bool RtfComposer::RecomposeRTF ( )
static

◆ SetComposeFS()

static void RtfComposer::SetComposeFS ( bool  b)
static

◆ SetRecomposeRTF()

static void RtfComposer::SetRecomposeRTF ( bool  b)
static

◆ SetTextEditorFontSize()

static void RtfComposer::SetTextEditorFontSize ( unsigned int  size)
static

◆ TextEditorFontSize()

static int RtfComposer::TextEditorFontSize ( )
static