Rhino C++ API  8.6
Public Attributes | List of all members
RtfComposer::RunInfo Class Reference

#include <opennurbs_textiterator.h>

Public Attributes

bool m_bold = false
 
ON_wString m_facename = L"Arial"
 
int m_facename_key = -1
 
bool m_italic = false
 
ON_wString m_run_text
 
ON_TextRun::RunType m_run_type = ON_TextRun::RunType::kNone
 
bool m_strikeout = false
 
ON_TextRunm_text_run = nullptr
 
bool m_underline = false
 

Member Data Documentation

◆ m_bold

bool RtfComposer::RunInfo::m_bold = false

◆ m_facename

ON_wString RtfComposer::RunInfo::m_facename = L"Arial"

◆ m_facename_key

int RtfComposer::RunInfo::m_facename_key = -1

◆ m_italic

bool RtfComposer::RunInfo::m_italic = false

◆ m_run_text

ON_wString RtfComposer::RunInfo::m_run_text

◆ m_run_type

ON_TextRun::RunType RtfComposer::RunInfo::m_run_type = ON_TextRun::RunType::kNone

◆ m_strikeout

bool RtfComposer::RunInfo::m_strikeout = false

◆ m_text_run

ON_TextRun* RtfComposer::RunInfo::m_text_run = nullptr

◆ m_underline

bool RtfComposer::RunInfo::m_underline = false