Click or drag to resize

GH_IWriterSetInterval1D Method (String, GH_Interval1D)

Add a new data item to this chunk. The name must be unique or an exception will be thrown.

Namespace:  GH_IO.Serialization
Assembly:  GH_IO (in GH_IO.dll)
Syntax
void SetInterval1D(
	string item_name,
	GH_Interval1D item_value
)

Parameters

item_name
Type: SystemString
Name of item to add.
item_value
Type: GH_IO.TypesGH_Interval1D
Value of item to add.
Exceptions
ExceptionCondition
InvalidOperationExceptionThrown if another item with the same name already exists.
See Also