Click or drag to resize

GH_IWriter Methods

The GH_IWriter type exposes the following members.

Methods
  NameDescription
Public methodAddComment
Adds a text comment to this chunk. Comments are serialized only if the output flavour is a human readable format. Comments are never deserialized, they are purely for the benefit of the humans reading the file data.
Public methodCreateChunk(String)
Create a new child chunk with the specified name but without an index qualifier. If another chunk already exists with similar properties, an exception will be thrown.
Public methodCreateChunk(String, Int32)
Create a new child chunk with the specified name and index qualifier. If another chunk already exists with similar properties, an exception will be thrown.
Public methodRemoveChunk(GH_IChunk)
Remove the specified chunk from the litter.
Public methodRemoveChunk(String)
Remove the first chunk with a matching name. Only chunks without index qualifiers are considered. Name comparisons are not case-sensitive.
Public methodRemoveChunk(String, Int32)
Remove the first chunk with a matching name and index. Only chunks with index qualifiers are considered. Name comparisons are not case-sensitive.
Public methodRemoveItem(String)
Remove an unindexed item from this chunk.
Public methodRemoveItem(String, Int32)
Remove an indexed item from this chunk.
Public methodSetBoolean(String, Boolean)
Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public methodSetBoolean(String, Int32, Boolean)
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public methodSetBoundingBox(String, GH_BoundingBox)
Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public methodSetBoundingBox(String, Int32, GH_BoundingBox)
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public methodSetByte(String, Byte)
Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public methodSetByte(String, Int32, Byte)
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public methodSetByteArray(String, Byte)
Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public methodSetByteArray(String, Int32, Byte)
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public methodSetDate(String, DateTime)
Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public methodSetDate(String, Int32, DateTime)
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public methodSetDecimal(String, Decimal)
Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public methodSetDecimal(String, Int32, Decimal)
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public methodSetDouble(String, Double)
Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public methodSetDouble(String, Int32, Double)
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public methodSetDoubleArray(String, Double)
Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public methodSetDoubleArray(String, Int32, Double)
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public methodSetDrawingBitmap(String, Bitmap)
Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public methodSetDrawingBitmap(String, Int32, Bitmap)
Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public methodSetDrawingColor(String, Color)
Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public methodSetDrawingColor(String, Int32, Color)
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public methodSetDrawingPoint(String, Point)
Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public methodSetDrawingPoint(String, Int32, Point)
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public methodSetDrawingPointF(String, PointF)
Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public methodSetDrawingPointF(String, Int32, PointF)
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public methodSetDrawingRectangle(String, Rectangle)
Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public methodSetDrawingRectangle(String, Int32, Rectangle)
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public methodSetDrawingRectangleF(String, RectangleF)
Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public methodSetDrawingRectangleF(String, Int32, RectangleF)
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public methodSetDrawingSize(String, Size)
Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public methodSetDrawingSize(String, Int32, Size)
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public methodSetDrawingSizeF(String, SizeF)
Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public methodSetDrawingSizeF(String, Int32, SizeF)
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public methodSetGuid(String, Guid)
Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public methodSetGuid(String, Int32, Guid)
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public methodSetInt32(String, Int32)
Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public methodSetInt32(String, Int32, Int32)
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public methodSetInt64(String, Int64)
Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public methodSetInt64(String, Int32, Int64)
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public methodSetInterval1D(String, GH_Interval1D)
Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public methodSetInterval1D(String, Int32, GH_Interval1D)
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public methodSetInterval2D(String, GH_Interval2D)
Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public methodSetInterval2D(String, Int32, GH_Interval2D)
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public methodSetLine(String, GH_Line)
Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public methodSetLine(String, Int32, GH_Line)
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public methodSetPath(String, String, String)
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public methodSetPath(String, Int32, String, String)
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public methodSetPlane(String, GH_Plane)
Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public methodSetPlane(String, Int32, GH_Plane)
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public methodSetPoint2D(String, GH_Point2D)
Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public methodSetPoint2D(String, Int32, GH_Point2D)
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public methodSetPoint3D(String, GH_Point3D)
Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public methodSetPoint3D(String, Int32, GH_Point3D)
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public methodSetPoint4D(String, GH_Point4D)
Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public methodSetPoint4D(String, Int32, GH_Point4D)
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public methodSetSingle(String, Single)
Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public methodSetSingle(String, Int32, Single)
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public methodSetString(String, String)
Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public methodSetString(String, Int32, String)
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public methodSetVersion(String, GH_Version)
Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public methodSetVersion(String, Int32, GH_Version)
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Public methodSetVersion(String, Int32, Int32, Int32)
Add a new data item to this chunk. The name must be unique or an exception will be thrown.
Public methodSetVersion(String, Int32, Int32, Int32, Int32)
Add a new data item to this chunk. The combination of name and index must be unique or an exception will be thrown.
Top
See Also