Click or drag to resize

GH_ItemWrite Method (XmlWriter)

Serialize this item into an Xml stream.

Namespace:  GH_IO.Types
Assembly:  GH_IO (in GH_IO.dll)
Syntax
public void Write(
	XmlWriter writer
)

Parameters

writer
Type: System.XmlXmlWriter
Writer to serialize with.

Implements

GH_IXmlSupportWrite(XmlWriter)
Exceptions
ExceptionCondition
MemberAccessExceptionThrown if !HasName.
MemberAccessExceptionThrown if !HasType.
IOExceptionThrown if the internal data could not be serialized.
See Also