Click or drag to resize

GH_DocDiagramPainterPaintDiagram Method (IEnumerableIGH_DocumentObject, Int32, Int32, Int32)

Paint a diagram of a document.

Namespace:  Grasshopper.GUI.Canvas
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public bool PaintDiagram(
	IEnumerable<IGH_DocumentObject> objs,
	int mapWidth,
	int mapHeight,
	int inflate
)

Parameters

objs
Type: System.Collections.GenericIEnumerableIGH_DocumentObject
Objects to paint.
mapWidth
Type: SystemInt32
Width (in pixels) of diagram.
mapHeight
Type: SystemInt32
Height (in pixels) of diagram.
inflate
Type: SystemInt32
Padding around the objects.

Return Value

Type: Boolean
True on success, false on failure.
See Also