Click or drag to resize

GH_DocDiagramPainter Class

This class paints diagrammatic images of a collection of objects.
Inheritance Hierarchy
SystemObject
  Grasshopper.GUI.CanvasGH_DocDiagramPainter

Namespace:  Grasshopper.GUI.Canvas
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_DocDiagramPainter

The GH_DocDiagramPainter type exposes the following members.

Constructors
  NameDescription
Public methodGH_DocDiagramPainter
Initializes a new instance of the GH_DocDiagramPainter class
Top
Properties
  NameDescription
Public propertyBoundingBox
Gets the 2D domain of the diagram in canvas coordinates.
Public propertyDrawingBox
Gets the 2D domain of the diagram in image coordinates.
Public propertyIgnoreSelectedStates
Gets or sets the Ignore Selected State flag. When set to True, selected objects are not drawn in a different colour.
Public propertyImage
Gets the diagram image (only available after a call to PaintDiagram().
Public propertySize
Gets the width and height (in pixels) of this diagram image.
Public propertyZoom
Gets the zoom factor for this diagram.
Top
Methods
See Also